Kein Bild nach zappen

  • Ich möchte meine Probleme beim Umschalten nochmal aufwärmen. Ich hatte das immer dem streamdev Plugin zugeordnet: streamdev bleibt hängen
    Dies war jedoch nur bedingt richtig, es ist lediglich so das sich das Plugin nach dem Problemen nicht mehr ohne Neustart zu 'erholen' scheint, die Probleme selbst liegen jedoch nicht am streamdev.

    Um das einzugrenzen habe ich in der Zwischenzeit einiges versucht, unter anderem hat mein VDR Server nun ein eigenes Frontend wodurch ich das besser testen und eingrenzen kann.


    Das Problem:


    - beim zappen bleibt das Bild dunkel

    - tritt stochastisch auf

    - manchmal 2-3 mal an einem Fernseh-Abend manchmal eine Woche garnicht


    Die Situation:


    - ich habe diese Probleme seit vielen Jahren, mal mehr mal weniger, subjektiv würde ich sagen das es irgendwann mit einer frühen 2.3.x Version des VDR angefangen hat.

    - habe seit dem schon den LNB und den Multiswitch erneuert

    - ich verwende im Moment den Unicalble Ausgang des Inverto 51510 IDLU-UST110-CUO1O-32P hatte auch vorher mit einem 'normalen' Switch schon Probleme diese jedoch damals nie weiter eingegrenzt

    - es tritt mit einem Plain VDR nur mit softhddevice und remote Plugin auf
    - passiert mit dem aktuellsten VDR aus dem git (gestern aktualisiert)

    - manchmal geht es nach einigem hin und her zappen wieder

    - schalte ich mittels des femon Plugins die verfügbaren Tuner durch bekomme ich wieder Bild, nur eben nicht auf dem einen Tuner. Dieser geht jedoch bei anderen Kanälen - und nach einem Neustart auch auf dem Kanal auf welchem er gerade nicht lief (ab und zu auch ohne Neustart nach einigem zappen und warten)

    - es tritt mit der max S8 auf, tausche ich diese gegen eine Cine gleiches Problem.

    - die Sat Anlage und Verkabelung funktioniert mit den in den TVs eingebauten DVB-S komplett unauffällig

    - mit minisatip (ganz ohne VDR) läuft es auch einwandfrei auf Pad und Smartphone (selbe DVB Karte in selbem Host auf welchem auch der VDR läuf)

    - mit minisatip und dem VDR (satip Plugin) läuft es besser als wenn der VDR direkt die Tuner handelt jedoch nicht 100% stabil (vermutlich noch ein kleines Problem des satip Plugins)


    ggf. hat ja jemand den entscheidenden Tipp


    Danke und viele Grüße
    Jörg

  • 9000H

    was hast du den jetzt genau gemacht, das es perfekt läuft.

    Blicke durch den Thread nicht ganz durch.

    Thanks

    speed

  • ich vermute es geht nur um das auskommentieren der return in Zeile 226?

  • Hi,

    genau das, bei mir gibt es sonst Probleme wenn defekte channels in der channels.conf sind.

    CU

    9000h

    Es ist eagl in wlehcer Reiehnfogle die Bchustebaen in Woeretrn vokrmomen. Huapstache der estre und leztte Bchustbae sitmmen.

  • hier noch das Abschließende Ergebnis der Fehlersuche.

    Klaus hat mir die letzten Tage beim einkreisen des Problems geholfen - auch hier nochmals vielen Dank dafür!


    Ursache für alles was in Richtung Empfang und Tuner auf dem Server VDR also dem VDR mit der MaxS8 mit Unicable nicht ging war einzig auf mein Testen mit dem femon Plugin zurück zuführen! Also der Empfang und die Hardware sind prima und auch der VDR hat keinen Fehler!


    Das Problem ist dass das femon Plugin das ich bei der Fehlersuche verwendet habe da man damit so schön Kanäle und Tuner durchschalten kann! Diese blockiert auch nach dem umschalten weiterhin Tuner mit den letzten Kanälen - wohl nicht immer aber sehr oft wenn man zwischen nicht FTA Kanälen umschaltet. Damit stehen dann immer weniger freie Tuner zur Verfügung.


    Angefangen zu testen habe ich weil ich an einem Client VDR wenn ich diesem über das streamdev Plugin versorge hin und wieder kein Bild bekomme was ich in dann oft nur durch Neustart des Server VDR wieder beheben kann. Weiterhin hatte ich auch auf dem Server VDR hin und wieder leere Aufnahmen.


    Soweit wir das nachvollziehen konnten blockt auch das straemdev-server Plugin Tuner welche es nicht mehr benötigt - dies führt dazu das der Client kein Signal mehr bekommt und auch auf dem Server Aufnahmen leer bleiben.


    Sicher ist wenn ich streamdev nicht verwende und auch nicht lade die Probleme nicht auftreten!


    Mein Setup ist nun, Server VDR mit 4 Tunern für die Aufnahmen und minisatip mit den restlichen Tunern zum streamen zu den Clients.


    Bleiben nur die im Verhältnis ganz oben beschriebenen kleinen Problemchen mit satip.


    Grüße

    Jörg

  • Quote

    ...Mein Setup ist nun, Server VDR mit 4 Tunern für die Aufnahmen und minisatip mit den restlichen Tunern zum streamen zu den Clients. ...

    Es wäre fein, wenn es für VDR ein satip-Server Plugin gäbe... 😜😁

  • Naja, es gibt doch minisatip.

    In meinem Server mit MAX S8 läuft minisatip und ein VDR als Server. Dem VDR habe ich untersagt sich den physischen Tuner zu krallen, der wird auch über minisatip gespeist.

    Der Server hat aktuell 7 Devices zur Verfügung und der Client im Wohnzimmer 1 für Live-TV. Alles andere macht der Server der auch per NFS das Videoverzeichis zur Verfügung stellt.


    Klar mit so einem Plugin würde man sich das minisatip sparen, aber das kann eben auch echt viel.

  • ich finde die Trennung besser, oder soll der VDR den STREAM noch irgendwie anreichern?