Raspberry Pi 4B Unterstützung

  • nein ist es nicht, es brauch die ganzen patches + ffmpeg 4.3.1

    Horchi testet gerade diese Kombi. Allerdings wird HWAccel drm nicht erkannt. Der selbe Code funktioniert mit Rockchip und AW. Muss der decoder mit avcodec_find_decoder_by_name geöffnet werden? Sonst muß ich mir die Konfiguration von FFmpeg noch mal genauer ansehen.

    Ich hab kein Raspi4 kann deshalb nicht testen.

  • Evtl. kann Horchi für Dich Testen, sonst müsste ich mir den ffmpeg bauen, um für Dich Testen zu können.


    Wäre auch nicht schlecht, wenn Horchi ein ffmpeg Paket zur Verfügung stellen könnte.


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • mit dem:

    Code
    1. root@rpi4:~# uname -r
    2. 5.10.0-rc5-v7l+


    sollte es auch gehen?



  • /proc/config.gz wenn man vorher configs lädt.

    schaut hinsichtlich DRM so aus:

  • Hast PN


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • fürs Protokoll: mit einem aktuellen nightly-build von LibreElec läuft der Raspi4 jetzt auch mit Kodi ruckelfrei und ohne tearing beim Scrollen. Die Freude bleibt dennoch getrübt, denn die Bildqualität ist nicht so gut wie beim Raspi 2. Obwohl der volle RGB-Farbraum ab 0 in Kodi bereits gewählt ist und ich sicherheitshalber auch hdmi_pixel_enconding=2 in der config.txt ergänzt habe, sind schwarze Flächen nicht völlig schwarz, sondern leuchten etwas in Richtung grau. Nicht so schlimm, wie mit eingeschränktem Farbraum ab 16, aber immer noch störend, wenn man das gute Bild des Raspi 2 gewohnt ist.

    Möglicherweise passen die default-Werte für Helligkeit und Kontrast im Treiber nicht - einstellen kann man das offenbar nicht. Eine Nachregelung am TV ist mir zu aufwändig, da das dann alle am AVR angeschlossenen Geräte betrifft.

    Ich habe auch schon die Anschlüsse am AVR getauscht, aber daran liegt es nicht.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • gerade mal getestet:


    Bei h264 zeigt die CPU-Auslastung in der Kodi-Systeminfo phasenweise um 50% Last auf drei abgebildeten Kernen an. Das dürfte wohl SW-Dekodierung sein.

    Bei h265 ist die CPU-Auslastung minimal, der Balken klebt links mit geringen Ausschlägen bis ca. 10%

    MPEG2: Das muss ja beim Pi4 SW-Dekodierung sein. Ich sehe hier bei einem Testfilm eine geringe Auslastung bei ca. 10-20%.


    Habe das Bild jetzt auch nochmal mit dem von einer nvidia GT1030 verglichen. Die liefert wie der Raspi 2 sattes dunkles schwarz. Nur beim Pi4 müsste ich dafür die Helligkeit am TV deutlich reduzieren.

    VDR 1: Silverstone LC20, Cougar A300/R, Asrock J4105B-ITX, WinTV DualHD, WD10EADS; Atric-IR-Einschalter. SW: Xubuntu 20.04 per SSD. Für den Produktiveinsatz leider nicht zu gebrauchen.
    VDR 2: ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, WD40EZRX, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisc SSD. Mein zuverlässiges Arbeitspferd!

  • Wir haben uns beim Entwickeln der Unterstützung von Raspi4 im softhddevice-drm festgefahren. Bei HEVC kommt vom Decoder das erste Frame, aber mit den Daten kann kein FB angelegt werden. Die Werte sind auch nicht schlüssig. Die plane 1 hat ein offset von 139.264. Bei pitch 1920 und Höhe 1080 sollte das aber mindestens 2.073.600 sein. Da brauch ich doch ein Board hier um das Umsetzen zu können.

  • Raspi 4b wird Dank Heifisch der mir ein Board zur Verfügung gestellt hat, jetzt auch von softhddevice-drm unterstützt. Mpep2 wird in SW decodiert und deinterlaced. H264 wird nur in SW decodiert. HEVC wird in HW decodiert.


    Voraussetzung ist ein neueres Kernel. Ich habe das benutzt. Nach der Kernel Installation ist das Installieren der neuen Kernel Header notwendig. Danach FFmpeg von da. Dabei sollte --enable-sand --enable-v4l2_m2m --enable-v4l2-request --enable-libudev --enable-libdrm an configure mit übergeben werden. Nach configure sollte unter Enabled hwaccels: hevc_v4l2request stehen.


    Warum H264 momentan nur in SW geht weiss ich nicht. Meine Suche hat bisher nix ergeben.

  • H265 wird nur in SW decodiert. HEVC wird in HW decodiert.

    H265 = HEVC, Du meinst sicherlich H264


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • ffmpeg compile läuft, bin mal gepannt, wie lange das dauert ...


    vdr-User-# 755 to_h264 chk_r vdr-transcode

  • Der Compile ging verdächtig schnell, er hat auch nur das compiliert, was ich configuriert hatte:


    zillerbaer  

    Kannst Du mal Deine Configuration posten?


    vdr-User-# 755 to_h264 chk_r vdr-transcode