Softhddevice und das leidige Thema Ton

  • Habe vdr 0.6 installiert. Und eins vornweg, ich habe jede Menge Beiträge hier im Board zu diesem Thema gelesen. Jedoch komme ich nicht weiter deswegen bitte ich um Hilfe.

    Meine Einstellungen im Softhddevice-Plugin sind:


    Softhddevice Pass-Through -Standart: ein

    PCM pass-through: ein

    AC-3 passthrough: ein


    Ich bekomme nur ein Knattern und Zischen als Ton. Manchmal funktionierte der Ton und dann nach ca. 2min wieder dieses Zischen und Ton weg.

    Ich bringe den Ton per HDMI ins TV. Habe im TV ein optisches Kabel das dann weiter in meinen Denon Reciever geht und der zeigt mir auch Dolby Digital an, auch wenn es so zischt bzw. knattert.


    Meine Asound.conf:


    pcm.!default {

    type hw

    card NVidia

    device 3

    }


    ctl.!default {

    type hw

    card NVidia

    }


    Meine softhddevice.conf:

    -D


    Der Log

    May 26 16:28:19 ubuntu vdr: audio: 'alsa' output module used

    May 26 16:28:19 ubuntu vdr: audio/alsa: supports pause: yes

    May 26 16:28:19 ubuntu vdr: audio: 44100Hz supports 2 2 6 6 6 6 8 8 channels

    May 26 16:28:19 ubuntu vdr: audio: 48000Hz supports 2 2 6 6 6 6 8 8 channels

    May 26 16:28:19 ubuntu vdr: audio: 192000Hz supports 2 2 6 6 6 6 8 8 channels

    May 26 16:28:19 ubuntu vdr: audio/alsa: using pass-through device 'default'

    May 26 16:28:19 ubuntu vdr-frontend[10967]: conntected to Lirc-Socket on /var/run/lirc/lircd

    May 26 16:28:19 ubuntu vdr: audio/alsa: start delay 336ms


    Natürlich habe ich hier im Board eine Lösung gefunden um überhaupt Ton zu haben, allerdings geht damit nur stereo. Ich hätte gern Dolby Digital, vielleicht kann mir jemand helfen.

  • PCM pass-through kann über spdif nicht funktionieren. Ansonsten kommt es drauf an, was Dein TV weitergibt.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • jsffm dieses "Zischen u. Kattern" kommt ja auch aus dem Fernseher wo ich mit HDMI dran bin. Aber wie gesagt es hat ja auch schon wie ich es beschrieben habe funktioniert. Wenn ich wüßte wie man einen debug-log erstellt dann könnte man sicherlich mehr erfahren.

  • Poste doch mal das Ergebnis von


    Code
    1. cat /proc/asound/NVidia/eld#0.0


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

    The post was edited 1 time, last by jsffm ().

  • Könnte an der kernel Konfiguration liegen.

    Gibt es /proc/asound ?

    wenn ja, gibt es dort einen link NVidia ?

    wenn ja, wie schaut das Verzeichnis aus?


    Das wären die möglicherweise fehlenden kernel Parameter:


    Code
    1. CONFIG_SND_PROC_FS=y
    2. CONFIG_SND_VERBOSE_PROCFS=y


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Also /proc/asound gibt es , einen link NVidea gibt es auch. Das Verzeichnis hat folgende Ordner :pcm3p,pcm2c,pcm1p,pcm0p,pcm0c.

    Dann sind darin noch die Dateien: codec#0,codec#3 und id.

  • Bei mir sieht codec#0 so aus:



    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Bei Ubuntu läuft die Soundausgabe doch standardmäßig über Pulseaudio. Ist in pavucontrol passthrough aktiviert? Das funktioniert nach meiner Erinnerung nur, wenn die Lautstärke auf Mittelstellung ist. Und es muss ein 2.0-Profil konfiguriert sein, i.d.R. "Digital Stereo (HDMI)"

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • Du nutzt ja Alsa, stell mal softhddevice so ein :

    Softhddevice Pass-Through -Standart: aus

    PCM pass-through: ein

    AC-3 passthrough: ein

    ...

  • ich bin der Meinung, dass er nicht alsa benutzt

    Quote

    May 26 16:28:19 ubuntu vdr: audio/alsa: using pass-through device 'default'

    default device bei Ubuntu ist pulseaudio - es sei denn, er hat es deinstalliert.

    ACT-620, Asrock B75 Pro3-M, Intel Core i3-3240, 4 GB DDR3 RAM 1600 MHz, passive Geforce GT1030 von MSI, Sandisk 2TB SSD, 2xWinTV DualHD, Atric-IR-Einschalter. SW: Xubuntu 20.04 auf 64GB Sandisk SSD.

  • ich bin der Meinung, dass er nicht alsa benutzt

    default device bei Ubuntu ist pulseaudio - es sei denn, er hat es deinstalliert.

    hast recht - umstellen im WebIF geht aber auch.

  • froschi wenn ich Softhddevice Pass-Through -Standart: aus einstelle habe ich bei 5.1 Kanälen nicht alle Kanäle. Die Centerbox bleibt stumm.



    Dr. Seltsam ich habe pulsaudio nicht im Webinterface angewählt HDA MVidia - HDMI 0 habe ich eingestellt


    jsffm anbei meine codec#0, konnte sie nicht direkt Posten weil mehr als 10000 Zeichen

  • hier noch meine codec#3


  • In keinem Deiner Codecs taucht AC3 auf, also kann Dein TV kein AC3.

    Hat Dein AV-Receiver keinen HDMI-Eingang?


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Also mein TV ist zwei Wochen alt ein LG Oled. Hab da PCM im TV eingestellt. Das komische ist ja das es so wie ich es habe funktioniert hat also Dolby Digital wurde angezeigt im Receiver und der Ton war auch richtig zu hören. Dann nach ca. 2min war der Ton weg und es war dieses "Zischen" zu hören. Ja HDMI hat der Receiver aber ich will ja nur den Receiver nutzen wenn ich einen Film mit 5.1 Ton schaue.

    Trotzdem vielen Dank füt deine Mühe und Geduld mit mir.

  • Was kannst Du denn alternativ zu PCM im TV einstellen?


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Das Zischen kommt doch vermutlich vom TV, kannst Du nicht einfach den Ton runterdrehn und vom AV-Receiver hören?


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Wenn Dein TV und Dein AV-Receiver beide ARC unterstützen brauchst Du kein spdif Kabel dazwischen, Du musst nur den AV-Receiver entsprechend konfigurieren, dann ginge auch PCM 6-Kanal paththrough


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • habe ich das nun richtig gelesen :

    vom VDR geht der Ton via HDMI an den TV und vom TV dann über Toslink an den Receiver ?