yavdr ansible

  • Ok, dann hat der Bildschirm wie vermutet keine quadratischen Pixel. Interessant finde ich auch, dass xdpyinfo und xrandr da unterschiedliche Bildschirmgrößen angeben. Ich denke da werde ich die Bildschirmerkennung im Playbook erweitern müssen, um in so einem Fall die DPI-Option in der xorg.conf zu setzen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Nachdem jetzt git pull funktionierte, hat das update


    Code
    1. sudo -H ./install-yavdr.sh

    folgende Fehlermeldung ausgegeben:

    Code
    1. TASK [autoinstall-ubuntu-drivers : apt | install ubuntu-drivers-common] *******************************************************************************************************************************************
    2. ok: [localhost]
    3. TASK [autoinstall-ubuntu-drivers : use ubuntu-drivers to install additional drivers automatically] ****************************************************************************************************************
    4. fatal: [localhost]: FAILED! => {"changed": true, "cmd": ["ubuntu-drivers", "--package-list", "/etc/yavdr/autoinstalled", "autoinstall"], "delta": "0:00:08.737626", "end": "2019-08-21 23:30:47.614499", "msg": "non-zero return code", "rc": 100, "start": "2019-08-21 23:30:38.876873", "stderr": "E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.", "stderr_lines": ["E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete."], "stdout": "Paketlisten werden gelesen...\nAbhängigkeitsbaum wird aufgebaut....\nStatusinformationen werden eingelesen....\nEinige Pakete konnten nicht installiert werden. Das kann bedeuten, dass\nSie eine unmögliche Situation angefordert haben oder, wenn Sie die\nUnstable-Distribution verwenden, dass einige erforderliche Pakete noch\nnicht erstellt wurden oder Incoming noch nicht verlassen haben.\nDie folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:\n\nDie folgenden Pakete haben unerfüllte Abhängigkeiten:\n nvidia-driver-430 : Hängt ab von: xserver-xorg-video-nvidia-430 (= 430.26-0ubuntu0.18.04.2) soll aber nicht installiert werden\n Hängt ab von: libnvidia-cfg1-430 (= 430.26-0ubuntu0.18.04.2) soll aber nicht installiert werden", "stdout_lines": ["Paketlisten werden gelesen...", "Abhängigkeitsbaum wird aufgebaut....", "Statusinformationen werden eingelesen....", "Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass", "Sie eine unmögliche Situation angefordert haben oder, wenn Sie die", "Unstable-Distribution verwenden, dass einige erforderliche Pakete noch", "nicht erstellt wurden oder Incoming noch nicht verlassen haben.", "Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:", "", "Die folgenden Pakete haben unerfüllte Abhängigkeiten:", " nvidia-driver-430 : Hängt ab von: xserver-xorg-video-nvidia-430 (= 430.26-0ubuntu0.18.04.2) soll aber nicht installiert werden", " Hängt ab von: libnvidia-cfg1-430 (= 430.26-0ubuntu0.18.04.2) soll aber nicht installiert werden"]}
    5. PLAY RECAP ********************************************************************************************************************************************************************************************************
    6. localhost : ok=21 changed=5 unreachable=0 failed=1 skipped=2 rescued=0 ignored=0

    Wer kann helfen?


    Gruß Micha

  • Hallo Micha,


    hast du noch einen alten nvidia Treiber installiert? Ich musste bei mir auch erst den alten deinstallieren bevor der neue sauber installiert werden konnte.

  • Hallo Murry,


    Ist ein 430-iger zu alt?


    Ich kann ihn ja mal rauswerfen :)


    Gruß Micha

  • Guten Tag


    Bis auf bbc one hd funktioniert alles, auch bbc two hd und bbc Four hd. Wenn auf bbc one hd schalte startet Vdr und im syslog sehe ich


    softhddev video[4528]: segfault at 18 ip 00007f9f4756fa62 sp 00007f9ecba33860 error 4 in libavcodec.so.57.107.100[7f9f47266000+ca6000]


    Auch nach einer Aktualisierung besteht das Problem. Was könnte die Ursache sein?


    Gruß

    Eric

  • Was könnte die Ursache sein?

    Möglicherweise hängt das am vorinstallierten vdr-plugin-softhddevice-vpp in Kombination mit ffmpeg 3.4 zusammen.


    Du könntest mal das Paket vdr-plugin-softhddevice (entspricht Softhddevice + ffmpeg > 3.2 (vdpau)) oder die gegen die alte ffmpeg-Version 2.8 gebauten Varianten vdr-plugin-softhddevice-ffmpeg-2.8 bzw. vdr-plugin-softhddevice-ffmpeg-2.8 probieren.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Thanks with vdr-plugin-softhddevice (so with ffmpeg 3.2) bbc one HD works like a charm.


    Schätze mal der NVIDIA 8200 (mit zehn Jahre) an seine Grenzen mit ffmpeg 3.4 stößt.


    Schönen Sonntag

  • Guten Abend


    Kodi startet nicht


    Einzige Fehlermeldung


    set-kodi-display[3540]: Could not change videoscreen.* settings: local variable 'xml_tree' referenced before assignment


    Danach


    ERROR: Unable to create application. Exiting

    kodi.service:

    Main process exited, code=exited, status=255/n/a


    Habe Kodi gelöscht (apt-get remove kodi*) und yavdr ansible wieder runter geladen und Installation durchgeführt aber nicht geholfen.


    kann mir jemand sagen wie ich den Fehler beheben das kodi (wieder) läuft..


    Gruß

    Eric

  • Welche KODI-Version ist denn bei dir installiert? apt policy kodi


    Wie sehen die Rechte für das Verzeichnis /var/lib/vdr/.kodi/.display_cache und die Datei /var/lib/vdr/.kodi/userdata/guisettings.xml aus?

    Code
    1. ls -la /var/lib/vdr/.kodi/.display_cache
    2. ls -l /var/lib/vdr/.kodi/userdata/guisettings.xml

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Ich bekomme leider kein Bild. Kann jemand damit was anfangen:

    ...

    fatal: [localhost]: FAILED! => {"changed": false, "msg": "AnsibleUndefinedVariable: 'dict object' has no attribute 'primary'"}

    ...



    Silverstone LC 16-MR, P5N7A-VM , Cine S2 Dual DVB-S2 V5.5, E5200, 64 GB Crucial CT064M4, 2 TB WD 20EARX

  • Da hat die Erkennung der angeschlossenen Bildschirme nicht geklappt - was sagt denn dkms status?

    Falls das der erste Aufruf des Playbooks war und ein nvidia-Treiber installiert wurde, würde ich mal probieren, ob das Problem nach einem Neustart weg ist, wenn man das Playbook erneut laufen lässt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo Seahawk


    Welche KODI-Version ist denn bei dir installiert? apt policy kodi


    Installiert: 2:18.3+git20190621.1610-final-0bionic

    Installationskandidat: 2:18.3+git20190621.1610-final-0bionic

    Versionstabelle:

    *** 2:18.3+git20190621.1610-final-0bionic 500

    500 http://ppa.launchpad.net/yavdr/experimental-kodi/ubuntu bionic/main amd64 Packages

    500 http://ppa.launchpad.net/yavdr/experimental-kodi/ubuntu bionic/main i386 Packages

    100 /var/lib/dpkg/status

    2:17.6+dfsg1-1ubuntu1 500

    500 http://de.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages


    Komisch dachte wäre 17 .. apt cache show kodi zeigt


    Package: kodi

    Architecture: amd64

    Version: 2:17.6+dfsg1-1ubuntu1


    Wie sehen die Rechte für das Verzeichnis /var/lib/vdr/.kodi/.display_cache und die Datei /var/lib/vdr/.kodi/userdata/guisettings.xmlaus?


    drwxr-xr-x 2 vdr vdr 4096 Mai 5 22:07 .

    drwxrwxr-x 8 vdr vdr 4096 Mai 5 22:07 ..

    -rw-r--r-- 1 vdr vdr 0 Mai 5 22:07 Default-videoscreen.xml

    -rw-r--r-- 1 vdr vdr 0 Mai 5 22:07 HDMI-0-videoscreen.xml


    -rw-r--r-- 1 vdr vdr 0 Mai 5 22:07 /var/lib/vdr/.kodi/userdata/guisettings.xml


    Nach der Installation hat es ja geklappt mit


    sudo frontend-dbus-send switchto kodi


    aber irgendwann danach nicht mehr.


    Gruß

    Eric

  • Mir ist gerade nicht ganz klar, wie es zu der undefinierten lokalen Variable in dem Skript kommt, aber das allein sollte KODI nicht davon abhalten zu starten.

    Was steht denn in /var/lib/vdr/.kodi/temp/kodi.log?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hab in einem anderen Post die Lösung gefunden. Das Problem ist wohl die GT 730 und der nvidia-driver-430, nvidia-384 oder nvidia-driver-390 Treiber.
    Wenn man den nvidia-340 Treiber installiert, sieht das Menu wieder gut aus und geht auch mit softhddevice-vpp.


    habe hier mit einer GT630 ein ähnliches Verhalten.
    - Menüs werden nicht richtig dargestellt

    - initial war die Bildschirmerkennung nicht gut


    gegen welchen Kernel hast du den nvidia-340 Treiber gebaut?
    geht hier gegen den mit ubuntu 18.04 installierten Kernel 5.0.0-25 nicht.

    die alte und die von ansible automatisch erstellte xorg.conf habe ich mal angehängt.


    mit der alten xorg.cong in das neue System hereinkopiert habe ich wenigsten wieder Vollbild, aber ...

    zusätzlich ist das Bild verwaschen, viel weniger crisp und die Farben sind blass ... nicht nur ein bisschen schlechter, sondern signifikant

    sollte es ausschließlich am anderen Nvidia Treiber liegen, dass das Bild so viel schlechter ist - im yavdr 0.6 System läuft 384, nun 430?


    wie kann ich den einfach austauschen ... der 384 und der 340 bauen nicht gegen den aktuellen Kernel ... wie habt ihr dies hinbekommen?
    gibt es ein ansible Kommando nur für diesen Part?


    Files

    vdr3: yavdr-ansible | MSI B150M Mortar| Celeron 3930 | GT 630 passiv | DD Cine C/T/T2 (V7) | Noctua NH-L12 | Seasonic SS-300TGW (semi-passiv) | targavfd | Atric v5 | im Revox B-226 Gehäuse

  • EricAmir : Kannst du bitte mal die /usr/bin/set-kodi-display durch diese Version ersetzen: https://gist.githubusercontent…4240ed7b/set-kodi-display und sie so aufrufen:

    Quote

    sudo -u vdr DISPLAY=:0 set-kodi-display

    Kommt da auch eine Fehlermeldung?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • gegen welchen Kernel hast du den nvidia-340 Treiber gebaut?
    geht hier gegen den mit ubuntu 18.04 installierten Kernel 5.0.0-25 nicht.

    In https://launchpad.net/~graphic…ield.series_filter=bionic gibt es einen nvidia-340 Treiber, der gegen den Kernel 5.0 baut.

    zusätzlich ist das Bild verwaschen, viel weniger crisp und die Farben sind blass ...

    Hast du schon die Videoeinstellungen fürs Deinterlacing, Helligkeit, Kontrast und ggf. die Studio-Levels angepasst? Das Playbook ändert da bislang nichts an den Vorgabewerten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi Seahawk


    Ergebnis von dein set-kodi-display


  • Versuch mal die Datei /var/lib/vdr/.kodi/userdata/guisettings.xml zu löschen - laut Fehlermeldung ist die leer und da stolpert der Parser drüber. Ich ändere das Skript noch so ab, dass der Fehler abgefangen wird.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Code
    1. sudo frontend-dbus-send switchto kodi
    2. Traceback (most recent call last):
    3. File "/usr/bin/frontend-dbus-send", line 11, in <module>
    4. load_entry_point('yavdr-frontend==0.0.24', 'console_scripts', 'frontend-dbus-send')()
    5. File "/usr/lib/python3/dist-packages/yavdr_frontend/frontend_dbus_send.py", line 10, in main
    6. fe = bus.get('de.yavdr.frontend')
    7. File "/usr/lib/python3/dist-packages/pydbus/proxy.py", line 47, in get
    8. 0, timeout_to_glib(timeout), None)
    9. GLib.Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name de.yavdr.frontend was not provided by any .service files (2)
  • Passiert das auch noch nach einem sudo systemctl restart yavdr-xorg? Das sudo braucht es übrigens nicht für frontend-dbus-send.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)