[gelöst]060 Monitorproblem nach installation, friert ein

  • Hallo,
    nach der installation kein Bild,lande nur auf der Konsole.
    Für meine GeForce 8300 von nvida empfohlenen Treiber nvidia-opencl-icd-340 installiert.
    Jetzt friert das ganze System kurz nach dem Start VDR ein.
    Mit Glück und schnelligkeit komme ich gelegentlich noch in die anmeldung um VDR zu stoppen.
    In den Anzeigeeistellungen wird der Fernseher erkannt.
    Das syslog ist rudimentär.
    Das X.log ist da:


    Den media-build-experimental hatte ich gegen den dddvb-dkms getauscht, macht aber erst mal keinen Unterschied.
    Die ähnlichen Posts hier haben mir nicht weiter geholfen.
    Was mach ich blos wieder falsch?
    André

    ASUS M4N78 PRO, 1xDD-CineCTV6, 1xDD DuoFlex CT (V2), 1x Technisat SkyStar2, 1xAirstar2, 1xCreatix Polymedia Medion 7134
    yaVDR 0.6.0

    The post was edited 1 time, last by Hustler ().

  • Stoppe mal den VDR und den xorg-launcher, dann installiere mal den nvidia-304 Treiber und starte den Rechner neu. IIRC gab es hier auch schon einen Thread zu der Hardware-Konstellation.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Der nvidia-304 war doch in der Grundkonfiguration?
    Damit hatte ich doch kein Bild, nur Konsole.
    Deshalb hab ich doch auf 340 gewechselt.


    Edit:
    Versuch macht kluch, hab alle nvida entfernt und 304 installiert. Kamen ein par Meldungen:


    Relevant?
    Aber Bild ist da, sogar meine FB geht, aber, kein Ton.
    André

    ASUS M4N78 PRO, 1xDD-CineCTV6, 1xDD DuoFlex CT (V2), 1x Technisat SkyStar2, 1xAirstar2, 1xCreatix Polymedia Medion 7134
    yaVDR 0.6.0

    The post was edited 1 time, last by Hustler ().

  • Hi,


    Ja aber dennoch mach das mal was @seawhawk1986 schrieb, denn das Probs mit fehlendem Bild hatten einige User
    auch ich.
    Ich konnte es lösen indem ich den Laptop anwarf und ins WebIf ging und dort bisschen konfigurierte
    danach hatte ich Bild zuvor landete ich einfach immer in der Konsole 1



    GRuss
    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Hustler :


    Ich habe auch das M4N78 Pro Motherboard hier im Einsatz und hatte auch bei 0.6 das Problem, daß das System kurz nach dem Booten Probleme machte. Die Lösung war in /etc/default/grub bei GRUB_CMDLINE_LINUX_DEFAULT die Option pci=nomsi hinzuzufügen und danch sudo update-grub aufzurufen. Es hat bei mir mehrere Anlaufe gebraucht, da das System sich oft schon beim Booten oder sehr kurz danach verabschiedete.


    Ansonsten läuft der nvidia 340 Treiber hier sehr gut. Probleme gibt es bei Softhddevice+Kodi beim Ton mit Alsa, wenn man Passthrough beim Ton verwendet. Hat man einmal Passthrough verwendet, klappt der normale PCM Ton danach nicht mehr. Hier muss man evtl. in /etc/vdr/conf.d/50-softhddevice.conf das Ausgabedevice angeben, wobei bei mir seit 2 Wochen folgendes fehlerlos klappt:


    Code
    1. [softhddevice]
    2. -D
    3. -a plughw:NVidia,3
    4. -p hw:0,3

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Da ich bei der Installation einen Fehler mit dem Einbinden meiner alten srv Partition gemacht habe,
    hab ich noch mal neu installiert. Auf dddvb-dkms gewechselt.
    Alle nvida entfernt und 304 genommen und nach "process-template /etc/X11/xorg.conf.yavdr"
    hab ich auch ein Bild.
    Ich trau mich ehrlich nicht noch mal 340 zu versuchen, bei abstürzendem System noch rechtzeitig
    auf die Konsole zu kommen ist recht abenteuerlich.
    Ton hab ich natürlich nicht.
    Das eintragen des in der /etc/vdr/conf.d/50-softhddevice.conf ergibt
    wieder kein Signal am Monitor.


    Edit:
    Nach nochmaligem Neustart ist Bild wieder da, aber immer noch kein ton.
    André

    ASUS M4N78 PRO, 1xDD-CineCTV6, 1xDD DuoFlex CT (V2), 1x Technisat SkyStar2, 1xAirstar2, 1xCreatix Polymedia Medion 7134
    yaVDR 0.6.0

  • Auch ich hatte zuerst den Eindruck das es am NVidia Treiber liegt, doch beim Testen fiel mir teilweise auf, daß die Fehlermeldungen im Syslog einfach keinen Sinn ergaben. Es gab teilweise Ausfall des Netzwerks, dann war es die Grafik, kein USB, kein Ton usw. . Dies deutete letztlich auf ein Problem des Kernels mit dem Motherboard/Steckkarten hin und ich fing an die diversen Kernel Optionen (noapic, nomsi,...) in Grub auszuprobieren. Letztlich war es wirklich einfach nur die nomsi Option. Seit zwei Wochen läuft das System nun hier mit 0.6 und hatte nur einen Kodi-Absturz. Derart zuverlässig war yaVDR 0.3-0.5 bei mir bei weitem nicht ;-)


    Kein Ton? Trotz nomsi? Taucht das HDMI Audio Device in bei der aplay Liste auf? Verwendest Du Pulseaudio oder Alsa? Ich nehme Alsa, da man bei PulseAudio erst noch via VDR plugin nach dem Booten auf das passende Profile umschalten müsste, um Ton zu bekommen. Da fand ich Alsa einfach zuverlässiger. Wie hier schon im Forum geschildert, mußte ich durchaus mehrmals zwischen PulseAudio und Alsa umschalten, bis ich nach einem Reboot bei Alsa einen Ton hatte. Keine Ahnung wieso, tritt auch mit anderen Motherboards manchmal auf.


    Die funktionierende /etc/asound.conf Einstellung für HDMI Stereo lautet (ist glaube ich die per webif auch default eingestelllte Config):



    Falls Du 5.1 Sound mit passthrough ausgeben willst, hier meine /etc/asound.conf die auch in Kodi mit AAC 5.1 funktioniert:


    Ich denke, die 5.1 asound.conf Datei läßt sich sicherlich noch deutlich aufs Wesentliche verschlanken, doch dazu hatte ich noch keine Zeit. Ich war schon froh, daß damit scheinbar alles mit meinem Verstärker in Kodi korrekt funktioniert.
    Wie oben erwähnt, musst Du bei obiger 5.1 asound.conf noch das Ausgabedevice für softhddevice ändern und in Kodi war bei mir das letzte der beiden gelisteten "HDMI" Ausgabegeräte das richtige für PCM, damit nach Passtrough wieder ein Ton bei PCM kommt.


    Tja, das war eigentlich schon alles, was bei mir für das M4N78Pro Motherboard bei yaVDR 0.6 nötig war.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Kommt nix mit ton.

    Code
    1. [softhddevice]
    2. -D
    3. #neuer Eintrag Hustler 25.02.2016
    4. -a plughw:NVidia,3
    5. -p hw:0,3


    asound.conf

    Code
    1. pcm.!default {
    2. type hw
    3. card NVidia
    4. device 3
    5. }
    6. ctl.!default {
    7. type hw
    8. card NVidia
    9. }


    grub

    Code
    1. GRUB_CMDLINE_LINUX_DEFAULT="vmalloc=256m quiet splash noresume nohz=off acpi_enforce_resources=lax pci=nomsi"
    2. GRUB_CMDLINE_LINUX="pci=""


    update grub

    Code
    1. /etc/default/grub: Zeile 44: Dateiende beim Suchen nach »`« erreicht.


    Mit pulse geht wie im Forum beschrieben der ton nach Einstellung Ausgabegerät im Tools Menü,
    dei Einstellung ist aber nach Neustart wieder weg.
    Alsa über HDMI wär für mich schon ausreichend.
    André

    ASUS M4N78 PRO, 1xDD-CineCTV6, 1xDD DuoFlex CT (V2), 1x Technisat SkyStar2, 1xAirstar2, 1xCreatix Polymedia Medion 7134
    yaVDR 0.6.0

  • GRUB_CMDLINE_LINUX="pci=""

    Was soll das bewirken? Und die ungerade Anzahl an Anführungszeichen dürfte zu der Fehlermeldung bei update-grub führen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hustler :


    1. Die Angabe des plughw:NVidia,3 Ausgabedevices für softhddevice ist wie beschrieben nur nötig, wenn Du passthrough (z.B. mit der obigen 5.1 asound.conf) verwendest. Bei normalen HDMI Stereo mit der kleinen asound.conf oben brauchst Du das wohl nicht und ich weiss noch nicht einmal, ob plughw:NVidia,3 mit der kleinen asound.conf überhaupt exisitiert?


    2. Hatte überlesen, daß bei Dir PulseAudio geht. Damit hast Du auch das HDMI Ausgabedevice: Erscheint bei aplay -l das HDMI Ausgabedevice überhaupt? Ist es auch card 0/device 3? Ich habe den normalen Ubuntu 340 Treiber installiert. Wenn ich das richtig mitbekommen habe, wird dieser auch bei einer yaVDR Installation mit Internet-Zugang installiert (ohne Internet gibt's die 304?). Ich frage mich, ob überhaupt das System korrekt installiert wurde, bedenkt man die massiven Probleme die ich ohne nomsi hatte. Vielleicht doch noch einmal mit nomsi neu installieren?


    Code
    1. aplay -l**** List of PLAYBACK Hardware Devices ****card 0: NVidia [HDA NVidia], device 0: VT1708S Analog [VT1708S Analog] Subdevices: 1/1 Subdevice #0: subdevice #0card 0: NVidia [HDA NVidia], device 1: VT1708S Digital [VT1708S Digital] Subdevices: 1/1 Subdevice #0: subdevice #0card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0] Subdevices: 1/1 Subdevice #0: subdevice #0



    3. Schalte noch einmal kurz zu PulseAudio zurück. Dann reboote. Wie gesagt, das Umschalten auf Alsa klappte bei mir auch zweimal nicht auf Anhieb. Keine Ahnung wieso.


    4. Ansonsten klappt ja auch PulseAudio, wenn Du jedes mal nach dem Booten in Pavucontrol das richtige Ausgabedevice/Profil auswählst. Du mußt jetzt nur noch via VDR Plugin dies nach dem Booten automatisieren. Dazu mußt Du eine Datei /var/lib/vdr/plugins/pulsecontrol/startup.script mit dem entsprechenden Umschaltbefehl erstellen (siehe andere Postings hier im Forum). Ich glaube beim M4N78Pro MB war set-card-profile 0 output:hdmi-stereo als Umschaltbefehl ok.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

    The post was edited 4 times, last by backalive ().

  • Noch eine Warnung: Wenn Du wie oben beschrieben die Einstellungen für grub und softhddevice änderst, werden diese bei Updates bzw. webif Aufrufen evtl. wieder überschrieben. Du mußt also templates verwenden, wenn die Änderungen dauerhaft gespeichert bleiben sollen. Hier die nötigen Befehle (vorher mittels sudo su root werden):


    nomsi Option bei grub dauerhaft installlieren:

    Code
    1. mkdir -p /etc/yavdr/templates_custom/etc/default/grub
    2. echo 'GRUB_CMDLINE_LINUX_DEFAULT="$GRUB_CMDLINE_LINUX_DEFAULT pci=nomsi"' >/etc/yavdr/templates_custom/etc/default/grub/12_nomsi
    3. chown root:root /etc/yavdr/templates_custom/etc/default/grub/*
    4. chmod 644 /etc/yavdr/templates_custom/etc/default/grub/*
    5. process-template /etc/default/grub
    6. update-grub


    Falls Du die Audiodevices für softhddevice angeben willst:

    Code
    1. mkdir -p /etc/yavdr/templates_custom/etc/vdr/conf.avail/softhddevice.conf/
    2. echo "-a plughw:NVidia,3" >/etc/yavdr/templates_custom/etc/vdr/conf.avail/softhddevice.conf/22_audiodevices
    3. echo "-p hw:0,3" >>/etc/yavdr/templates_custom/etc/vdr/conf.avail/softhddevice.conf/22_audiodevices
    4. chown root:root /etc/yavdr/templates_custom/etc/vdr/conf.avail/softhddevice.conf/*
    5. chmod 644 /etc/yavdr/templates_custom/etc/vdr/conf.avail/softhddevice.conf/*
    6. process-template /etc/vdr/conf.avail/softhddevice.conf


    Rein aus Interesse, da Du PCI-Express-Karten hast: Hat denn nomsi bei Dir geholfen? Oder musstest Du evtl. noch mit noapic experimentieren? Wollte demnächst evtl. zwei 952 installieren.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

    The post was edited 2 times, last by backalive ().

  • <Hat denn nomsi bei Dir geholfen
    Nein.


    Ich glaub, ich komm näher.
    Da stimmt doch was nicht:


    lspci | grep -i audio

    Code
    1. 00:07.0 Audio device: NVIDIA Corporation MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio (rev a1)


    cat /proc/asound/cards

    Code
    1. 0 [NVidia ]: HDA-Intel - HDA NVidia
    2. HDA NVidia at 0xf9e78000 irq 20
    3. 1 [SAA7134 ]: SAA7134 - SAA7134
    4. saa7134[0] at 0xf9fffc00 irq 16


    aplay -l

    Code
    1. **** Liste der Hardware-Geräte (PLAYBACK) ****
    2. Karte 0: NVidia [HDA NVidia], Gerät 0: VT1708S Analog [VT1708S Analog]
    3. Sub-Geräte: 1/1
    4. Sub-Gerät #0: subdevice #0
    5. Karte 0: NVidia [HDA NVidia], Gerät 1: VT1708S Digital [VT1708S Digital]
    6. Sub-Geräte: 1/1
    7. Sub-Gerät #0: subdevice #0
    8. Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0]
    9. Sub-Geräte: 0/1
    10. Sub-Gerät #0: subdevice #0


    dmesg | egrep -i "alsa|snd"

    Code
    1. [ 12.349039] saa7134 ALSA driver for DMA sound loaded
    2. [ 12.349061] saa7134[0]/alsa: saa7134[0] at 0xf9fffc00 irq 16 registered as card -2
    3. [ 21.087943] init: alsa-restore main process (1257) terminated with status 99


    Wird da ein Treiber für die falsche Karte geladen?
    André

    ASUS M4N78 PRO, 1xDD-CineCTV6, 1xDD DuoFlex CT (V2), 1x Technisat SkyStar2, 1xAirstar2, 1xCreatix Polymedia Medion 7134
    yaVDR 0.6.0

  • Hustler :


    Ich denke, wir sollten klar machen, wovon wir hier reden. Du hast scheinbar zwei Probleme???


    1. Dein System friert ein? Hier hilft bei mir wie gesagt pci=nomsi. Allerdings habe ich eben drei PCI Sat Karten im System und keine PCI-Express. Wenn Du also weiterhin Probleme mit dem Einfrieren hast, würde ich mal neben/anstatt pci=nomsi ein paar weitere Sachen probieren (inbesondere die nopic und pci=routeirq Option scheint mir interessant). Siehe auch https://wiki.ubuntuusers.de/Bootoptionen/


    2. Dein Ton geht bei Alsa nicht. Bei PulseAudio geht er nachdem Du die gewünschte Ausgabe einstellst bis zu einem Reboot???


    Also, Deine lspci/log Ausgaben oben scheinen mir vollkommen normal. Das gewünschte Ausgabedevice Karte 0: NVidia [HDA NVidia], Gerät 3: HDMI 0 [HDMI 0] ist da. SAA7134 dürfte von einer Deiner Sat Steckkarten herkommen. Ich habe da auch einige zusätzliche Soundkarten durch meine Sat Karten (CX8811, CX8801). Ich hatte ja oben schon im meinem Posting nachträglich die aplay Ausgabe gestrichen, eben weil ich erkannt hatte, daß Du bei PulseAudio einen Ton bekommst. Das wäre nicht möglich, wenn der NVidia Treiber und zumindest die lowlevel Funktionen der verwendeten Alsa Treiber nicht gehen würden. Insofern sollte die oben gepostete kleine asound.conf mit Alsa funktionieren. Hast Du auch in Alsamixer den Ausgang unmuted?


    Aber vielleicht ist es angesichts Deiner Alsa Probleme erst einmal einfacher auf PulseAudio zurückzuschalten, da Du hier ja einen Ton bekommst. Ich vermute, nachdem Du in PavuControl das gewünschte Ausgabedevice usw. gewählt hast? Das die Einstellung nach einem Reboot gerne wieder verloren geht, ist hier im Forum ja schon (siehe hier und hier) schon beschrieben worden. Wie gesagt, hier hilft es normalerweise, mittels /var/lib/vdr/plugins/pulsecontrol/startup.script nach dem Booten wieder auf das gewünschte Ausgabegerät/Profil in PulseAudio umzuschalten. Ich vermute set-card-profile 0 output:hdmi-stereo in der Datei dürfte reichen.

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE

  • Das Einfrieren wurde vor Einstellung nomsi mit Treiber nvida-304 behoben. Wenn ich mich traue teste ich das noch mal mit nvida-340.
    Das Problem mit Audio wollt ich eigentlich in diesem Thread wegen OT nicht groß ausbreiten, hat sich wohl etwas verselbstständigt.
    Ist aber gelöst. Lag daran, das ich mangels Bedarf den alsamixer noch nie aufgerufen hatte. S/PDIF war aus.


    Danke allen für Hilfe für VDR-Dummi (ich)!


    André

    ASUS M4N78 PRO, 1xDD-CineCTV6, 1xDD DuoFlex CT (V2), 1x Technisat SkyStar2, 1xAirstar2, 1xCreatix Polymedia Medion 7134
    yaVDR 0.6.0

  • Noch ein Nachtrag: Ich habe eben auch auf meinem älteren Asus M4N78Pro Motherboard einmal die pci=nomsi Option aus Grub rausgenommen. Die Ursache des Problems ist wohl ein Resourcenkonflikt inbesondere mit dem forcedeth Netzwerk Treiber, der auf vielen NVidia Chipsatz Boards zum Einsatz kommt. Der forcedeth Treiber scheint oft zu Problemen mit Hängern bei Netzwerk, Bildschirm usw. zu führen. Um das Problem dauerhaft bei mir auszuschalten reichen folgende Befehle als root auszuführen:


    Code
    1. echo options forcedeth msi=0 msix=0 >> /etc/modprobe.d/options
    2. update-initramfs -u
    3. reboot


    Für weitere Info siehe hier und hier

    Stable: YaVDR 0.4, Asus M4N78 Pro mit nVidia 8300, Atric IR, Athlon 235e/2GB RAM, HVR-4000, 2xNova S2, Onkyo SR875, Samsung TV
    Testing: YaVDR mit Zotac ND 22, Hama MCE