Suche asound.conf für vernünftige Wiedergabe von DD 5.1

  • Ich muss euch schon wieder mal mit der Tonausgabe nerven.
    Ich benutze eine GT630, Tonausgabe über Hdmi und SofthdDevice. Ich habe nun alle Einstellungen über das Webif durchprobiert (momentan läuft Audio über Hdmi Passthrouh) und auch schon in der asound.conf herumgespielt, kriege es aber nicht hin, dass bei Aufnahmen oder Live TV in Dolby der Ton vernünftig rüberkommt. Dialoge sind kaum zu verstehen, die Hintergrundmusik schon.(Bei Tonausgabe Stereo funktioniert es natürlich). Spiele ich die Aufnahme direkt über den TV ab, ist alles ok.
    In den Einstellungen zu Softhddevice kann ich nur PCM Passthrough einstellen, bei AC3 Passthrough höre ich nur ein Knattern...
    Woran muss ich drehen, damit auch Dolby digital funktioniert?
    (bzw. hat jemand eine funktionierende asound.conf)


    Vielen Dank schonmal
    Dumpfbacke

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)

  • Was hat Du denn da als Anlage ? Receiver mit HDMI/Audio Eingang der Dolby versteht oder VDR direkt an Fernseher angeschlossen ? Und was heisst "Spiele ich die Aufnahme direkt über den TV ab, ist alles ok" - Meinst Du damit dass Du das Programm live am TV ansiehst mit Dolby Ton, empfangen ueber den Tuner des TV ? Oder hast Du die VDR .ts file auf eine SD getan und dann direkt auf dem TV abgespielt und sichergestellt, dass der auch den Dolby Ton nimmt ?


    Mein "Billig"-Fernseher von Panasonic (800 Teures, 2 Jahre alt) kann kein 5.1 decodieren. Hat auch einiges an Zeit gekostet bis ich damals ueberhaupt erst auf die Idee kam, das der sowas fundamentales nicht kann und dann in die spec geschaut habe.

  • Der vdr ist über hdmi am Tv angeschlossen. Am Tv hängt eine Panasonic soundbar, die Dolby, DTS etc. dekodieren kann. Genau so ist mein bluray player angeschlossen. Über ARC leitet der Tv den Ton an die Soundbar.
    Funktioniert beim bluray problemlos.
    Über Tv abspielen: Mache ich mit dem Mediaplayer des Fernsehers, der mir die unter "recordings" freigegebenen ts.-files problemlos abspielt (auch gesplittete ohne Pause )

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)

  • versuch doch mal folgendes:
    unter System/Einstellungen/plugin/Softhddevice:
    *Audio: anzeigen
    ob AC3 pass-through und E-AC-3 pass through auf Ja gesetzt sind.


    Ich hatte genau das selbe Problem, bei DD5.1 fehlte der Mittel Kanal, die beiden Parameter waren off


    Gruss Willi

    TV: Samsung SUHD UE55JS9090
    Sound: Onkyo TX-NR636 mit 5.1 Teufel Set


    VDR1: Reelbox AVG2 mit NAS QNAP 12 TB
    Streamingclient1: Intel NUC mit Openelec XBMC 12.2
    Streamingclient2: Arctic MC001


    VDR2 (Neu) Server auf Basis yavdr 0.5 (stable) headless Asus H97M-E Core i3-4130T 12Gb Ram 56Gb SSD 3TB WD-Red
    Client1 VDR yavdr0.5/Frodo ppa (stable) ASRock B85M-HDS Core i3-4130T 4Gb GT730 Zotac
    Client2 Arctic MC001 OpenElec XBMC 12.2


    VDR3 (testing) INTEL Nuc D34010WYK wahlweise mit Openelec 5.0.5 oder BM2LTS V2.61A
    Kodi 14.2 oder Kodi 15.0 Alpha

  • Habe ich oben schon geschrieben, wenn ich im softhddevice ac3 passthrough einstelle, habe ich nur ohrenbetäubendes knattern.

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)

  • Der vdr ist über hdmi am Tv angeschlossen. Am Tv hängt eine Panasonic soundbar, die Dolby, DTS etc. dekodieren kann. Genau so ist mein bluray player angeschlossen. Über ARC leitet der Tv den Ton an die Soundbar.
    Funktioniert beim bluray problemlos.
    Über Tv abspielen: Mache ich mit dem Mediaplayer des Fernsehers, der mir die unter "recordings" freigegebenen ts.-files problemlos abspielt (auch gesplittete ohne Pause )



    Danke fuer die Erklaerungen. Womit exportierst Du denn das Aufnahmeverzeichnis so dass der Panasonic das mounten kann ? Muss ja irgendein UPnP server sein, odr ? Habe auch Panasonic und fand das alles grauselig...


    Ansonsten: Da ich mich ja mit dem softhddevice nicht auskenne kann ich nur empfehlen zu probieren, ob Du das mit dem sound mit einem anderen Program hinbekommst. VLC, XBMC oder so. Dann weisste wenigstens ob es irgendwie and Deiner Systemconfig liegt oder am softhddevice.

  • Dumpfbacke :


    Hast Du beim Plugin-Aufruf die AES0-Parameter hinzugefügt?
    Wenn nicht, wird wahrscheinlich genau das Dein Problem sein.

    Code
    1. Beispiel:
    2. -a hdmi:AES0=0x4 -p hdmi:AES0=0x6


    CafeDelMar


    PS: Am besten erstmal ohne eine asound.conf probieren, die solltest Du eigentlich gar nicht brauchen.


    PPS: AC3-Passthrough solltest Du einschalten, Downmix aus.

  • Quote


    Danke fuer die Erklaerungen. Womit exportierst Du denn das Aufnahmeverzeichnis so dass der Panasonic das mounten kann ? Muss ja irgendein UPnP server sein, odr ? Habe auch Panasonic und fand das alles grauselig...


    Ich exportiere gar nichts. Der Mediaplayer im neuen Panasonic kann direkt auf alle freigegebenen Ordner zugreifen, ich wähle nur den aufnahmeordner aus, dann spielt er alle ts darin nacheinander ab.
    @cafe delmar
    Wo trage ich den Aufruf ein?

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)

  • Du kannst es auch mal mit den folgenden Parametern für softhddevice probieren:


    -p hw:1,7 -a hw:1,7


    Die erste zahl steht für die Nr. der Soundkarte, die zweite für das Gerät. Im zweifelsfall kannst du das mit aplay -l überprüfen.


    In den Einstellungen von softhddevice musst du noch ac3 passthrough und pcm passthrough einstellen.


    Bei allen anderen Varianten, die ich mit der asound.conf probiert habe, hatte ich das Problem, dass entweder gar nicht vernünftiges herauskam oder das es beim Wechsel des Soundformats, oder beim Kanalwechsel Störgeräusche gab. Mit dieser Variante ist es egal, was in asound.conf steht.


    Falk


  • Ich exportiere gar nichts. Der Mediaplayer im neuen Panasonic kann direkt auf alle freigegebenen Ordner zugreifen, ich wähle nur den aufnahmeordner aus, dann spielt er alle ts darin nacheinander ab.


    Probiere hier gerade so'n Pana TV mit file sharing zum laufen zu bringen, verstehe aber nicht wie ich auf dem linux-VDR Rechner einen "Ordner Freigeben" soll. Kannst DU mal erlkären, wie Du das machst ?


    Danke!

  • Ich nehme an, du hast nicht yaVdr installiert, dort ist es so gemacht:
    Für die Freigabe ist samba installiert, in der /etc/samba/smb.conf ist ein include


    include = /etc/samba/smb.conf.yavdr.recordings


    die include Datei sieht so aus:


    Hope this helps
    Dumpfbacke

    VDR1: Asus q1900 Pro M, 2GB, Cine2 Dual DVB S2,Atric USB, yaVDR 0.6 stable, Gehäuse Modushop CD21

    VDR2: RaspBerry Pi2 mit MLD 5.3 als Client
    Ausgemustert: VDR: ASUS M2N-SLI,2GB, TT1600, Zotac GT210, yaVDR 0.4 im Mozart SX Gehäuse, Atric
    Ausgemustert: VDR: Activy 300 , FF Fusi 1.3 + , Celeron 1100, Gen2Vdr AE (momentan defekt)

    Ausgemustert: VDR: Lintec Senior Gehäuse,Technotrend 1.6, Siemens D1215 Mainboard mit Celeron 1000,Pabst Lüfter, EasyVDR 0.5, KäptnKoma Display 260x64,Schäfer Front (ausgemustert)

  • Danke.


    Hatte zuerst versucht am Pana die IP-adresse des VDR einzugeben, das ging garnicht.


    Und dann den Fehler gemacht das Verzeichnis mit meinem kompletten Archiv freizugeben. Der Mediplayer vom Pana ist ja eine Katastrophe, da kommt die ewige, unstrukturierte Liste die nach der Quersumme der Mondphase der Aufnamen sortiert ist. Widerlich. Warum koennen die nicht einfach den VDR auf ihre CPU portieren statt so einen #$^%&^%#& :D


    Ist ja ganz nett dass die 2014'er Generation jetzt CIFS direkt kann, früher (2012'er Fernseher) konnten die nur UPnP, allerdings war beim UPnP die MediaDarstellung noch etwas besser, und der UPnP-Server auf meinem VDR hat wohl auch noch die Dateien besser angepasst, so dass da mehr abgespielt wurde. Aber das ganze Konzept von "ich muss mir jedes Jahr einen neuen Fernseher kaufen damit ich aktuelle Mediaspieler Software bekomme" ist ja eh fuer die Tüte.

  • @cafe delmar
    Wo trage ich den Aufruf ein?


    Ich kenne mich mit yaVDR nicht aus. Aber es gibt mit Sicherheit irgendwo die Möglichkeit, Plugins eigene Parameter mitzugeben, und dort müssen die Angaben für softhddevice rein.


    Der AES0-Parameter sorgt dafür, dass Deine Soundbar den DD-Ton erkennt und kein Knattern mehr ausgibt.


    CafeDelMar