Posts by te36

    Jo, Ich konnte auf die schnelle die transponderparameter nicht rausfinden. technisch gehen wohl bis 60Mbps, aber da man die nicht leicht in kabelnetze uebertragen kriegt werden die wohl ungern genommen.


    bei multicast ist es ja eigentlich nicht schlimmer als bei unicast solange die switches IGMP snooping machen (Unifi oder so): Der Port vom SATIP server zum switch kann ja beliebig voll sein.


    So ein grundrauschen kann natuerlich alle arten von problemen hervorkitzeln, vor allem wenn man vorher nur TCP im ethernet verwendet hat. Aber schon witzig. Schaun mer mal..

    Ging mir ja nur um die Bandbreitenberechnung. Wenn man sich denkt, ein TV Kanal hat nur, z.b.6 Mbps, aber man bekommt halt einen kompletten 60 Mbps transponder, dann kann das schon ueberraschen. So ein breitbandkabel mit splittern arbeitet ja schon ein wenig anders als ethernet mit switches.


    Mal gucken, ob/wieviele Pakete da so verloren gehen im ethernet vom SATIP server.

    Ah, ok. JETZT kapiere ich es. Bloss in welche VDR Wiki Seite passt die Erklaerung am besten ;-)


    Ich hab ja frueher immer gesehen, das auch neue Transponder hinzugekommen sind. Deine Erklaerunge, das da ein "Bouquet" wohl auch information ueber andere Transponder liefert wuerde dann erklaeren, warum man im Laufe der Zeit mehr und mehr Transport kriegt - und dann, wenn man nicht kapiert wie das funktioniert denkt das "VDR macht channel scan".


    Ok, habe jetzt gerade gesehen, das das mit dem anlernen neuer Kanaele auch bei satip funktioniert. Schickt. Muss man dann nur im Netzwerk damit rechnen das jeder SAT-IP Unicaststream halt die volle Transponder Bandbreite hat.

    Was ist denn dieser geheime 'pilot mode' bei DVB ?


    Hab gerade versucht satip zum laufen zu bringen - mit Kathrein EXIP 418, und da gingen dann nur SD Kanaele, aber nicht HD Kanaele. Also im Forum gesucht und gefunden, das es wohl einen 'pilot mode' gibt. Und mit noch mehr wuehlen, zeigt sich, das man das in channel.conf im Parameter Feld konfigurieren kann. Ist aber nicht im VDR wiki, channels.conf beschrieben gewesen, und im vdr manual auch bloss erwaehnt, aber nicht beschrieben.


    Aka: was ist das, was macht das ? Vor allem: macht das irgendwas ausserhalb vom satip plugin ?


    Habs dann mal in channels.conf konfiguriert und danach ging dann auch HD ueber SATIP. Interessanterweise wurden dann auch neu gefundene Kanaele vom VDR mit N1 eingetragen. ALs ich vorher denselben VDR mit einer FF am laufen hatte, wurden Kanaele neu erzeugt OHNE das der N? Parameter eingefuegt wurde. Ich hatte ja auch frueher Kanaele bequem von https://channelpedia.yavdr.com/gen/DVB-S/S19.2E/de/ gezogen, und da ist auch kein N? Parameter drin. Auch merkwuerdig.


    Neben den channels.conf hab ich das auch mal versucht passend im VDR wiki satip plugin zu dokumentieren. Halt das wenige was ich weiss.

    VDR macht keinen 'channel scan', weder mit oder ohne Satip.

    Stattdessen wird auf den bereits vorhandenen Tranpondern nach weiteren geschaut. Was auf bereits vorhandenen TP nicht zu finden ist, wird nicht zur Kanalliste hinzugefügt.

    :huh:

    Versuche das was Du erklaerst mit dem zusammenzubringen was ich auf meinem Produktivsystem gesehen habe..


    was macht denn VDR ohne plugins genau ?


    Schaltet der selbsttaetig "ungenutzte" tuner im hintergrund auf kanaele aus der channels.conf und "guckt dann" was auf dem transponder = (MP)TS von dem kanal sonst noch alles ist (pid/programm/..) und erneuert dann je nach VDR konfig seine kanalliste ?


    Aber wie ist das dann bei satip ? Wenn man da einen kanal empfaengt, was macht der satip server ? Schickt der den kompletten transponder oder nur den angeforderten kanal ? Wenn der satip server nur den angeforderten kanal schickt und nicht den ganzen transponder, dann waere das ja ein entscheidender unterschied ?

    Versuche gerade neues VDR auf Testsystem aufzusetzen, eigentlich um auf satip zu gehen, aber im Moment mal bloss mit einer eingebauten FF konfiguriert.


    Das system sagt mit jetzt "channel not available", wenn ich auf einen HD channel gehe. Will (wohl deswegen) auch keine Aufnahmen von HD Kanal machen wollen.


    Ich dachte mich erinnern zu koennen, das die FF Karte doch HD transponder empfangen = aufzeichnen kann, bloss halt nicht dekodieren/widergeben. Oder ist das falsch ?


    Gibts da eine diagnose dafuer warum VDR sagt "channel not available" ?

    Danke fuer die Hinweise mit den Plugins. Mir geht es aber erst mal darum, zu kapieren:


    a) Wie vergleicht sich die Funktionalitaet von satip zu pci dvb karten MIT BOARDMITTELN, also ohne weitere plugins. Einfach weil ich ja halt von PCI auf SATIP migrieren will und den vergleich brauche. Und ims mal im wiki zu dokumentieren. Wenn also etwas mit dem satip plugin native nicht geht sondern plugin braucht wofuer man mit pci dvb kein plugin braeuchte will ich das gerne dokumentieren.


    b) Wie man am einfachsten diagnostizieren kann, ob da ueberhaupt channel scan gemacht wird. Aber das scheint ja leider ein wenig wie "magie" programmiert zu sein. passiert im hinergrund ohne das man es diagnostizieren kann

    Versuche gerade vdr-2.2 mit satip zum laufen zu bringen, erstes mal, das ich satip ausprobiere.

    satip server ist kathrein 418 an astra S19.2E


    Q1: http://www.vdr-wiki.de/wiki/index.php/Satip-plugin

    • SAT>IP Satelliten Positionen (signal sources) können in vdrs sources.conf hinzugefügt werden. Wenn eine source Beschreibung mit einer Nummer beginnt wird diese als SAT>IP Signalquelle verwendet. Mit '0' kann man eine Signalquelle deaktivieren, andernfalls wird der Standard '1' verwendet.


    Bahnhof. Die Saetze kapiere ich vorne und hinten nicht.


    "koennen in vdrs" soll ja wohl "muessen" heissen, zumindestens steht im README des plugins "shall".


    Aber was macht die Nummerierung dann ? b.z. was passiert, wenn man da keine Nummern einfuegt ?


    Also ich habe da erstmal nicht an sources.conf rumgepfuscht und auch keine parameter fuers sat-ip plugin gemacht. vdr sagt dann:


    SATIP poller thread started (pid=15054, tid=15076, prio=high)

    SATIP: Creating device CardIndex=1 DeviceNumber=1 [device 0]

    SATIP#0 tuner thread started (pid=15054, tid=15078, prio=high)

    SATIP#0 section handler thread started (pid=15054, tid=15079, prio=high)

    SATIP: Creating device CardIndex=2 DeviceNumber=2 [device 1]

    SATIP discover thread started (pid=15054, tid=15077, prio=high)

    SATIP#1 section handler thread started (pid=15054, tid=15082, prio=high)

    SATIP#1 tuner thread started (pid=15054, tid=15081, prio=high)

    SATIP: Using CURL 7.74.0 rtsp

    SATIP: Adding server '192.168.42.42|DVBS2-8|satip' Bind: default Filters: none CI: no Quirks: none


    Q2: Wie kriege ich VDR jetzt dazu einen channel scan zu machen so das Kanaele in der channels.conf auftauchen ?


    Operating mode: high

    Enable EPG Scanning: yes

    Disabled Sources: none

    Disabled Filters: none

    Untermenu fuer den SATIP Server:

    Active: yes


    Ich hab im channels.conf mal einen kanal drin (ARD), von einem VDR mit DVB-S2 PCI karte, der wird auch prima empfangen und widergegeben.


    Aber kann bei Onkel google nix finden, wie ich den vdr dazu bringe, weiter zu scannen. Wenn ich ueber SVDRP ein SCAN absetze sagt er das er einen channel scan absetzt, sonst kommt da aber kein weiterer log (log steht auf 3 vom vdr).


    Danke!

    Habe VDR seit 2007 auf gentoo laufen und das system im Prinzip nie neu aufgesetzt sondern immer nur nachgezogen.

    Leider scheint ja gentoo stale zu werden, also ueberlege ich, was ich da jetzt mal neu aufsetzen sollte, und bin derzeit bei debian haengen geblieben.

    Allerdings nicht wirklich gluecklich, und noch nicht wirklich weit gekommen - produktionsserver laeuft weiterhin mit ewig altem gentoo, bastel-vdr mit gentoo.

    Vielleicht gibts ja auch Empfehlungen fuer eine andere distribution.


    Habe derzeit buster am Laufen, aber weil ich noch mehrere RPI clients mit vdr-2.2 habe, muss ich auf dem server erstmal vdr 2.2 installieren. Das gestaltete sich schon als nerviges unterfangen, weil ich dazu halt noch stretch repos ins system reinbinden musste, weil nur dort vdr-2.2 verfuegbar ist. Bei gentoo war es viel einfacher moeglich, eine bestimmte version eines packages zu installieren, weil halt immer die letzten N versionen im repository zur verfuegung standen,und selbst wenn nicht konnte man sich trivialst die package files zum system dazutun. Bei debian kann ich keine Doku finden ob es was vergleichbares gibt, und dieser Mist mit repos von aelteren debian distos einzubinden laesst mich nicht sehr zuversichtlich fuer debian sein.


    Als zweites wollte ich noch das IPTV plugin einbinden, aber das finde ich weder in debian noch in squeez. Allerdings liegt es als package auf salsa.debian.org. Bloss finde ich keine Erklaerung warum das wie viele der dortigen Packages dann nicht in den distros drin ist.


    Im moment sieht das fuer mich so aus, als ob der ganze debian package krams eben nur einen teil der vdr programme als packages hat, und man auch nicht die versionen leicht waehlen kann, und wenn man dann versuchen muss noch plugins von quelle dazu zu compilieren finde ich auch keine Beschreibung wie ich das gegen die packages vom debian machen kann.


    yada yad yada: Scheint mir im moment so zu sein, als ich ich die ganze debian paketverwalteung vergessen sollte und einfach manuell alle vdr pakete/plugins selbst compiileren und nach /usr/local installieren sollte.


    Kann das sein, das frueher mit gentoo alles besser war als heute mit debian ? Ausser man braucht zufaellig nur genau das was sich die debian goetter als teilmenge der pakete und einzig unterstuetzte versionen vorstellen ?


    Sorry fuer den rant..

    Jo, Diseqc ist natuerlich auf beiden VDR eingeschaltet.

    6ter ausgang geht jetzt auf die giga blue STB.


    Hatte mir einen kleinen Adapter gebaut um sie spannung auf einem Kabelanschluss abzugreifen. Sehe, das da immer brav um die 13v drauf sind, und wenn SCR/Disecq gesendet wird gehts auf naja, wohl 18v hoch (hab bloss multimeter mit minimal-oszi funktion). Also nix offensichtlich kaputtes.


    Ich habe jetzt mal verteiler kaskadiert: LNB -> (neuer-vdr, 2ter-verteiler), 2ter-verteiler-(restliche5 anschluesse). Damit geht es jetzt.


    Der alte 4-fach verteiler den ich jetzt als ersten einsetze ist von kathrein, der neue 6-fach ist von dur-line. Eigentlich muesste ich ja jetzt nochmal einen 6-fach verteiler von einer anderen firma kaufen zum vergleichen. Von Kathrein gibt es das nicht identisch. Schwaiger sehe ich noch Bei amazon. Empfehlung ?

    Hab noch zum test einen GigaBlue UHD UE angeschlossen, aber der alleine verursacht keine Probleme. Scheint also ein Problem vom ersten BDR zu sein.


    Wenn ich beim aktiven VDR einen von den vier Antennenanschluessen am Verteiler trenne, dann kommt der zweite VDR durch und kann umschalten. Ist bloss egal welches. Von daher kapiere ich nicht, was da passiert.


    S19.2E 11700 V 9750 t V W50 S0 [E0 10 5A 00 00] W10 v

    S19.2E 99999 V 10600 t V W50 S1 [E0 10 5A 00 00] W10 v

    S19.2E 11700 H 9750 t V W50 S2 [E0 10 5A 00 00] W10 v

    S19.2E 99999 H 10600 t V W50 S3 [E0 10 5A 00 00] W10 v


    Macht keinen Unterschied. wenn ich W50 hinten reinsetze dann kann der neue VDR nicht umschalten (auch wenn er nur alleine am Kabel haengt). Anscheinend kann man also auch zu lange warten...


    tscha. so ohne diagnosetools ist kaese. Bei guter Software sollte man ja debuggen koennen, was da disq messig gesendet wird. scheints ja leider nicht zu geben.





    Hi,

    versuch mal mit

    Code
    1. S19.2E 11700 V 9750 t v W15 [E0 10 38 F0] W15 A W15 t
    2. S19.2E 99999 V 10600 t v W15 [E0 10 38 F1] W15 A W15 T
    3. S19.2E 11700 H 9750 t V W15 [E0 10 38 F2] W15 A W15 t
    4. S19.2E 99999 H 10600 t V W15 [E0 10 38 F3] W15 A W15 T

    CU

    9000h

    Kannst Du erklaeren, was das machen sollte ? da sind ja keine Sxx drin, und die braucht man ja wohl fuer SCR. Ausserdem sind die [..] befehlssequenzen unterschiedlich. Das sieht eher aus wie eine non-SCR konfiguration ??

    Ach ja, eine falsche diseqc.conf auf dem funktionierenden VDR kann die Leitung für alle blockieren, wenn nicht auf 14V herunter geschaltet wird am Ende der Sequenz.

    Jo, das am mir auch als erstes in den Sinn, aber die sequenzen die ich habe machen ja tone off (t) und voltage low (v):


    S19.2E 11700 V 9750 t V S0 [E0 10 5A 00 00] v

    S19.2E 99999 V 10600 t V S1 [E0 10 5A 00 00] v

    S19.2E 11700 H 9750 t V S2 [E0 10 5A 00 00] v

    S19.2E 99999 H 10600 t V S3 [E0 10 5A 00 00] v

    Erster VDR 2.2.0 mit 4 x DD Cine S2 V6.5. Lief ca 10 Jahre prima an altem Unicable LNB.

    Aufgeruestet auf: https://www.amazon.de/gp/product/B084662RQ1, keine config aenderungen noetig, laeuft immer noch prima.


    Grund der aktion war, einen zweiten VDR anzuschliessen, eigentlich bloss um langsam von eiem 10 jahre alten Gentoo wegzukommen und spaeter auch mal vdr auf 2.4 und spaeter hochzuruesten (geht derzeit nicht, weil zuviel RPI VDR clients mit 2.2.0 laufen, muss da erst noch eine RPI installation basteln die automatisch 2.2 oder eine neuere version started je nachdem welche version auf dem server laeuft..) Anderes Thema. Bloss "rueste mal auf 2.4. auf" hilft mir im moment nicht.


    Zweiter VDR hat jetzt nur eine FF, SCR konfiguriert auf einem freien kanal (e.g: "4 1005", habe auch andere probiert). Laeuft prima solange der erste VDR nicht laeuft (VDR prozess nicht starten reicht).


    Alter und neuer VDR ueber diesen Verteiler angeschlossen (4x auf den alten, 1x auf den neuen): https://www.amazon.de/gp/product/B01F97YY50


    Problem: Wenn erster VDR laeuft, dann kann zweiter VDR nicht umschalten. Schwarzed bild. Manchmal/selten geht es, aber nicht zufaellig sondern bei festen programmen, glaube also eher das das halt der transponder ist, wo die SCR-ID eh schon drauf getuned ist.


    Manchmal gibt es beim umschalten: "frontend 0/0 timed out while tuning to channel", aber nicht immer.

    Der erste VDR kann weiterhin prima umschalten wenn der zweite VDR laeuft.


    diseq.conf ist default auf beiden VDR:


    S19.2E 11700 V 9750 t V S0 [E0 10 5A 00 00] v

    S19.2E 99999 V 10600 t V S1 [E0 10 5A 00 00] v

    S19.2E 11700 H 9750 t V S2 [E0 10 5A 00 00] v

    S19.2E 99999 H 10600 t V S3 [E0 10 5A 00 00] v


    Bloss live und dvbsddevice plugins am laufen, nix anderes (neuer VDR).


    Das es ab und zu mal diseq kollisionen gibt, kein thema, aber es geht halt im prinzip nie.


    Habe auf dem neuen VDR auch bloss einen clone vom ersten im moment laufen, also alle merkwuerdigen parameter sollten identisch sein. habe bloss scr.conf angepasst und plugins entfernt. Bloss live und dvbsddevice plugins am laufen, nix anderes (neuer VDR).


    Wie kann man hier troubleshooting machen, hab ich vielleicht doch irgendeine config vergessen ?

    e.g.: DiseQ logging. Wann faengt er an, wann hoert er auf diseq zu senden ?


    gibt es guenstige messgeraete die helfen wuerden ?


    HELP :O

    Bei meiner Unicableeinrichtung hatte ich ein ähnliches Problem. Ich fand heraus, daß in der scr.conf von "0" an gezählt wurde, auf der Verpackung aber ab "1".

    Das hat mich auch gerade einen Tag gekostet bei meinem neuen vdr. Habe das jetzt im wiki dokumentiert:


    http://www.vdr-wiki.de/wiki/index.php/Scr.conf

    (Hinweis am Ende)


    Besser noch ware es, wenn ein passender Kommentar in die Kommentarabteilung des scr.conf in den vdr quellen reingebaut wuerden koennen, weiss leider nicht wie man das beantragt. Pull request im git ?