FritzBox Plugin und neuste Laborfirmware für 7270

  • Hallo
    ich benutze die Fritzbox 7270, mit der neusten Laborfirmware (war wohl ein Fehler), aber jetzt kann sich mein
    VDR mit der Fritzbox Plugin 1.5 nicht mehr einloggen.
    Hat einer eine Idee ??
    Ein Downgrade der Fritzbox ist nur mit großem Aufwand möglich :rolleyes: :rolleyes: :rolleyes:
    Thanks
    speed

  • Hallo


    Was ist mit einer Sicherung hast du dir eine Sicherung vorher gemacht wenn ja kannst du die wieder drauf geben. Wenn nein hast du auf jeden Fall dir einiges an Arbeit gemacht. ?(


    MfG

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • hoi,


    mit dem recover-image geht das immer...
    ftp://ftp.avm.de/fritz.box/fri…n_7270_v3/x_misc/deutsch/

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Hallo
    die alte Firmware wieder aufzuspielen, stellt für mich kein Problem dar.
    Meine ganzen Settings muß ich dann von Hand einpflegen :rolleyes: :rolleyes: :rolleyes: .
    Was muß mann denn am Plugin ändern, damit das login wieder funktioniert ??
    Gruß
    speed

  • Ok 3PO jetzt hast du einen neuen Freund..
    habe ich natürlich gemacht, das Plugins zeigt zb ankommende Anrufe an, aber ich kann nicht mehr ins Telefonbuch.
    Und es kann auch nicht mehr die Umsetzung von Nummern zu Namen , aus dem Telefonbuch .
    Thank
    Speed

  • Hallo
    er sagt immer Passwort falsch ..ist aber korrekt ..schau hier
    Dec 16 20:14:27 vdr: [9343] [libfritz++/FritzClient.cpp:228] login failed, check your password settings.
    Dec 16 20:14:27 vdr: [9343] [libfritz++/FritzClient.cpp:304] Looking up SIP Settings...
    Dec 16 20:14:28 vdr: [9343] [libfritz++/Tools.cpp:284] Parser error in GetSipSettings(). Could not find SIP list.
    Dec 16 20:14:28 vdr: [9343] [libfritz++/Tools.cpp:285] SIP provider names not set! Usage of SIP provider names not possible.
    Dec 16 20:14:28 vdr: [9343] Fritz Plugin Initialization thread ended (pid=9319, tid=9343)
    Dec 16 20:14:28 vdr: [9375] [libfritz++/Listener.cpp:120] Listener thread started
    Dec 16 20:14:28 vdr: [9374] [libfritz++/CallList.cpp:123] CallList thread started
    Dec 16 20:14:28 vdr: [9373] [libfritz++/FritzFonbook.cpp:49] FritzFonbook thread started
    Dec 16 20:14:28 vdr: [9375] [libfritz++/Listener.cpp:128] Waiting for a message.
    Dec 16 20:14:28 vdr: [9374] [libfritz++/FritzClient.cpp:213] logging into fritz box using old scheme without SIDs.
    Dec 16 20:14:29 vdr: [9374] [libfritz++/FritzClient.cpp:228] login failed, check your password settings.
    Dec 16 20:14:29 vdr: [9374] [libfritz++/FritzClient.cpp:320] sending callList request.
    Dec 16 20:14:31 vdr: [9374] [libfritz++/FritzClient.cpp:345] Exception in connection to 192.168.1.100 - Could not connect
    Dec 16 20:14:31 vdr: [9374] [libfritz++/FritzClient.cpp:345] waiting 60 seconds before retrying
    Dec 16 20:14:44 vdr: [9346] epgsync thread ended (pid=9319, tid=9346)

  • Bei AVM gibts irgenwo nen PDF was die diversen Loginvarianten genau erklärt/beschreibt. D.h. da steht genau beschrieben was Programme tun müssen um da Daten über HTTP von der Fritz.Box zu bekommen.


    So aus der Erinnerung... da was umgestellt das nur noch der Hash gesendet wird (oder so ähnlich). Und vom alter des letzten FritzBox Plugins Releases... da müsste vermutlich irgendwer mit richtigen C Kenntnissen (und nem Blick auf dieses PDF) mal gründlich ans Plugin ran.


    cu

  • Tja, dann auf die alte Firmware zurück und warten bis sich jemand mit Ahnung drum kümmert ;)



    War nur als Hinweis gedacht wie man dem Problem auf die Spur kommen könnte. Halt das PDF suchen (mit dem SOLL vor Augen fällt sowas ja leichter) und dann schauen was das FritzBox Plugin macht und wie die Box drauf reagiert. Damit sollte sich der Grund finden lassen.


    cu

  • Hallo
    ich habe gerade mal Joachim Wilke (Fritzbox Plugin Entwickler) angeschrieben zu meinem Problem.
    Und er hat mir folgendes geantwortet :
    Hallo Carlo,


    AVM hat mit dem Update auf FW *.50 den Login für externe Anwendungen
    kaputt gemacht. Ich stehe derzeit in Kontakt mit AVM, da derzeit ein
    Login von externen Anwendungen (wie z.B. das Plugin) über die von AVM
    vorgesehene Schnittstelle überhaupt nicht möglich ist. Es hängt also an
    AVM wie schnell das ganze wieder funktionieren wird.


    Viele Grüße,
    Joachim.


    Naja nicht schön, wollen wir mal das beste hoffen :]
    speed

  • Bei AVM gibts irgenwo nen PDF was die diversen Loginvarianten genau erklärt/beschreibt. D.h. da steht genau beschrieben was Programme tun müssen um da Daten über HTTP von der Fritz.Box zu bekommen.


    So aus der Erinnerung... da was umgestellt das nur noch der Hash gesendet wird (oder so ähnlich). Und vom alter des letzten FritzBox Plugins Releases... da müsste vermutlich irgendwer mit richtigen C Kenntnissen (und nem Blick auf dieses PDF) mal gründlich ans Plugin ran.


    cu

    Die Doku ist diese hier: http://www.avm.de/de/Extern/Technical_Note_Session_ID.pdf
    An die hält sich das Plugin schon seit 2009, die letzte Plugin-Version ist vom März diesen Jahres. Nur wie schon gesagt, mit der aktuellsten FW tut es nicht mehr. Mehr dazu, wenn AVM sich gemeldet hat.