XBMC IOS/ATV2 Builds inkl. PVR Support

  • In diesem Thread möchte ich meine Build von XBMC inkl. PVR Support zur Verfügung stellen:


    Zu finden sind die Builds hier:


    http://xbmc.picmania.org


    Meine letzten Builds sind vom 22.07.2012, neue werden bald folgen.


    Alternative Builds gibt es auch im XBMC Forum hier: http://forum.xbmc.org/showthread.php?t=94905&page=11


    Grüsse
    TheChief

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 15 times, last by TheChief ().

  • Ich hab mal eine Testversion hochgeladen, wäre auf ein Feedback gespannt. Vielleicht findet ja jemand raus, wie man das auf dem iPhone
    bedient und ob PVR überhaupt funktioniert.


    Zuerst muss cURL via Cydia installiert werden.


    Danach das XBMC Iconpack.
    http://xbmc.picmania.org/ios/o…ck_1.0-0_iphoneos-arm.deb


    Und dann XBMC.
    http://xbmc.picmania.org/ios/x…s_10.0-7_iphoneos-arm.deb


    Das ganze am besten via SSH und dpkg -i.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 1 time, last by TheChief ().

  • Habe deine Version nicht versucht, aber im XBMC-Forum gibt es auch eine IOS-Version.
    Habe diese getestet und funktioniert supi. einmal ist mein iphone gecrasht.
    Aber an sich geht es- auch vnsi!!!!. Hier gibt es diese.


    Zur bedienung:
    Bei mir geht es, wenn ich in der Mitte auf den Balken drücke und dann zum Rand schiebe.
    Am Rand dann kurz verweilen.


    MfG
    FatFred

  • Dann brauch ich ja theoreitsch keine Builds machen?! Oder besteht Interesse?


    Wie installiert man die .deb's?


    EDIT: Hab was gefunden


    Code
    1. To install them on your iPhone follow the next steps:
    2. 1. SFTP or SCP your deb file into /tmp
    3. 2. SSH into your iPhone with Terminal and type: dpkg -i /tmp/filename.deb


    EDIT: Konnte inzwischen das VNSI Addon aktivieren. Verbinden tut es sich zwar, aber irgendwie hängts bei "In Arbeit".

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 2 times, last by TheChief ().

  • Meinerseits besteht auf jeden fall interesse an aktuellen builds.
    Ich glaube nicht das amet weitere builds anbietet.
    So wie ich das sehe, hat er nur die anpassungen gemacht, welche auch in opdenkamps git gelandet sind.


    Habe es eben noch mal versucht. Da hat er sich auch nicht verbunden.
    Musste XBMC im Taskmanager nochmal schliessen und dann ging es wieder.
    Braucht aber SEHR lang zum verbinden - also warten ;-)


    MfG
    FatFred


  • Dauerts mit Deiner Version so lange oder hast Du meine getestet?


    Einmal hatte ich auch eine Verbindung, aber das LiveTV ruckelte nur vor sich hin. Also scheint noch recht
    suboptimal zu laufen. Aber ansich sollte es doch fast der gleiche Code, wie für OSX oder Linux sein.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Habe noch die Version aus dem XBMC-Forum drauf.
    Als ich es eben nochmal versucht habe, war es wie bei dir.
    Starkes ruckeln und zweimal Totalcrash (iphone ist neu gestartet).
    Erst beim dritten versuch lief es dann mal. Aber erst nach 20 sek.
    Erst nur Bild. dann steht Bild und nur Ton und dann lief es!?!


    Denke, das ich deine nicht noch testen muss, oder?
    Das verhalten ist ja gleich (ähnlich).


    MfG
    FatFred

  • Da die Linux Version momentan auch nicht wirklich bei mir funktioniert, hoffe ich,
    es liegt daran. Hab heute meinen Linux Client aktualisiert, sobald ich Live TV
    konfiguriere, stürtzt XBMC inkl. XServer ab.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Ich habe mir den Take 4 installiert aus dem XBMC Forum, habe eine aktuelle vdr-vnsi Version aus dem GIT kompiliert und installiert und kann nun auf dem Apple TV 2:


    - Live TV und Aufnahmen ansehen (allerdings nur interlaced ohne Ruckeln by hoher Bandbreite)
    - Timer setzen/ändern/löschen


    und halt alles was auch XBMC so kann.


    Wegen des Interlaced kann es meine Frau noch nicht überzeugen (die sieht noch lieber mit der MediaMVP), aber das kann sich vielleicht noch verbessern.

    Debian 11 Bullseye, ASRock J3455-ITX, DVB-S2 quattro, Raspi 3+ (Kodi-VNSI), 1 Raspi A+ (VOMP)

  • Auch ier hab ich mal neue Build für IOS und ATV2 bereit gestellt. Auf dem iPhone läuft das VNSI-Addon aber bei mir noch nicht
    wirklich. Die Verbindung zum VNSI-Server scheint tierisch langsam zu sein. Hat jemand eine Idee, wieso das so ist? Braucht schon 5-10
    min ehe die EPG Daten geladen sind. LiveTV ruckelt nur.


    Grüsse
    TheChief


    EDIT: Aufnahmen gehen ein bisschen besser, obwohl auch dauernd zwischengespeichert wird.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 1 time, last by TheChief ().

  • Hallo,


    heute erst entdeckt! Danke für die Arbeit.


    Gerade mal getestet. Läuft hier ganz gut. Ich kann SD TV sogar ruckelfrei über WLAN schauen. HDTV geht leider nicht. Manchmal ist ein hinundher schalten nötig, damit es ohne ruckeln läuft. Im Vollbild läuft es auch besser ...
    Unter Einstellungen -> LiveTV noch einstellen, das er nur 1 Tag EPG syncen soll und das er bei LiveTV nicht syncen soll ...


    Gruß Uwe


    PS: kann man nicht die FB so konfigurieren, das man mit "hoch" und "runter" zappen kann? Es hilft bisher nur lange auf "OK" drücken und dann eine auswahl treffen bzw. lange auf Menu drücken ...

  • Also erstma, auf was hast Du getestet? :D Ich nehme an ATV2 (wegen der Fernbedienung).


    Ich bin kein Entwickler, nur "Kompilierer", aber irgendwo in den Einstellungen gab es auch was zu Apple-Remote. Schau da mal nach.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hoplla, jep genau, ATV2! :D
    Ok, werde mal schauen, ob ich dazu was finde ...

  • Hab die Pakete wieder mal auf den neuesten Stand gebracht.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Kann es sein, dass ich was falsch mache? Deine xbmc Version ist auf dem ATV2 installiert. Ich kann es sogar in den Einstellungen aktivieren. Im Hauptmenü bekomme ich aber eine Fehlermeldung. Er kann den PVR Client nicht finden.


    Hast das addon pvr client aktiviert? Siehe hier.

  • Ja, ich denke schon. In den Einstellungen unter Addons, habe ich etwas zu VDR gefunden, wenn ich dort auf aktivieren gehe, tut sich gar nichts. Direkt in den Einstellungen unter Live TV habe ich die Funktion eingeschaltet. Bei einer der älteren Versionen habe ich dort schon den Fehler bekommen.

  • Hattest Du schon eine ältere Version laufen? Dann musst Du eventuell die alten Einstellungen mal löschen. Unter OSX findet man die unter
    Library/Application Support/XBMC, wie es bei ATV2 ist weiß ich nicht. Anonsten mal Logs vom VDR gecheckt?

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hm, dann scheint sichs ja nicht mal zu verbinden. Zumindest unter OSX und iOS tuts das, also sollte es mit dem
    ATV2 auch gehen. Würde nochmal alle Einstellungen prüfen. Addon konfigurieren und aktivieren sowie Live TV
    aktivieren. Hab leider kein ATV2 und kanns nicht testen.


    EDIT: Kriegs gerade nicht zum laufen. Ich versuchs die Tage nochmal.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 2 times, last by TheChief ().