[ANNOUNCE] iVDR 0.3.3 - VDR WebFrontend for Touch Devices

  • Gut, dann kontrollier ich das nachher nochmal. Momentan komm ich nicht mehr an die Kiste, aber ich prüf das und melde mich!


    Jetzt hab ich wenigstens Gewißheit, wie es funktioniert und kann gezielt suchen. Danke!

    Gruß
    Holger


    HTPC: yaVDR 0.5, M3N78-VM, Athlon II X2 240, 2GB, 2x TT S2-1600, Antec Fusion Remote, Harmony 650, LG 50PK550

  • Hallo Phill,


    Danke für Dein tolles Projekt. Folgendes habe ich bereits geschafft:
    Apache2 installiert
    ivdr.conf angepasst (bis jetzt nur ein paar Punkte)
    Auf dem iPhone erhalte ich schon die Oberfläche und die Kanäle werden angezeigt
    Unter dem Punkt VDR steht jedoch: "No connection to VDR (SVDRP)"
    Beim Versuch nach der Streaming-Anleitung weiter vorzugehen hänge ich bei diesen Punkten:


    und beim configurieren von x264

    Code
    1. vdruser@vdr:/usr/src# cd x264/
    2. vdruser@vdr:/usr/src/x264# ./configure --prefix=/usr
    3. Found no assembler
    4. Minimum version is yasm-0.7.0
    5. If you really want to compile without asm, configure with --disable-asm.


    ?


    Danke und Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

  • Schon ausprobiert?

    Code
    1. E: Einige Archive konnten nicht heruntergeladen werden; vielleicht "apt-get update" ausführen oder mit "--fix-missing" probieren?


    Ansonsten stimmt was mit deinen repos nicht.


    Zu 2. apt-get install yasm denk ich mal.

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices


  • Hallo Kail ich antworte mal hier, dann haben alle was davon.


    Also das Problem mit den libs habe ich heute mittag auch festellen müssen.
    Folgende Zeilen in der istream.sh ab zeile 16 einfügen:

    Code
    1. LD_LIBRARY_PATH="/usr/lib/cgi-bin/ivdr/ffmpeg/lib:$LD_LIBRARY_PATH"
    2. export LD_LIBRARY_PATH


    Allerdings musste ich auch festellen das bei Zeile 59 das -async 2 raus muss. Der neuste ffmpeg kam damit bei mir nicht klar.
    Ist die lösung bei folgender Fehlermeldung:

    Code
    1. Assertion ost->audio_resample failed at ffmpeg.c:902


    Dann noch der at Prozess. Der wird ab und zu benötigt.
    In /etc/at.deny "#" vor www-data

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hallo Phill,


    Deine Änderungen habe ich wie beschrieben eingepflegt. Könntest Du bitte
    die Änderungen beim at Prozess ein wenig ausführlicher erklären. Bei der
    Angabe stehe ich auf dem Schlauch.


    Anbei der aktuelle log:


    Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

  • Ist denn die streamdevhosts.conf richtig konfiguriert? Bei mir ist sie in /var/lib/vdr/plugins/streamdev.
    Gehen denn Aufnahmen zu streamen?


    Der at prozess wird hier nicht unbedingt benötigt, aber du musst die Datei /etc/at.deny mit einem editor öffnen und die zeile www-data mit # auskommentieren.

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hallo Phill,


    streamdev ist (noch) nicht auf dem Test-vdr. Wird umgehend installiert.


    Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Kail ()

  • Hallo,
    streamdev-server ist installiert. Es geht jetzt auch einen Schritt weiter :] 
    Nun erhalte ich 3 Buttons (save, off, delete) und darunter eine schwarze Fläche mit einem
    durchgestrichenen Play-Zeichen.
    Anbei meine conf-Einstellung:


    Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

  • Das www-dir ist noch falsch.

    Code
    1. cd /var/www
    2. ln -s /dev/shm/ram


    In ivdr www-dir = /ram

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hallo Phill,


    die Änderung werde ich heute Abend einpflegen.
    Warum kann ich in der ivdr.conf nicht den Pfad direkt eingeben?
    "wwwdir" => "/dev/shm/ram


    Auf dem Desktop des iPhone steht immer noch unter dem Punkt
    VDR "No connection to VDR (SVDRP)"
    Ist das auf die obrigen Fehler zurückzuführen oder gibt es u.U. noch
    weitere Probleme?


    Danke und Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

  • Zitat

    Warum kann ich in der ivdr.conf nicht den Pfad direkt eingeben?


    Weil der Browser auf das Verzeichnis zugreifen können muss. Und das geht am einfachsten über einen link.



    Schon den SVDRP-Port gecheckt? Oder mal in "/etc/vdr/svdrphosts.conf" schauen!

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hallo Phill,


    :thumbsup: Das Bild ist da :thumbsup:


    Danke für Deine Unterstützung und die tolle Erweiterung des VDR.
    Nachdem ich den softlink gesetzt und die Änderung in der ivdr.conf
    durchgeführt hatte, lief alles.

    Code
    1. cd /var/www
    2. ln -s /dev/shm/ram ram


    Code
    1. ivdr.conf
    2. "wwwdir" => "/ram/", # URI to Workdirectory


    Die Verbindung zum VDR funktioniert nach Überprüfung und Einstellung des
    SVDR-Ports auch.

    Code
    1. netstat -ltnp


    Code
    1. ivdr.conf
    2. $port = "6419"; # Port of SVDRP connection


    Bei einer HD-Aufnahme ist mir aufgefallen, dass die Lippensynchonität nicht
    stimmt. Gibt es dafür eine Einstellmöglichkeit? Es betrifft aber nicht alle
    Aufnahmen oder Live-Streams.


    Danke und Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

  • :/ mhhh, bei mir funktionieren HD Inhalte vom VDR eigentlich gar nicht...


    Kann das also nicht wirklich debuggen. Hast du den Paramater "-async 2" raus nehmen müssen? Der ist nämlich für den audiovideo sync zuständig!

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hallo Phill,


    bei dem HD Material handelt es sich um eine Aufnahme. Live
    hat gestern bei mir auch noch nicht funktioniert.


    Das Tonproblem habe ich aber auch bei SD Live übertragungen.
    Rausgenommen habe ich bis jetzt noch nichts. Soll ich den
    Parameter herausnehmen? Wo steht der denn?


    Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

  • Hallo Phill,


    mit -async=1 ist es perfekt. Super!
    -async=2 geht bei mir auch nicht.


    HD Kanäle gehen bei mir nur über den Umweg einer Aufnahme. Die Aufnahme
    wird dann normal wiedergegeben. Der Timer für die Aufnahme wurde über das
    iDevice (iPhone) programmiert und Funktioniert auch super!


    Bei Remote wird das erste obere Bild nur als kleines Fragezeichen dargestellt,
    fehlt da noch etwas?


    Gruß Kail

    VDR: ASUS P4P800-VM, Celeron 2.5 GHz, 256 MB-RAM, 2 x 160 GB Samsung SV1604N, TT 1.5 (4MB), TT-Budget, Extension-Board (TBE)
    LinVDR0.7 + Dr.Seltsam 2.6.18 + vdr-1.4.7 + BP + diverse Plugins
    Betatester v. steini-Paketen
    Test-VDR: ASUS P5QL Pro, E7500, 4 GB RAM, 1TB WD EADS, Media-Pointer S2, Ubuntu10.10 + vdr-1.7.16

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Kail ()

  • Zitat

    HD Kanäle gehen bei mir nur über den Umweg einer Aufnahme. Die Aufnahme
    wird dann normal wiedergegeben.


    Schau ich mir mal an, danke für den Tipp.


    Zitat

    Bei Remote wird das erste obere Bild nur als kleines Fragezeichen dargestellt,
    fehlt da noch etwas?


    Müsste eig. gehen. Was sagt die log?


    [edit]Da fällt mir ein. Hat der VDR-Benutzer Schreibrechte für $tempdir[/edit]

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Phill ()

  • Hallo,


    auch bei mir läuft eigentlich (mein erster Wurf von iVDR) alles sehr gut mit der Version 0.3.0a9.


    Bei dem Live TV-Streaming (SD) scheint sich aber bei mir etwas zu verwackeln.
    Ich kann ohne Probleme die Aufnahmen (SD & HD) von meinem VDR im iPad
    streamen.
    Aber wenn ich auf das Live TV gehe wird auch das Session-Verzeichnis angelegt und die ersten
    2 Dateien, aber dann geht es nicht weiter und ich bekomme die Meldung das mit dem Stream etwas nicht
    stimmt, Hmm nur was?


    Steigt hier der Segmenter aus? Oder ist er OK wenn er die Aufnahmen streamen
    kann?


    Was seltsam ist wenn ich über den vdradmin auf den Streamdev-Server zugreife bleibt das TV Bild am Fernseher stehen
    und es wird auf das gewählte Programm umgeschaltet und das Live TV Bild erscheint im VLC im Browser (PC).


    Diese geschieht nicht wenn iVDR auf den Streamdev-Server zugreift. Das Live TV-Bild(SD) läuft weiter is die Fehlermeldung kommt.


    Ich habe da Gefühl das kein TV-Stream gefunden wird?


    Ich habe bei mir eine eHD im VDR wo die Tuner vom NetCeiver kommen (dvbloop) --
    kann hier das Problem liegen?


    Wer kann helfen in welche Richtung hier das Problem liegt (Segmenter,
    Streamdev-Server, eHD mit NetCeiver (dvbloop) etc...?



    Grüße
    cinfo

    [size=8]Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern, AVG 1, SSD: 64GB, HD1 750GB VDR1: Intel NUC i5 Broadwell Mobile, SSD: 128GB, 8GB RAM VDR2:AVG1, SSD 64GB, 2GB RAM Software: Ubuntu 14.04-16.04, VDR-2.2.0 , Kernel: 4.x NAS: CPU Intel Atom 1.8 GHz, 4GB RAM mit 4 TB Speicher Client1-2: Amazon Fire TV / RPI - OLED TV: LG OLED55E6D

  • Hi,


    Aber wenn ich auf das Live TV gehe wird auch das Session-Verzeichnis angelegt und die ersten
    2 Dateien, aber dann geht es nicht weiter und ich bekomme die Meldung das mit dem Stream etwas nicht
    stimmt, Hmm nur was?


    Die Rückgabe von ffmpeg sollte in der apache error.log stehen, notfalls mit $debug=1;


    Steigt hier der Segmenter aus? Oder ist er OK wenn er die Aufnahmen streamen
    kann?


    Genau der Segmenter sollte nicht das Problem sein.


    Passt denn der Parameter "live" in der ivdr.conf unter %stream? Vergleiche ihn mal mit dem was dein VLC erhält.
    Evtl. auch mal schauen ob localhost zugriff auf den streamdev-server hat. (streamdevhosts.conf)

    my VDR... 
    VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600


    my SZ-VDR... 
    VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient


    myProjects... 
    iVDR - VDR-Frontend and LiveTV for TouchDevices

  • Hi,

    Zitat

    Die Rückgabe von ffmpeg sollte in der apache error.log stehen, notfalls mit $debug=1;

    hier verwende ich lighthttpd.

    Zitat


    Passt denn der Parameter "live" in der ivdr.conf unter %stream? Vergleiche ihn mal mit dem was dein VLC erhält.

    Das werde ich noch einmal machen -- sah aber eigentlich gleich aus.

    Zitat


    Evtl. auch mal schauen ob localhost zugriff auf den streamdev-server hat. (streamdevhosts.conf)

    Da könnte was nicht passem am localhost -- weil der Streamdev-Server überhaupt nicht auf die Anfrage reagiert.


    Ich werde es heute noch einmal testen und berichten.


    Grüße
    cinfo

    [size=8]Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern, AVG 1, SSD: 64GB, HD1 750GB VDR1: Intel NUC i5 Broadwell Mobile, SSD: 128GB, 8GB RAM VDR2:AVG1, SSD 64GB, 2GB RAM Software: Ubuntu 14.04-16.04, VDR-2.2.0 , Kernel: 4.x NAS: CPU Intel Atom 1.8 GHz, 4GB RAM mit 4 TB Speicher Client1-2: Amazon Fire TV / RPI - OLED TV: LG OLED55E6D