Beiträge von pandel

    Pah, alles, soweit kommt's noch ;-) - ich hab außerdem noch nen RPi hier rumliegen, wenn ich mal Langeweile hab... nur mag ich mein schönes Antec Gehäuse auch gar nicht aufgeben ;-) und der RPi, zumindest als VDR Client, ist *gefühlt* so viel langsamer (trotz Storage auf USB, etc.), als meine Kiste mit den echten Platten, hatte den mal als Streaming Client....


    Bzgl. der channels.conf gebe ich dir recht, aber wer weiß...


    bist du dir SICHER das du die fw vorher richtig heruntergeladen hast ? weil github ist ein bisschen zickig wenn du eine Datei herunterladen willst, wenn du die falsche Adresse nimmst hast du dann in der irgendwas.fw nur html drin ;)


    Ja bin ich, hab sogar mal nen bindiff durchgeführt, die beiden Dateien waren identisch. Außerdem habe ich statt Github mal den Link hier genommen, um das auszuschließen: http://palosaari.fi/linux/v4l-dvb/firmware/


    Es muss definitiv an einer Macke in der channels.conf gelegen haben. Jetzt läuft ja alles wunderbar! ... Ich bin wirklich begeistert, dass meine "angegraute HW" ;) das alles noch so problemlos macht. Ich wüsste auch momentan gar nicht, was ich da alles neu bräuchte, weil ich das Ding vor 6 Jahren zusammengeschraubt hab und seitdem läuft er. Da ich mittlerweile auch ne Horizon Box da rumstehen habe und ich zugeben muss, dass das HD Bild bei den meisten Sendern schon ne tolle Sache ist, nutze ich ihn eh "nur" für Netflix, Prime, alte Aufnahmen und (gaaaanz wichtig!) für Suchtimer, weil ich gerne schonmal selteneren Krempel aufnehme, den ich garantiert verpassen würde, wenn ich danach Ausschau halten müsste ;-)

    Hey danke! Aber hier passiert Merkwürdiges: ich habe jetzt die Firmware nochmal neu runtergeladen, die channels.conf gelöscht und mit w_scan losgelegt. Alles gut, kein Absturz. Dann hab ich die channels.conf weggesichert, geleert und neu aus der channelpedia gefüllt und siehe da, auch jetzt kein Absturz. Ich tue jetzt mal so, als wäre alles in Ordnung.


    Danke für's mitlesen und Ideen liefern.


    Lieber Gruß
    Holger

    Hallo zusammen!


    Ich muss auf Unitymedia umsteigen und habe mir zu diesem Zweck einen TechnoTrend CT2-4400 USB Stick gekauft. Eigentlich sollte es ja angeblich kein Problem damit geben, aber leider, egal was ich anstelle, steigt meine Maschine nach 1 bis 2 Sekunden Wiedergabe mit nachfolgender Meldung aus:



    Erstaunlich finde ich, dass der VDR erstmal mit Bild und Ton losläuft, aber dann friert das Bild ein und die Meldung taucht parallel dazu auf. Ich habe mittlerweile gemäß LTSEnablementStack den aktuellsten Kernel (Xenial) drauf, weil ich dachte, es gäbe da vielleicht ein Treiberproblem, was sich damit beheben ließe. Leider hat das nicht geholfen. Es auch (außer die bei OpenElec) nirgendwo noch weitere Firmware, dich ausprobieren könnte. Bin ziemlich ratlos...


    Gibt es hier evtl. noch weitere DVB-C User, die diesen Stick erfolgreich einsetzen und mir vielleicht helfen können, das Ding ans Laufen zu bekommen?


    Lieber Gruß
    Holger

    Hallo!


    Seit dem letzten Kernelupdate kommt mein mhddfs Mountpoint (via fstab) nicht mehr hoch, sondern es gibt einen segfault im Kernel Log. Wenn ich den Mountpoint per Hand entferne und dann einen mount -a mache, kommt er wieder sauber hoch. Danach VDR restarten und alles ist schön.


    Kann man irgendwie ein Script in diesen PM Mechanismus einhängen, um diesen Remount NACH dem Wakeup und VOR dem Start vom VDR automatisch machen zu lassen?

    So...


    Das mit dem Mounten via fstab war zwar ein Erfolg, ABER.... der Mountpoint ist nach einem Wakup aus S3 trotzdem ab und an weg und da irgendein Prozess, ich schätze vdr-net-monitor, da so schnell, dass ich kaum gucken kann, eine .update Date in den Ordner knallt, wird der Mount offensichtlich blockert! Sh*t!


    Hat jemand eine Ahnung, wie ich das ganze VDR Zeugs so verzögern oder im schlimmsten Fall verhindern kann, bis dieser Mountpoint da ist?



    EDIT: ich hab mal nonempty und bootwait also Optionen hinzugefügt, mal sehen, ob es dauerhaft hilft.


    Lieber Gruß
    Holger

    Das ist ja, wie du schon sagst, bereits in yaVDR 0.6 fest integriert und funktioniert so: entweder hast du nur ein /srv/vdr/video.00 Verzeichnis, dann wird es per mount --bind auf /srv/share/vdr gemappt, oder du hast mehrere video.xx, dann werden sie per mhddfs dahin gemappt.


    Und du verstehst richtig! Eigentlich braucht es das nicht dynamisch... Ich wusste allerdings nicht, dass man das auch direkt über die fstab machen kann, hab aber gerade auf deinen Hinweis hin mal googelt.
    Folgendes in der fstab sollte es tun:


    Code
    1. mhddfs#/srv/vdr/video.00,/srv/vdr/video.01 /srv/share/vdr fuse defaults,allow_other,mlimit=1G,logfile=/var/log/mhddfs.log,loglevel=1 0 0


    Dann muss ich nur noch den Upstart Job wegtemplaten, sonst vergesse ich das wieder :D, und fertig.


    Vielen Dank für den Denkanstoß!

    Hi!


    Ich weiß, mein Thema klingt etwas merkwürdig, aber vielleicht kann mir jemand sagen, wie ich definitiv sicherstelle, dass der Init-Prozess "mhddfs-vdr" vor allen anderen, für den VDR wichtigen Prozessen läuft?


    Hintergrund ist folgender:


    Ich fasse mit mhddfs-vdr ein paar Mountpoints für den VDR zusammen, soweit nichts ungewöhnliches und läuft ja auch. Bei einem normalen Neustart der Maschine läuft auch alles in der richtigen Reihenfolge. Mir ist jedoch aufgefallen, dass es offenbar gaaaanz selten passieren kann, dass der Mountpoint bei oder nach einem S3 iwie verloren geht. Wenn ich die Kiste danach wieder aufwecke, kommt der VDR hoch und knallt eine .update Datei in den jetzt leeren Mountpoint. Aus welchem Grund auch immer läuft mhddfs-vdr jetzt allerdings erst nach dem vdr an und beschwert sich dann natürlich, dass sein Zielordner nicht leer ist und er da nix mounten kann. Ende vom Lied, Aufnahmeordner leer, manuelles Nacharbeiten nötig, WAF in den Keller gerauscht...


    Vielleicht ist die Frage ja auch trivial, aber wie bringe ich den Upstart Skripten (deren Stop/Start-Mechanismus und -Reihenfolge ich einfach nicht raff...) bei, dass sie da eine ganz fest Reihenfolge einzuhalten haben? Ggf. muss dafür ja auch nach dem Aufwachen aus S3 noch was passieren, aber da weiß ich dann gar nicht mehr weiter...


    Hat jemand vielleicht einen Tipp?


    Lieber Gruß
    Holger

    Hallo zusammen!


    Nachdem ich jetzt auf die yaVDR 0.6 aktualisiert hatte, war ja erstmal Ende mit iVDR. Wollte es aber mit allem, auch Streaming nutzen, und hab mich mal dran gesetzt und es umgebaut. Die besonderen ffmpeg und segmenter Versionen sind mit einer aktuellen libav nicht mehr nötig, denn die kann von Hause aus bereits Apple-konforme HTTP Segmente für Streaming erzeugen.


    Was für Streaming nötig ist, ist also eine möglichst aktuelle Version der libav-tools, die hier zu bekommen sind: https://launchpad.net/~mc3man/+archive/ubuntu/trusty-media
    Vor der Installation von iVDR muss dieses Repo also eingebunden sein.


    Dann mal diese Version von iVDR einbinden: https://launchpad.net/~holger-…hive/ubuntu/ivdr-unstable


    Die Beschreibungen von Frodo aus seinem Announcement für die 0.3.3 als yaVDR Paket für das grundlegende Vorgehen bei der Inbetriebnahme stimmen überein, nur habe ich lighthttpd nicht mehr getestet und ausprobiert. Wer das verwendet, muss sich selber mal durch das Installationsskript wurschteln.


    Mit einem aktuelle Apache2 sollte es jedoch wie folgt aussehen:


    iVDR


    Nach dem einbinden der Repositories reicht ein

    Code
    1. sudo apt-get update
    2. sudo apt-get install ivdr


    Zur vollständigen Installation sind noch zwei Skripte auszuführen welche unter /usr/share/ivdr liegen.

    Code
    1. sudo /usr/share/ivdr/install_ivdr.sh


    und

    Code
    1. sudo /usr/share/ivdr/install_apache2.sh


    install_ivdr.sh: Erstellt fehlende Verzeichnisse und passt rc.local an um /dev/shm/ram beim booten zu erstellen.
    Einiges des Skripts install_ivdr.sh ist eventuell bereits in das Paket iVDR eingeflossen, so das es möglich ist das man dieses nicht mehr benötigt. Ich bin aber noch nicht dazu gekommen dies zu testen.


    install_apache2.sh: Installiert Apache und passt die Konfigurationsdateien von apache für iVDR und YaVDR an (z.B. Port 80 -> 8080).


    Nach der Installation ist iVDR unter folgender URL erreichbar:
    http://[yavdr host oder ip]:8080/cgi-bin/ivdr/ivdr.pl
    bei der Apache Installation reicht
    http://[yavdr host oder ip]:8080/ivdr


    Ich hoffe, ich habe nix vergessen... achso, na klar, Benutzung auf eigene Gefahr ;-)


    Lieber Gruß
    Holger

    @all:
    Ja, sorry, die menuorg.xml ist ausm Template. Ich hab mir halt alles getemplated...


    An was ihr alles denkt, VDPAU und so ;-) hätte ich nie drüber nachgedacht, Hauptsache, es läuft überhaupt ;-) aber nu gut, wenn das auch noch ginge, wäre das natürlich noch ne Spur besser!

    Hi!


    Ich hab's mal zusammengestellt. Ich hab mir analog zur Netflix Geschichte eine Konfiguration für Prime angelegt. Dazu gehören die prime.conf, die den Starter macht, dann eine spezielle lircrc_prime, die die Tasten der Fernbedienung etwas abändert, als für Netflix nötig, und zu guter Letzt noch mein modifziertes 'netflix_mousemove' Skript, näheres dazu im unten genannten Posting. Wenn ihr das nicht wollt, dann müsst ihr die nachfolgenden Dateien entsprechend anpassen.


    Erst die /etc/init/prime.conf:


    Dann die /etc/lirc/lircrc_prime:


    Dann noch der Eintrag für die menuorg.xml:

    Code
    1. <command name=<?cs call:quote(_("Amazon Prime")) ?> execute="/usr/share/vdr/menuorg-appswitcher standalone=yes app=prime &amp;> /dev/null " />


    Und meine netflix_mousemove gibt's hier: Netflix und VDR (evtl mit xbmc?)


    Zum Thema on-screen Tastatur und xdotool für netflix_mousemove siehe hier: Netflix und VDR (evtl mit xbmc?)

    Hallo zusammen!


    Krame das alte Ding hier nochmal raus...


    Das Addon funktioniert auch hervorragend mit Amazon Prime, seit die da auf HTML5 umgestellt haben. Einfach die netflix.conf als Vorlage nehmen und entsprechend anpassen. Dachte ich geb's mal weiter, falls hier nochmal wer reinschaut :D


    Lg,
    Holger

    Frodo :
    Besten Dank nochmal! Jetzt funktinioniert alles!


    louis :
    Was für ein schönes Theme! Herzlichen Dank! Werde wohl erstmal bei shady_KISS bleiben, weil es etwas flotter ist und TVGuideNG so fein funktioniert!

    In yavdr stable-vdr lag bisher die Version 0.4.2, in wieweit das Plugin mit vdr 2.0.6 funktioniert muss jeder selbst probieren.
    Das Plugin ist nicht Bestandteil von yaVDR 0.5 und wird nicht durch das Team supportet, auch wenn es nun verfügbar ist.


    Ich habe gerade die aktuelle Version 0.4.3 nach stable-vdr kopiert.


    Wow! Vielen herzlichen Dank! Dann werde ich das gleich mal ausprobieren ;-)!!!