Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

21

Mittwoch, 2. November 2011, 14:35

KlusiHH warte mal 5 min. dann ist das in stable-vdr
also
apt-get update
apt-get install vdr-plugin-vdrmanager

wenn das da :
https://launchpad.net/~yavdr/+archive/st…/+build/2895900
published, dann kann man es runterladen

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

22

Mittwoch, 2. November 2011, 14:40

Hmm, hat er nicht die 0.4 er amd64 Version von yaVDR?
KlusiHH warte mal 5 min. dann ist das in stable-vdr
also
apt-get update
apt-get install vdr-plugin-vdrmanager

wenn das da :
https://launchpad.net/~yavdr/+archive/stable-vdr/+build/2895900
published, dann kann man es runterladen

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

23

Mittwoch, 2. November 2011, 14:42

ups:
https://launchpad.net/~yavdr/+archive/st…natty_amd64.deb

habs eben mal installiert, hier crasht da nix.
jetzt mal den androiden füttern

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

24

Mittwoch, 2. November 2011, 14:44

Ich denke an dem Plugin liegt sein Crash wohl nicht, da in dem crashlog es gar nicht erst auftaucht und es ist relativ harmlos, zwar kann es natürlich vdr zum Abstürz bringen aber erst wenn mit ihm kommuniziert wird :D
ups:
https://launchpad.net/~yavdr/+archive/stable-vdr/+files/vdr-plugin-vdrmanager_0.2.4b-0yavdr0%7Enatty_amd64.deb

habs eben mal installiert, hier crasht da nix.
jetzt mal den androiden füttern

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

25

Mittwoch, 2. November 2011, 14:48

hier läuft es perfekt !
passwort "change" muss ich noch ändern :D
aber sehr hübsh !!

da stürzt nix ab bisher ....

26

Mittwoch, 2. November 2011, 14:53

schön !!! auch live tv streaming klappt hier auf anhieb !
(daroon player)

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

27

Mittwoch, 2. November 2011, 15:05

Was ich noch gerne machen würde, Tonspur Auwahl -> Die info ist bereits im Hintergrund vorhanden. Oder die Parameter für den Remux definieren. (Wäre quasi in den Settings konfigurierbar)
Wobei soll das ergonomische passieren und der User soll nicht durch dutzenden Auswahllisten belästigt werden. Falls Ideen da sind, gerne habe ich ein Ohr dafür.
schön !!! auch live tv streaming klappt hier auf anhieb !
(daroon player)

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

Beiträge: 683

Wohnort: Hamburg

Beruf: Web-Developer

  • Nachricht senden

28

Mittwoch, 2. November 2011, 15:07

Hilft alles nix. Was hab ich da nur kaputt gespielt? ;(

syslog von vdr start bis crash im Anhang.
»KlausiHH« hat folgende Datei angehängt:
  • syslog.txt (21,96 kB - 94 mal heruntergeladen - zuletzt: 6. November 2016, 15:15)
Mein VDR: OrigenAE/Amisos X15e, Asrock G41M-GE3, C2D E5700, 4 GB DDR3, WD SATA-HDD 500 GB, Nvidia GT 230 PCIe, TechnoTrend C-1501 + Terratec Cinergy C HD, 7" TFT (GraphTFT, ohne Touch), imon-Empfänger + Harmony 300i, yaVDR 0.4, Frontend xineliboutput, XBMC Eden aus testing, 24" PC-Monitor als Fernseher, 2.1 Boxen-Set Edifier C2 rev2, Kabelprovider Wilhelm Tell (ohne Grundverschlüsselung), 5 TB extern (USB) für Serien und Filme.
Hinweis für Allergiker: Dieser Beitrag kann Spuren von Nüssen enthalten.

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

29

Mittwoch, 2. November 2011, 15:11

Bitte vdr-xine ausprobieren statt xineliboutput. Bei mir läuft yaVDR 0.4 mit keinem der 1920er anthras. Und stürzt sofort ab.
Alternativ z.B. NarrowHD ausprobieren falls es xineliboutput sein muss.

Daran könnten deine Abstürze liegen.

Gruß,
Lado
Hilft alles nix. Was hab ich da nur kaputt gespielt? ;(

syslog von vdr start bis crash im Anhang.

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

Beiträge: 683

Wohnort: Hamburg

Beruf: Web-Developer

  • Nachricht senden

30

Mittwoch, 2. November 2011, 15:13

Probieren kann ich es gerne mal. Aber in will eigentlich kein xine, weil
das der Medienabspieler fehlt. Und xineliboutput läuft ja weitgehend
problemlos bei mir.
Mein VDR: OrigenAE/Amisos X15e, Asrock G41M-GE3, C2D E5700, 4 GB DDR3, WD SATA-HDD 500 GB, Nvidia GT 230 PCIe, TechnoTrend C-1501 + Terratec Cinergy C HD, 7" TFT (GraphTFT, ohne Touch), imon-Empfänger + Harmony 300i, yaVDR 0.4, Frontend xineliboutput, XBMC Eden aus testing, 24" PC-Monitor als Fernseher, 2.1 Boxen-Set Edifier C2 rev2, Kabelprovider Wilhelm Tell (ohne Grundverschlüsselung), 5 TB extern (USB) für Serien und Filme.
Hinweis für Allergiker: Dieser Beitrag kann Spuren von Nüssen enthalten.

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

31

Mittwoch, 2. November 2011, 15:15

Geht mir genauso, aber NarrowHD ist mit zu klein :(
Aber wie gesagt, xineliboutput und anthra laufen bei mir nicht. Abstürze ähnlich wie bei dir (gemäß syslog)
Probieren kann ich es gerne mal. Aber in will eigentlich kein xine, weil
das der Medienabspieler fehlt. Und xineliboutput läuft ja weitgehend
problemlos bei mir.

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

Beiträge: 683

Wohnort: Hamburg

Beruf: Web-Developer

  • Nachricht senden

32

Mittwoch, 2. November 2011, 15:21

Na klasse, auf xine umgeschaltet und läuft.

Testweise wieder zurück auf xineliboutput und crash.

Hallo ...?

Ich hab doch blos das Plugin von hier installiert, und deinstalliert.
Wie kann da sowas passieren?

Naja, notfalls überlebe ich das. In den letzten Tagen hab ich zum
Angucken meiner Serien eh immer xmbc genutzt. Das läuft ja richtig
gut jetzt in der 0.4. Und wenn man noch diese Scraper nutzt ... *schwärm*
Mein VDR: OrigenAE/Amisos X15e, Asrock G41M-GE3, C2D E5700, 4 GB DDR3, WD SATA-HDD 500 GB, Nvidia GT 230 PCIe, TechnoTrend C-1501 + Terratec Cinergy C HD, 7" TFT (GraphTFT, ohne Touch), imon-Empfänger + Harmony 300i, yaVDR 0.4, Frontend xineliboutput, XBMC Eden aus testing, 24" PC-Monitor als Fernseher, 2.1 Boxen-Set Edifier C2 rev2, Kabelprovider Wilhelm Tell (ohne Grundverschlüsselung), 5 TB extern (USB) für Serien und Filme.
Hinweis für Allergiker: Dieser Beitrag kann Spuren von Nüssen enthalten.

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

33

Mittwoch, 2. November 2011, 15:28

Das habe ich von Anfang an, also keine Ahnung was los ist. In den Logs findet man
leider auch nichts. Was ich noch machen werden, text2skin mit DEBUG=1 kompilieren und gucken.
Einmal hatte ich ein Fehler bei mir dadurch bereits gefunden. Ohne geben syslog und crashlog keine Infos leider :(
Alternativ NarrowHD oder PearlHD(native) nehmen, damit läuft xineliboutput auch prima.


Aber am besten einen eigenen Thream zu dem Problem aufmachen, sonst sind wir zu weit weggedritftet :)
Na klasse, auf xine umgeschaltet und läuft.

Testweise wieder zurück auf xineliboutput und crash.

Hallo ...?

Ich hab doch blos das Plugin von hier installiert, und deinstalliert.
Wie kann da sowas passieren?

Naja, notfalls überlebe ich das. In den letzten Tagen hab ich zum
Angucken meiner Serien eh immer xmbc genutzt. Das läuft ja richtig
gut jetzt in der 0.4. Und wenn man noch diese Scraper nutzt ... *schwärm*

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »herrlado« (2. November 2011, 15:34)


Beiträge: 683

Wohnort: Hamburg

Beruf: Web-Developer

  • Nachricht senden

34

Mittwoch, 2. November 2011, 15:51

Ja, hast recht. Ich schau mir das heute Abend zu Hause genauer an.
Arbeite ja die ganze Zeit nur remote.

Zum Thema. Die App funktioniert prima. Sehr schick. *lob*

Livestream geht leider nicht. Daroon-Player puffert sich tot
und MoboPlayer spielt nur ein paar Sekunden und geht wieder aus.
Kurz mal mit VLC hier auf'm PC testen ... ja, Streamdev und externremux
laufen wie gewünscht.
Naja, liegt vielleicht an meiem alten Milestone, egal.

Feature-Request (irgendwann zu Weihnachten):
Profile, damit man schnell umschalten kann, je nach dem, ob man
unterwegs oder zuhause ist.
Mein VDR: OrigenAE/Amisos X15e, Asrock G41M-GE3, C2D E5700, 4 GB DDR3, WD SATA-HDD 500 GB, Nvidia GT 230 PCIe, TechnoTrend C-1501 + Terratec Cinergy C HD, 7" TFT (GraphTFT, ohne Touch), imon-Empfänger + Harmony 300i, yaVDR 0.4, Frontend xineliboutput, XBMC Eden aus testing, 24" PC-Monitor als Fernseher, 2.1 Boxen-Set Edifier C2 rev2, Kabelprovider Wilhelm Tell (ohne Grundverschlüsselung), 5 TB extern (USB) für Serien und Filme.
Hinweis für Allergiker: Dieser Beitrag kann Spuren von Nüssen enthalten.

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

35

Mittwoch, 2. November 2011, 15:54

Hast du schon vplayer ausprobiert?

Und ja die Profile kommen.
Ja, hast recht. Ich schau mir das heute Abend zu Hause genauer an.
Arbeite ja die ganze Zeit nur remote.

Zum Thema. Die App funktioniert prima. Sehr schick. *lob*

Livestream geht leider nicht. Daroon-Player puffert sich tot
und MoboPlayer spielt nur ein paar Sekunden und geht wieder aus.
Kurz mal mit VLC hier auf'm PC testen ... ja, Streamdev und externremux
laufen wie gewünscht.
Naja, liegt vielleicht an meiem alten Milestone, egal.

Feature-Request (irgendwann zu Weihnachten):
Profile, damit man schnell umschalten kann, je nach dem, ob man
unterwegs oder zuhause ist.

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

Beiträge: 683

Wohnort: Hamburg

Beruf: Web-Developer

  • Nachricht senden

36

Mittwoch, 2. November 2011, 16:01

Hast du schon vplayer ausprobiert?

Noch nicht. Der kostet ja. Weiß nicht, ob ihn noch mal 7 Tage testen kann. Hatte den
früher schon mal drauf.
Mein VDR: OrigenAE/Amisos X15e, Asrock G41M-GE3, C2D E5700, 4 GB DDR3, WD SATA-HDD 500 GB, Nvidia GT 230 PCIe, TechnoTrend C-1501 + Terratec Cinergy C HD, 7" TFT (GraphTFT, ohne Touch), imon-Empfänger + Harmony 300i, yaVDR 0.4, Frontend xineliboutput, XBMC Eden aus testing, 24" PC-Monitor als Fernseher, 2.1 Boxen-Set Edifier C2 rev2, Kabelprovider Wilhelm Tell (ohne Grundverschlüsselung), 5 TB extern (USB) für Serien und Filme.
Hinweis für Allergiker: Dieser Beitrag kann Spuren von Nüssen enthalten.

  • »herrlado« ist der Autor dieses Themas

Beiträge: 747

Wohnort: Kassel

Beruf: Softwareentwickler

  • Nachricht senden

37

Mittwoch, 2. November 2011, 16:07

Hast du schon vplayer ausprobiert?

Noch nicht. Der kostet ja. Weiß nicht, ob ihn noch mal 7 Tage testen kann. Hatte den
früher schon mal drauf.

Ich denke der Unterschied war, man musste die Warnung wegklicken( Hinweis auf die Testversion) nach dem Ablauf.

herrlado(DJ9LK)'s VDR

ASUS P8H77-M LE, 4GB DDR3-1333, Core i3 2100T / Asus NVidia GT 610 (mit 1GB RAM ) / yaVDR 0.5 (testing-vdr, testing-xbmc) / 3.5.0-27er Kernel / TeVii S480 & TT S2-1600 / softhddevice / yaUsbIR V3 mit Logitech Harmony 600 / Samsung UE40B8000 über HDMI / 50Hz / 13.0°,19.2°,28.2°,42.0°

38

Donnerstag, 3. November 2011, 17:07

Hallo,

ersteinmal danke für die App bzw. das Plugin, sieht vielversprechend aus!

Wollte das testweise zum Laufen bringen, und habe aber nur teilweise Erfolg. Es funktioniert Anmeldung mit dem (geänderten) Passwort, das Programmieren / Ändern von Timern, Anzeige von EPG und der Aufnahmen, die Kommunikation scheint also ersteinmal zu passen.

2 Fragen:

1) Wenn ich auf "Kanäle" tippe, bekomme ich immer "Verbindung unnormal beendet..." - was ist hier faul?

2) Beim Streaming bekomme ich nur ein schwarzes Fenster. Mir ist das technisch auch noch nicht klar. Greift Dein Plugin lokal via loopback den Streamdev-Server ab, oder muss das Smartphone direkt auf den Port 3000 zugreifen (was natürlich ein Ding der Unmöglichkeit wäre)? Im Wiki steht "The access must be enabled in streamdevhosts.conf" - für welche IP / welches Interface? (Hat aber auch mit testweisem 0/0 nicht funktioniert)


Infos: Hab Dein Plugin auf von Hand auf einer Debian Squeeze-Box mit vdr 1.7.20 kompiliert; die Box steht hinter einem Router, der Port 6420 forwardet.

Wäre für Tips dankbar!

Grüße
K.

Beiträge: 683

Wohnort: Hamburg

Beruf: Web-Developer

  • Nachricht senden

39

Donnerstag, 3. November 2011, 17:32

oder muss das Smartphone direkt auf den Port 3000 zugreifen (was natürlich ein Ding der Unmöglichkeit wäre)?

Natürlich geht das so. Warum sollte das unmöglich sein?
Man braucht doch eine Videoplayer-App, die den Stream wiedergeben kann,
und die muss halt auf streamdev zugreifen können.

Zitat

Greift Dein Plugin lokal via loopback den Streamdev-Server ab

Du meinst vermutlich, dass das so irgendwie sicherer wäre, also man den
streamdev Server nicht nach aussen öffnen müsste?
Ginge sowas überhaupt? Das Plugin müsste dazu wohl eine Art Streaming-Proxy
implementieren. Aber im Grunde, würde es an der Situation wenig ändern.

Notfalls kann man ja auch den streamdev auf einem anderen Port laufen lassen und ferner
kann man auch für den Zugriff auf den streamdev-Server Nutzername und Passwort
festlegen.

Zitat

für welche IP / welches Interface? (Hat aber auch mit testweisem 0/0 nicht funktioniert)

Sind doch Beispiele in der streamdevhosts.conf. Für Zugriff von aussen, weil die zugreifende IP ja in
Regel wechselnd ist, muß man zwangsläufig alles freigeben und natürlich 3000/TCP auch im Router
freigeben bzw. weiterleiten.
Bin mir aber nicht sicher ob 0/0 eine korrekte Notation ist. 0.0.0.0/0 geht aber. Der VDR muss
nach solchen Änderungen AFAIK neu gestartet werden.
Mein VDR: OrigenAE/Amisos X15e, Asrock G41M-GE3, C2D E5700, 4 GB DDR3, WD SATA-HDD 500 GB, Nvidia GT 230 PCIe, TechnoTrend C-1501 + Terratec Cinergy C HD, 7" TFT (GraphTFT, ohne Touch), imon-Empfänger + Harmony 300i, yaVDR 0.4, Frontend xineliboutput, XBMC Eden aus testing, 24" PC-Monitor als Fernseher, 2.1 Boxen-Set Edifier C2 rev2, Kabelprovider Wilhelm Tell (ohne Grundverschlüsselung), 5 TB extern (USB) für Serien und Filme.
Hinweis für Allergiker: Dieser Beitrag kann Spuren von Nüssen enthalten.

40

Donnerstag, 3. November 2011, 18:43

Hallo,

danke für Deine Antwort.
Notfalls kann man ja auch den streamdev auf einem anderen Port laufen lassen und ferner
kann man auch für den Zugriff auf den streamdev-Server Nutzername und Passwort
festlegen.
Das wusste ich nicht. Ohne Schutz ist es eben nicht ratsam, streamdev nach außen für die Welt aufzumachen - außer eben, der vdr-manager fungiert irgendwie als Proxy, und regelt die Authentifizierung. Deswegen meine Annahme, und meine Frage nach der Kommunikation zwischen vdr-manager und streamdev-server.

Habe testweise Port 3000 kurz geöffnet, und jetzt bekomme ich auch tatsächlich einen Stream auf´s Smartphone, wenn ich 0/0 freigebe - was ich eben nicht möchte.

Habe dann als nächstes auf Deinen Tip hin den streamdev-server mit Passwort geschützt. Das kann aber doch nur funktionieren, wenn vdr-manager dieses Passwort an den externen Player mit übergibt (nehme an via http://user:passwort@hostname/...). Diese Option gibt es denke ich noch nicht, oder?

Der von mir verwendete Player (daroon) ist auch nicht so schlau, dass er auf den unautorisierten Zugriff mit einem Prompt nach User/Passwort antwortet..

Müsste hier noch etwas in die App eingebaut werden, oder habe ich jetzt noch etwas übersehen?

Danke
K.

Immortal Romance Spielautomat