You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

1

Tuesday, May 8th 2007, 8:46pm

Tv-Anwendungen in x wollen nicht/xv../grafikkartenproblem

Hallo zusammen,

hat schon einer ne tv-Anwendung in kde am laufen? (mit der gen2vdr1.2)
Am liebsten wäre mir kvdr so eingerichtet wie bei der 1.1 (so das kvdr und vdr(am ausgang der ff) gleichzeitig umschalten) Also emerge kvdr funktioniert nicht (die aktuelle version 0.64r1) aber die 0.63 konnte ich mergen allerdings bekomme ich kein Bild. Bei der1.1 war das auch erst da nach drücken auf "v" da. Wenn man bei der 1.2 auf "v" drückt wird gemeckert das "xv-dispaly could not be activated" und auf einen entsprechenden eintrag von xvideo in der xf86 hingewiesen. Hmm, xf86 ist doch ne ältere variante von x11 oder?
Btw. bedienung des vdr ist aber möglich
Also mal die anderen Kanditaten angesehen und probiert.

Bei xine blicke ich gar net durch

Kaffeine findet keine dvb karte

Kmplayer kann vdr (nach dem verbinden) bedienen aber auch kein Bild nur im Fenster (nach umschalten auf konsole) nen ev. Hinweis : no vailid xvport found.

tvtime installiert wird aber nicht geöffnet (ohne fehermeldung).

xawtv hier muss ich noch mal schauen (sind im moment keine kanäle angelegt)

xvport und xvideo scheinen die schlüsselwort zu sein aber was brauchbares habe ich noch nicht gefunden. Zu doof oder auf den falschen weg?

Wer hat ne idee hierzu?

Danke Lexi

Nachtrag
Signatur geändert geht um das akt. Testsystem nicht das es mit der merge-orgie zusammenhängt. Teste das gerade noch mal mit dem portal wo die 1.2 drauf ist gegen.

Ps. kann auch gerne xine werden hat das einer mit der g2v 1.2 am laufen und kann das kurz beschreiben wie man das starten sollte?
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

This post has been edited 3 times, last edit by "lexi" (May 12th 2007, 10:13am)


Posts: 3,603

Occupation: Admin;Support

  • Send private message

2

Wednesday, May 9th 2007, 1:20am

RE: Tv-Anwendungen für kde

xawtv hier muss ich noch mal schauen (sind im moment keine kanäle angelegt)

evtl mit Parameter aufrufen dann ist OSD da unter freevo war auch die fb aktiv :)
Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
Links für Neueinsteiger

"Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

3

Wednesday, May 9th 2007, 8:44pm

hi,

so mal ein kleiner update. Auf den Portal läuft kvdr wie es bei der 1.1 er auch war. Witzerweise ging hier anstandslos die aktuelle Version drauf. Also kommt nur die grafikkarte in frage oder ich habe bei der merge orgie was zerschossen.
Im gentoo-nvidia-guide steht

Quoted

Einige Tools, wie mplayer und xine-lib, verwenden ein lokales USE-Flag, das "nvidia" heißt. Es aktiviert die Unterstützung für XvMCNVIDIA, hilfreich beim Abspielen von hochaufgelösten Videos. Fügen Sie "nvidia" zu Ihrer USE-Variable in /etc/make.conf hinzu oder als USE-Flag zu media-video/mplayer und/oder media-libs/xine-lib in /etc/portage/package.use hinzu.

Dann führen Sie emerge -uD --newuse world aus, um die Anwendungen neu zu bauen, die von der Änderung des USE-Flags profitieren würden.


Also wird das jetzt mal getestet. Wo ich immer noch auf den schlauch stehe ist xvport, xvideo, XvMCNVIDIA, und xv. Steht das alles für das selbe?

Gruss lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

4

Thursday, May 10th 2007, 11:10pm

hi,

so habe jetzt erst mal ausgeschlossen das es an der mergen des systems lag. Ein neu aufgesetztes gen2vdr bringt hier auch keine Verbesserung.

Beim suchen nach den ursachen bin ich über xvinfo gestolpert. Hierbei bekomme ich die info das kein screen gefunden wurde. Kann das sein das die graka (geforce 6100 onboard) die Ursache ist? Unter kantonix läuft zwar xine aber mit sehr deutlichen aussetzern. An der rechenleistung vom system sollte das aber nicht liegen? Btw. xvinfo unter kanotix ebenfalls "no screen found"

Da mein englisch nicht gerade gut ist habe ich immer nur nach deutschen Beiträgen im gentoo forum gesucht und natürlich hier. Irgendwie komme ich aber nicht weiter. Wenn das an xvxxx liegt wie finde ich heraus ob es meine onboard-karte unterstützt oder ob hier ev. ein emerge xxx oder eine änderung im kernel abhilfe schafft?

Gruss lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

This post has been edited 1 times, last edit by "lexi" (May 11th 2007, 1:25am)


5

Friday, May 11th 2007, 1:10am

gibt es nicht mal ne liste von den unterstützen graka´s oder nen Hinweis für die suche ?

@Mr.N!ce
Danke für deinen Beitrag aber anfangen kann ich damit nichts. Mit Parameter aufrufen klar (nur welche?) und dein Hinweis auf freevo ist mir auch nicht klar. Bei freevo funktioniert das paralle umschalten nicht (gleichzeitiges umschalten über lircd und tastatur möglich). Das war bei der 1.1 auch über kde möglich.

lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

6

Friday, May 11th 2007, 5:11pm

RE: Tv-Anwendungen in x wollen nicht/xv../grafikkartenproblem

Quoted

Original von lexi
Kaffeine findet keine dvb karte

Wenn du vdr laufen hast, wird keine dvb-karte gefunden.
Kaffeine hat eigenen dvb-port.

netz

Master

Posts: 1,791

Location: Sachsen

  • Send private message

7

Friday, May 11th 2007, 5:45pm

Hallo Lexi,
auf meinem Testsystem mit sis661Grafik on Board (4:3 Ausgabe) habe ich TVTime installiert (emerge tvtime).

Auf einen Rechner mit WideScreen habe ich Xine(xineliboutput) genommen.
[gelöst]Frage zu: 16:9 und 4:3 am Widescreen DVI (mit Ati Nebenfragen)

Probleme gibt es auch bei mir auf Suse/Gen2VDR, wenn ich den Treiber von Ati installiere. Die TV-Anwendungen beenden die X-Session (Xv, Opengl ging glaube ich).

bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

8

Friday, May 11th 2007, 7:07pm

hi,

habe jetzt noch mal sabayon gebootet und hier kommt bei xvinfo screnns. Also ist das ganze anscheinend ne Einstellungssache. Habe einfach mal die xorg.conf von sabayon genommen und in gen2vdr getestet. Das bringt aber den x-server zum abschmieren (keine bedienung mehr möglich, nur per ssh). Habe mal meine bisherige xorg.conf beigelegt (xorg.conf-g2v.txt) sowie die xorg.conf von sabayon. Vielleicht wird da ja einer schlau draus und kann mir sagen was ich abändern muss, das die benötigen screen gefunden werden?

Gruss lexi
lexi has attached the following files:
  • xorg.conf-g2v.txt (15.36 kB - 90 times downloaded - latest: Nov 17th 2014, 2:21am)
  • xorg.conf-sabayon.txt (6.44 kB - 71 times downloaded - latest: Jul 26th 2014, 1:41pm)
  • xdm-log.txt (1.4 kB - 83 times downloaded - latest: Jan 7th 2015, 11:48am)
  • Xorg.0.log.txt (18.33 kB - 76 times downloaded - latest: Jan 6th 2015, 11:23am)
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

9

Saturday, May 12th 2007, 8:22pm

hi,

die ersten Fortschritte sind zu vermelden! Eine Änderung im kernel bringt mir nun zumindest screens bei xvinfo. Allerdings wird dadurch nun meine tt nicht mehr erkannt. :wand seperater kernel-thread Die Auflösung ist auch noch nicht ideal aber zumindest bekomme ich schon mal auf anhieb ein bild in xine nachdem ich auf xvdr geklickt habe.

Gruss lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

vdrtux

Intermediate

Posts: 539

Location: Fulda

Occupation: Rohrverleger

  • Send private message

10

Saturday, May 12th 2007, 9:12pm

Moin,
in deiner xorg.conf-g2v steht:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
Section "Device"
	Option      "RenderAccel"	"1"
	### Available Driver options are:-
# sw_cursor is needed for some ati and radeon cards
        #Option     "sw_cursor"
        #Option     "hw_cursor"
        #Option     "NoAccel"
        #Option     "ShowCache"
        #Option     "ShadowFB"
        #Option     "UseFBDev"
        #Option     "Rotate"
	Identifier  "Card0"
# The following line is auto-generated by KNOPPIX mkxf86config
	Driver      "vesa"
	VendorName  "All"
	BoardName   "All"
#	BusID       "PCI:1:0:0"
EndSection


in deiner xorg.conf-sabayon:

Source code

1
2
3
4
5
6
7
8
9
Section "Device"
    Identifier  "VESA"
    Driver      "nvidia" # do not remove vesa
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
EndSection


Ich meine das dir der NVIDIA Treiber fehlt um xv überhaupt zu nutzen.
Das ist nur so ne Vermutung, da ich keine Ahnung von gen2vdr hab.

vdrtux
LINUX - the Engine of Creation!

11

Saturday, May 12th 2007, 9:35pm

hi,

Quoted

Ich meine das dir der NVIDIA Treiber fehlt um xv überhaupt zu nutzen. Das ist nur so ne Vermutung, da ich keine Ahnung von gen2vdr hab.


stimmt teilweise, den nvidia treiber konnte ich erfolgreich manuell laden. Allerdings in der xorg.conf von sabayon hat es das komplette system (bis zum kernelupdate) lahmgelegt. Jetzt steht aktuell "nv" drinn, klar das das besser geht. An die detailierte Einstellung habe ich mich noch nicht gemacht. (ohne funktionierende ff mach das keinen spass) :versteck. Zumindest sind erste Erfolge da....

Gruss lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

vdrtux

Intermediate

Posts: 539

Location: Fulda

Occupation: Rohrverleger

  • Send private message

12

Saturday, May 12th 2007, 10:22pm

Quoted

Jetzt steht aktuell "nv" drinn, klar das das besser geht.


Der "nv" Treiber unterstützt aber kein xv bzw. XvMCNVIDIA, da muß schon der Treiber von Nvidia selbst (Driver "nvidia") installiert sein. ...XvMCNVIDIA

vdrtux
LINUX - the Engine of Creation!

13

Saturday, May 12th 2007, 11:12pm

hmm,

habe gerade mal nvidia als treiber getestet, damit bleibt das system hängen. Zumindest local per ssh komm ich rein. Ansonsten habe ich keine weiteren änderungen in der xorg.conf vorgenommen.

lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

vdrtux

Intermediate

Posts: 539

Location: Fulda

Occupation: Rohrverleger

  • Send private message

14

Saturday, May 12th 2007, 11:35pm

Quoted

da muß schon der Treiber von Nvidia selbst (Driver "nvidia") installiert sein.


lexi, du hast mich nicht verstanden (oder ich hab mich zu blöd ausgedrückt):
bevor du Driver "nvidia" in der xorg.conf setzen kannst musst erstmal den Nvidia-Treiber installieren auf deinem System und zwar von hier, oder du findest ein Pendant für dein gen2vdr dazu.
Ist das soweit klar?

vdrtux
LINUX - the Engine of Creation!

15

Saturday, May 12th 2007, 11:50pm

hi vdrtux,

vielen Dank für deine mühen, ja klar ist der treiber installiert und geladen lt. gentoo-doku das war er aber auch schon vorher. Das lustige ist ja das ich per xvinfo screens mit den "nv" treiber bekomme, obwohl du das ausschliesst. (deinen link verstehe ich leider nicht ganz, fehlende englischkentnisse)

lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

Posts: 8,596

Location: Schwabenländle

Occupation: Bootmanager

  • Send private message

16

Saturday, May 12th 2007, 11:51pm

Quoted

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.


Das ist ein Bug bei der Treiber Installation, Ich habe hier mal HowTo zur Behebung gepostet:

Klick

vdrtux

Intermediate

Posts: 539

Location: Fulda

Occupation: Rohrverleger

  • Send private message

17

Sunday, May 13th 2007, 12:13am

@C-3PO
Damit kommt dann Licht ins Dunkel...

@lexi
somit ist der Treiber nicht installiert wurden, und ich bin raus aus dem Thread ;)

Gruß vdrtux
LINUX - the Engine of Creation!

18

Sunday, May 13th 2007, 12:45am

hi,

@C-3PO

das howto kenne ich und habe dort auch bereits nachgefragt ;)

woran hast du es den gemerkt das hier was nicht so läuft wie gewünscht?
Solange nur Fehlermeldungen kommen und der rest wie gewünscht hinhaut ist mir das alles ...egal, erst wenn es nicht mehr hinhaut gehe ich der sache auf der Grund.

@vdrtux

danke nochmals

lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

Posts: 8,596

Location: Schwabenländle

Occupation: Bootmanager

  • Send private message

19

Sunday, May 13th 2007, 12:58am

Quoted

Original von lexi
.....
woran hast du es den gemerkt das hier was nicht so läuft wie gewünscht?
......


Anhand des angehängten logs.

Quoted

(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.

20

Sunday, May 13th 2007, 1:06am

ne is klar ich meine bei dir! Was hat bei dir nicht hingehauen das du nach dich auf die suche nach der Ursache und der Behebung des gleichen gemacht hast?

gruss lexi
GA-M61P-S3, X2 BE-2400, 3 x 1000GB-SataII, 1GB Ram, tt1.3, nova-s (62 W Idle), g2v 2.0, up 24, (System ist gleizeitig fileserver) kvm-switsch, Monitorsplitter, Deckenmonitor ...

jede menge weitere HW zum testen (meist Mediaportal mit qdi...)

Einsteigerlektüre zur gen2vdr
gen2vdr-wiki
gentoo-handbuch

Immortal Romance Spielautomat