Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

1

Montag, 16. Oktober 2006, 08:21

Die Akte A8N-VM CSM mussen doch fonktionnieren

Hallo Wiki,

Ich habe das A8N-VM CSM Methode directisa,
Ich habe versucht die config datei zu erzeugen ich meine das es so nicht stimmen kann.
Das zwischen Booten ist nicht richtig gelaufen. Wie kann ich es nochmals richtig durchführen. Oder hat jemand das Board am laufen mit nvram ? :)
Gruss Pat

Zitat

################################################
## Mainboard autodetection information:
##
## - Mainboard vendor: "ASUSTeK Computer INC."
## - Mainboard type: "A8N-VM CSM"
## - Mainboard revision: "Rev 1.xx"
## - BIOS vendor: "American Megatrends Inc."
## - BIOS version: "1001"
## - BIOS release: "04/19/2006"

addr_stat = 0x1C
shift_stat = 2
addr_stat = 0x1D
shift_stat = 2
addr_stat = 0x1E
shift_stat = 2
addr_stat = 0x1F
shift_stat = 2
addr_stat = 0x21 # but differs somewhere else
shift_stat = 5
addr_stat = 0x30
addr_stat = 0x75 # but differs somewhere else
shift_stat = 2
addr_stat = 0x77 # but differs somewhere else
shift_stat = 3
addr_stat = 0x77 # but differs somewhere else
shift_stat = 4

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »pat« (17. Oktober 2006, 08:36)


2

Montag, 16. Oktober 2006, 08:56

RE: Die Akte A8N-VM CSM mussen noch fonktionnieren

Zitat

Original von pat
Hallo Wiki,

Ich habe das A8N-VM CSM Methode directisa,
Ich habe versucht die config datei zu erzeugen ich meine das es so nicht stimmen kann.


...das glaube ich auch.

Such mal nach "A8N-VM" und "nvram-wakeup" hier im Forum und bei google. Eventuell hat es schon jemand geschafft, eine nvram-wakeup.conf ohne guess-helper per Hand zu erstellen.

Gruß
Wicky
Hardware: M2NPV-VM, AthlonXP-64 5700, Samsung 1TB HD, TT-1600, GF210
Software: Ubuntu 10.04 und yaVDR Pakete
dxr3-Links:
dxr3config, dxr3-Howto :], dxr3-Modul-Entwicklerseite, dxr3-Plugin-Entwicklerseite

pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

3

Montag, 16. Oktober 2006, 12:22

RE: A8N-VM CSM geht zum Teil

Hallo Wiki,

Ich habe im Netzt ein Config für mein Board gefunden. Habe noch problem mit den Minuten.

Zitat

################################################
## Mainboard autodetection information:
##
## - Mainboard vendor: "ASUSTeK Computer INC."
## - Mainboard type: "A8N-VM CSM"
## - Mainboard revision: "Rev 1.xx"
## - BIOS vendor: "American Megatrends Inc."
## - BIOS version: "0506"
## - BIOS release: "11/17/2005"

addr_stat = 0x30 # but differs somewhere else
shift_stat = 2
addr_min = 0x57
addr_sec = 0x58
addr_day = 0x62
addr_hour = 0x63
addr_chk_h = 0x30 # guessed
addr_chk_l = 0x31


Ich teste es im Moment mit MLD0.6
die options --directisa habe ich noch nicht versucht.

Eine Idee warum im Bios die Minuten nicht stimmen??

Gruss Patrice

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

4

Montag, 16. Oktober 2006, 12:34

@pat

Trifft das hier vielleicht für dich zu?
http://www.vdr-portal.de/board/thread.php?threadid=55792
Hardware:Athlon XP 2000@1250 Mhz, Asrock K7VT2, 512 MB RAM, 1x60 GB + 1x250 GB Maxtor HDD, FF Nexus-s 2.1, TT Budget
Software:C't VDR5, nvram-wakeup

5

Montag, 16. Oktober 2006, 19:26

RE: A8N-VM CSM geht zum Teil

Zitat

Original von pat
Hallo Wiki,

Ich habe im Netzt ein Config für mein Board gefunden. Habe noch problem mit den Minuten.

Zitat

################################################
## Mainboard autodetection information:
##
## - Mainboard vendor: "ASUSTeK Computer INC."
## - Mainboard type: "A8N-VM CSM"
## - Mainboard revision: "Rev 1.xx"
## - BIOS vendor: "American Megatrends Inc."
## - BIOS version: "0506"
## - BIOS release: "11/17/2005"

addr_stat = 0x30 # but differs somewhere else
shift_stat = 2
addr_min = 0x57
addr_sec = 0x58
addr_day = 0x62
addr_hour = 0x63
addr_chk_h = 0x30 # guessed
addr_chk_l = 0x31


Ich teste es im Moment mit MLD0.6
die options --directisa habe ich noch nicht versucht.

Eine Idee warum im Bios die Minuten nicht stimmen??

Gruss Patrice


Ja, habe ich. Du verwendest eine ander Bios-Version !!!
Von der Bios Version könnte es abhängen, wo im Nvram die Einträge abgelegt werden. Dies verdeutlicht auch, wie gefährlich es seien kann, eine nvram-wakeup.conf zu verwenden, die nicht mit dem eigenen Mainboard UND Bios-Revision übereinstimmt.

Ich habe für das M2NPV-VM ein Paket gebastel, dass nvram-wakeup vollständig einrichtet. In diesem Paket frage ich deshalb sowohl die Bios-Revision als auch die Typbezeichnung ab.

Gruß
Wicky
Hardware: M2NPV-VM, AthlonXP-64 5700, Samsung 1TB HD, TT-1600, GF210
Software: Ubuntu 10.04 und yaVDR Pakete
dxr3-Links:
dxr3config, dxr3-Howto :], dxr3-Modul-Entwicklerseite, dxr3-Plugin-Entwicklerseite

ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

6

Montag, 16. Oktober 2006, 20:59

Danke an skiller2k1 für die sinnvolle Zerteilung

Hallo Pat,
du musst dir scheinbar mit guess-helper eine eigene *.conf erzeugen
falls du dabei Hilfe brauchst melde dich nochmal,
allerdings muss ich mich da auch erst wieder einlesen
-upper_methode scheit da vor allem lesenswert
siehe auch
http://sourceforge.net/search/?type_of_s…ords=A8N-VM+CSM

und das in einem anderen Thread zu verstecken war keine so gute Idee :lehrer1

Achso die andere Möglichkeit waehre einfach das bios vom "11/17/2005"
zu verwenden, mit der passenden .conf oben.

Gruss Ulf
PS @Wicky
hallo, endlich lehrnt das wiki sprechen, hatt ich das nicht auch schon mal geschafft :lol2
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »ULF« (16. Oktober 2006, 21:06)


pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

7

Montag, 16. Oktober 2006, 21:37

RE: Danke an skiller2k1 für die sinnvolle Zerteilung

Hallo Ulf,

Da mit dem Datum stimmt mit der Config die oben genannt ist. Das Bios Update hatte ich schon länger eingespielt. Das Problem jetzt ist nur noch das nvram scheinbar sauber alles reinschreibt aber nicht bootet an der vorsehene Zeit.

Ein problem ist auch gebacku mit der zukurze eingestellt Weckzeit was zu den seltsame Urzeit geführt hat. Siehe den Thread über Falsche Weckzeit in NVram .

Der server von SourceForge herreicht nicht im Moment.

Gruss Pat :)

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

8

Montag, 16. Oktober 2006, 21:58

Hi Pat,
deine selbsterstelle konfig sagt Bios vom "04/19/2006"
und für dieses Bios gibt es keine fertig *conf in der MainboardList auf sourceforce, sprich deine (oben im ersten Post) muss neu erstellt werden.

Oder du spielst halt das Bios vom "11/17/2005" und loest in der gefunden conf
den Konflikt mit den beiden gleichen Adressen:

Zitat


addr_stat = 0x30 # but differs somewhere else
addr_chk_h = 0x30 # guessed


Mein Tip:lass das neue Bios drin lies nochmal das readme und mach dir per guess-helper ganz in Ruhe eine neue conf

Gruss Ulf
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

9

Montag, 16. Oktober 2006, 22:45

Hi Ulf,

So ich bin deinem Rat gefolgt.

Zitat

################################################
## Mainboard autodetection information:
##
## - Mainboard vendor: "ASUSTeK Computer INC."
## - Mainboard type: "A8N-VM CSM"
## - Mainboard revision: "Rev 1.xx"
## - BIOS vendor: "American Megatrends Inc."
## - BIOS version: "1001"
## - BIOS release: "04/19/2006"

addr_min = 0x57
addr_sec = 0x58
addr_day = 0x62
addr_hour = 0x63
addr_stat = 0xCB
shift_stat = 4
addr_chk_h = 0x30 # guessed
addr_chk_l = 0x31

upper_method = VT82Cxxx


Ob es mit Via Nforce als auswahl richtig war hoffe ich im Ersten Versuch hatte ich Unbekannt angegeben. Es ging auf jeden Fall besser als beim Ersten Versuch.

Die Daten sind Richtig ob er anspringt weiß ich noch nicht.

Danke für die Hilfe .. .

Gruss Pat

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

10

Montag, 16. Oktober 2006, 23:08

Zitat

Original von pat
Hi Ulf,
...
Ob es mit Via Nforce als auswahl richtig war hoffe ich im Ersten Versuch hatte ich Unbekannt angegeben. Es ging auf jeden Fall besser als beim Ersten Versuch.

Die Daten sind Richtig ob er anspringt weiß ich noch nicht.

Danke für die Hilfe .. .

Gruss Pat

Hi Pat
na das wird doch!
zur upper methode hat bistromat im Board auch viele Hinweise gegeben (evtl mal suchen)
seit einem Jahr ist er allerdings nimmer so aktiv hier
wenn du von deiner .conf überzeugt bist solltest du sie ihm mal mailen.
http://sourceforge.net/users/bistr-o-math/
(btw die Webseite geht hier ohne Mucken)

Gruss Ulf und frohes Aufwachen

Falls es doch nicht klappt
(need reboot koennte evtl noch notwendig werden)
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »ULF« (16. Oktober 2006, 23:11)


pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

11

Dienstag, 17. Oktober 2006, 08:43

Hallo Ulf,

Das mit nvram geht mir sehr viel Zeit drauf .... :((

der Test aus dem Wiki
grub-set-default 9 && nvram-wakeup -D -C /etc/nvram-wakeup.conf --directisa -s $(( `date +%s`+ 10*60 ))
grub-set.default 9 sollte ein reboot auf vmlinuz.poweroff verursachen. Geht leider auch nicht.
Die Werte scheinen alle Sauber in Bios sollte ich mal ohne directisa versuchen.

Zitat

root:grub-set-default 9 && nvram-wakeup -D -C /etc/nvram-wakeup.conf --directisa -s $(( `date +%s`+ 10*60 ))
nvram-wakeup: Printing debug messages enbled.
nvram-wakeup: $Id: nvram-wakeup.h,v 1.38 2005/03/16 22:43:39 bistr-o-math Exp $
nvram-wakeup: $Id: nvram-wakeup.c,v 1.78 2005/03/16 23:41:35 bistr-o-math Exp $
nvram-wakeup: $Id: nvram-wakeup-mb.c,v 1.283 2005/07/18 12:32:58 bistr-o-math Exp $
nvram-wakeup: $Id: bios.c,v 1.6 2004/01/23 12:00:04 bistr-o-math Exp $
nvram-wakeup: $Id: gmt-test.c,v 1.17 2004/07/21 12:19:57 bistr-o-math Exp $
nvram-wakeup: $Id: byteops.c,v 1.6 2003/03/18 13:44:03 bistr-o-math Exp $
nvram-wakeup: $Id: nvramops.c,v 1.3 2004/05/03 22:40:13 bistr-o-math Exp $
nvram-wakeup: $Id: guess.c,v 1.24 2005/03/16 22:43:39 bistr-o-math Exp $
nvram-wakeup: $Id: biosinfo.c,v 1.8 2005/03/16 22:43:39 bistr-o-math Exp $
nvram-wakeup: $Id: tools.c,v 1.3 2004/01/23 12:04:21 bistr-o-math Exp $
nvram-wakeup: $Id: readconf.c,v 1.12 2004/07/20 14:20:36 bistr-o-math Exp $
nvram-wakeup: $Id: cat_nvram.c,v 1.3 2004/05/03 22:40:13 bistr-o-math Exp $
nvram-wakeup: $Id: rtc.c,v 1.6 2003/03/18 13:44:07 bistr-o-math Exp $
nvram-wakeup: $Id: time.c,v 1.5 2004/06/26 07:21:23 bistr-o-math Exp $
nvram-wakeup: Built at: Aug 4 2006 00:10:50
nvram-wakeup: Direct ISA access enabled.
nvram-wakeup: Opening /etc/nvram-wakeup.conf in 'r' mode...
nvram-wakeup: /etc/nvram-wakeup.conf: 2: comment: ################################################
nvram-wakeup: /etc/nvram-wakeup.conf: 3: comment: ## Mainboard autodetection information:
nvram-wakeup: /etc/nvram-wakeup.conf: 4: comment: ##
nvram-wakeup: /etc/nvram-wakeup.conf: 5: comment: ## - Mainboard vendor: "ASUSTeK Computer INC."
nvram-wakeup: /etc/nvram-wakeup.conf: 6: comment: ## - Mainboard type: "A8N-VM CSM"
nvram-wakeup: /etc/nvram-wakeup.conf: 7: comment: ## - Mainboard revision: "Rev 1.xx"
nvram-wakeup: /etc/nvram-wakeup.conf: 8: comment: ## - BIOS vendor: "American Megatrends Inc."
nvram-wakeup: /etc/nvram-wakeup.conf: 9: comment: ## - BIOS version: "1001"
nvram-wakeup: /etc/nvram-wakeup.conf: 10: comment: ## - BIOS release: "04/19/2006"
nvram-wakeup: /etc/nvram-wakeup.conf: 12: name : addr_min
nvram-wakeup: /etc/nvram-wakeup.conf: 12: value : 0x57
nvram-wakeup: /etc/nvram-wakeup.conf: 13: name : addr_sec
nvram-wakeup: /etc/nvram-wakeup.conf: 13: value : 0x58
nvram-wakeup: /etc/nvram-wakeup.conf: 14: name : addr_day
nvram-wakeup: /etc/nvram-wakeup.conf: 14: value : 0x62
nvram-wakeup: /etc/nvram-wakeup.conf: 15: name : addr_hour
nvram-wakeup: /etc/nvram-wakeup.conf: 15: value : 0x63
nvram-wakeup: /etc/nvram-wakeup.conf: 16: name : addr_stat
nvram-wakeup: /etc/nvram-wakeup.conf: 16: value : 0xCB
nvram-wakeup: /etc/nvram-wakeup.conf: 17: name : shift_stat
nvram-wakeup: /etc/nvram-wakeup.conf: 17: value : 4
nvram-wakeup: /etc/nvram-wakeup.conf: 18: comment: # guessed
nvram-wakeup: /etc/nvram-wakeup.conf: 18: name : addr_chk_h
nvram-wakeup: /etc/nvram-wakeup.conf: 18: value : 0x30
nvram-wakeup: /etc/nvram-wakeup.conf: 19: name : addr_chk_l
nvram-wakeup: /etc/nvram-wakeup.conf: 19: value : 0x31
nvram-wakeup: /etc/nvram-wakeup.conf: 21: name : upper_method
nvram-wakeup: /etc/nvram-wakeup.conf: 21: value : VT82Cxxx
nvram-wakeup: Closing /etc/nvram-wakeup.conf ...
nvram-wakeup: Using following bios info:
nvram-wakeup: need_reboot = 0
nvram-wakeup: addr_chk_h = 0x30
nvram-wakeup: addr_chk_l = 0x31
nvram-wakeup: addr_chk_h2 = 0x00
nvram-wakeup: addr_chk_l2 = 0x00
nvram-wakeup: addr_stat = 0xCB
nvram-wakeup: addr_mon = 0x00
nvram-wakeup: addr_day = 0x62
nvram-wakeup: addr_wdays = 0x00
nvram-wakeup: addr_hour = 0x63
nvram-wakeup: addr_min = 0x57
nvram-wakeup: addr_sec = 0x58
nvram-wakeup: shift_stat = 4
nvram-wakeup: shift_mon = 0
nvram-wakeup: shift_day = 0
nvram-wakeup: shift_wdays = 0
nvram-wakeup: shift_hour = 0
nvram-wakeup: shift_min = 0
nvram-wakeup: shift_sec = 0
nvram-wakeup: rtc_time = 0
nvram-wakeup: rtc_day = 0x00
nvram-wakeup: rtc_mon = 0x00
nvram-wakeup: rtc_day_0_is_c0 = 0
nvram-wakeup: rtc_mon_0_is_c0 = 0
nvram-wakeup: reset_day = 0
nvram-wakeup: reset_mon = 0
nvram-wakeup: nr_stat = 1
nvram-wakeup: nr_mon = 4
nvram-wakeup: nr_day = 5
nvram-wakeup: nr_hour = 5
nvram-wakeup: nr_min = 6
nvram-wakeup: nr_sec = 6
nvram-wakeup: nr_rtc_day = 6
nvram-wakeup: nr_rtc_mon = 5
nvram-wakeup: nr_wdays = 7
nvram-wakeup: bcd = 0
nvram-wakeup: day_hack = 0
nvram-wakeup: upper_method = 3
nvram-wakeup: chk_method = 0
nvram-wakeup: Opening /dev/rtc in O_RDONLY mode...
nvram-wakeup: Hardware clock: 2006-10-17 08:38:27
nvram-wakeup: rtc.tm_isdst : 1
nvram-wakeup: rtc.tm_gmtoff: 7200
nvram-wakeup: diff : -1
nvram-wakeup: RTC is running in localtime!
nvram-wakeup: Test (this should be the current time of the hardware clock): Tue Oct 17 08:38:26 2006
nvram-wakeup: Requesting permissions for io ports 0x70...0x75
nvram-wakeup: The size of NVRAM is 256 bytes.
nvram-wakeup: 0000000: 0000 0030 0030 0E80 02FF FF31 0000 0000
nvram-wakeup: 0000010: 0000 0000 0000 0000 0000 0030 4343 4343
nvram-wakeup: 0000020: 045B FFFF 20BF BBBF 0300 00FF 7EBF 2AFF
nvram-wakeup: 0000030: 1C44 0000 0000 0000 0000 0000 0000 0000
nvram-wakeup: 0000040: 0000 0000 0000 0000 003F 7BFF FF37 0000
nvram-wakeup: 0000050: 3030 5D30 3030 004C 4881 0002 1800 0000
nvram-wakeup: 0000060: 0000 F128 0000 0000 0000 00FB 00B3 B000
nvram-wakeup: 0000070: 1020 2700 3850 0815 0317 1006 2602 0080
nvram-wakeup: 0000080: 7FBB BF3E 7ADF BFBE 63FF F7BF FAFF 3133
nvram-wakeup: 0000090: 5476 98BA 1032 5476 98BA F020 4005 0080
nvram-wakeup: 00000A0: 4042 5143 5153 0200 0100 001F 2604 0000
nvram-wakeup: 00000B0: 0080 FF00 0040 B82F 0A00 015E 4565 DBB6
nvram-wakeup: 00000C0: 8100 8014 9CC6 1803 0D78 1EF0 EF83 1706
nvram-wakeup: 00000D0: C8E8 3DBF 73FF FDB3 F3FF FDBF 7B7B 9F7F
nvram-wakeup: 00000E0: FA7B F53F FBFF FFBF DAFF FD3F 7377 FD3F
nvram-wakeup: 00000F0: FAFF FFB7 FA7F FDBD FBEF FF3F FBFF 6F2F
nvram-wakeup: value of the addr_stat byte is: 0xF0.
nvram-wakeup: value of the addr_day byte is: 0xF1.
nvram-wakeup: value of the addr_hour byte is: 0x28.
nvram-wakeup: value of the addr_min byte is: 0x4C.
nvram-wakeup: value of the addr_sec byte is: 0x48.
nvram-wakeup: value of the addr_chk_h byte is: 0x1C.
nvram-wakeup: value of the addr_chk_l byte is: 0x44.
nvram-wakeup: Checksum is: 0x1C44.

All values are displayed as they are stored in the nvram/rtc.
(and do not correspond necessarily to the system date/time)

WakeUp : Enabled (0xF0)
Day : 17 (0xF1)
Hour : 08 (0x28)
Minute : 12 (0x4C)
Second : 08 (0x48)
Checksum: 0x1C44

Enabling (0xF0) WakeUp-on-RTC in nvram.
New Day : 17 (0xF1)
New Hour : 08 (0x28)
New Minute : 43 (0x6B)
New Second : 26 (0x5A)
New Checksum: 0x1C75

nvram-wakeup: Byte 0x31 is changed: 0x44 -> 0x75
Now really WRITING into /dev/nvram...
nvram-wakeup: Requesting permissions for io ports 0x70...0x75
nvram-wakeup: Writing value 0x75 into byte 0x31 of NVRAM
nvram-wakeup: Byte 0x57 is changed: 0x4C -> 0x6B
nvram-wakeup: Writing value 0x6B into byte 0x57 of NVRAM
nvram-wakeup: Byte 0x58 is changed: 0x48 -> 0x5A
nvram-wakeup: Writing value 0x5A into byte 0x58 of NVRAM
nvram-wakeup: need_reboot: 0


Leider geht es noch nicht.
Aber auch der Test Direkt im Bios eine Zeit einzustellen hat den PC nicht starten lassen...



Gruss Pat

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »pat« (17. Oktober 2006, 10:05)


ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

12

Dienstag, 17. Oktober 2006, 11:18

Zitat

Original von pat
Hallo Ulf,

Das mit nvram geht mir sehr viel Zeit drauf .... :((


Ja leider aber wenn es funktioniert kann es die Zeit für dich wieder ansparen ;-)

Zitat



Leider geht es noch nicht.
Aber auch der Test Direkt im Bios eine Zeit einzustellen hat den PC nicht starten lassen...
Gruss Pat


Ups auch mit Reboot nach manuellem Einstellen nicht?

Gruss Ulf
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

13

Dienstag, 17. Oktober 2006, 12:21

Hi Ulf,

Was ich nicht verstehe ist die adressen in der /etc/nvram-wakeup.conf
addr_min = 0x57
addr_sec = 0x58
addr_day = 0x62
addr_hour = 0x63
addr_stat = 0xCB
shift_stat = 4
addr_chk_h = 0x30 # guessed
addr_chk_l = 0x31

upper_method = VT82Cxxx


Und das was der Debug dazu meint.. ... ?????
nvram-wakeup: value of the addr_stat byte is: 0xF0.
nvram-wakeup: value of the addr_day byte is: 0xF1.
nvram-wakeup: value of the addr_hour byte is: 0x28.
nvram-wakeup: value of the addr_min byte is: 0x4C.
nvram-wakeup: value of the addr_sec byte is: 0x48.
nvram-wakeup: value of the addr_chk_h byte is: 0x1C.
nvram-wakeup: value of the addr_chk_l byte is: 0x44.
nvram-wakeup: Checksum is: 0x1C44.

Sollte ich der Werte anpassen ???
Gruss Pat

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »pat« (17. Oktober 2006, 14:51)


pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

14

Dienstag, 17. Oktober 2006, 18:40

Ich gebe es auf >> Acpi geht

Hallo Ulf,

Schade ich verstehe es nicht mit acpi geht es sofort da passiert doch das gleich nur das er kein Datum verarbeitet.
Aber das ist für mich eine Saggasse..

Danke für deine Hinweise. Er springt nicht mal zuverlässig an wenn ich es im Bios entstelle.

Ich gedanke mit bei ASUS für so fehlerhafte Bios.. :( Ich werde mir andere Board aussuchen.

Vorschläge Viele PCI AM2 und nvram besser als bei dem Board.

Gruss Pat

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

15

Dienstag, 17. Oktober 2006, 19:00

Hoi Pat,
schade war gerade dabei des Readme downzuladen zum nachlesen.

btw hast du ACPIwakeup probiert, das ist recht einfach zu konfigurieren,
und geht fast mit jedem Bios.

http://www.vdr-wiki.de/wiki/index.php/ACPI_Wakeup

Gruss Ulf
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ULF« (17. Oktober 2006, 19:05)


pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

16

Dienstag, 17. Oktober 2006, 20:53

Hallo Ulf,

Mit acpi ist es schon vorher gegangen. Nvram wollte ich einbauen das er nicht jeden Tag anspringt.
Besteht eine Offnung für das Board .. aber ohne reboot.
Hast du die Infos mit den Adressen Unterschied gesehen??
Was mir am meinsten zu bedenken gibt das er nicht mal an geht wenn ich es direkt im Bios einstellen ... Da liegt mit sicherheit das Problem im Bios..

Gruss Pat :)

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

17

Dienstag, 17. Oktober 2006, 21:05

Hi pat,

ich habe zwr nicht das selbe Board wie du, aber ich hatte ähnliche Probleme wie du, um genau zu sein,

1. Nvram erstellte korrekt die nvram.conf
2. Bei gesetztem Timer wollte das Ding anfangs nicht runterfahren
3. Manchmal gings und dann startete er nciht, weil kein Eintrag im Bios
4. Manchmal war ein Eintrag im Bios gesetzt, er startet dann nicht, auch von Hand gesetzte Einträge wurden ignoriert.

Nachdem ich mein vdrshutdown-skript abgeändert habe und zwar so:

Ursprünglicher Eintrag:

su root -c "hwclock -w --localtime"

in

su root -c "hwclock -s --localtime"

werden Timer gesetzt und der Rechner ohne reboot startet wenn er soll und das immer!

Ich vermute mal da ist am Bios was faul bei mir, aber es hat geholfen!

Gruß
Wolfgang
Hardware: -
Software: -

ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

18

Dienstag, 17. Oktober 2006, 21:11

Hi Pat
also ich lese das so

Zitat

Original von pat
Was ich nicht verstehe ist die adressen in der /etc/nvram-wakeup.conf
addr_min = 0x57
addr_sec = 0x58
addr_day = 0x62
addr_hour = 0x63
addr_stat = 0xCB
shift_stat = 4
addr_chk_h = 0x30 # guessed
addr_chk_l = 0x31

upper_method = VT82Cxxx

das sind die Adressen wo im Bios was steht

Zitat


Und das was der Debug dazu meint.. ... ?????
nvram-wakeup: value of the addr_stat byte is: 0xF0.
nvram-wakeup: value of the addr_day byte is: 0xF1.
nvram-wakeup: value of the addr_hour byte is: 0x28.
nvram-wakeup: value of the addr_min byte is: 0x4C.
nvram-wakeup: value of the addr_sec byte is: 0x48.
nvram-wakeup: value of the addr_chk_h byte is: 0x1C.
nvram-wakeup: value of the addr_chk_l byte is: 0x44.
nvram-wakeup: Checksum is: 0x1C44.

das sind die Werte die in den Adresssen stehen

Zitat


Sollte ich der Werte anpassen ???
Gruss Pat


was willst du da anpassen?

Hast du beim Manuellen Eintragen einen Reboot vor dem Halt gemacht?
Und danach wachte das Board auch nicht auf?

Gruss ulf
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »ULF« (17. Oktober 2006, 21:11)


pat

Meister

  • »pat« ist der Autor dieses Themas

Beiträge: 1 950

Wohnort: Alsace/France

Beruf: Informatique

  • Nachricht senden

19

Dienstag, 17. Oktober 2006, 21:41

Hi Ulf,

Zitat

Hast du beim Manuellen Eintragen einen Reboot vor dem Halt gemacht?
Und danach wachte das Board auch nicht auf?


Sorry verstehe ich so nicht..
1. nvram ein Weckzeit einstellen zum Test in 10 Minuten
2. reboot
3. Halt ??

Pat

Diskless Client: SMT 7020S und S100 128SDRAM 32DOM zendeb 0.4.0 beta1 mit MMS 1.0.8.5
Hardware: Pundit-R Celeron 2.4 256DDRAM Samsung SATA 400 Gbyte Festplatte Hauppage Nexus-S Rev 2.3 Nova-S Plus DVD-RAM LG
Software: EasyVDR 0.6.0 (vdr-1.6.0-2-ext64), LinVDR 0.7 1.4.7 Mahlzeit, SUSE-Server 10.2 1.6.0-1
Test System: Shuttel AMD Athlon 2.6 Ghz 256DDRAM Samsung 250Gbyte Hauppage Nexus-S Rev 2.3 DVD-RAM LG ......

:fans :welle

ULF

Erleuchteter

Beiträge: 3 898

Wohnort: Niedersachsen

  • Nachricht senden

20

Dienstag, 17. Oktober 2006, 21:52

Zitat


Sorry verstehe ich so nicht..
1. nvram ein Weckzeit einstellen zum Test in 10 Minuten
2. reboot
3. Halt ??


1. nix nvram, einfach nur ins Bios gehen und Zeit einstellen
2. booten und nochmal reboot
(der reboot bringt hier wahrscheinlich nichts schadet aber keinesfalls)
3. shudown -h now

4. warten ob das Board aufwacht

Gruss Ulf

Ps wenn das nicht tut liegt es nicht am nvram
achja nvram sollte während des Versuchs nicht aktiv sein,
nicht das dir das die Zeit verstellt oder so
Antec Fusion Black, M3N78-VM, Athlon 4850e, 2xDVB-c, yavdr

Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von »ULF« (17. Oktober 2006, 21:59)


Immortal Romance Spielautomat