Sind Umschaltzeiten unter einer Sekunde OK? VNSI-Server für XBMC ist da!

  • Sowohl beim Vorgehen nach aelo als auch schnere kompiliert die cmdcontrol.c nicht durch:



    Was habe ich übersehen?
    EDIT
    OK, ich hatte noch ne alte vdr-dev (1.6.x) installiert, nachdem ich die removed hatte gings auch mit dem Nachbarn (ein paar symlinks sei dank).
    /EDIT


    Danke,
    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

    The post was edited 1 time, last by gandalf ().


  • Weiß leider noch nicht woran das liegt, ist seit den trunk merge so, irgendwas hat die Umschaltzeiten im trunk verdoppelt, weshalb er gegen den Timeout läuft, hab als workaround die Zeit von 5 auf 15 Sekunden erhöht, allerdings müsstet ihr wenn XBMC schon Einstellungen hat dies auch manuell in den TV Einstellungen ändern.


    Grüße,


    Alwin

  • pingpong
    Ich habe jetzt mal alles aus der Version 29132 kompiliert, auch das plugin, die Erweiterung hinzugefügt und los gings.


    Leider bekomme ich schon beim Tunen des ersten Kanals kein Bild und folgende Logausgabe

    Also muss ich wohl noch ein paar files erzeugen/anpassen die den Zugriff regeln, der default hat aber wohl erstmal gegriffen. Wie kriege ich jetzt das Problem mit dem buffer noch in den Griff?


    Gruss,
    Gandalf

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • Quote

    Original von gandalf
    pingpong
    Ich habe jetzt mal alles aus der Version 29132 kompiliert, auch das plugin, die Erweiterung hinzugefügt und los gings.


    Leider bekomme ich schon beim Tunen des ersten Kanals kein Bild und folgende LogausgabeAlso muss ich wohl noch ein paar files erzeugen/anpassen die den Zugriff regeln, der default hat aber wohl erstmal gegriffen. Wie kriege ich jetzt das Problem mit dem buffer noch in den Griff?


    Gruss,
    Gandalf


    Sieht so aus als wenn du das xbmc-dir/xbmc/pvrclients/vdr-vnsi/vdr-plugin-vnsi/vnsi-server Verzeichnis noch nicht nach: vdr-dir/plugins/vnsi-server kopiert hast. Das ist aber nicht kritisch, er nimmt dann eben statt der allowed_hosts.conf die svdrphosts.conf.


    Aber die Buffer overflows habe ich leider auch.
    Liegt das evtl. daran, dass ich (wir?) eine FF Karte haben? (nur eine spontane/dumme idee :D)


    Grüße

    silence: Ubuntu 9.10 | Asus M3N78-VM | AMD 4450e | TT-budget S2-1600 DVB-S2 | 5 X 1TB Raid5 | vdr (1.7.10) | xbmc opdenkamp master | Optoma HD65 Beamer | Samsung LE37B530 LCD | Onkyo 605 AVR | Heco Victa 700/300/100/25A

  • sphere
    Ja, ich habe in der Tat eine FF, Signatur verrät es ;).


    Zum Empfangen nehme ich aber die DVB-S2 Karte, darauf ist der vdr eigentlich zuverlässig geeicht. An der FF ist auch gar kein Antennenkabel angeschlossen da ich keine zwei Leitungen zum vdr liegen habe. Ich benutze sie nur wenn vdrpau mal wieder nicht so will wie ich.


    Das mit den conf Dateien habe ich inzwischen im Griff, das mit den buffern leider noch nicht.


    aelo
    Das schaue ich mir mal jetzt an, auch wenn ich noch nicht genau weiss worauf du hinauswillst...

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • gandalf :
    Habe das selbe Problem beim kompilieren wie du. Hatte auch noch eine alte vdr version installiert, obwohl ich die neuste vdrdevel nutze. Habe die alte vdr nun inkl. vdr-dev entfernt und statt dessen vdrdevel-dev installiert. Leider habe ich immernoch keinen Erfolg. Könntest du mir dein genaues Vorgehen vielleicht erläutern? Habe leider auch erst ein paar Monate Linux-Erfahrung auf dem Buckel...


  • bin mir nicht "ganz" sicher, aber wenn ihr das plugin für debian-vdrdevel installieren/kompilieren
    wollt braucht ihr das make-special-vdr skript/paket. (keine ahnung ob das skript selber auch angepasst werden muss)
    übersetzen muss man es so :


    PATCHVARIANT=multipatch SPECIAL_VDR_SUFFIX=devel fakeroot dpkg-buildpackage -b -uc -tc -Rmake-special-vdr



    aber wie gesagt, kann muss nicht sein


    hier kompiliert es ohne probleme, auch mit der version von tomg aber auf ubuntu und ohne devel (deshalb auch ohne -Rmake-special-vdr)

  • Hallo gandalf,


    aus irgendwelchen Gründen scheint der receiver noch nicht aktiv zu sein weswegen der das Streamer Thread sich sofort wieder beendet, hab in r29136 mal einen andere Überprüfung eingebaut. Hoffe das es damit besser geht.


    Postet nochmal das syslog wenn es doch nicht geht.


    Habe auch das plugin angepasst das es unter 1.6.0 kompiliert.


    Grüße,


    Alwin

  • Also was habe ich gemacht?


    Ich habe wie du die vdr-devel deinstalliert, danach, das hatte ich schon befürchtet, hatte ich eine ganze Reihe von Fehlermeldung a la Datei so und so nicht gefunden, es wurden halt immer noch die include Dateien in /usr/include/vdr gesucht.


    Ich habe das jetzt mal so gelöst das ich unter /usr/inlude

    Code
    1. lrwxrwxrwx 1 root root 9 8. Apr 15:24 vdr -> vdrdevel/
    2. drwxr-xr-x 4 root root 4,1k 16. Mär 19:04 vdrdevel


    und /usr/share die gezeigten symlinks angelegt habe:

    Code
    1. lrwxrwxrwx 1 root root 13 8. Apr 15:25 vdr-dev -> vdrdevel-dev/
    2. drwxr-xr-x 6 root root 4,1k 22. Jun 2009 vdrdevel

    Danach ging es dann. Ich habe allerdings die hier beschriebene Anleitung benutzt.


    Wichtig war auch beim letzten Kopiervorgang die Datei gleich umzubenennen, also statt

    Code
    1. cp /usr/src/vdr-1.7.14/PLUGINS/lib/libvdr-vnsiserver.so.1.7.14 /usr/lib/vdr/plugins/


    muss es für eine vdrdevel Installation heissen:

    Code
    1. cp /usr/src/vdr-1.7.14/PLUGINS/lib/libvdr-vnsiserver.so.1.7.14 /usr/lib/vdrdevel/plugins/libvdrdevel-vnsiserver.so.1.7.14


    Das war alles denke ich.


    Sag Bescheid ob es klappt.


    Liebe Grüsse,
    Gandalf

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin


  • Bedeutet ich muss nur das plugin neu kompilieren?


    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • Quote

    Original von hotzenplotz5
    hä ? aber vdr-dev (vdr-1.6.0) vdrdevel-dev (vdr-1.7.14)
    sicher das es so läuft ?


    Ja, aber die besagte Anleitung geht schon von einem vdr der Version 1.7.14 aus, nur das er dort nur vdr heisst, bei mir aber vdrdevel. Es sollte aber am Ende derselbe Stand sein.
    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin


  • Was soll ich sagen, es wird aus irgendeinem Grund nichtmal mehr versucht das Programm zu starten, egal welchen Sender ich wähle.
    Im Log sehe ich auch nur:

    Code
    1. Apr 8 19:06:19 VDR1 vdrdevel: [19254] loading /var/lib/vdrdevel/plugins/vnsi-server/allowed_hosts.conf
    2. Apr 8 19:06:19 VDR1 vdrdevel: [19254] VNSI: Client with ID 0 connected: 127.0.0.1:50324
    3. Apr 8 19:06:19 VDR1 vdrdevel: [19253] VNSI: Welcome client 'XBMC Media Center' with protocol version '1'


    Danach nichts VNSI spezifisches.


    :ratlos


    G.

    --------------------------------------------------------------------------
    HW: AMD Athlon(tm) 7850, 2 GB RAM, Gainward G210 (NVidia GF 210), nvidia 195.36.31, 640+750GB internal HD, 1TB +(2*1TB) NAS (WD My Book World Edition I&II), Hauppauge FF Rev. 2.1, Budget: AVerTV DVB-T 771, WinTV HVR-4000 DVB-S(2)
    VDR: 1.7.15, Plugins: xineliboutput osdteletext dvbsddevice epgsearch streamdev-server vnsiserver skinsoppalusikka tvonscreen live fritzbox menuorg externalplayer dvd text2skin

  • Quote

    Original von pingpong
    aus irgendwelchen Gründen scheint der receiver noch nicht aktiv zu sein weswegen der das Streamer Thread sich sofort wieder beendet, hab in r29136 mal einen andere Überprüfung eingebaut. Hoffe das es damit besser geht.


    Hi,


    ich hatte vorher identische Probleme wie Gandalf, die scheinen jetzt mit dem neu gebauten vdr plugin weg zu sein.


    Ich lasse heute abend den WAF heute bei Germanys Next Topmodel mal analysieren :D


    Grüße

    silence: Ubuntu 9.10 | Asus M3N78-VM | AMD 4450e | TT-budget S2-1600 DVB-S2 | 5 X 1TB Raid5 | vdr (1.7.10) | xbmc opdenkamp master | Optoma HD65 Beamer | Samsung LE37B530 LCD | Onkyo 605 AVR | Heco Victa 700/300/100/25A