keni WakeUp bei Timer

  • Nabend zusammen,


    ich lese hier schon lange Zeit mit, komme nun aber nicht weiter.


    Ich hatte zum Testen LinVDR mit Mahlzeit Image installiert, da funktionierte Aufwachen / herunterfahren ohne Probleme, jedoch gab es einige andere Probleme, weswegen ich nun den c't VDR installiert habe. Die Aktualisierung der Autotimer und tvmovie2vdr funktioniert hier nun einwandfrei.


    Nun zu meinem Problem: Der PC wacht nicht auf, wenn er etwas aufnehmen soll. Nach der Anleitung von www.vdr-wiki.de funktioniert alles und der PC wacht auch auf. D.h. ein


    echo "2007-01-18 11:33:00" >/proc/acpi/alarm
    und ein
    cat /proc/acpi/alarm


    führen zum Erfolg und der PC fährt auch hoch. Wenn ich jedoch einen Timer setze, interessiert ihn das gar nicht. Unter LinVDR - Mahlzeit funktionierte das, d.h. die Hardware unterstützt das wohl ...


    Die Suche habe ich auch schon bemüht, bin jedoch nciht wirklich fündig geworden. Falls ich nicht richtig gesucht habe, teilt mir das bitte mit, ansonsten würde ich mich freuen, wenn mir jemand auf die Sprünge helfen könne.


    Dankeschön,


    DerStandart

  • Hi,
    das vdr-ddon-acpiwakeup hast Du installiert ?


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Standard wird mit 'd' geschrieben. *g* Das andre sind Standarten, also diese kleinen Fähnchen am Auto oder auch Fahnen früher.



    Dein echo Befehl in /proc/cat/alarm hat nichts mit addons zu tun, das ist ein Kommando direkt an den Kernel (sofern der das unterstützt, wie in deinem Falle).

  • Gut ... aber wie gesagt, das Addon ist installiert. Habe den Befehl zur Installation bereits mehfach eingegeben. Bei wiederholter Eingabe passiert nichts mehr, d.h. da wird nichts mehr runtergeladen.


    Wie kann ich weiter verfahren?

  • Also ich würd jetzt schauen, ob das shutdown Script richtig aufgerufen wird und es die Aufwachzeit auch richtig schreibt.


    Nur wie?


    Vielleicht kann man das Shutdownkommando (/usr/default/vdr glaub ich), welches ja wohl als letztes ausgeführt wird, einfach mal in etwas sorgloses wandeln, maybe 'cd /'. Dann checken, ob der richtige Wert in jener Datei steht.


    Faudeer

    Synchronisieren und Backup auch unter Linux! 250MB extra für euch und mich bei Dropbox-Anmeldung (zu den kostenlosen 2GB), wenn ihr meinen Referral nutzt.

  • Hilft mir jetzt leider nicht weiter ... Welches Script ist das und was muss drinstehen?


    Wie gesagt, auf der selben Hardware mit dem Mahlzeit-Image lief das ohne Probleme. Muss also irgendwas software-seitiges sein. Neuinstallation hat auch nichts gebracht.


    Gibts noch Lösungsansätze?

  • Hi,
    a) wie sieht Deine /etc/vdr/vdr-addon-acpiwakeup.conf aus. ?
    Wenn sie da nicht liegt, suche sie mit "locate" oder "find"


    b) wie sieht Dein Script /etc/init.d/vdr-addon-acpiwakeup aus ?
    besteht ein Link aus dem Verzeichnis /etc/rc2.d dahin ?


    c) was liefert: ps ax | grep vdr ?


    Gruss
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Hallo beagle,


    vielen Dank für Deine Antwort:


    zu a:


    zu b:


    Es gibt von /etc/rc2.d einen Link zu S20vdr-addon-acpiwakeup


    zu c:

    Code
    2366 ? Ss 0:00 /bin/bash -p /usr/sbin/runvdr -v /var/lib/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown.wrapper -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 2001 --lirc -P pilot -P "autotimeredit " -P femon -w 60 < /dev/tty8
    2396 ? Sl 0:29 /usr/bin/vdr -v /var/lib/video.00 -c /var/lib/vdr -L /usr/lib/vdr/plugins -r /usr/lib/vdr/vdr-recordingaction -s /usr/lib/vdr/vdr-shutdown.wrapper -E /var/cache/vdr/epg.data -u vdr -g /tmp --port 2001 --lirc -P pilot -P autotimeredit -P femon -w 60
    2408 ? SNs 0:02 /usr/bin/perl /usr/bin/vdradmind -nf
    2462 ? SN 0:12 /usr/bin/perl -w /usr/bin/xxvd --configfile=/var/lib/vdr-xxv/xxvd.cfg --logfile=/var/log/vdr-xxv/xxvd.log --pidfile=/var/run/vdr-xxv/xxvd.pid --localedir=/usr/share/locale/ --moduledir=/usr/share/perl5/vdr-xxv/XXV/MODULES --docudir=/usr/share/doc/vdr-xxv/ --htmldir=/usr/share/vdr-xxv/html/ --fontdir=/usr/share/fonts/truetype/ttf-bitstream-vera/ --verbose=3 --contrib=/usr/share/vdr-xxv/contrib --newstmpl=/usr/share/vdr-xxv/news/ --newsmods=/usr/share/perl5/vdr-xxv/XXV/OUTPUT/NEWS --vtxdir=/usr/share/vdr-xxv/vtx --poddir=/var/cache/vdr-xxv/doc/
    2723 pts/0 D+ 0:00 grep vdr
  • Hm, sieht eigentlich gut aus. Wenn ich das Ganze richtig versteh, muß vdr in die Datei /var/cache/vdr/acpiwakeup.time die Aufweckzeit reinschreiben.
    Test mal, den vdr zu stoppen mit
    > /etc/init.d vdr stop


    dann schau mal, ob eine /var/cache/vdr/acpiwakeup.time existiert und was drinsteht.


    Der ACPI wakeup Script schreibt diesen Inhalt dann in die /proc/acpi/alarm wenn er gestoppt wird.


    Also:
    > /etc/init.d/vdr-addon-acpiwakeup stop


    und die Zeit sollte in /proc/acpi/alarm stehen.

    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Vielen Dank für Deine Hilfe - wir kommen der Sache näher.


    Wenn ich den VDR stoppe, existiert die Datei /var/cache/vdr/acpiwakeup.time nicht.


    Rufe ich danach /etc/init.d/vdr-addon-acpiwakeup stop auf, so ist die alarm-datei leer.


    Beim Stoppen des VDR klappt also etwas nicht...


    Gruß,
    Christoph

  • Hi,
    ich habe gerade mal bei mir geschaut. Das stoppen des vdr alleine erzeugt bei mir diese Datei auch nicht.
    Die kommt irgendwo anders her, wenn die Kiste runterfährt. Ich schau mal, ob mir noch etwas einfällt.


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Aaalso:


    Bei mir gibt es eine /usr/bin/poweroffvdr


    darin steht:


    at now <<EOF
    /usr/lib/vdr/svdrpsend.pl HITK Power
    EOF


    hast Du die ?
    Ansonsten gibt es im Wiki eine Beschreibung zum ACPI Wakeup. Bist Du da mal duirch ?


    Ich glaube mich erinnern zu können, daß Debian standardmäßig die Hardwareuhr wieder verstellt. Das hatte ich bei mir mal geändert.
    Der init Scrpt heißt hwclock.sh und sollte in rc2 nicht aufgerufen werden.


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

    Edited 3 times, last by beagle ().

  • Ja, die habe ich und da steht auch das gleiche drin, wie bei Dir!


    Durch den Wiki-Artikel bin ich durch. Bin mir allerdings nicht sicher, ob ich da nicht evtl. Fehler gemacht habe. Aber eigentlich habe ich mich Schritt für Schritt dran gehalten.

  • ich habe noch etwas editiert.

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Also, die Datei hwclock.sh gibt es, doch wie stelle ich es an, dass sie in rc.2 nicht aufgerufen wird?


    Im Wiki hier heißt es, dass man dort was einfügen soll.


    Habe ich gemacht, doch mit

    Quote

    Außerdem muss hier in jeder Zeile mit hwclock der Parameter $HWCLOCKPARS hinzugefügt werden.

    kann ich nichts anfangen.


    Gruß,
    Christoph

  • Sorry, beim Runterfahren wird hwclock.sh aus rc0.d aufgerufen.
    Ich hatte es auch bei einer älteren Installation mal entfernt.


    Was im WIKI gemient ist:
    Die Definition


    HWCLOCKPARS="--directisa"


    muß irgendwo am Anfang in der Datei /etc/init.d/hwclock.sh stehen (bei mir steht diese Definition schon drin)


    Dann muß überall, wo der Befehl hwclock im Script hwclock.sh aufgerufen wird (das siehst Du an der vollen Pfadangabe /bin/hwclock blabla) der Parameter $HWCLOCKPARS angehängt werden.


    Gruß
    beagle

    Asus TUSL2-C, 128MB, 1xTT FF 2300 mod. 2xTT Budget DVB-S 1.5, SP1614, ND3550A, 2.6.20.3, Debian etch, Tobi experimental etch(1.4.7-1ctvdr1), ACPI wakeup, Psone Display.

  • Es sieht mir so aus, als wird die hwclock.sh aus rc0.d heraus aufgerufen.


    HWCLOCKPARS="--directisa" steht bei mir auch schon drin.


    Wie gehts weiter? Soll ich die da rauslöschen? Oder dafür sorgen, dass der Paramteter da mit angehängt wird?

  • hwclock.sh sieht nun so aus:


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!