Ich will kein Autodetect !!

  • Hi,


    also ich dachte ich kann es inzwischen etwas besser - allerdings fühle ich mich im Moment an meine ersten Linux und VDR Tage zurückerinnert.
    Also:
    Habe nun nach langer Zeit den Schritt von SuSE8.2 auf 10.1 gemacht, und in dem Zuge wollte ich von VDR 1.2.6 auf 1.4.3 wechseln. Erstes Problem: DVB-Treiber; habe ich einfach nicht nach der Anleitung im WIKI hinbekommen, habs dann mit den SuSE-Treibern verucht und voila-ging direkt! Weiter im Text: Remote-Plugin (Ver. 0.3.9) für meine NEXUS Rev 2.1 compiliert - ohne Fehler.
    Erster Start: ./vdr -Premote und dann will die Büchse die FB anlernen/autodetecten... Hm, meine alte remote.conf ins /video Verzeichnis kopiert - bringt nix :-(


    Obwohl die gleiche FB, gleicher IR-Empfänger, gleiche HW, nix im Raum verrückt, gleiche Mondphase und Gezeitenstand erkennt der VDR die FB nicht. Kann man die Autodetectfunktion nicht abstellen und einfach die alte remote.conf weiter nutzen?


    PS: Früher mußte ich noch eine "alles.rc5" Datei einbinden, kanns daran liegen? Wie müßte ich die nun einbinden?

    VDR 1.4.6 Duron 1300 - 736 MB Ram - 4*160GB Samsung SP1604N - 2*160GB WD - 1*400GB Samsung - 1*500GB WD - 1*Nexus Rev.2.1 - 1*NovaSE

  • Weiß jetzt auch nicht so genau, aber vielleicht ist dein VDR einfach so eingestellt, dass er als erstes immer einmal die FB einrichten will. Vielleicht nervt er einfach solange, bis es erledigt ist...


    In dem Fall könntest du doch einfach mal 1-2 Tasten einrichten und anschließend deine alte Configdatei an die Stelle schieben, wo der VDR sie abgelegt hat.



    Ist nur ein Schuss ins Blaue,
    Marcus

    Hardware: Zalman HD160XT; Asus H97M-Plus, 1024MB RAM, Digital Devices Cine S2 (rev 7), Atric-Einschalter, NEC3520 DVD-Laufwerk, Samsung 256 GB SSD-Festplatte --> darauf yaVDR 0.6
    Hifi: Denon AVR4306, Samsung UE40ES6300

  • Hi,


    hätte ich ja gerne gemacht, aber meine FB die vorher ging wird auf einmal nicht mehr erkannt - ergo kann ich um die Hürde so nicht umher ....

    VDR 1.4.6 Duron 1300 - 736 MB Ram - 4*160GB Samsung SP1604N - 2*160GB WD - 1*400GB Samsung - 1*500GB WD - 1*Nexus Rev.2.1 - 1*NovaSE

  • Ich hatte mal ein ähnliches Problem. Lag an der Reihenfolge, wie der DVB Treiber die Karten erkennt. Du kannst ja mal probehalber die Nova rausziehen und den VDR dann mit der FF alleine starten. Falls das dann klappt, evtl. Karten umstecken oder aktuelleren Treiber installieren.

    VDR1: Dign HV5 mit Noritake GU 256x64C-3900 VFD,Asus P4B-E, P4 1,8 GHz, 160 GB Samsung SP1614N + 200 GB Samsung SP2014N, 2 FF DVB-S (1x4MB MOD), AV-Board 1.3, WLAN, Debian Sarge 2.6.15, VDR 1.5.2
    VDR2: OrigenAE X15e, Asus P5Q, Intel E5200, MSI N9500 GT, 1 TB Samsung HD103SI, TT S2-3200 + Nova HD-S2, Ubuntu 8.10 + VDR 1.7.0


    VDR3: Mediacenter-Gehäuse mit L4M-Display, DFI LANPARTY JR GF9400-T2RS, Intel E8400, 1 TB Samsung HD103UJ, Digital Devices Cine S2 Rev 5.5, yavdr 0.3.0a

  • Hi,


    danke für den Hinweis - ich muß ergänzen das ich während des ganzen DVB-Treiber Ärger die NOVA bereits entfernt habe und aktuell nur die NEXUS drin ist. (Fußzeile stimmt noch nicht da dort die alte Konfiguration steht)


    Zwischenzeitlich habe ich mal mit den -Premote-Parametern rumprobiert z.B.


    -i dev/input/event0...2 (1 ist wohl richtig)


    kein Erfolg

    VDR 1.4.6 Duron 1300 - 736 MB Ram - 4*160GB Samsung SP1604N - 2*160GB WD - 1*400GB Samsung - 1*500GB WD - 1*Nexus Rev.2.1 - 1*NovaSE

    The post was edited 1 time, last by oli33 ().

  • Neuer Versuch, neue Frage:


    Mit dem alten DVB-Treiben gab es ein Programm av7110_loadkeys über das man die alles.rc5 geladen hat. da ich nun die SUSE Treiber verwende tut das nicht mehr. Der DVB-Treiber nach WIKI hat auch keine entsprechende Software im Bauch.


    Wie kann in den die alte remote.conf behalten??

    VDR 1.4.6 Duron 1300 - 736 MB Ram - 4*160GB Samsung SP1604N - 2*160GB WD - 1*400GB Samsung - 1*500GB WD - 1*Nexus Rev.2.1 - 1*NovaSE

  • hi,


    habe den vdr "klassisch" (kein Suse RPM) von hand installiert unter /usr/local/src. Wollte vorher den DVB-Treiber auf gleichem Wege installieren, hing da aber einfach fest. (trotz Anleitung WIKI) Habe dann den DVB-Treiber von Suse zum testen geladen, ging sofort. Nun kann ich zwar den VDR mit dem Suse dvb-Treiber starten, abe rdas remote 0.3.9 will nicht....


    Bin im Moment ratlos - wie kann ich denn testen mit welchem /dev/input/eventX ich den IR-Empfänger denn anspreche?

    VDR 1.4.6 Duron 1300 - 736 MB Ram - 4*160GB Samsung SP1604N - 2*160GB WD - 1*400GB Samsung - 1*500GB WD - 1*Nexus Rev.2.1 - 1*NovaSE

  • :moin,


    zu deinem remote.conf Problem.


    Wenn ich das richtig in Erinnerung habe legt SuSE eine .conf für die KBD Kommandos und eine für die LIRC Kommandos an. Zur Laufzeit wird darau dann eine remote.conf erstellt, die man tunlichst nicht von Hand editieren sollte.
    Irgendwo liegt dann eine remote.kbd.conf und eine remote.lirc.conf rum.


    Also simm deine vorhandene und splitte Sie entsprechend.


    Zu den Treibern:


    SuSE lädt die Treiber über Hotplug. Ist die Reihenfolge falsch, hat man zwei Möglichkeiten. Entweder die Karten in den PCI Slots tauschen, oder die Treiber alle Blöacklisten und von Hand laden(Eigenes init Script)

    Registered VDR User #841
    P4 1.7, 256 MB Ram, 200 GB Samsung, TT DVB-C 2.1, TT DVB-C 1500, VDR Extension Board, 12.1" TFT, Pearl Mod-It Gehäuse  
    Suse 10, Kernel 2.6.13-15.11-default, VDR 1.4.2-BP

  • Quote

    Irgendwo liegt dann eine remote.kbd.conf und eine remote.lirc.conf rum.


    Hm, ich nutze aber kein lirc, sollte es dann logischerweise nicht remote.rc5.conf (oder so) heißen?


    Zum Treiber:


    Ich habe nur die Nexus im System gehabt, da kann es eigentlich kein Reihenfolgeproblem geben ...

    VDR 1.4.6 Duron 1300 - 736 MB Ram - 4*160GB Samsung SP1604N - 2*160GB WD - 1*400GB Samsung - 1*500GB WD - 1*Nexus Rev.2.1 - 1*NovaSE

  • Hi,


    weiss nicht, ob du dein Problem schon behoben hast.


    Miit "cat /proc/bus/input/devices" den event rausfinden: "DVB on-card IR receiver" oder so.


    Schau mal in yast->system->Editor für /etc/sysconfig-Dateien->Hardware->DVB->DVB_AV7110_LOADKEYS...solltest du da eine haben, dann einfach eintragen dvbtreiber neu laden->remoteplugin richtigen event übergeben.


    Wenn du eine andere hast, mußt du ne eigene Keymap erstellen und im runvdr laden lassen. Is aber auch nicht weiter wild.


    Grüße

  • Gibt es eine Möglichkeit beim Autodetect eine SAT Karte mit IR Schnittstelle vom Autodetect auszuschließen ? Bei mir nimmt Autodetect immer die Budget Karte, aber an der funktioniert meine Fernbedienung nicht. Konfiguration ist vorhanden, aber regieren tut sie nicht.

    ASRock K7S41, Geode 1750+, 512 MB, 1xNexus-S + 1xNova-S, SP1614, ND3550A, 2.6.15, Tobi experimental (1.4.45), NVRAM wakeup, LCD Display.