[tvscraper] Fehlende Scrapings

  • die Bilder im *.rec Folder sind nur für Anwendungen, die das plugin service interface von tvscraper nicht nutzen, also z.B. für KODI.

    live und die VDR skins nutzen das plugin service interface von tvscraper und ignorieren diese Bilder.

    Wäre es nicht sinnvoll für KODI und auch allgemeine Archivierungszwecke die Bilddateien in die geschnittene "mitzunehmen"?

    Ich mein, wenn sie eh schon im Ursprungsordner liegen...

  • Also, ich kann hier wieder zurückrudern und die Startzeit der Aufnahme ignorieren. Es ist doch recht selten, dass 2 Aufnahmen das gleiche Event haben, aber unterschiedliche Sendungen sind.

    Das würde ich als die beste Lösung ansehen.

    Wäre es nicht sinnvoll für KODI und auch allgemeine Archivierungszwecke die Bilddateien in die geschnittene "mitzunehmen"?

    Ich mein, wenn sie eh schon im Ursprungsordner liegen...

    Das würde bedeuten, das der Core-VDR gepatcht werden müsste, hmm...

    Andererseits nutzen ja nicht alle Skins diese Bilder, so das es dann immer noch Probleme gibt.

    Eine Lösung im tvscraper wäre hier sicherlich die allgemeinere.


    Grüße

    kamel5

    VDR 2.6.6: ASUS Prime X470-PRO, Ryzen 7 5700X, 64GB, 6TB HD, GT1030, Fedora 39 Kernel 6.8 X86_64, Devicebonding 2 x 1 auf 2, TT6400, DVBSky S952 V3

    Git-Repo: gitlab.com/kamel5

  • Im git ist ein update.

    Damit sind die scraper Daten für geschnittene Aufnahmen über das VDR interne Service Interface wieder sofort verfügbar.

    Sollte mit live und den Skins funktionieren.


    Bitte testen.


    ~ Markus

    Client1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 20.04, VDR 2.6x

    Client2: RPI3

    Server: RPI4, Sundtek SkyTV Dual 2x

  • Im git ist ein update.

    Damit sind die scraper Daten für geschnittene Aufnahmen über das VDR interne Service Interface wieder sofort verfügbar.

    Sollte mit live und den Skins funktionieren.


    Bitte testen.


    Hier mit Live getestet, funktioniert es wie es soll.

    Vielen Dank!

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • Hallo,


    ich habe seit einiger Zeit (weiß aber nicht seit wann) Probleme mit dem Scraping von Aufnahmen.


    Hier mal ein Beispiel aus der Serie Sherlock:


    Das Seltsame ist, dass manche im Verzeichnis Nummerierte Folgen sauber gescrapt werden:



    Code: log 2
    Apr  3 14:07:44 vdr vdr[3082]: [3287] SVDRP vdr < 127.0.0.1:54804 client connection accepted
    Apr  3 14:07:44 vdr vdr[3082]: [3287] SVDRP vdr > 127.0.0.1:54804 server created
    Apr  3 14:07:44 vdr vdr[3082]: [3148] tvscraper: scanning video dir
    Apr  3 14:07:44 vdr vdr[3082]: [3287] SVDRP vdr < 127.0.0.1:54804 connection closed
    Apr  3 14:07:44 vdr vdr[3082]: [3287] SVDRP vdr < 127.0.0.1:54804 server destroyed
    Apr  3 14:07:44 vdr vdr[3082]: [3148] tvscraper: Scrap recording "/video/videos/_Sherlock/06_Sherlock_-_Der_Reichenbachfall/2016-08-01.20.15.24-0.rec"
    Apr  3 14:07:44 vdr vdr[3082]: [3148] tvscraper: touch "/var/cache/vdr/plugins/tvscraper/.recordingsUpdate"
    Apr  3 14:07:44 vdr vdr[3082]: [3148] tvscraper: scanning video dir done
    Apr  3 14:07:44 vdr vdr[3082]: [3148] tvscraper: start scraping epg

    Manchmal werden dann, nach mehrfachen Versuchen, des Scrapens einzelner Aufnahmen, die Daten doch angezeigt.


    Irgendwie funktioniert das gerade bei mir recht unzuverlässig.
    Aber das hatte doch schon mal alles gut funktioniert.


    Browser Cache löschen und reload habe ich natürlich gemacht.


    MarkusE hast Du eine Idee, was bei mir schief läuft?

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • Auch habe ich das Problem, dass manche neuen Aufnahmen, die eigentlich schon einen Bezug zu tvscraper hatten, irgendwann nach einem reboot in live wieder ungescrapt erscheinen.

    Wenn ich die Aufnahme dann manuell scrape, kommen meist wieder die Einträge.


    Kann das auch mit dem API-Fehler zusammenhängen?

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • Hi,


    Im git ist ein Update. Damit reagiert tvscrapper besser auf den Fehler in der TheTVDB API:

    • Altes Verhalten: bei "Not Found" wurde die Serie aus der lokalen Datenbank gelöscht (not found -> existiert nicht mehr in TheTVDB).
    • Neues Verhalten: bei "Not Found" werden die Episoden in der Originalsprache geladen.

    Also, ich kann nicht zaubern: Wenn TheTVDB API die Namen der Episoden in deutsch nicht liefert, kann ich auch die Episoden nicht identifizieren :( .


    Außerdem:

    • Diverse bug fixes
    • Update von override_tvs.conf (thanks to rüsseltier )

    Bitte testen.

    heifisch , ich hatte bereits mit dem letzten git commit einen Fehler gefixed, aufgrund von dem die Zuordnung von geschnittenen Aufnahmen zum Film verloren ging. Bitte teste doch mal das neueste git ...



    ~ Markus

    Client1: ASUS P5QC, Dual Core 3G, Cine S2, Ext. Board von TBE, Xubuntu 20.04, VDR 2.6x

    Client2: RPI3

    Server: RPI4, Sundtek SkyTV Dual 2x

  • Bitte testen.

    heifisch , ich hatte bereits mit dem letzten git commit einen Fehler gefixed, aufgrund von dem die Zuordnung von geschnittenen Aufnahmen zum Film verloren ging. Bitte teste doch mal das neueste git ...

    Danke MarkusE .


    Leider bekomme ich damit ein Segfault:


    Wann der Segfault auftritt, konnte ich noch nicht nachvollziehen.

    Sieht danach aus, das keine Benutzerinteraktion nötig ist.


    Am Anhang noch bt full

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!