Yavdr anisble + secure boot

  • Hi,


    Eventuell hat das nur bedingt mit yavdr zu tun, aber ich frag mal hier (wenn es hier nicht passt bitte verschieben).

    Habe ein Multiboot System also einmal Win 10, einmal Kubuntu-20.04, und einmal yavdr Ansible, bislang hat alles weitgehends reibungslos geklappt

    und ich konnte alle drei Systeme über Grub booten wobei im Bios unter Boot -> Sicheres Booten immer Uefi Windows eingestellt war.

    Doch neulich habe ich das Kubuntu-20.04 upgedatet (nur Pakete aktualisiert) und nun fährt yavdr nur noch hoch wenn ich im Bios

    bei Boot -> Sicheres Booten auf "anderes Betriebssystem" umstelle.

    Wie das sein kann ist mir nicht klar denn das yavdr Ansible habe ich ja nicht angerührt


    Wie geht das (kann ja eigentlich damit das ich das Kubuntu-20.04 upgedatet habe nichts zu tun haben) ?

    Sollte man das yavdr Ansible ab und zu auch mal updaten um sowas zu vermeiden ? Eventuell liegt das Problem ja genau daran

    weil ich yavdr Ansible bisher noch nie upgedatet habe.


    Wenn ich unter Boot -> Sicheres Booten auf Uefi Windows umstelle kann ich nur noch Win10 und das Kubuntu-20.04 hochfahren, versuche ich so das yavdr Ansible hochzufahren kommt die folgende Meldung: bad shim signature - you need to load the kernel first


    Gruss

    Bert

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

    Edited 2 times, last by Bert ().

  • sudo apt update

    sudo apt dist-upgrade

    hat das Problem tatsächlich gelöst doch nun kommt der VDR nicht mehr hoch es ist nur noch das blaue yavdr Logo zu sehen

    aber kein Bild vom Sender.

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

  • Hmm, Sript (sudo -H ./install-yavdr.sh) neu angestossen Fehlermeldung ansible Version zu alt

    Also Ordner yavdr-ansible gelöscht, neu aus Git ausgescheckt, wieder Script gestartet.


    Code
    TASK [yavdr-common : create vdr user] *******************
    fatal:[localhost] : FAIKLED! => {
    "changed" : false,
    "name" : "vdr"
    "rc" : 8
    }
    
    MSG:
    usermod : Benutzer vdr wird derzeit von Prozess 11859 verwendet

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

  • Kill den genannten Prozess, oder mach gleich einen Reboot.

    Danach nochmal das Skript starten (vorher ggf. VDR stoppen).
    Viel Erfolg!

    MyVDR: yaVDR-Ansible (Ubuntu 20) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hi,


    Leider kein Glück das hab ich alles schon durch hat leider nix gebracht.

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

  • Hab ich beim Schreiben schon fast befürchtet.
    Und was ist dieser ominöse Prozess (11859) der "den VDR-User verwendet" (was auch immer das bedeuten mag)?


    Eins noch: beim Löschen von Ansible und Drüberbügeln vom GIT, hast du hoffentlich deine host_vars/localhost mit deinen individuellen Einstellungen behalten, oder? Nicht, dass jetzt vom Skript "default" installiert wird und das bei dir nicht passt.

    MyVDR: yaVDR-Ansible (Ubuntu 20) - softhddevice-openglosd (ffmpeg 2.8) - epgd/epg2vdr - skindesigner estuary4vdr (adaptiert) - 1920x1080@50 Hz | kodi 18 - inputstream + amazon vod
    Aerocube M40 | 300W | ASRock H61M-GE | Intel G530 | Asus ENGT520 | 2 x TT-budget S2-3200 | ASRock Smart Remote (CIR) | 4 GB RAM | 120 GB SSD | 3 TB HDD

  • Hi,


    Ich weiss nicht was das für ein Prozess ist die PID ist jedenfalls immer eine andere, doch das ist nun eh egal denn es hat jetzt plötzlich doch geklappt

    auf ganz normalem Weg also PID killen und das Script ist danach durchgelaufen (Bild und Ton gibts jedoch nicht) nur das Yavdr Logo ist zu sehen.

    Im Moment habe ich aber neue Probleme plötzlich seit dem Ausführen und erfolgreichem Durchlaufen des Scripts sehe ich den BootManager (Grub)

    also das Auswahlfenster nicht mehr.


    Es fährt immer sofort das Yavdr hoch, kann kein anderes Bertriebssystem mehr starten, habe nachgeguckt in der /etc/default/grub und da stand plötzlich das drinnen:

    Code
    GRUB_TIMEOUT_STYLE=hidden
    GRUB_TIMEOUT=0

    Dachte ok das ist das Problem, doch nach Umstellen zu:

    Code
    GRUB_TIMEOUT_STYLE=menu
    GRUB_TIMEOUT=10

    und anschliessendem sudo upodate-grub ändert sich nichts, das Problem bleibt hartnäckig bestehen.

    Macht yavdr da was extra mit grub ich meine gibts da irgendwelche default templates die da dazwischenfunken (bin absolut nicht up-to-date das macht alles schwieriger).

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

  • Macht yavdr da was extra mit grub ich meine gibts da irgendwelche default templates die da dazwischenfunken

    Da gibt es zwei Dinge, die das Playbook macht: einmal wird die Grub-Konfiguration erweitert (https://github.com/yavdr/yavdr…ig/templates/50_custom.j2 wird als Template nach /etc/grub.d/50_custom expandiert) und dann werden noch einige Dinge in der /etc/default/grup angepasst (über die Tasks in https://github.com/yavdr/yavdr…config/tasks/main.yml#L10 ff.) - wenn der grub.timeout (https://github.com/yavdr/yavdr…focal/group_vars/all#L166) auf 0 steht, wird das Menü versteckt, ansonsten sollte es angezeigt werden: https://github.com/yavdr/yavdr…config/tasks/main.yml#L29

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,


    Danke für die Links - seh ich mir an.

    Hatte es in der Zwischenzeit geschafft die Probleme zu vergrössern ^^

    Habe mittels USB Bootmedium per boot-repair (mit Optionen wie u.a. purge grub usw..) den Grub im yavdr ansible neu installieren können, das hat zwar den Grub Boot-Auswahlbildschirm zurück gebracht doch nun war nur noch yavdr ansible auswählbar - also nicht der grosse Wurf.


    Danach blieb mir nichts anderes übrig als per chroot Methode den Grub vom Kubuntu-20.04 wiederherzustellen was auch geklappt hat, nun konnte

    ich wieder alle drei Betriebssyteme auswählen und auch hochfahren.

    Nun aber steht natürlich als erster Booteintrag im Auswahlbildschirm das Kubuntu-20.04 was ich aber so nicht will, denn wenn ich mal einfach hochfahre soll default (falls ich nichts anderes auswähle) das yavdr ansible hochfahren nach dem Timeout.


    Normalerweise hatte ich wenn sich das durch ein Update vom Kubuntu-20.04 geändert hat immer einfach folgendes getan im yavdr ansible:

    Code
    sudo grub-install /dev/nvme0n1p6  # das entspricht der yavdr partition
    sudo update-grub

    Und danach war wieder yavdr ansible an erster Position im Boot-Auswahlbildschirm.

    Doch seit ich boot-repair verwendet habe findet der Grub im yavdr ansible kein weiteres Bertriebssystem, das ändert sich auch dann nicht wenn

    ich von einem USB Bootmedium (Kubuntu-20.04 Desktop.iso) die chroot Methode um den Grub wiederherzustellen anwende also das mache:

    Code
    sudo mount /dev/nvme0n1p6 /mnt
    sudo mount /dev/nvme0n1p1 /mnt/boot/efi
    for dir in /dev /dev/pts /proc /sys /run; do sudo mount --bind $dir /mnt$dir; done
    grub-install
    update-grub

    Mache ich das selbe oben im Code aber mit /dev/nvme0n1p5 für den Grub im Kubuntu-20.04 werden alle Betriebssyteme gefunden.


    Was kann ich noch tun oder bleibt mir wirklich nichts anderes übrig als die Ubuntu Server Distri und yavdr ansible neu zu installieren?

    Genau das wollte ich eigentlich vermeiden.


    Habe noch eine Reinstallation vom Grub im yavdr ansible selbst versucht aber dabei wird os-probe nicht mehr gefunden nun und es ändert nichts am Problem, vielleicht ist ja genau das das Problem wegen os-probe


    Edit, oh sehe gerade das Paket sollte ja os-prober lauten, wie blöd.

    new Edit, ok Kommando retour - die Grub Probleme sind nun behoben mit einer neuen Reinstallation vom Grub direkt im yavdr ansible diesmal mit dem korrekten Paketnamen also einfach mit:

    Code
    sudo apt-get --reinstall install grub-common grub-efi-amd64 os-prober

    ist wenigstens diesbezüglich alles wieder im Lot.


    Gruss

    Bert

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

    Edited 6 times, last by Bert ().

  • Hi,


    Gut also zurück zum eigentlichen Problem, ich häng mal ein bisschen syslog vom Vdr Start an

    (da sieht man schon ein paar Fehler drinnen, kann aber nichts damit anfangen), auch:

    no DVB device found

    steht da unter Anderem - ist wohl auch nicht so gut.

    Vielleicht sieht ja jemand wos hakt.

    syslog_start_vdr_auszug.txt


    Gruss

    Bert

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

  • Ich versteh das nicht ich will das Script also "sudo -H ./install-yavdr.sh" nochmal laufen lassen doch es kommt immer:

    Code
    TASK [yavdr-common : create vdr user] *******************
    fatal:[localhost] : FAILED! => {
    "changed" : false,
    "name" : "vdr"
    "rc" : 8
    }
    
    MSG:
    usermod : Benutzer vdr wird derzeit von Prozess 11859 verwendet

    Ich habe das nun sicher 7x hintereinander probiert mit auch vorher vdr stoppen, Prozess killen ist jedesmal eine andere PID, Kompletter Neustart

    aber es läuft nie durch (kurz vor dem Fehler wird auch immer der VDR vom Script gestartet).

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

  • Schau mal nach, was das für ein Programm mit der PID ist - also z.B.: pidof 11859

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,


    Ja also pidof PID zeigt leider gar nix an, aber ps -aux | grep PID und zwar das:

    Code
    vdr         1833  0.0  0.0 237292  4996 ?        Sl   21:49   0:00 /usr/libexec/geoclue-2.0/demos/agent
    yavdrus+   10364  0.0  0.0   9420   724 tty3     S+   22:11   0:00 grep --color=auto 1833

    Sagt mir aber gar nichts.

    Habe nun mal meine host_vars/localhost einfach gelöscht und das Script mittels "sudo -H ./install-yavdr.sh" gestartet

    dabei kommt auch das Problem mit dem Prozess der blockiert doch in diesem Fall nützt es wenn ich die PID dieses Prozesses kille

    und das Script läuft danach fehlerfrei durch. Mache ich das hingegen mit meiner host_vars/localhost geht das nicht.


    Grub Bootmenü ist auch wieder weg nun, aber ich kanns erreichen beim Start mit der Shifttaste und schnell ne Cursertaste nach unten da der Timeout

    und überhaupt nichts was ich in die /etc/default/grub eintrage greift.

    Das muss ich jetzt mal richtig lösen da das bei einem MultibootSystem nicht günstig ist.


    In meiner host_vars/localhost steht ja z.b:

    Code
    # settings for grub
    grub:
      timeout: 10
      boot_options: quiet splash

    Das würde vermutlich helfen aber mit meiner localhost läuft ja nichts durch (greift also nicht), ich probier mal:

    Code
    cd yavdr-ansible
    sudo -H ansible-playbook yavdr07.yml -b -i 'localhost_inventory' --connection=local --tags="grub-config"

    Edit, Das hat geklappt, hätte ich das mal früher gewusst dann hätte ich mir die Prozedur aus Post #7 und vor Allem aus Post #9 erspart.

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

    Edited 2 times, last by Bert ().

  • Sagt mir aber gar nichts.

    Das ist ein Dienst, der versucht den Standort des Rechners zu ermitteln (vgl. https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home) - yavdr-ansible installiert den nicht von sich aus, da musst du etwas nachinstalliert haben, das das Paket als Abhängigkeit zieht (z.B. redshift).


    Dass geoclue nicht mit der Session beendet wird, scheint ein bekannter Bug zu sein: https://bugs.launchpad.net/ubu…/geoclue-2.0/+bug/1871728


    Du kannst den maskieren, dann sollte der nicht mehr automatisch gestartet werden:

    Code
    sudo systemctl mask geoclue.service

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hab ich gemacht Danke, aber das Problem bleibt genau gleich.

    Hardware: Intel Core i9-9900K, ASUS ROG Maximus XI Hero, MSI GeForce GTX 1050 Ti (vdpau), Dvbsky S952 V3 mit 2X DVB-S2 Tuner
    Multibootsystem (yavdr-ansible auf Ubuntu-20.04, Kubuntu-20.04 Focal Fossa, Win10)
    yavdr-ansible, Ausgabe über Nvidia vdpau

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!