yavdr7 unter ubuntu 22.04 auf NUC7

  • Habe mich nach langer Zeit getraut meinen Wohnzimmer-Fernseh-Nuc von einem 3-4 Jahre alten yavdr mit vielen manuellen Anpassungen auf eine aktuelle yavdr upzudaten (yavdr-7 aus ansible auf Ubuntu_Server 22.04 und dem ppa:seahawk1986-hotmail repo):


    Insgesamt hat das echt super gut funktioniert und ich muss nur keine Anpassungen machen:

    - softhddevice lief nicht und ich habe durch softhdvaapi ersetzt

    - Ich hatte seltsame xorg.conf Einstellungen (nur 720p Auflösungen), ich habe einfach meine alte Xorg.conf kopiert

    - Mir fehlt noch skindesigner damit ich wieder meinen gewohnten Metrix-Skin wieder bekommen habe


    Insgesagt funktioniert damit das Setup sehr gut bis auf folgendes:

    - Nach dem Einschalten funktioniert das OSD nicht erst nach ein oder zweimal umschalten kommt ein OSD dann aber ohne Probleme (bei mir habe ich den vdr so eingestellt das er auf einen Radio Kanal startet, habe nicht ausprobiert ob das Problem auch auf einen TV Kanal existiert)

    - Wenn ich von einem TV Kanal auf einen Radio Kanal wechsele dann bleibt immer das letzte TV Bild stehen (ich habe schon Decoder leeren und Schwarzbild aktiviert in softhdvaapi eingeschaltet das hat aber keine Änderungen gebracht)

    - Ich habe jetzt so ~25% Prozessor Last bei TV Wiedergabe, das ist glaube ich deutlich höher also auf den alten Setup mit softhddevice (kann sein das ich die falschen De-Interlacer eingestellt habe, das ist den eine sinnvolle Einstellung für nuc7).


    Ich hoffe Ihr habt ein paar Tipps, damit ich die Probleme noch lösen kann.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • - softhddevice lief nicht und ich habe durch softhdvaapi ersetzt

    Ich habe den Verdacht, dass da etwas mit dem iHD Treiber in Kombination mit Kaby Lake nicht will. Mangels Hardware aus der Generation bin ich da noch nicht weiter gekommen.

    - Ich hatte seltsame xorg.conf Einstellungen (nur 720p Auflösungen), ich habe einfach meine alte Xorg.conf kopiert

    Kannst du mal zeigen, was das Playbook da gesehen hat? Die Dateien in /etc/ansible/facts.d/ enthalten die Informationen zur Bildschirmerkennung des letzten Laufs des Playbooks.

    - Mir fehlt noch skindesigner damit ich wieder meinen gewohnten Metrix-Skin wieder bekommen habe

    Das Plugin ist doch im PPA - was genau klappt da nicht? https://launchpad.net/~seahawk…shed&field.series_filter=

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo,

    Ich habe kein Problem mit Skin Designer, musste nur aus dem PPA installiert werden und dann fehlt noch der logopath in dem config File.


    Zur Xorg config:

    Ich habe offensichtlich nachdem ich Xorg und edid aus der alten Installation rein kopiert habe nochmal ansible drüber laufen lassen damit passt jetzt die facts.d

    Ich habe aber noch das Intel snippet das erzeugt wurde am Anfang:


    Kann aber leider nicht mehr nachvollziehen wie das zustande kam.


    Zurück zu meinem softhdvaapi und Radio Thema:

    Ich habe den Vorschlag von oben befolgt und das Radio Plugin installiert und konfiguriert. Ist schon mal besser weil es jetzt schwarz ist aber ein OSD kann ich immer noch nicht auf Radio Seiten bekommen (muss erst auf eine TV Seite wechseln) und jetzt sehe ich echte Fehlermeldungen im log. Da passt also was zwischen softhdvaapi und Radio nicht:


    Code
    1. Jul 14 17:37:36 nuc vdr[889]: error: Validation failed: (image->planes[i]).texture (../src/renderer.c:2170)
    2. Jul 14 17:37:36 nuc vdr[889]: error: #6 /lib/x86_64-linux-gnu/libc.so.6(+0x126a00) [0x7fa4048a6a00]
    3. Jul 14 17:37:36 nuc vdr[889]: error: #5 /lib/x86_64-linux-gnu/libc.so.6(+0x94b43) [0x7fa404814b43]
    4. Jul 14 17:37:36 nuc vdr[889]: error: #4 /usr/lib/vdr/plugins/libvdr-softhdvaapi.so.2.6.1(+0x33638) [0x7fa3fecfa638]
    5. Jul 14 17:37:36 nuc vdr[889]: error: #3 /usr/lib/vdr/plugins/libvdr-softhdvaapi.so.2.6.1(+0x2c119) [0x7fa3fecf3119]
    6. Jul 14 17:37:36 nuc vdr[889]: error: #2 /lib/x86_64-linux-gnu/libplacebo.so.175(pl_render_image+0x98) [0x7fa3fe4c2cb8]
    7. Jul 14 17:37:36 nuc vdr[889]: error: #1 /lib/x86_64-linux-gnu/libplacebo.so.175(+0x77cb9) [0x7fa3fe4c1cb9]
    8. Jul 14 17:37:36 nuc vdr[889]: error: #0 /lib/x86_64-linux-gnu/libplacebo.so.175(+0x6ba41) [0x7fa3fe4b5a41]
    9. Jul 14 17:37:36 nuc vdr[889]: error: Backtrace:

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • OK. Wie mache ich das ?

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible

  • Habe jetzt Zeit gefunden mich darum zu kümmern.

    Mit dem neuen radio-ng Plugin und der Rinstellung PES-play funktioniert jetzt die Wiedergabe eines Hintergrund Bilds sowie des RDS.

    Server HW: Core i3| 4GB RAM | DVB-S Satix S2 Dual, TT3200, TT 1401 | 34TB SW: Ubuntu 16.04 , yaVDR vdr2.4 reposatory, Emby Server
    Client: HW: Intel NUC7i3BNK| 8GB RAM | DVB: TT 3600 SW yaVDR ansible