Posts by Eisbaer128

    Hallo,

    Ich habe kein Problem mit Skin Designer, musste nur aus dem PPA installiert werden und dann fehlt noch der logopath in dem config File.


    Zur Xorg config:

    Ich habe offensichtlich nachdem ich Xorg und edid aus der alten Installation rein kopiert habe nochmal ansible drüber laufen lassen damit passt jetzt die facts.d

    Ich habe aber noch das Intel snippet das erzeugt wurde am Anfang:


    Kann aber leider nicht mehr nachvollziehen wie das zustande kam.


    Zurück zu meinem softhdvaapi und Radio Thema:

    Ich habe den Vorschlag von oben befolgt und das Radio Plugin installiert und konfiguriert. Ist schon mal besser weil es jetzt schwarz ist aber ein OSD kann ich immer noch nicht auf Radio Seiten bekommen (muss erst auf eine TV Seite wechseln) und jetzt sehe ich echte Fehlermeldungen im log. Da passt also was zwischen softhdvaapi und Radio nicht:


    Code
    1. Jul 14 17:37:36 nuc vdr[889]: error: Validation failed: (image->planes[i]).texture (../src/renderer.c:2170)
    2. Jul 14 17:37:36 nuc vdr[889]: error: #6 /lib/x86_64-linux-gnu/libc.so.6(+0x126a00) [0x7fa4048a6a00]
    3. Jul 14 17:37:36 nuc vdr[889]: error: #5 /lib/x86_64-linux-gnu/libc.so.6(+0x94b43) [0x7fa404814b43]
    4. Jul 14 17:37:36 nuc vdr[889]: error: #4 /usr/lib/vdr/plugins/libvdr-softhdvaapi.so.2.6.1(+0x33638) [0x7fa3fecfa638]
    5. Jul 14 17:37:36 nuc vdr[889]: error: #3 /usr/lib/vdr/plugins/libvdr-softhdvaapi.so.2.6.1(+0x2c119) [0x7fa3fecf3119]
    6. Jul 14 17:37:36 nuc vdr[889]: error: #2 /lib/x86_64-linux-gnu/libplacebo.so.175(pl_render_image+0x98) [0x7fa3fe4c2cb8]
    7. Jul 14 17:37:36 nuc vdr[889]: error: #1 /lib/x86_64-linux-gnu/libplacebo.so.175(+0x77cb9) [0x7fa3fe4c1cb9]
    8. Jul 14 17:37:36 nuc vdr[889]: error: #0 /lib/x86_64-linux-gnu/libplacebo.so.175(+0x6ba41) [0x7fa3fe4b5a41]
    9. Jul 14 17:37:36 nuc vdr[889]: error: Backtrace:

    Habe mich nach langer Zeit getraut meinen Wohnzimmer-Fernseh-Nuc von einem 3-4 Jahre alten yavdr mit vielen manuellen Anpassungen auf eine aktuelle yavdr upzudaten (yavdr-7 aus ansible auf Ubuntu_Server 22.04 und dem ppa:seahawk1986-hotmail repo):


    Insgesamt hat das echt super gut funktioniert und ich muss nur keine Anpassungen machen:

    - softhddevice lief nicht und ich habe durch softhdvaapi ersetzt

    - Ich hatte seltsame xorg.conf Einstellungen (nur 720p Auflösungen), ich habe einfach meine alte Xorg.conf kopiert

    - Mir fehlt noch skindesigner damit ich wieder meinen gewohnten Metrix-Skin wieder bekommen habe


    Insgesagt funktioniert damit das Setup sehr gut bis auf folgendes:

    - Nach dem Einschalten funktioniert das OSD nicht erst nach ein oder zweimal umschalten kommt ein OSD dann aber ohne Probleme (bei mir habe ich den vdr so eingestellt das er auf einen Radio Kanal startet, habe nicht ausprobiert ob das Problem auch auf einen TV Kanal existiert)

    - Wenn ich von einem TV Kanal auf einen Radio Kanal wechsele dann bleibt immer das letzte TV Bild stehen (ich habe schon Decoder leeren und Schwarzbild aktiviert in softhdvaapi eingeschaltet das hat aber keine Änderungen gebracht)

    - Ich habe jetzt so ~25% Prozessor Last bei TV Wiedergabe, das ist glaube ich deutlich höher also auf den alten Setup mit softhddevice (kann sein das ich die falschen De-Interlacer eingestellt habe, das ist den eine sinnvolle Einstellung für nuc7).


    Ich hoffe Ihr habt ein paar Tipps, damit ich die Probleme noch lösen kann.

    Schau Dir al epgd und epghttp an. Das ist wie Live Plugin hat aber auf jedenfall so eine Art Fernsehzeitungs-Ansicht. Bin mir nicht mehr sicher ob es auch eine Timeline gibt.

    Noch was anderes:

    Das Problem skinnopacity lädt die Logos nicht ist gelöst und mein Fehler ich hatte auf dem alten System Metrixhd auf dem Skindesigner Package verwendet und damit gehen dann auch die Logos. Waren also tatsächlich inkompatible Logos.

    Sieht erst mal gut aus. Habe das im laufenden Betrieb ausgeführt. Ist durchgelaufen hat X angehalten und wieder gestartet. Xorg wurde erzeugt und damit kam X auch wieder hoch und ich sehe 50Hz Modus.


    Hier die Xorg:

    In meinen headless Server der für alle Aufnahmen zuständig ist sind seit langem drei Karten: Mystique SaTiX-S2 (2y PCIe) , TT-Budget S2-3200 PCI & TT-Budget-S-1401 PCI. Das läuft alles ziemlich stabil ausser das ich die Mystique einfach nie wirklich stabil bekomme. Die Karte stürzt alle paar Tage ab egal ob ich die Standard Kernel Treiber oder die neuesten Treiber installiere. Nachdem mir das immer wieder Aufnahmen zerstört würde ich jetzt einfach gerne diese Karte durch eine stabile ersetzten. Ich habe mal im Forum geschaut da gibt es aber schon länger keinen Eintrag mehr in diese Richtung. Was ist den aktuell eine empfehlenswerte PCIe 2x DVB-S2 Karte ?

    Danke für die Feedbacks. Werde dann man die Tage vdr-2.4 auf meinem Server und das andere Frontend ausprobieren. Hier schon mal meine aktuelle Xorg.


    Ich musste dabei die Extensions Section auskommentieren weil ich ansonsten eine Crash hatte


    Hier dann auch nochmal mein menuorg.xml was eine angepasste Kopie aus yavdr 0.6 ist dazu dann der neue Kodi Eintrag

    Status Report und ein paar Fragen/Probleme für meinen NUC7i3:

    Hatte schon mal vor einem Jahr versucht den Kabylake NUC mit yavdr0.6 zu versorgen aber das zugrunde liegende Ubuntu 14.04 war so alt das weder Netzwerk noch Grafik sinnvoll hinbekommen habe. Das Projekt wurde dann erst mal aufgegeben. Jetzt über die Ferien hatte ich mich dann drangesetzt das ganze mit yavdr ansible nochmal zu versuchen.

    In Summe funktioniert das sehr problemlos. Ubuntu 18.04 Server aufspielen und dann das playbook laufen lassen erzeugt ein fast vollständiges System. Folgende Sachen musste ich noch machen:

    - Channel.conf vom alten Rechner kopieren

    - Mit dem Pulseaudio Plug-in auf hdmi-stereo setzten und sowohl in den Plug-in und bei softhddevice die feedthrough anschalten (der NUC ist über HDMI an einen AV Receiver angeschlossen)

    - Es gibt keine xorg.conf damit läuft zwar die Anzeige aber in 60Hz. Habe meine alte vom Vorgänger reinkopiert läuft jetzt

    - Ich habe das menuorg Plug-in addiert und so konfiguriert das ich vor allem Kodi auf der obersten Ebene sehe (Anleitung findet man in den selben Thread)


    Mit diesem Setup kann ich Fernsehen und die Fernbedienung mit den NUC IR funktioniert inklusive Rechner starten/anhalten, ich kann Kodi starten und stoppen. => Grosses Lob an die Entwickler tolle Leistung


    Kleinere offene Probleme:

    - Wenn ich von TV auf Radio Sender schalte dann bleibt in 50% der Fälle das letzte Bild stehen. Habe schon versucht den Switch beim Umschalten Puffer lehren und Schwarzbild einschalten das ändert aber nichts

    - Bei Änderungen der Einstellungen in softhddevice habe ich danach oft das laufende Program in Falschfarben

    - Ich nutze skinnopacy und habe mir die Logos runtergeladen. Habe den Pfad zu den Logos in den skinnopacy setupfile mit --logopaths=/.. gesetzt, ich kriege die Senderlogos aber nicht angezeigt.


    Fragen:

    -Ich nutze eine Client/Server Setup. Mit einem Headless Server mit 4Karten und den NUC als Client (mit einer USB2 Karte). Bis jetzt habe ich Remote-time Plug-in verwendet um die Timer auf dem Server abarbeiten zu lassen. Wie kriege ich das jetzt hin ( Server läuft auf 16.04 mit einem der 2.2 aus dem yavdr Repo)?

    - Um 50Hz zu bekommen habe ich die Monitor Modeliney angelegt und dann die Moses in entsprechender Reihenfolge in die Screen Section eingetragen. Ich die aber das der Rechner schon alle Modelines vom Fernseher bekommt. Ich also nur noch die 50Hz auswählen müsste. Ich habe aber kein Konfigurationsbeispiel gesehen wie da gehen sollte. Die _xxx Modes sind meine eigenen. Würde also eigentlich gerne

    Code
    1. "1920x1080"x50.0

    Nutzen.

    Mal ein paar updates:
    - Ich glaube mein grub Problem ist hausgemacht weil ich wahrscheinlich unabsichtlich einen MBR Partitionierung gemacht habe.
    - Ich habe jetzt mal Easy-vdr stable 3.0.0 versucht die basiert auf 14.0.4.5, aber auch da sind die notwendigen Kernel Treiber nicht drin
    - Ich habe jetzt mal LibreElec 7.95.2 ausprobiert und da geht dann Ethernet und WLAN out of the box (da wird Kernel 4.9.3 verwendet)


    Nachdem 16.04 wegen systemd erst mal ein grösseres Thema ist werde ich als nächstes versuchen einen aktuellen ubuntu mainline Kernel in Ubuntu 14.04 zu integrieren, dann muss ich mich natürlich noch an die Grafik Themen machen.

    Habe mal wieder ein neues Bastelprojekt gestartet und mir einen neuen NUC zugelegt (NUC7i3BNK), nachdem der jetzt HDMI2.0 und damit 4k@60Hz kann sollte das eigentlich ein recht zukunfssicherer Multimedia Computer sein. Ich brauche aber mal wieder ein paar Tipps weil die Installation definitiv nicht so einfach ist:


    - Ich habe einfach mal das yavdr 0.6.1 ISO versucht und bootet soweit auch aber es kann keine Netztwerkkarte gefunden werden weder Ethernet noch WLAN (vermutlich ist der Kernel zu alt)
    - Installation geht dann bis zum Ende aber grub wird nicht installiert (habe ich nicht verstanden warum).


    Was ist den jetzt die beste Idee: Macht es überhaupt Sinn mit Ubutu 14.04 weiterzumachen oder besser erst mal 16.04 plain installieren und dann yavdr drauf ? Oder besser letzten Kernel aus 14.04.5 probieren.
    Hat einer eine Idee warum grub nicht fuktioniert ich habe das im UEFI Modus gebootet und die SSD mit einer Standard Partitionierung versehen ?

    Hört sich interessant an nachdem ich immer wieder mal Treiber Stabilitaets Themen mit den DVB Karten im Server habe und die auch zum Teil schon recht alt sind überlege ich auf so eine sat-ip Lösung umzusteigen. Ich habe einen Quadro LNB und einen 6 fach Multischalter, wenn ich das aus der Anleitung richtig verstehe kann ich damit auch den Multischalter ersetzen richtig ?


    Gibts Infos zum Stromverbrauch, vorallem im Standby ?

    Hatte aehnliche Anforderungen letztes Jahr als ich mir in den Keller mein Heimkino gebaut habe. Die Top-Beamer kommen von Epson und Sony. Ich habe mir beide angeschaut und konnte keinen Unterschied feststellen. Nachdem Sony nochmal ein bischen teurer ist habe ich mich fuer den Epson 9200 entschieden. Das ist dann so ziemoich das obre Ende der Full-HD Beamer. Eine Klasse tiefer habe ich auch keinen Ubterschied in der Bildqualiaet gesehen ausser bei 3D was eher eine seltene Anwendung ist.


    Ich bin das letzte Jahr recht zufrieden. Bild ist ziemlich gut und Beamer funktioniert zuverlaessig. Bei normalen Betrieb (nicht 3D) laeuft der Beamer immer im Eco Mode und ist damit recht leise. Man kann Ihn schon noch hoeren bei ganz leisen Stellen, ist aber OK. Die automatische Blende zur Verbesserung des Schwarzwerts ist deutlich lauter, habe ich deshalb abgeschaltet (Schwarzwert Unterschied ist gering). Ich habe auch das Wireless Uebertragungssystem, eigentlich vorallem deshalb gekauft weil es den Epson nur damit in weiss gibt und ich nicht ein grosses schwarzes Teil an der Decke haben wollte. Das Uebertragungssystem funktioniert ganz OK, aber der Sync fuer neue Aufloesungen dauert recht lang. Heisst immer wenn Kodi die Bildwiederholungsfrequenz aendert ist das Bild erst mal ein paar Sekunden schwarz.


    Btw: Ich wuerde die Beamer mal selber anschauen. In Muenchen gibt es in der Balanstrasse einen Heimkino laden mit toll eingerichteten Heimkino und einer grossen Auswahl an Beamern zu anschauen. Wenn Dein Profil mit Taufkirchen aktuell ist dann ist das ganz in deiener Naehe. Ich habe mir da auch noch die 4k Beamer angeschaut. Bild selbst von der Blueray war erkennbar besser, aber irgendwo muss dann ja auch mal Ende sein....


    Btw: Projektionsentfernung ist ungefaehr 3.5m und ich habe eine Leinwannbreite von 2.5m. Laut Rechnern ist das an der oberen Grenze, aber ganz ehrlich Bild kann eigentlich kaum zu gross sein ....