Minisatip Server findet keinen Tuner

  • Hi,
    ich habe hier Testweise einen Nuc 2820 mit einer USB DVBSky S960 und easyvdr 2.5 am laufen.
    So weit so gut alles funktioniert besser als erwartet. Nun wollte ich den minisatipserver mal probieren, aber im WebIf werden keine Tuner erkannt.
    die /etc/default/minisatip ist noch unverändert und bei den Optionen sehe ich nichts wo ich ein dvb Device definieren könnte.


    Kann es sein, das der minisatip Server exclusiven Zugriff benötigt und solange der VDR den Tuner benutzt auch kein Tuner gefunden werden kann?


    Gibt es eigentlich nirgends eine howto oder wiki dazu? Irgendwie ist alles sehr wenig beschrieben. Das Forum kenne ich und sonst sehe ich kaum Quellen wo für Einsteiger das zusammengefasst ist.


    Gruß und Danke

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Kann es sein, das der minisatip Server exclusiven Zugriff benötigt und solange der VDR den Tuner benutzt auch kein Tuner gefunden werden kann?

    Genau, du musst dem VDR sagen, dass er die Tuner, die sicht minisatip greifen soll, nicht anfassen soll.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • vdr mit -D 0 starten. (Unter Debian in /etc/vdr/conf.d/00-vdr.conf)
    vdr-plugin-satip mit -d 2 (wobei 2 auch der Standardwert ist). (Unter Debian in /etc/vdr/conf.d/50-saitp.conf)
    Am besten dem satip auch noch "-s IP-vom-MINISATIP-Server|DVBS2-2" mitgeben.


    Die automatische SAT>IP-Server-Erkennung dauert meist etwas, das kann beim Einschalten bzw. NVRAM Wakup & Timern lästig sein.

  • Danke.
    Das mit dem -D 0 beim VDR starten funktioniert nur leider nicht. Ich sehe auch die Option beim gestarteten VDR, nur leider ist der dvb Tuner trotzdem aktiv, Oder braucht es dafür ein dynamite bei easyvdr?
    Ich habe den Tuner wenn der VDR beendet ist. zumindest etwas.


    Edit:
    Toll, ein Test Panasonic im Laden findet automatisch den Tuner und solange der VDR nicht gestartet wird läuft es auch ohne Klimmzüge :tup Jetzt muß ich nur noch herausfinden wie es mit CI für HD Plus Karten geht, also den legalen Weg meine ich damit.


    Warum der easyvdr die Option -D0 in der /etc/vdr/vdr.default nicht annimmt kann mir bestimmt auch einer erklären, oder einen Tipp geben?

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

    The post was edited 1 time, last by Torsten73 ().

  • -D 0 bedeutet, dass der vdr nur den ersten Tuner nehmen soll. Wenn er gar keinen nutzen soll, musst du da eine Zahl angeben, die es nicht gibt, z.B. -D 10.


    Lars

  • ...musst du da eine Zahl angeben, die es nicht gibt, z.B. -D 10.


    Endlich ist es raus, ich wusste schon immer das mit der 10 was nicht stimmt! :mua

    CKone: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G540, 2x 2GB Kingston DDR3, Zotac GT630 1GB, S2-1600, Ocz Agility 3 60GB, LG GH24NS DVD, 15.6" Selbstbau TFT, Harmony 665, CIR Selbstbau - das Ganze im Silverstone SST-SG03B
    CKtwo: yavdr-ansible/18.04 LTS/2.4.1/kodi18 auf Intel DH67BL, Intel Celeron G1610, 2x 2GB Corsair DDR3, Zotac GT630 1GB, TT S2-1600, Ocz Vertex 2 50 GB, 92 Kanal Seduatmo, Harmony 665, atric USB
    CKthree: yavdr-ansible/22.04 LTS/2.6.1/kodi19.3 auf Intel NUC, Celeron J4005, UHD Graphics 600, 4GB Crucial DDR4, Ocz Vertex2 50 GB, Harmony 350

    PowerEdge: Ubuntu Server 16.04 LTS / VDR 2.4.1 auf Dell PowerEdge T20, Xeon E3-1225 v3, 16GB ECC DDR3, 2x Cine S2 V6 mit Duoflex, Samsung 840 EVO 120GB, 3x WD White WD80EZAZ 8TB in SW Raid5



  • Bingo Lars, das war der Fehler.


    Können eigentlich wie bei DVB-S die Transponder parallel genutzt werden? Oder kann pro Satip Tuner nur ein Client sich verbinden?


    Ich vermute auch mal der vdr kann nicht die gleiche channels nehmen, auch wenn beides theoretisch dvb-s2 ist, da es ja eine andere Quelle darstellt.


    Muß man bei SatIP immer einen Suchlauf machen? Kann der Server nicht eine Senderliste zur Verfügung stellen? Der Suchlauf dauert ja eine halbe Ewigkeit :sleepbeim Panasonic.

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue

  • Kannst du nicht einfach die vorhandene channels.conf weiter benutzen? Ich hab allerdings kein Sat und kein satip, da müssen dann andere weiterhelfen.


    Lars

  • Können eigentlich wie bei DVB-S die Transponder parallel genutzt werden? Oder kann pro Satip Tuner nur ein Client sich verbinden?

    Du könntest mal die Protokoll-Spezifikation für Sat>IP lesen: http://www.satip.info/sites/sa…ication_version_1_2_2.pdf

    Ich vermute auch mal der vdr kann nicht die gleiche channels nehmen, auch wenn beides theoretisch dvb-s2 ist, da es ja eine andere Quelle darstellt.

    Doch, das sollte möglich sein.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Endlich ist es raus, ich wusste schon immer das mit der 10 was nicht stimmt! :mua


    Ja, ich hätte es genau spezifizieren sollen, es muss eine Zahl sein, die größer als die Anzahl der verfügbaren DVB-Devices ist. Früher hätte eine 5 o.ä. gereicht, aber heutzutage ist ein vdr mit 8 Tunern ja nichts besonderes mehr. :)


    Und die 10 ist ja nicht eindeutig, weil man nie genau weiß, welche Basis dieser Darstellung einer Zahl zugrunde liegt...


    Lars

  • So ein paar satip Plugineinstellungen musste ich noch nach diesen Infos für easyvdr anpassen:


    https://www.easy-vdr.de/forum/index.php?topic=18287.msg172419#msg172419


    Das ist zwar für easyvdr 3.0 und ich habe 2.5 und offenbar ist für 2.5 der Fehler für die Pluginparameter (-d 4 und nicht -d=4) noch nicht korrigiert worden. Ich habe hier -d 1 gewählt.


    Der Panasonic TV muß ich nächste woche noch mal testen. Der war scheinbar fertig und danach wurde der satip Server nicht mehr gefunden. Im WebIF war er noch da. Sender hinzugefügt hatte der LCDTV leider nicht (hat bisher eine DVB-C Liste).


    Zumindest der VDR passt jetzt schon mal!


    Wenn jetzt noch die Apps für Android damit auch arbeiten, das wäre Mega :rolleyes:

    Proxmox VE, Tyan Xeon Server, OMV, MLD-Server 5.1
    MLD 5.1 64bit: Asus AT5iont-t, ION2, 4GB Ram, SSHD 2,5" 1Tb, HEX TFX 300W 82+, Cine S2 V6.2 , 38W max.
    Yavdr 0.5:
    Zotac D2550ITXS-A-E mit GT610 OB, TT S2-4100 PCI-e ,Joujye NU-0568I-B
    Yavdr 0.5:
    Sandy Bridge G840, Tests und Energieverbrauch , CoHaus CIR, Cine S2 V6.2
    MLD 5.1 Beebox N3150
    , DVBSky S960 und 1Tb WD Blue