Aufnehmen + Schauen geht trotz Twin Tuner nicht

  • Hallo Forum,


    ich nutze VDR als Backend für mein OSCM Mediacenter und bin soweit sehr zufrieden.
    Was mich irritiert ist aber, dass ich trotz Twintuner (DVBSky S952) nicht gleichzeitig eine Aufnahme mit dem VNSI Plugin in Kodi schauen kann.
    Der "Fehler" ist reproduzierbar. Sobald eine Aufnahme läuft passiert nichts mehr wenn ich in der Kanalliste in OSMC einen anderen Sender anwähle. Sobald die Aufnahme beendet ist, geht es wieder. Es scheint sich so zu verhalten, als gäbe es nur einen Tuner.


    VDV -V liefert mir:

    Code
    1. Dec 23 22:25:29.498 [general.debug] using new 1.7.11+ capture codevdr (2.2.0/2.2.0) - The Video Disk Recorderepgsearchonly (0.0.1) - Direct access to epgsearch's search menustreamdev-server (0.6.1-git) - VDR Streaming Servervnsiserver (1.3.1) - VDR-Network-Streaming-Interface (VNSI) Serverxineliboutput (2.0.0-cvs) - X11/xine-lib output pluginsvdrpservice (1.0.0) - SVDRP clientquickepgsearch (0.0.1) - Quick search for broadcastsremoteosd (1.0.0) - Show menu of a remote VDRdummydevice (2.0.0) - Output device that does nothingsvdrposd (1.0.0) - Publish OSD menu via SVDRPrecsearch (0.3.6) - search your recordingsconflictcheckonly (0.0.1) - Direct access to epgsearch's conflict check menulive (0.3.0) - Live Interactive VDR Environmentfemon (2.2.1) - DVB Signal Information Monitor (OSD)epgsearch (1.0.1.beta5) - search the EPG for repeats and moremarkad (0.1.5pre) - Mark advertisements


    Kodi ist die Version 15.2. 2015-11.2


    Im Kodi Log sieht das Auswählen eines Senders wie folgt aus:

    Code
    1. 22:09:18 176404.203125 T:1957540400 NOTICE: DVDPlayer: Opening: pvr://channels/tv/All channels/pvr.vdr.vnsi_498217352.pvr22:09:18 176404.203125 T:1957540400 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED22:09:18 176404.203125 T:1031795744 NOTICE: Thread DVDPlayer start, auto delete: false22:09:18 176404.203125 T:1031795744 NOTICE: Creating InputStream22:09:18 176404.203125 T:1031795744 NOTICE: AddOnLog: VDR VNSI Client: Logged in at '1450904958+3600' to 'VDR-Network-Streaming-Interface (VNSI) Server' Version: '1.3.1' with protocol version '8'22:09:18 176404.203125 T:1031795744 ERROR: AddOnLog: VDR VNSI Client: ReadSuccess - failed with error code '997'22:09:18 176404.203125 T:1031795744 ERROR: AddOnLog: VDR VNSI Client: SwitchChannel - failed to set channel22:09:18 176404.203125 T:1031795744 ERROR: CDVDPlayer::OpenInputStream - error opening [pvr://channels/tv/All channels/pvr.vdr.vnsi_498217352.pvr]22:09:18 176404.203125 T:1031795744 NOTICE: CDVDPlayer::OnExit()22:09:18 176404.218750 T:1957540400 NOTICE: CDVDPlayer::CloseFile()22:09:18 176404.218750 T:1957540400 NOTICE: DVDPlayer: waiting for threads to exit22:09:18 176404.218750 T:1957540400 NOTICE: DVDPlayer: finished waiting22:09:18 176404.218750 T:1957540400 NOTICE: CDVDPlayer::CloseFile()22:09:18 176404.218750 T:1957540400 NOTICE: DVDPlayer: waiting for threads to exit22:09:18 176404.218750 T:1957540400 NOTICE: DVDPlayer: finished waiting


    Im VDR findet man dazu nur:

    Code
    1. Dec 23 22:10:14 bigigloo vdr: [8403] VNSI: cxSocket::read: eof, connection closedDec 23 22:10:14 bigigloo vdr: [8403] VNSI: LiveStreamer::Close - closeDec 23 22:10:14 bigigloo vdr: [8403] VNSI: close video input ...Dec 23 22:10:14 bigigloo vdr: [8403] VNSI: close video input ...Dec 23 22:10:14 bigigloo vdr: [3774] loading /var/lib/vdr/plugins/vnsiserver/allowed_hosts.confDec 23 22:10:14 bigigloo vdr: [3774] VNSI: Client with ID 31 connected: 192.168.0.28:37306Dec 23 22:10:14 bigigloo vdr: [8540] VNSI: Welcome client 'XBMC Media Center' with protocol version '8'Dec 23 22:10:14 bigigloo vdr: [8540] VNSI: LiveStreamer::Close - closeDec 23 22:10:14 bigigloo vdr: [8540] VNSI: close video input ...Dec 23 22:10:14 bigigloo vdr: [3783] VNSI: Client with ID 30 seems to be disconnected, removing from client list


    Gehe ich mit einem Browser auf den Streamdev Port 3000 und streame dort einen Sender z.B. mit MPlayerX geht das wunderbar gleichzeitig. Die nur um Fragen vorzubeugen, ob die Karte korrekt erkannt wurde. Sie wurde erkannt, und es wurden auch 2 Tuner gefunden.


    Ich habe serverseitig und clientseitig (KODI VNSI Server Plugin) alles was mit EPG zu tun hat, "runtergefahren".


    Code
    1. /etc/vdr/setup.confvnsiserver.AvoidEPGScan = 1EPGScanTimeout = 0


    Hat jemand eine Idee, wieso das unter Kodi nicht funktioniert?


    Danke!


    Mod.: Bitte Code Blöcke verwenden!

  • Hi.
    Als erstes nimm mal das "böse" Plugin raus. Dies sollte wenn schon genutzt als erstes geladen werden weil es sonst zu Problemen führt. Schmeiß das mal raus und teste es dann nochmal. Vielleicht war es ja dann schon. Und solange du dieses Plugin weiterhin aktiviert hast wird, bzw darf, dir hier auch niemand weiter helfen.

    Gruß Patrick


    [size=8]* Meine NeverEndingProjects ;-) *


    vectra --- glasslike ---

  • Programmiere zwei gleichzeitige Aufnahmen auf unterschiedlichen Transpondern. Wenn beide funktionieren, ist der Empfang schon mal geklärt.
    Durch xineliboutput bzw. dummydevice wird der vdr immer "denken", dass er ein Live-Bild darstellt (beide Plugins bieten ein primäres Devices an). Du kannst mal ohne die beiden probieren, ob es dann geht.


    Lars.

  • Hallo, ich habe auch das Problem, ich habe meine Clients von
    KOdi 14.2 auf 15.2 geupdatet zuvor liefen die mit XVDR jetzt wird XVDR nicht
    mehr weiter entwickelt und in Openelec nicht mehr benutzt daher bin ich bei
    VNSI gelandet jetzt habe ich genau dasselbe Problem!




    Wenn ich etwas aufnehme kann ich nicht mehr umschalten (nur auf derselben
    kanalgruppe)




    => zwei Aufnahmen gehen und wenn ich direkt am Server (nicht Kodi) umschalte
    klappt es auch!


    => ich denke das liegt am VNSI server vom VDR meine Version 1.10 => jetzt geupdatet auf 1.3
    => ich werde heute mittag berrichten ob es geht oder nicht ....

  • Unter Kodi in den Vnsi Settings mal mit dem Wert priorität gespielt?


    Lg,
    Joe

  • guten morgen,




    nein hab ich noch nicht, hab die Einstellung gestern nicht gefunden.....




    => gerade gesehen in den Plugin Settings ...




    Versuch ich wenn ich nachhause komme, Danke


    => was für einen Wert trägt man da ein, was für eine Prio hat eine Aufnahme?

  • Vielleicht ja auch erstmal prüpfen, ob auf beiden Tunern Empfang ist und ob beide Tuner erkannt wurden. Dann vielleicht auch mal das Log vom VDR posten und nicht nur von Kodi.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hey TheChief,


    bei mir werden beider Karten erkannt und haben auch empfang, unter Kodi 14.2 mit XVDR hat es hervorragend funktoniert!
    erst seit dem Update auf Openelec 6 und Kodi 15.2 mit VNSI läuft es nicht mehr richtig....


    alsoklappt nicht, nicht mit neuem VNSIserver und auch nicht mit der höheren Prio...


    Hier der Log vom VDR


  • Ein wenig mehr Logfile wäre nicht schlecht. Vom Start des VDR weg damit man sieht wie die Karten initialisiert werde, usw.



    lg,
    Joe

  • Hey alles gut!


    Klappt das mit der Priorität
    bei mir war vor eingestellt -99 und mein EPG hatte Prio 1 meine Aufnahmen hatten alle Prio 40 also hatte mein Kodi keine Berechtigung
    Jetzt mit Prio 35 klappt alles!!!


    Super Danke an alle!!