[SOLVED] [softhddevice] Probleme mit der Konfiguration von softhddevice (VDPAU) => Kein Bild / Kein Ton

  • Hi !
    Ich bekomme kein Bild vom vdr auf meinem TV mit softhddevice,
    ich sehe lediglich den KDE Desktop auf dem TV.


    Ich habe das System neu aufgesetzt und softhddevice vorher nie benutzt, ich kenne mich damit also nicht aus.


    System: Open Suse 13.2 64-bit
    vdr-2.2.0
    softhddevice aus dem git vom 23.03.2015


    Ziel ist es, das Bild über VDPAU (Nvidia Grafikkarte) auf dem TV auszugeben.
    Propietärer NVIDIA Treiber ist installiert und qvdpautest funktioniert auch.


    Momentan ist an die Grafikkarte ein Monitor und der TV angeschlossen,
    das Suse System ist ja per default so installiert, dass automatisch KDE und damit der X-Server gestartet wird.
    Das würde ich gerne so lassen falls das möglich ist (bequem für Wartungszwecke).


    Kann das automatische starten von KDE so bleiben oder muss daran etwas geändert werden?


    Welche Einstellungen für softhddevice muss ich nun verwenden?


    Ich habe damit ohne Erfolg ausprobiert:


    Quote


    -P 'softhddevice -a hw:0,0 -p hw:0,0 -g 1920x1080+0+0 -v vdpau -x'


    Parameter -xx funktioniert auch nicht.


    Muss ich -D verwenden und mich nachher verbinden?
    Wie mache ich das und wie finde ich das richtige Device?


    z.Zt. taucht im Log folgende Meldung auf:


    Quote


    2015-03-26T14:16:46.292051+01:00 linux-pwt9 vdr: video: Can't connect to X11 server on ':0.0'



    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

    The post was edited 2 times, last by gromit ().

  • Du must sicherstellen das der X Server bereits läuft.
    Deshalb ist ein starten mit -D besser.


    Dann braucht der VDR Benutzer Zugriffsrechte auf den X11 Server. Man xhost +.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Ich bekomme kein Bild vom vdr auf meinem TV mit softhddevice,
    ich sehe lediglich den KDE Desktop auf dem TV.


    Und was passiert, wenn Du mal ein Terminal unter KDE öffnest und ein "svdrpsend plug softhddevice atta" ausführst? Ansonsten mal softhddevice mit -D starten, dann KDE starten und versuchen zu attachen.


    Code
    1. -P 'softhddevice -a hw:0,0 -p hw:0,0 -g 1920x1080+0+0 -v vdpau -x'


    Die Ausgabedevices für den Sound stimmen? Ggfs mal mit aplay -l schauen.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

    The post was edited 1 time, last by TheChief ().

  • Danke für die promten Antworten.
    Habe jetzt auf -D umgestellt, aber das alleine reicht nicht.
    Ich gehe mal der Reihe nach:


    johns

    Quote


    Dann braucht der VDR Benutzer Zugriffsrechte auf den X11 Server. Man xhost +.


    Sorry für die blöde Frage, "Man xhost +" sagt mir leider nichts :-(
    Muss das in in die runvdr eingetragen werden oder in eine X11 Konfigurationsdatei?
    Könntest Du mir bitte sagen was ich genau machen muss um die Zugriffsrechte richtig zu setzen? :-)




    TheChief
    Wenn ich ein Terminal unter KDE öffne und "svdrpsend softhddevice atta" ausführe kommt:


    Quote


    linux-pwt9:~ # svdrpsend softhddevice atta
    220 linux-pwt9 SVDRP VideoDiskRecorder 2.2.0; Thu Mar 26 16:26:12 2015; ISO-8859-1
    500 Command unrecognized: "softhddevice"
    221 linux-pwt9 closing connection


    ??? Ist der Befehl falsch?



    Habe mal HELP ausgeführt, also der vdr läuft zumindest:



    Sound kam mit "-a hw:0,0 -p hw:0,0"
    am analogem Mainboard Ausgang heraus.
    Die richtige Einstellung für HDMI habe ich noch nicht gefunden.


    "aplay -l" gibt aus:



    Muss ich die durchprobieren oder welcher ist der richtige? :-)


    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

  • Code
    1. linux-pwt9:~ # svdrpsend softhddevice atta


    ??? Ist der Befehl falsch?

    Ja, du willst ein Plugin ansteuern, also sagst du das auch:

    Code
    1. svdrpsend plug softhddevice atta

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Sorry, habs korrigiert und das PLUG hinzugefügt: svdrpsend plug softhddevice atta


    HDMI Sound ist meist hw:1,3 oder hw:1,7 Im Alsamixer nicht vergessen, das entsprechende Device zu aktivieren.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Sound kam mit "-a hw:0,0 -p hw:0,0"
    am analogem Mainboard Ausgang heraus.
    Die richtige Einstellung für HDMI habe ich noch nicht gefunden.



    Muss ich die durchprobieren oder welcher ist der richtige? :-)

    Bei mir ist es 'hw:1,7'.


    Ansonsten sind es ja nicht so viele Möglichkeiten zum Probieren.


    Stichwort X-Server: läuft der auch sicher auf ':0.0'? Nicht, daß es daran liegt.


    Christian

  • Ahhh die Syntax war mir jetzt nicht so geläufig.


    Also wenn ich auf der Konsole


    Quote


    xHost +


    und dann

    Quote


    svdrpsend plug softhddevice ATTA


    ausführe bekomme ich das gewünschte vdr-Bild am TV als KDE-Fenster, die Bildqualität ist allerdings mäßig :-(



    Aufrufparameter sind:

    Quote


    -P 'softhddevice -a hw:1,3 -p hw:1,3 -g 1920x1080+0+0 -v vdpau -D'



    - Wo muss ich das einstellen/konfigurieren, damit dies automatisch passiert?
    - Wie bekomme ich nicht ein KDE-Fenster, sondern ein Vollbild auf dem TV angezeigt?
    - Welche Einstellungen verbessern die Bildqualität?


    Ton höre ich mit den Einstellungen "-a hw:1,3 -p hw:1,3" leider keinen am TV.


    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

  • http://www.vdr-wiki.de/wiki/index.php/Softhddevice-plugin


    Mit -f startet das Plugin Fullscreen. Und dann kannst Du mal mit den Plugineinstellungen im OSD spielen. Einstellungen => Plugins => softhddevice glaub ich.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Sorry für die blöde Frage, "Man xhost +" sagt mir leider nichts :-(
    Muss das in in die runvdr eingetragen werden oder in eine X11 Konfigurationsdatei?
    Könntest Du mir bitte sagen was ich genau machen muss um die Zugriffsrechte richtig zu setzen? :-)


    man man


    "man" ist das eingebaute Unix / Linux Manual = Handbuch.


    Also "man xhost". Bzw. "xhost +".


    Sorry, aber ich gebe nur Denkanstösse, die Lösung muß man schon selber finden, sonst lernt man nichts.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Auf "xhost +" bin ich ja selbst gekommen,
    da ganz oben aber "Man xhost +" stand, habe ich die man page wegen der Großschreibung halt ausgeschlossen ;-)
    Sorry.
    Auf der man-Page ist zwar die Bedeutung des Befehls erklärt, aber nicht wo er in einer vdr Konfiguration mit softhddevice hinkommt.
    Die softhddevice wiki Seite gibt darüber leider auch keine Auskunft.


    Wo gehören diese Zusatzbefehle sinnvollerweise hin?


    Code
    1. xhost +
    2. svdrpsend plug softhddevice ATTA


    In der runvdr an der Stelle nach dem vdr Start jedenfalls nicht:



    Das funktioniert nicht, :-(
    wo habt ihr das stehen?



    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

  • Ins Autostart von KDE? Bei mir ist es mehr oder weniger im Autostart vom fluxbox.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Der Tipp war gut, habe die beiden Kommandos in ein Skript gepackt werlches mit den KDE Autostat
    automatisch aufgerufen wird und es funktioniert. :-)
    D.h. das Bild am TV kommt nun automatisch. Bleibt jetzt nur noch der fehlende Ton (per HDMI).



    Ich hab eigendlich alle Einstellungen durch (1,3 1,7 1,8 1,9) und auch mit dem Alsa-Mixer
    kontrolliert ob kein MUTE aktiviert war, aber leider hab ich es noch nicht hinbekommen der Ton am TV auszugeben.




    Sind die Logeinträge nomal oder läuft hier etwas schief?



    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

  • Quote
    Code
    1. 2015-03-28T23:13:18.409384+01:00 linux-pwt9 vdr: video/vdpau: out of surfaces
    2. 2015-03-28T23:13:18.409620+01:00 linux-pwt9 vdr: video/vdpau: release surface 0x000011, which is not in use


    Sollten nicht drin stehen.


    Könnte daran liegen:

    Code
    1. Section "Extensions"
    2. Option "Composite" "Disable"
    3. EndSection


    Composite im xorg.conf ausschalten.


    Ansonsten suche mal im Forum, irgendwie sind mir die Meldungen bekannt.


    Für den Ton.


    Erstmal läuft ein Sounddämon? Pulseaudio oder Ähnliches?
    Dann mit speaker-test herausfinden, welcher HDMI Anschluss es ist, meist hw:1.7 bzw. hw:NVidia,7


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Beim Ton über HDMI stehe ich noch auf dem Schlauch:


    aplay -l



    Sounddämon Pulseaudio läuft.


    Wie gebe ich jetzt das HDMI Device bei speaker-test an ?
    (möglicherweise mit Parameter -D aber was kommt dahinter? Eine Nummer funktioniert jedenfalls nicht)


    => speaker-test ohne parameter höre ich nichts


    Bei
    speaker-test -Dplug:spdif
    leider auch nichts.


    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

  • Wenn du pulseaudio hast -Dpulse oder wie es bei alsa heisst.


    Entweder pulseaudio und darueber alles oder kein pulseaudio.
    Mischen geht nicht.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch

  • Also ich habe glaube ich das pulseaudio Paket installiert, aber ich war mir nicht sicher ob das auch aktiv ist
    bis ich im Log folgenden Eintrag gesehen habe:


    Code
    1. 2015-04-13T01:23:33.875476+02:00 linux-pwt9 pulseaudio[1527]: Daemon already running.



    Ich habe die Onboard Soundkarte auf dem Mainboard einmal ausgeschaltet um das zu vereinfachen.


    aplay -l ergibt dann:



    Dann bekomme ich mit


    speaker-test -c2 -D hw:0,7


    einen Ton über HDMI.



    Wenn ich die gleichen Parameter (0,7) bei softhddevice angebe, kommt leider kein Ton, sondern folgende Fehlermeldung:




    Soll ich das pulseaudio Paket nun deinstallieren? Kommt sich das in die Quere?


    cu
    gromit

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C

  • So, hab's jetzt hinbekommen, Ton über HDMI funktioniert.


    Hier meine Lösung:


    Ich habe Pulseaudio deaktiviert und dann funktionierte es !


    Ich habe dann auch die interne Soundkarte wieder aktiviert, die ich zum Testen deaktiviert hatte, es läuft nun mit folgenden Einstellungen:


    -a hw:1,7 -p hw:1,7


    Danke an johns für die Hilfe!
    :prost2


    cu
    gromit



    P.S.
    Was ist denn der Hintergrund warum es mit Puseaudio nicht funktioniert? Unterstützt softhddevice die Pulseaudio Schnittstelle nicht?

    Mein Glotz-o-fon-Konservierer im Aufbau:
    vdr-2.3.1, v4l Treiber, OpenSuse 42.1, Satelco Easywatch DVB-C


  • Was ist denn der Hintergrund warum es mit Puseaudio nicht funktioniert? Unterstützt softhddevice die Pulseaudio Schnittstelle nicht?


    Es sollte funktionieren. SoftHdDevice selber unterstützt kein Pulseaudio, weil ich es nicht mag. Freiwillige dürfen gerne Pulseaudiosupport einbauen. Aber alsa sollte Pulsaudio unterstützen und mit den richtigen Paramtern "-a pulse", dann Pulseaudio verwenden.


    Johns

    Sag mir, wo die Developer sind. Wo sind sie geblieben? . . . . . . . . . . . . . . . . . . . . SoftHdDevice - A software and GPU emulated HD output device plugin.
    Sag mir, wo die Developer sind. Was ist geschehn?


    Client0: Crown CW02 MSI_C847MS-E33 Zotac_GT640_passiv Cine-S2 iMon-MCE / streamdev softhddevice
    Client1: Lian_Li_PC-Q09FB ASRock_H67M-ITX/HT I3-2100 ASUS_ENGT520_passiv / streamdev softhddevice
    Test: Lian_Li_PC-Q09R Asus C60M1-I / streamdev
    Server0: Dockstar TT-S2-3600-USB / streamdev
    Server2: Lian_Li_PC-Q07R Intel_DH61DL G620 WD20EARX 90W PicoPSU Cine-S2+DuoFlex-S2+DuoFlex-CT / streamdev / 22 Watt Verbrauch