[Announce] epgd 0.2.0, scraper2vdr 0.1.0, Happy Easter Eggs


  • nur truncate, so wie der chef es geschrieben hat.
    also alles nochmal mit einem drop machen?


    Was sagt denn ein select count(*) from <table> für die Tabellen? Wenn die leer sind, musst Du kein Drop machen. Dann helfen eventuell die Optimize-Befehle weiter oben.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hatte das optimize gemacht und vorsichtshalber bei allen nochmal ein drop.
    Am freien Speicherplatz hat sich nichts verändert.
    Die Tabellen sind jez aber auch nicht mehr da:

    Code
    1. root@VDR:~# mysql -u epg2vdr -pepg -Depg2vdr -e 'select count(*) from movie;'
    2. ERROR 1146 (42S02) at line 1: Table 'epg2vdr.movie' doesn't exist


    Muss ich noch mal suchen, was denn den Speicherplatz plötzlich belegt.

  • Wenn Du epgd neu startest, werden die tabellen wieder angelegt.


    Sonst schau doch mal, ob der Platz überhaupt von der DB benötigt wird oder vielleichgt doch von was anderem:


    SQL
    1. SELECT table_schema "Data Base Name",
    2. sum( data_length + index_length ) / 1024 /
    3. 1024 "Data Base Size in MB",
    4. sum( data_free )/ 1024 / 1024 "Free Space in MB"
    5. FROM information_schema.TABLES
    6. GROUP BY table_schema ;



    Läuft denn scraper2vdr auf der Kiste? Dann eventuell mal /var/cache/vdr checken.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Ja ich muss nochmal suchen ...
    scrapen habe ich erstmal deaktiviert.
    Nach dem Neustart des epgd kamen aber einige sql-Errors.
    Aktuell sehe ich im Log sowas:

    Code
    1. Apr 16 13:20:27 VDR epgd: SQL-Error in 'execute(stmt_execute)' - Incorrect key file for table '/tmp/#sql_b75_0.MYI'; try to repair it (126) 'Incorrect key file for table '/tmp/#sql_b75_0.MYI'; try to repair it' [call mergeepg]


  • Wenn Du epgd neu startest, werden die tabellen wieder angelegt.


    Wenn scrapEpg und scrapRecordings in epgd.conf auf 0 stehen werden die scraper Tabellen nicht angelegt ;)


    ofenheizer : die 135 MB sind sicherlich die EPG Bilder, für den Scraper ist das Kleinkram :D Irgendwie hat dir da wohl was anderes die Platte voll gemacht.


    Ciao Louis

  • epg-bilder sind auch deaktiviert und jepp, das scheint der hier zu sein:


    was ist ibdata1? und warum ist das 2,9GB groß?

  • Da sind die eigentlichen Daten drin. kannst ja mal googleln, wie man die "Shrinkt".


    http://erikimh.com/how-to-shri…h-minimal-mysql-downtime/

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Hab schon gesucht.
    Hab sie erstmal weg kopiert und mysql neu gestartet, zur Sicherheit auch noch die DB gelöscht und neu angelegt und nun den epgd wieder loslaufen lassen.
    Bekomme aber trotzdem noch seltsame Meldungen beim Starten des epgd:

    Quote

    Apr 16 13:58:04 VDR epgd: SQL-Error in 'create index idxSourceFileref on fileref(source, fileref);' - The table 'fileref' is full (1114)
    Apr 16 13:58:04 VDR epgd: SQL-Error in 'createIndices()' - The table 'fileref' is full (1114) '' [create index idxSourceFileref on fileref(source, fileref);]


    Das auch für die anderen Tabellen. Normal? Habe da sonst nie drauf geachtet.


    Und im Log taucht weiterhin das auf:

    Code
    1. Apr 16 14:02:46 VDR epgd: SQL-Error in 'execute(stmt_execute)' - Incorrect key file for table '/tmp/#sql_1880_0.MYI'; try to repair it (126) 'Incorrect key file for table '/tmp/#sql_1880_0.MYI'; try to repair it' [call mergeepg]


    Sehr seltsam.


    EDIT: Wenn die aktuelle Aufnahme durch ist, werde ich mal rebooten, denn auch ein Paket bauen quittiert mir mit fehlendem Speicherplatz unter /tmp.

    The post was edited 1 time, last by ofenheizer ().

  • Wenn Du ibdata wegkopierst, dürfte mysql garnicht mehr laufen.


    Probier noch das:


    Code
    1. mysqlcheck -c epg2vdr -u epg2vdr -p


    Ansonsten vielleicht mysql neu installieren, wenn Du sonst keine Datenbanken laufen hast.

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB

  • Doch die Datei wird wieder angelegt.


    EDIT: Läuft wieder und mein Platz ist auch wieder da. Schon komisch, dass diese ibdata1 nicht richtig bereinigt wurde.

    The post was edited 1 time, last by ofenheizer ().

  • Da ich keine Ahnung hab, kann ich dir leider nicht weiterhelfen - poste doch beide (am besten bei pastebin und dann nur die Links hier).


    Lars.

  • So alles läuft jetzt, aber meine Aufnahmen werden nicht "bebildert". Wo ran liegt das?


    MFG SVen


    skinnopacity aktuell? Aufnahmescraping aktiviert? scraping schon gelaufen? Fragen über Fragen :D

    - Client1: Thermaltake DH 102 mit 7" TouchTFT * Debian Stretch/vdr-2.4.0/graphtft/MainMenuHooks-Patch * Zotac H55-ITX WiFi * Core i3 540 * 4GB RAM ** Zotac GT630 * 1 TB System HDD * 4 GB RAM * Harmony 900 * satip-Plugin

    - Client2: Alfawise H96 Pro Plus * KODI
    - Server: Intel Pentium G3220 * DH87RL * 16GB RAM * 4x4TB 3.5" WD RED + 1x500GB 2.5" * satip-Plugin
    - SAT>IP: Inverto iLNB


  • scraping schon gelaufen? ja aber nicht fertig


    aber im epg-info von VDR widr schon alles angezeigt.
    Mus das scraping fertig sein?


    Die Aufnahmen werden erst nach dem ersten kompletten Live EPG Scrap angegangen...das scraper2vdr Plugin schaut zyklisch, ob was für ihn in der DB ist und holt sich das dann, deswegen siehst du schon was. Aber bei den Aufnahmen war der epgd dann noch nicht. Also ein bisschen Geduld und das epgd Log im Auge behalten ;)


    Ciao Louis

  • Ich hatte einen Fehler in meiner channelmap, wie bekomme ich jetzt am schellsten die korrekten Daten? epg.data löschen und dann was? Oder besser eine andere Vorgehensweise?


    und was bedeutet das?

    Code
    1. Apr 17 13:47:05 microserver epgd: SQL-Error in 'prepare(stmt_prepare)' - Unknown column 'svdrp' in 'field list' (1054) 'Unknown column 'svdrp' in 'field list'
    2. ' [select uuid, inssp, updsp, name, version, dbapi, lastupd, nextupd, state, master, ip, svdrp from vdrs where uuid = ?;]


    Hätte ich die Datenbank wieder droppen müssen? Wenn ja, wo habe ich den Hinweis darauf übersehen?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • gerald : wenn du die DB droppst, dann benutze das epgd-dropall script, das löscht nur die EPG relevanten Tabellen und lässt die scraper Tabellen in Ruhe...und das ist auch gut so :-)


    Den SQL Fehler kann ich mir nur aufgrund einer nicht korrekten API Version erklären...wenn die nach dem epgd-dropall immer noch kommt (beim nächsten Start vom epgd werden ja alle gelöschten Tabellen automatisch neu angelegt), ist was faul...da müsste dann aber Jörg oder Christian was zu sagen.


    Ciao Louis