DVB API v5.3 or higher

  • Hi all, I've run in to slight problem, if anyone can help.

    When compiling I get this error.

    ERROR: requires linux DVB API v5.3 or higher.
    *** Please update your linux dvb headers,
    *** (usually /usr/include/linux/dvb).
    *** EXITING!

    I've tried updating kernel and headers and also trying to download v4l drivers but without success.

    Anyone have the deb for lucid ubuntu 10.4?

    How can I resolve this?


  • Anyone have the deb for lucid ubuntu 10.4?

    Which vdr version do you need?
    The yaVDR PPAs for lucid provide VDR 1.7.27 (https://launchpad.net/~yavdr/+…field.series_filter=lucid) and 1.7.31 (https://launchpad.net/~yavdr/+…field.series_filter=lucid).

    How can I resolve this?

    AFAIK there is an apiwrapper patch for those cases: http://www.udo-richter.de/vdr/…s.en.html#dvb-api-wrapper

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Look in the directory listed, see what files are in it and which version they are. Also look in the VDR makefile to see to which directory it points.

    I'm sorry for the English postings but I can't write German, reading isn't a problem.

    VDR server: P4 with vdr 2.1.6 / streamdev / SmartTVweb / vipclient Javascript
    Clients : Motorola Vip1903/1963

  • Thanks for the reply guys.

    Just to make it clear I don't need the vdr as deb I was asking for deb to update dvbapi modules to resolve that problem, and update the driver to api 5.3 or above.

    I can get the vdr to skip the check or use an older version of vdr for that matter, but it's not just the vdr but also the plugins too, that give out the same error.

    These two latest have given me that error.


Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!