2.HDD als video.01 in System einbinden

  • Hallo!


    Ich versuche schon einiger zeit meine zweite HDD in meine System ein zu binden. Habe hier auch schon einiges nach gelesen per Hand kann ich sie mounten aber bei Neustart bekomme ich immer Fehlermeldung das ich sie mit S Konfiguration überspringen oder M manuell Konfigurieren


    Bis jetzt habe ich folgendes gemacht:


    Festplatte als Ordner /media/video.01 erstellt

    Code
    1. sudo mkdir /media/video.01]


    Die Festplatte gemountet

    Code
    1. sudo mount /media/video.01


    Die UUID anzeigen lassen mit

    Code
    1. sudo blkid /dev/sdb


    /dev/sdb: UUID="bf88648f-665e-4ab3-a448-26c942c017b9" TYPE="ext4"


    In der /etc/fstab eingetragen mit

    Code
    1. sudo nano /etc/fstab


    Das habe ich in die /etc/fsab eingetragen:
    UUID="bf88648f-665e-4ab3-a448-26c942c017b9 /media/video.01 ext4 defaults 0 0


    Muss ich beim eintragen in die fstab was beachten, habe die Zeile so eingetragen wie sie hier steht


    Nach dem Neustart bekomme ich immer die oben geschriebene Fehlermeldung. Kann aber die HDD per Hand mounten


    MfG

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • sudo blkid /dev/sdb


    Sicher, dass du nicht die UUID einer Partition auf der Platte statt der Platte selbst herausfinden willst? Oder hast du das Block-Device direkt mit dem Dateisystem formatiert?

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hallo!


    Ich habe die HDD 720GB als ext4 formatiert und dort möchte ich nur meine Daten und nicht die Aufnahmen drauf haben Aufnahmen bleibt auf video.00. Nun möchte ich die UUID von der 2. HDD sdb herausfinden. Die sdb hat nur eine Partition wo ich den video.01 Ordner mit Unterordner erstellt habe. Das ganze dann in die fstab eintragen das sie bei Start Automatisch gemountet wird. Da ich sie per Hand nach dem Start mounten kann, vermute ich das es nur am Eintrag ins der fstab liegt das ich die Fehlermeldung bekomme.


    Hier ist die ausgabe von fdsik -l


    In Zeile 22 die Fehlermeldung hat das auch mit dem nicht erkennen beim Start zu tun?


    MfG

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • In Zeile 22 die Fehlermeldung hat das auch mit dem nicht erkennen beim Start zu tun?


    OMG, du hast tatsächlich die Platte anstatt der Partition formatiert. Jetzt ist die Partitiontable weg, oder hast du die Platte noch nie partitioniert?


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Die sdb hat nur eine Partition


    Sie hat zumindest keine mit fdisk darstellbare Partition. Falls es sich nicht um eine GTP-Partitionstabelle handelt (dann kann man gdisk nutzen) scheint es, dass du das Block-Device für die Platte direkt formatiert hast.


    Was sagt denn "mount -a"? Das sollte ja eine aussagekräftige Fehlermeldung liefern.


    Im Zweifelsfall würde ich die mal sauber mit fdisk partitionieren und dann mit ext4 formatieren.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Naja. Wenn er die Platte "als ganzes" nutzen will und nicht vorhat davon zu booten, dann gibt es unter Linux keinen technischen Grund überhaupt eine Partitionstabelle zu haben ;) Bei Sticks ist es sogar garnicht mal so unüblich die ganz ohne Partitionierung direkt zu formatieren.

  • Das ist die Ausgabe von mount -a

    Code
    1. root@yavdr-0-5:~# mount -a
    2. mount: Gerätedatei UUID="bf88648f-665e-4ab3-a448-26c942c017b9 existiert nicht


    Bin genau so vergangen wie ich bei meinem Pi gemacht habe wo ich XBian installiert habe mit Owncloud und dort die USB Festplatte eingebunden habe.
    Mit dem Befehl habe ich die HDD formatiert

    Code
    1. sudo mkfs.ext4 /dev/sdb1

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • Zu allererst willst du dir zum Adminstrieren via "sudo -i" eine Root-Shell holen. Das ständige voranstellen von "sudo" kannst du dir dann sparen...


    Wenn du /dev/sdb1 formatiert hast, dann musst du auch "blkid /dev/sdb1" ausführen um an die UUID zu kommen.


    ... oder eben auf die UUID verzichten und in die fstab einfach /dev/sdb1 schreiben. Bei fest eingebauten Platten ändert sich die Reihenfolge normalerweise nicht.

  • OMG, du hast tatsächlich die Platte anstatt der Partition formatiert. Jetzt ist die Partitiontable weg, oder hast du die Platte noch nie partitioniert?

    Die Festplatte war vorher als NTSF formatiert und die habe ich gelöscht da war ein test win drauf das ich nicht mehr gebraucht habe. Auf der Platte sind auch noch keine Daten drauf und kann sie jeder Zeit noch mal Formatieren wie sie sein soll.

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • Zu allererst willst du dir zum Adminstrieren via "sudo -i" eine Root-Shell holen. Das ständige voranstellen von "sudo" kannst du dir dann sparen...


    Wenn du /dev/sdb1 formatiert hast, dann musst du auch "blkid /dev/sdb1" ausführen um an die UUID zu kommen.


    ... oder eben auf die UUID verzichten und in die fstab einfach /dev/sdb1 schreiben. Bei fest eingebauten Platten ändert sich die Reihenfolge normalerweise nicht.

    Das mit dem "sudo" Befehl in der Root-Shell weiss ich aber das ist eine blöde Gewohnheit von mir wenn ich Root-Rechte habe das ich auch "sudo" eingebe.


    fstab Ja dann werde ich statt der UUID nur /dev/sdb1 eintragen. Die Platte habe ich sowieso fest eingebaut.


    Noch eine andere Frage habe ich noch: Wenn die 2. HDD nicht gemountet ist, ist sie da außer betrieb? Ich meine läuft sie da auch weil ich brauche sie nur wenn ich über XBMC Filme u.s.w ansehe und sonst nicht. Wenn ja das sie immer läuft ist es egal das sie bei Start gleich gemountet wird sonst kann ich sie auch per Hand mounten wenn ich sie brauche oder gibt es da noch eine andere Möglichkeit. Habe auch schon überlegt ein Start-Skript das ich über das Netzwerk ausführe mir zu machen.

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • via "hdparm" kann ein "Timeout" gesetzt werden, nach dem die Platte "schlafen" geht. Beim ersten Zugriff läuft die Platte dann wieder an. Man sollte unnötig häufiges "Anlaufen" aber vermeiden. Die Platte verträgt langes Durchlaufen besser als häufiges anlaufen.

  • @Mreimer


    Muss ich mir ansehen mit "hdparm" aber die 2. HDD wir bei mir nicht so oft benutzt, nur wie ich schon geschrieben haben wenn ich Filme, Bilder, u.s.w. über XBMC schauen möchte.
    Das mit dem einbinden der 2. HDD hat jetzt geklappt mit dem Eintrag

    Code
    1. dev/sdb/ /media/video.01 ext4 defaults 0 0


    Die Festplatte war auf dev/sdb/ Formatiert

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2

  • Hallo!


    Danke nochmal für eure Hilfe Super Forum hier :tup


    MfG

    VDR1 | MLD 5.4 64Bit Stable | ASRock Q1900M | 4GB Ram | Intel VA-API | Digital Devices DuoFlex DVB-S2 | SSD 64GB

    MLD 5.1 Server | Banana Pi | Fhem |

    Test VDR: MLD 5.4 64Bit Unstable | ASRock Q1900M | 4GB RAM | Intel VA-API | OctopusNet S2-2