grmpf... - zweite Festplatte einbinden - ich kriegs echt nicht geregelt...

  • also ich die system-platte auf der ich yavdr installiert habe.


    mount -l zeigt mir:


    binde ich in der fstab


    Code
    1. /dev/sdb1 /srv ext4 errors=remount-ro 0 1


    die neue festplatte ein und habe dann die folgenden Befehle ausgeführt:


    Code
    1. mkdir /srv/vdr
    2. mkdir /srv/vdr/video.01
    3. chown -R vdr:vdr /srv/vdr


    mache dann nen reboot... - startet der vdr gar nicht mehr durch... er bleibt stehen... - weil aus irgendwelchen - für mich nicht nachvollziehbaren Gründen - hat er keine video.00 mehr...


    wie bekomme ich denn bitte diese 2. Platte zusammen mit dem video.00 Verzeichnis der ersten Platte????

    YAVDR-System: derzeit 0.5 stable
    Asus M5A87 mit einem AMD Athlon II X2 250 3Ghz AM3
    4GB Kingston DDR3, 2TB WD SATAII 64MB als video.01,
    Systemplatte: SSD Crucial 64GB Sata III,
    Asus ENGT520 Silent per HDMI an einem 42" Phillips LCD
    dieser befeuert über Digital Audio eine JBL ESC333
    Hauppauge PVR-500 und Nova-TD 500 weil kein DVB-C hier
    alles schön eng in ein MS-380 eingepasst

  • mache dann nen reboot... - startet der vdr gar nicht mehr durch... er bleibt stehen... - weil aus irgendwelchen - für mich nicht nachvollziehbaren Gründen - hat er keine video.00 mehr...


    Das ist nicht dein Ernst oder? Du mountest doch die sdb1 auf das Verzeichnis mit der video.00. Natürlich ist das dann nicht mehr sichtbar.

    wie bekomme ich denn bitte diese 2. Platte zusammen mit dem video.00 Verzeichnis der ersten Platte????


    Ist doch ganz simpel:

    Code
    1. sudo mkdir -p /srv/vdr/video.01
    2. sudo chown vdr:vdr /srv/vdr/video.01
    3. sudo cat <<EOF >>/etc/fstab
    4. /dev/sdb1 /srv/vdr/video.01 ext4 errors=remount-ro 0 1
    5. EOF


    Deine Änderungen musst du vorher natürlich rückgängig machen.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Müsste es nicht statt


    /dev/sdb1 /srv ext4 errors=remount-ro 0 1


    eher


    /dev/sdb1 /srv/video.01 ext4 errors=remount-ro 0 1


    heissen?

    Silverstone LC 16-MR, P5N7A-VM , Cine S2 Dual DVB-S2 V5.5, E5200, 64 GB Crucial CT064M4, 2 TB WD 20EARX

  • /dev/sdb1 /srv/video.01 ext4 errors=remount-ro 0 1


    Nein, so wie ich es geschrieben habe /srv/vdr/video.01.


    Gerald


    HP Proliant MicroServer Gen8, Xeon E3-1230, 12 GB RAM, 3xWD red 2TB im RAID 5, 2xSundtek MediaTV Home DVB-C/T, L4M TWIN-C/T, Ubuntu Server 14.04.1, Plex Media Server
    Samsung UE55H6470

  • Hy Gerald,


    DAAANNNKKKKEEEEE... - das war der entscheidende Tip... - keine Ahnung woran es gehangen hat... - vermutlich am gefährlichen Halbwissen...


    die mount -l sieht nun schon viiiel besser aus :-) und der vdr startet auch...



    Eine Frage noch: das Aufnahmeverzeichnis im vdr addiert die zweite Platte bzgl. Größe und verfügbare Prozentzahlen nicht hinzu... - ist das ok - oder muss ich da auch noch war "zwirbeln"...?

    YAVDR-System: derzeit 0.5 stable
    Asus M5A87 mit einem AMD Athlon II X2 250 3Ghz AM3
    4GB Kingston DDR3, 2TB WD SATAII 64MB als video.01,
    Systemplatte: SSD Crucial 64GB Sata III,
    Asus ENGT520 Silent per HDMI an einem 42" Phillips LCD
    dieser befeuert über Digital Audio eine JBL ESC333
    Hauppauge PVR-500 und Nova-TD 500 weil kein DVB-C hier
    alles schön eng in ein MS-380 eingepasst

  • ist zwar nur kosmetik, aber wie auch in vdr-live wird die Kapazität nicht addiert angezeigt - also z.B. Disk 3% - 276:02 frei ist lediglich die erste Platte - und nicht beide...

    YAVDR-System: derzeit 0.5 stable
    Asus M5A87 mit einem AMD Athlon II X2 250 3Ghz AM3
    4GB Kingston DDR3, 2TB WD SATAII 64MB als video.01,
    Systemplatte: SSD Crucial 64GB Sata III,
    Asus ENGT520 Silent per HDMI an einem 42" Phillips LCD
    dieser befeuert über Digital Audio eine JBL ESC333
    Hauppauge PVR-500 und Nova-TD 500 weil kein DVB-C hier
    alles schön eng in ein MS-380 eingepasst

  • also ich hab's so gemacht:


    meine 2TB Festplatte hat 2 Verzeichnisse - eines für den VDR, wo temporäre Aufnahmen (Serien die nach dem Ansehen wieder gelöscht werden oder Filme die nach dem Schneiden in der Videothek landen) hin kommen (/mnt/HTPCVideo/VDR.Recordings) und die Videothek (/mnt/HTPCVideo/VDR.Recordings). Das Ganze dann zusammengefasst auf /srv/video. Von dort gibts seit VDR0.4 einen link auf /media/Video/local - das wird dann auch von den anderen PCs im Netzwerk zum Filme ansehen verwendet.


    Zu diesem Zweck habe ich in der /etc/fstab folgenden Eintrag: "UUID=48f6f6fc-f52b-424c-8493-21eb3c8cdd9f /mnt/HTPCVideo ext4 defaults 0 2" und in der /etc/init ein upstart-script mit folgendem Inhalt:



    Das erste mount legt mir die VDR.Recordings "über" die /srv/vdr.video.00 - somit nimmt der VDR in Wahrheit auf die 2TB Festplatte auf. Der "mhddfs"-Befehl merged die beiden Verzeichnisse ´(/mnt/HTPCVideo/VDR.Recordings & /mnt/HTPCVideo/Videothek) unter /srv/video. Damit habe ich sichergestellt, dass ausschließlich auf "video.00" (=VDR.Recordings) aufgenommen wird und ausreichend Kapazität zur Verfügung steht; andererseits kann ich auf ALLE Vdeos über EIN EINZIGES Verzeichnis zugreifen (egal ob sie noch "temporär/vor Bearbeitung" sind, oder bereits in der Videothek.


    Ich hatte die Befehle im up-start script in der /etc/fstab, bin aber zu der Einsicht gekommen, dass wenn ich an der Konfiguration oder Namenskonvention etwas ändere, das System nicht mehr bootet, da die Platte, das verzeichnis oder sonstwas nicht gefunden wird und das System hängt...