You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

21

Friday, April 9th 2010, 2:52pm

Quoted

Original von C-3PO
Ich gehe mal davon aus, dass fb0 der Framebuffer der Grafikkarte ist.
Wie schaltet man denn den Framebuffer aus?


Habe es mittlerweile gefunden nun den FB der Graka deaktiviert.

Habe nun auch einen Teilerfolg, denn die Konsole wird nun auf dem Display angezeigt und ab und zu hatte ich auch mal ein paar "Fetzen" von GrphTFT auf den Display sehen können.

D.h.: Prinzipiell funktioniert es schonmal und ich denke mal, dass der Rest nur noch eine Sache der Einstellung ist. :)

:!: Hier nicht klicken!!



dreipo.cc

"Ubuntu" -- An african Word, meaning: "Gentoo is too hard for me".

my VDR


Gen2VDR V4.3PO

VDR: vdr-2.1.6
Mainboard: ASUS P8Z77-V LX2
CPU: i7-3770K
RAM: 16G
System HDD: OCZ-VERTEX4 SSD, 120 GB
Video HDD: WD Caviar Green, 3 TB
BD-ROM: Samsung SH-B123L
Gehäuse: Thermaltake DH202 Touch (VM90051N2Z)
DVB: DD Cine S2 V6.5 & DuofleX C/T
IR/FB: yaUSBIR v3 ; Harmony 885

This post has been edited 1 times, last edit by "C-3PO" (Apr 9th 2010, 3:58pm)


22

Saturday, April 10th 2010, 12:46pm

Mir ist aufgefallen, dass wenn ich den Framebuffer der Graka deaktiviere, dass dann die Wiedergabe mit dem xine-Lugin oder auch mit xinelibout ruckelt.
Am besten sieht man das z.B. bei N24 beim Newsticker.

Die Frage ist nun, wie die die Zusammenhänge von xine und dem Framebuffer sind?

:!: Hier nicht klicken!!



dreipo.cc

"Ubuntu" -- An african Word, meaning: "Gentoo is too hard for me".

my VDR


Gen2VDR V4.3PO

VDR: vdr-2.1.6
Mainboard: ASUS P8Z77-V LX2
CPU: i7-3770K
RAM: 16G
System HDD: OCZ-VERTEX4 SSD, 120 GB
Video HDD: WD Caviar Green, 3 TB
BD-ROM: Samsung SH-B123L
Gehäuse: Thermaltake DH202 Touch (VM90051N2Z)
DVB: DD Cine S2 V6.5 & DuofleX C/T
IR/FB: yaUSBIR v3 ; Harmony 885

23

Sunday, April 11th 2010, 4:47pm

Hat denn wirklich Niemand eine Idee dazu? :schiel

:!: Hier nicht klicken!!



dreipo.cc

"Ubuntu" -- An african Word, meaning: "Gentoo is too hard for me".

my VDR


Gen2VDR V4.3PO

VDR: vdr-2.1.6
Mainboard: ASUS P8Z77-V LX2
CPU: i7-3770K
RAM: 16G
System HDD: OCZ-VERTEX4 SSD, 120 GB
Video HDD: WD Caviar Green, 3 TB
BD-ROM: Samsung SH-B123L
Gehäuse: Thermaltake DH202 Touch (VM90051N2Z)
DVB: DD Cine S2 V6.5 & DuofleX C/T
IR/FB: yaUSBIR v3 ; Harmony 885

bexbier

Professional

Posts: 600

Location: bremen

  • Send private message

24

Thursday, April 29th 2010, 4:03pm

versuch mal diesen treiber -> TREIBER

vorher alte treiber entfernen.
MfG

bex

server -> Asus p8h67-i -Intel 2100T - Cine CT v6
client 1 -> Asus p5n7a-vm -Intel E5200 - Technisat Cablestar HD 2
client 2+3 -> Raspberry Pi - Openelec

kris

Professional

Posts: 1,658

Location: Bornheim, Rheinl.

  • Send private message

25

Friday, September 24th 2010, 10:02pm

Hi,

läuft das Display mittlerweile mit Graphtft? Sieht ja ganz nett aus.

MfG
KRis
Kopfstation: Intel DN2800MT 4GB RAM; 32GB mSata mit YaVDR 0.5 und 4x DVB-S2 USB Stick Sundtek SkyTV Ultimate

26

Friday, September 24th 2010, 10:19pm

Quoted

Original von kris
Hi,

läuft das Display mittlerweile mit Graphtft? Sieht ja ganz nett aus.

MfG
KRis

Ja.

:!: Hier nicht klicken!!



dreipo.cc

"Ubuntu" -- An african Word, meaning: "Gentoo is too hard for me".

my VDR


Gen2VDR V4.3PO

VDR: vdr-2.1.6
Mainboard: ASUS P8Z77-V LX2
CPU: i7-3770K
RAM: 16G
System HDD: OCZ-VERTEX4 SSD, 120 GB
Video HDD: WD Caviar Green, 3 TB
BD-ROM: Samsung SH-B123L
Gehäuse: Thermaltake DH202 Touch (VM90051N2Z)
DVB: DD Cine S2 V6.5 & DuofleX C/T
IR/FB: yaUSBIR v3 ; Harmony 885

russisch24

Beginner

Posts: 1

Location: Russland

  • Send private message

27

Friday, September 24th 2010, 11:47pm

Danke

Danke für das Thema!
Die Diskussion hat mir auch weitergeholfen...
Alles möglich - Russische Tastatur hilft dabei!

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

28

Tuesday, November 9th 2010, 11:19pm

also ich muss das thema wieder aufwaermen. hab bis dato immer graphtft gepatcht, aber das ist mir eigentlich auch zu bloed ;) versuche es also wieder "richtig".

display wird gruen, und das war's.
per mplayer:

Source code

1
 mplayer -vo fbdev film.avi
bekomme ich ton ueber die speaker (wenn vdr gestoppt ist), aber kein bild am tft. bild bleibt gruen.

dmesg sagt folgendes:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
root@ubuntu:~# dmesg |grep udlfb
[    3.611388] udlfb: DisplayLink Samsung UbiSync Monitor - serial #0103-000000HVASC00717
[    3.611395] udlfb: vid_17e9&pid_0103&rev_0009 driver's dlfb_data struct at edad0800
[    3.611397] udlfb: console enable=0
[    3.611399] udlfb: fb_defio enable=0
[    3.613484] udlfb: vendor descriptor length:e0 data:00 00 00 0000 00 00 00 00 00 00
[    3.613488] udlfb: Unrecognized vendor firmware descriptor
[    3.613624] udlfb: allocated 4 65024 byte urbs
[    3.712256] udlfb: 800x480 valid mode
[    3.712261] udlfb: Reallocating framebuffer. Addresses will change!
[    3.713107] udlfb: 800x480 valid mode
[    3.713110] udlfb: set_par mode 800x480
[    3.715190] udlfb: DisplayLink USB device /dev/fb0 attached. 800x480 resolution. Using 1504K framebuffer memory
[    3.715222] usbcore: registered new interface driver udlfb
[    3.799839] udlfb: open /dev/fb0 user=1 fb_info=ed8bcc00 count=1
[    6.447004] udlfb: open /dev/fb0 user=1 fb_info=ed8bcc00 count=2
[    6.447034] udlfb: mmap() framebuffer addr:4071161856 size:770048
[    8.508363] udlfb: released /dev/fb0 user=1 count=1
treiber ist von http://www.bexbier.bplaced.net/files/udlfb.tar.gz und geladen.

wer hat noch einen tip. vielleicht "ueberlagert" sich ja wirklich der fb der onboard graka und der von usb. aber wie find ich das raus, und wie bring ich es in ordnung? wie dreht man fb auf der graka ab?
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

bexbier

Professional

Posts: 600

Location: bremen

  • Send private message

29

Tuesday, November 9th 2010, 11:31pm

Nabend Izeman,

welchen kernel verwendest du ? muss jetzt lügen, meine ab Kernel 2.6.34 ist der treiber dabei.
MfG

bex

server -> Asus p8h67-i -Intel 2100T - Cine CT v6
client 1 -> Asus p5n7a-vm -Intel E5200 - Technisat Cablestar HD 2
client 2+3 -> Raspberry Pi - Openelec

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

30

Tuesday, November 9th 2010, 11:39pm

yavdr 0.3a
da ist 2.6.32 dabei (lucid) - daher auch der git treiber.
der tip mit 2.6.34 kam von dir eh schon mal in einem anderen thread - daher hab ich es auch gleich mit dem git udlfb probiert - leider genauso erfolglos.
hab jetzt auch mal beim booten mit "nofb" als kernel parameter fb deaktiviert. hat aber auch nix gebracht.
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

31

Tuesday, November 9th 2010, 11:43pm

vielleicht auch nuetzlich:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
root@ubuntu:~# fbset -v -i
Linux Frame Buffer Device Configuration Version 2.1 (23/06/1999)
(C) Copyright 1995-1999 by Geert Uytterhoeven

Opening frame buffer device `/dev/fb0'
Using current video mode from `/dev/fb0'

mode "800x480-62"
    # D: 33.000 MHz, H: 31.250 kHz, V: 61.881 Hz
    geometry 800 480 800 480 16
    timings 30303 88 40 21 1 128 3
    hsync high
    vsync high
    rgba 5/11,6/5,5/0,0/0
endmode

Getting further frame buffer information
Frame buffer device information:
    Name        : udlfb
    Address     : 0xefa4a000
    Size        : 770048
    Type        : PACKED PIXELS
    Visual      : TRUECOLOR
    XPanStep    : 0
    YPanStep    : 0
    YWrapStep   : 0
    LineLength  : 1600
    Accelerator : No
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

This post has been edited 1 times, last edit by "izeman" (Nov 9th 2010, 11:44pm)


bexbier

Professional

Posts: 600

Location: bremen

  • Send private message

32

Wednesday, November 10th 2010, 1:44am

nabend nochmal,

ok, also mal grundsätzlich, wenn man ein grünes display sieht ist das schonmal ein sehr gutes zeichen !
Das bedeutet der treiber wurde geladen und das display ist bereit.

Da du ja das selbe board wie ich benutzt ist es wohl unter dev/fb0 initialisiert.

was sagt denn vdr, wenn du mit "-P'graphtft -d /dev/fb0' startest ?

P.S.: die fage nach dem Kernel kam daher, dass ja ab Kernel 2.6.34 der treiber includiert ist, und man ihn sonst doppelt hätte.

Bei Kernel 2.6.32 ist dein vorgehen richtig, mit dem treiber von meiner seite ist auch kein patch von graphtft nötig.

Wie gesagt, poste mal bitte die vdr ausgaben.
MfG

bex

server -> Asus p8h67-i -Intel 2100T - Cine CT v6
client 1 -> Asus p5n7a-vm -Intel E5200 - Technisat Cablestar HD 2
client 2+3 -> Raspberry Pi - Openelec

This post has been edited 1 times, last edit by "bexbier" (Nov 10th 2010, 1:45am)


izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

33

Wednesday, November 10th 2010, 11:19am

Source code

1
root@ubuntu:~# vdr -Pdummydevice -P'graphtft -d /dev/fb0'


Nov 10 11:16:52 ubuntu vdr: [7545] VDR version 1.7.16 started
Nov 10 11:16:52 ubuntu vdr: [7545] codeset is 'UTF-8' - known
Nov 10 11:16:52 ubuntu vdr: [7545] found 27 locales in /usr/share/locale
Nov 10 11:16:52 ubuntu vdr: [7545] no locale for language code 'por'
Nov 10 11:16:52 ubuntu vdr: [7545] loading plugin: /usr/lib/vdr/plugins/libvdr-dummydevice.so.1.7.16
Nov 10 11:16:52 ubuntu vdr: [7545] loading plugin: /usr/lib/vdr/plugins/libvdr-graphtft.so.1.7.16
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/setup.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/sources.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/diseqc.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/channels.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/timers.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/commands.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/reccmds.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/svdrphosts.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/remote.conf
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/keymacros.conf
Nov 10 11:16:52 ubuntu vdr: [7545] reading EPG data from /var/lib/video.00/epg.data
Nov 10 11:16:52 ubuntu vdr: [7547] video directory scanner thread started (pid=7545, tid=7547)
Nov 10 11:16:52 ubuntu vdr: [7547] video directory scanner thread ended (pid=7545, tid=7547)
Nov 10 11:16:52 ubuntu vdr: [7548] video directory scanner thread started (pid=7545, tid=7548)
Nov 10 11:16:52 ubuntu vdr: [7548] video directory scanner thread ended (pid=7545, tid=7548)
Nov 10 11:16:52 ubuntu vdr: [7545] registered source parameters for 'A - ATSC'
Nov 10 11:16:52 ubuntu vdr: [7545] registered source parameters for 'C - DVB-C'
Nov 10 11:16:52 ubuntu vdr: [7545] registered source parameters for 'S - DVB-S'
Nov 10 11:16:52 ubuntu vdr: [7545] registered source parameters for 'T - DVB-T'
Nov 10 11:16:52 ubuntu vdr: [7545] probing /dev/dvb/adapter0/frontend0
Nov 10 11:16:52 ubuntu vdr: [7545] creating cDvbDevice
Nov 10 11:16:52 ubuntu vdr: [7545] new device number 1
Nov 10 11:16:52 ubuntu vdr: [7545] LNB-sharing: setting device 0 to use LNB 1
Nov 10 11:16:52 ubuntu vdr: [7545] frontend 0/0 provides DVB-S2 with QPSK ("STB0899 Multistandard")
Nov 10 11:16:52 ubuntu vdr: [7545] probing /dev/dvb/adapter1/frontend0
Nov 10 11:16:52 ubuntu vdr: [7545] creating cDvbDevice
Nov 10 11:16:52 ubuntu vdr: [7545] new device number 2
Nov 10 11:16:52 ubuntu vdr: [7545] LNB-sharing: setting device 1 to use LNB 2
Nov 10 11:16:52 ubuntu vdr: [7545] frontend 1/0 provides DVB-S2 with QPSK ("STB0899 Multistandard")
Nov 10 11:16:52 ubuntu vdr: [7549] tuner on frontend 0/0 thread started (pid=7545, tid=7549)
Nov 10 11:16:52 ubuntu vdr: [7545] found 2 DVB devices
Nov 10 11:16:52 ubuntu vdr: [7545] initializing plugin: dummydevice (1.0.2): Output device that does nothing
Nov 10 11:16:52 ubuntu vdr: [7545] new device number 9
Nov 10 11:16:52 ubuntu vdr: [7545] initializing plugin: graphtft (0.3.3): VDR OSD on TFT
Nov 10 11:16:52 ubuntu vdr: [7545] setting primary device to 3
Nov 10 11:16:52 ubuntu vdr: [7545] assuming manual start of VDR
Nov 10 11:16:52 ubuntu vdr: [7545] skin "anthra_1920_OS" not available - using "classic" instead
Nov 10 11:16:52 ubuntu vdr: [7545] starting plugin: dummydevice
Nov 10 11:16:52 ubuntu vdr: [7545] starting plugin: graphtft
Nov 10 11:16:52 ubuntu vdr: [7545] Device is '/dev/fb0'
Nov 10 11:16:52 ubuntu vdr: [7545] Loading themes
Nov 10 11:16:52 ubuntu vdr: [7552] section handler thread started (pid=7545, tid=7552)
Nov 10 11:16:52 ubuntu vdr: [7550] section handler thread started (pid=7545, tid=7550)
Nov 10 11:16:52 ubuntu vdr: [7551] tuner on frontend 1/0 thread started (pid=7545, tid=7551)
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/plugins/graphTFT/themes/anthraize/anthraize.theme
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/plugins/graphTFT/themes/PearlHD/PearlHD.theme
Nov 10 11:16:52 ubuntu vdr: [7545] loading /var/lib/vdr/plugins/graphTFT/themes/standard/standard.theme
Nov 10 11:16:52 ubuntu vdr: [7545] Loaded 3 themes
Nov 10 11:16:52 ubuntu vdr: [7545] Activated theme 'anthraize-800x480'
Nov 10 11:16:52 ubuntu vdr: [7558] GraphTFT plugin tcp communication thread started (pid=7545)
Nov 10 11:16:52 ubuntu vdr: [7545] skin "anthra_1920_OS" not available - using "classic" instead
Nov 10 11:16:52 ubuntu kernel: [42672.696709] udlfb: open /dev/fb0 user=1 fb_info=ede00400 count=1
Nov 10 11:16:52 ubuntu kernel: [42672.696740] udlfb: mmap() framebuffer addr:4020543488 size:770048
Nov 10 11:16:52 ubuntu vdr: [7545] remote control graphtft-fe - keys known
Nov 10 11:16:52 ubuntu vdr: [7545] remote control LIRC - keys known
Nov 10 11:16:52 ubuntu vdr: [7545] remote control KBD - keys known
Nov 10 11:16:52 ubuntu vdr: [7545] switching to channel 7
Nov 10 11:16:52 ubuntu vdr: [7545] OSD size changed to 720x480 @ 1
Nov 10 11:16:52 ubuntu vdr: [7562] KBD remote control thread started (pid=7545, tid=7562)
Nov 10 11:16:52 ubuntu vdr: [7545] ERROR: no OSD provider available - using dummy OSD!
Nov 10 11:16:52 ubuntu vdr: [7561] LIRC remote control thread started (pid=7545, tid=7561)
Nov 10 11:16:52 ubuntu lircd-0.8.6[858]: accepted new client on /var/run/lirc/lircd
Nov 10 11:16:52 ubuntu vdr: [7564] receiver on device 1 thread started (pid=7545, tid=7564)
Nov 10 11:16:52 ubuntu vdr: [7545] timer 2 (2 2339-0020 'Little Britain~2010.11.11-23:41-Do') set to event Don 11.11.2010 23:41-00:10 (VPS: 11.11 23:39) 'Little Britain'
Nov 10 11:16:52 ubuntu vdr: [7559] TouchTFT-Thread thread started (pid=7545, tid=7559)
Nov 10 11:16:52 ubuntu vdr: [7565] TS buffer on device 1 thread started (pid=7545, tid=7565)

das war's. schaut imho alles sauber aus. trotzdem unveraendert ein gruener bildschirm.
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

This post has been edited 1 times, last edit by "izeman" (Nov 10th 2010, 11:20am)


izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

34

Wednesday, November 24th 2010, 12:26pm

hat noch jemand eine idee? es nervt ohne ende dass das huebsche tft neben dem tv immer dunkel bleibt ... (und ich mein schoenes theme nicht sehen kann ;) - von weiterentwickeln ganz zu schweigen.
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367

bexbier

Professional

Posts: 600

Location: bremen

  • Send private message

35

Monday, November 29th 2010, 11:55pm

nabend izeman,

deine vdr ausgaben sehen ok aus, eigentlich müsste es so klappen.

Wenn du den Pc startest, kommt dann die consollenausgabe auf dem display ?

Benutze Debian sid, und musste das udlfb module auf die blacklist setzen, weil sonst das device beim start für die consolenausgabe benutzt wurde und somit belegt war.
Hab es somit auf die blacklist gesetzt und lade es erst vor vdr start per script.

vielleicht hilft dir das weiter.
MfG

bex

server -> Asus p8h67-i -Intel 2100T - Cine CT v6
client 1 -> Asus p5n7a-vm -Intel E5200 - Technisat Cablestar HD 2
client 2+3 -> Raspberry Pi - Openelec

izeman

Master

Posts: 1,710

Location: Österreich

  • Send private message

36

Tuesday, November 30th 2010, 8:14am

@bexbier: danke. ist ein interessanter ansatz. erstmal kam garkeine ausgabe. aber beim letzten mal kann ich mich erinnern, dass ich als erstes: "starting yavdr 0.3 ..." sah.
inzwischen hab ich mir das graphtft source pakage gezogen, gepatcht und neu gebaut. wie du selbst sagst: nicht die elegantestet loesung, aber es funktioniert. und damit reicht mir das erstmal. vielleicht geb ich dem ganzen noch eine chance wenn der 2.6.34er kernel den weg nach lucid gefunden hat :)
produktiv: asus p5n7a-vm, 1x tt-6400, 1x skystar dvb-s2, 8gig boot-ssd, 7" samsung u7, yavdr 0.5, atric 1.5 ir einschalter
testing: zotac ion-f itx, 2x tt s2-3600 usb (netceiver mit 2x dvb-s2), 60gig boot-hd, (level one usb-eth), yavdr 0.2 unstable
tv: lg 60pk-550 full-hd amp: yamaha rx-v367