USB-TFT Display mimo UM-720S

  • Hallo Zusammen,,


    ich habe mir mal ein mimo UM-720S USB Display besorgt. --> Info




    Unter Windows funktioniert das einwandfrei, also dachte ich mir, ich hänge mal an den VDR und sehe mal was sich tut....


    Ich habe dan auch nach einiger Zeit ein Projekt gefunden, wo Linuxtreiber für das Display entwickelt werden. --> KLICK


    Den Treiber heruntergeladen, installiert und geladen, - und siehe da, das Display wird sofort erkannt:



    Nun wollte ich die Ausgabe von GraphTFT darauf anzeigen lassen und habe das Plugin mit dem Parameter /dev/fb1 gestartet, aber leider bleibt die Anzeige dunkel. :(


    Im Log kann ich auch nichts auffälliges finden:


    Code
    1. .....
    2. Apr 07 14:25:46 [vdr] [2917] GraphTFT plugin tcp communication thread started (pid=2851)
    3. Apr 07 14:25:46 [vdr] [2918] TouchTFT-Thread thread started (pid=2851, tid=2918)
    4. Apr 07 14:25:46 [kernel] usb 1-2.2: dlfb: open /dev/fb1 user=1 fb_info=f671fc00 count=1
    5. Apr 07 14:25:46 [kernel] usb 1-2.2: dlfb: MMAP: 770048 770048
    6. .....


    So nun die Fragen:


    Geht das überhaupt mit diesem Display, oder fehlt noch irgend eine Einstellung?

  • Vieleicht das gleiche Problem wie beim U70 von Samsung. Schau mal im Portal unter U70. Wenn ich das richtig sehe ist es der gleiche Treiber, damit es funktioniert mur Graphtft gepatcht werden.


    beste Grüße
    Climber

    produktiv: Gen2VDR2.0 1xFF 1x Budget , SMT7020 mit Zenslack 1.0rc35
    bastel: wechselndes Teile gen2vdr2.0/ zenslack , S100, smt7020

  • Ich habe mal wie hier beschrieben die "fbrenderer.c" angepasst, aber das Display zeigt immer noch nichts an :(


    Im Log kommen z.B. beim Umschalten solche Meldungen:


    Code
    1. .....
    2. Apr 07 18:08:30 [kernel] usb 1-2.2: dlfb: open /dev/fb1 user=1 fb_info=f6baf800 count=2
    3. Apr 07 18:08:30 [kernel] usb 1-2.2: dlfb: release /dev/fb1 user=1 count=1
    4. Apr 07 18:09:00 [kernel] usb 1-2.2: dlfb: open /dev/fb1 user=1 fb_info=f6baf800 count=2
    5. Apr 07 18:09:00 [kernel] usb 1-2.2: dlfb: release /dev/fb1 user=1 count=1
    6. Apr 07 18:09:30 [kernel] usb 1-2.2: dlfb: open /dev/fb1 user=1 fb_info=f6baf800 count=2
    7. Apr 07 18:09:30 [kernel] usb 1-2.2: dlfb: release /dev/fb1 user=1 count=1
    8. ....
  • nabend,


    bin grad am testen mit debian squeeze, damit funktioniert das ganze bei mir auch nicht mehr.
    der treiber wird anstandslos geladen, graphtft findet auch das display und schreibt fleißig in den buffer aber es kommt kein bild.


    Beim rechner neustart kommen auf dem display die ausgaben die sonst auf dem bildschirm kommen und tests mit libdlo laufen auch anstandslos. Also somit funktioniert der treiber und auch das display. aber per graphtft kommt trotzdem kein bild.


    Auf meinem produktiv system (debian lenny) läuft es anstandslos. Ka was da bei aktuellen systemen schiefläuft.
    laut graphtft ausgaben läuft alles wunderbar.


    Auch mal allgemein gefragt läuft bei jemanden ein displaylink display mit aktuellem system ( squeeze, ubuntu lucid ) und graphtft ?

  • funktioniert die touchscreenfunktionalität ebenfalls?
    das Display sieht nämlich gut aus und evtl würd ich mir auch so eins zulegen bin gespannt was mit der "Schwarzen Bildschirm" sache wird

    HD-VDR (Wohnzimmer)
    HW: Zotac IONITX-F-E, 160GB SSD 2.5" & 320GB HDD 2,5", 2x1GB, Cine S2
    SW: yaVDR 0.6
    VDR:
    HW: SMT-7020S, 160GB Seagate 2.5"
    SW: zen2mms 1.1


  • Zitat

    Original von jensa
    funktioniert die touchscreenfunktionalität ebenfalls?


    Ja, es wird erkannt:



    Und mit :

    Code
    1. cat /dev/input/input9


    sehe ich auch, dass Daten empfangen werden.

  • Zitat

    Originally posted by C-3PO


    Hat da Jemand ein Beispiel, wie man eines o.g. Progamme aufruft um etwas über fb1 auszugeben?


    http://pwet.fr/man/linux/commandes/fbtv


    "-d device
    framebuffer device (default is $FRAMEBUFFER; /dev/fb0 if unset) "


    mplayer -vo fbdev name_of_video


    bei graphlcd muesste es im source geaendert werden (da fehlt noch die option in der
    config, merke ich gerade)


    -- randy

  • Wenn ich versuche mit mplayer ein file abzuspielen, bekommen ich folgenden Fehler:



    In dmegs steht dann:


    Code
    1. uvesafb: mode switch failed (eax=0x4f02, err=1)
    2. detected fb_set_par error, error code: -22
    3. uvesafb: mode switch failed (eax=0x4f02, err=1)
    4. detected fb_set_par error, error code: -22
    5. uvesafb: mode switch failed (eax=0x4f02, err=1)
    6. detected fb_set_par error, error code: -22
    7. uvesafb: mode switch failed (eax=0x4f02, err=1)
    8. detected fb_set_par error, error code: -22
    9. ......
  • fbi müsste für bilder gehen

  • > Meinst Du das? --> http://linux.bytesex.org/fbida/


    yepp



    > Leider habe immer noch kein Bild auf dem USB-TFT.
    > fbi geht leider auch nicht.


    Blöde Sache


    das display wäre schon schön

  • Wie hier beschrieben sehe ich den “green screen” , mehr aber leider auch nicht. :(


    Zitat

    udlfb provides Linux framebuffer (fbdev) support plus a private “damage” notification ioctl used by the Roberto DeIoris’ “displaylink” X server. Udlfb automatically detects and supports all current DisplayLink USB graphics chips – 120,160,115,125,165,195. It supports 16bpp, with modes up to the maximum supported by the DisplayLink chips. Plugging any DisplayLink device into a Linux PC with this support should result in a “green screen” which means udlfb has loaded, set the monitor default mode, and drawn to the device successfully.


    What udlfb does *not* do on its own is make configuring X easy – X sits on udlfb, but getting X running still involves editing configuration files like xorg.conf in different ways depending on what you’re trying to do, what distro version you have, and what primary GPU you have.



    Es muss doch nun eine Möglichkeit geben irgend etwas auf Display anzeigen zu lassen....