Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

shangkai

Anfänger

  • »shangkai« ist der Autor dieses Themas

Beiträge: 13

Wohnort: KR

Beruf: techniker

  • Nachricht senden

1

Mittwoch, 16. März 2005, 09:01

Wo Route eingeben?

HI,

ich komme über ein ping heise.de oder IP (Network is unreachable) nicht hinter das DSL Modem erst nach eingabe von "route add default gw 192.168.0.1" kann ich über das modem heraus pingen. So wo kann ich das fest eintragen in /etc/resolv.conf schon mehrere namensserver eingetragen funktioniert aber nich. Route gibt aus:

Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
Vdr im Aufbau YAVDR 0.6.1 GT730 MB ASRock J3710M TBS6905
Old VDR YARVDR 0.5.0 / GeForce 8400 GS / TT-premium S2-6400

2

Mittwoch, 16. März 2005, 09:09

RE: Wo Route eingeben?

Die Netzwerk-Konfiguration steht in /etc/network/interfaces. Dort solltest Du in etwa so was eintragen:

Quellcode

1
2
3
4
5
iface eth0 inet static
          address 192.168.0.2
          netmask 255.255.255.0
          broadcast 192.168.0.255
          gateway 192.168.0.254

Wichtig ist die Zeile, die mit "gateway" beginnt, dort muss dein Default-Gateway rein, also wohl der DSL-Router.

Gruß,
Reiner.
Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR 0.5.0a, vdr 2.0.6-6yavdr1
Frontend 2: SMT-7020S, zendeb-0.4.1-beta1, vdr 1.6.0-16ctvdr1 (e-tobi)
Backend: Athlon 2500+, Digital Devices CineS2 DVB-S2, ct-vdr 6, vdr 1.6.0-17ctvdr1 (e-tobi)

3

Mittwoch, 16. März 2005, 09:10

RE: Wo Route eingeben?

Hallo,

ich würde den Gateway in /etc/network/interfaces eingeben. Sollte dann etwa so aussehen (Ausschnitt):

Quellcode

1
2
3
4
5
6
iface eth0 inet static
        address 192.168.0.100
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

Viele Grüße,
Wolfi

shangkai

Anfänger

  • »shangkai« ist der Autor dieses Themas

Beiträge: 13

Wohnort: KR

Beruf: techniker

  • Nachricht senden

4

Mittwoch, 16. März 2005, 09:50

Hallo Reiner, Hallo Wolfi

meine interfaces sieht so aus (network habe ich noch per hand hinzugefügt)

auto lo eth0

iface lo inet loopback

iface eth0 inet static
address 192.168.0.100
netmask 255.255.225.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1

ich kann auch ping 192.168.0.1 eingeben das geht auch
trotzdem alles was ich hinter dem DSL Modem anpingen will geht erst anch dem Befehl "route add default gw 192.168.0.1". schon seltsam.

Kai
Vdr im Aufbau YAVDR 0.6.1 GT730 MB ASRock J3710M TBS6905
Old VDR YARVDR 0.5.0 / GeForce 8400 GS / TT-premium S2-6400

5

Mittwoch, 16. März 2005, 09:56

Wie sieht Deine Routing-Tabelle den direkt nach einem reboot aus?
Mach mal ein

Quellcode

1
netstat -rn
um sie anzuzeigen.

Gruß,
Reiner.
Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR 0.5.0a, vdr 2.0.6-6yavdr1
Frontend 2: SMT-7020S, zendeb-0.4.1-beta1, vdr 1.6.0-16ctvdr1 (e-tobi)
Backend: Athlon 2500+, Digital Devices CineS2 DVB-S2, ct-vdr 6, vdr 1.6.0-17ctvdr1 (e-tobi)

andreas_h

Fortgeschrittener

Beiträge: 258

Wohnort: Gelsenkirchen

Beruf: Admin

  • Nachricht senden

6

Mittwoch, 16. März 2005, 09:59

Hm, seltsam? Kontrolliert, dass kein Vertipper drin ist?
Kommt irgendeine Meldung beim Start? Im Zweifelsfall ruf mal

Quellcode

1
/etc/init.d/networking start
von Hand auf und schau, ob da was kommt.

Bye,
Andreas
VDR: AsRock Q1900M Pro, 2TB, 2GB RAM, GT720, 2x Cinergy C - Debian 8

7

Mittwoch, 16. März 2005, 10:02

Hallo shangkai,

mal ein paar Fragen:
1. ist 192.168.0.1 ein DSL Modem (was ich mir nicht vorstellen kann) oder ein Router?
2. Wenn es ein Router ist, ist der richtig konfiguiert (NAT)?
3. Hast Du mit dieser /etc/network/interfaces schon gebootet?
4. Wie schaut denn Dein Netzwerk genau aus (weitere Rechner, wen baut die Internetverbindung auf, etc.)
5. probier mal folgende /etc/network/interfaces

Quellcode

1
2
3
4
5
6
7
8
9
10
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
   address 192.168.0.100
   netmask 255.255.225.0
   network 192.168.0.0
   broadcast 192.168.0.255
   gateway 192.168.0.1
Es ist zwar nur eine kleiner Änderung aber evntl ist die Zeit auto lo eth0 nicht ganz richtig (ich weiss nicht, ob mein 2 Devices in einer Zeile angeben darf).
6. Post doch mal bitte die Ausgabe von "ifconfig", wenn Dein Netzwerk nicht geht und evntl. nochmal nachdem es geht.

Viele Grüße,
Wolfi

shangkai

Anfänger

  • »shangkai« ist der Autor dieses Themas

Beiträge: 13

Wohnort: KR

Beruf: techniker

  • Nachricht senden

8

Mittwoch, 16. März 2005, 10:05

Hallo Reiner,

netstat -rn gibt

media:~# netstat -rn
Kernel IP Routentabelle
Ziel Router Genmask Flags MSS Fenster irtt Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

aus.

Nachdem ich "route add default gw 192.168.0.1" eingegeben habe so

Kernel IP Routentabelle
Ziel Router Genmask Flags MSS Fenster irtt Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

oder liegt es an der /etc/host

### etherconf DEBCONF AREA. DO NOT EDIT THIS AREA OR INSERT TEXT BEFORE IT.

127.0.0.1 localhost
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

192.168.0.100 media.pc.de media

Gruß

Kai
Vdr im Aufbau YAVDR 0.6.1 GT730 MB ASRock J3710M TBS6905
Old VDR YARVDR 0.5.0 / GeForce 8400 GS / TT-premium S2-6400

9

Mittwoch, 16. März 2005, 10:23

Der netstat output sieht aus, als ob die /etc/network/interfaces einen Fehler hätte und die gateway Zeile ignoriert würde. Schau mal ob in der Datei irgendwelche (Windows) Sonderzeichen o.ä. drin sind und probier mal, ob wie von andreas_h beschrieben einen manuellen Restart des Netzwerks aus, um zu sehen, ob dabei was schief geht.

Gruß,
Reiner.
Frontend 1: Intel Atom D525, Digital Devices CineS2 DVB-S2 Karte, yaVDR 0.5.0a, vdr 2.0.6-6yavdr1
Frontend 2: SMT-7020S, zendeb-0.4.1-beta1, vdr 1.6.0-16ctvdr1 (e-tobi)
Backend: Athlon 2500+, Digital Devices CineS2 DVB-S2, ct-vdr 6, vdr 1.6.0-17ctvdr1 (e-tobi)

shangkai

Anfänger

  • »shangkai« ist der Autor dieses Themas

Beiträge: 13

Wohnort: KR

Beruf: techniker

  • Nachricht senden

10

Mittwoch, 16. März 2005, 10:28

Hallo Andreas,

networking start gibt aus

Setting up IP spoofing protection: rp_filter.
Configuring network interfaces...ifup: interface lo already configured
SIOCSIFNETMASK: Invalid argument
Failed to bring up eth0.

Hallo Wolfi,

1. Es ist ein Rooter,
2. ich habe den VDR komlett neu aufgespielt vorher hat es ohne Probleme funktioniert.
3. Sicher habe ich neu gebootet!
4. VDR ist direkt am Rooter angeschlossen und macht die vermittlung ins Internet.
5. Wenn ich eth0 wegnehme setze er die Netadress 127.0.0.1

ifconfig vor route

eth0 Protokoll:Ethernet Hardware Adresse 00:E0:18:FC:79:E6
inet Adresse:192.168.0.100 Bcast:192.168.0.255 Maske:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:718 errors:0 dropped:0 overruns:0 frame:0
TX packets:304 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:197105 (192.4 KiB) TX bytes:30131 (29.4 KiB)
Interrupt:20

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

if config nach route

eth0 Protokoll:Ethernet Hardware Adresse 00:E0:18:FC:79:E6
inet Adresse:192.168.0.100 Bcast:192.168.0.255 Maske:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:881 errors:0 dropped:0 overruns:0 frame:0
TX packets:407 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:1000
RX bytes:232715 (227.2 KiB) TX bytes:40571 (39.6 KiB)
Interrupt:20

lo Protokoll:Lokale Schleife
inet Adresse:127.0.0.1 Maske:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
Kollisionen:0 Sendewarteschlangenlänge:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)


Gruß

Kai
Vdr im Aufbau YAVDR 0.6.1 GT730 MB ASRock J3710M TBS6905
Old VDR YARVDR 0.5.0 / GeForce 8400 GS / TT-premium S2-6400

shangkai

Anfänger

  • »shangkai« ist der Autor dieses Themas

Beiträge: 13

Wohnort: KR

Beruf: techniker

  • Nachricht senden

11

Mittwoch, 16. März 2005, 10:56

Hallo Andreas, Hallo Wolfi,

also das Problem hat sich erledigt nach dem ich in der intrefaces mit WINSCP3 die netmask nur die 255.255.255.0 überschrieben habe ging es. Entweder habe Tomaten auf den Augen oder mann konnte den Fehler nicht sehen.

Danke für eure Hilfe

Kai

Never change a running system!
Vdr im Aufbau YAVDR 0.6.1 GT730 MB ASRock J3710M TBS6905
Old VDR YARVDR 0.5.0 / GeForce 8400 GS / TT-premium S2-6400

12

Mittwoch, 16. März 2005, 11:01

Zitat

also das Problem hat sich erledigt nach dem ich in der intrefaces mit WINSCP3 die netmask nur die 255.255.255.0 überschrieben habe ging es. Entweder habe Tomaten auf den Augen oder mann konnte den Fehler nicht sehen.


Klingt so, als ob sich ein Windows-Zeilenumbruch in eine Linux-Textdatei eingeschlichen hat. Deshalb nehme ich nur noch Editoren auf der Konsole.

Die Netzwerkeinstellungen kann man bei ct-VDR aber auch mit Dem Befehl

Quellcode

1
dpkg-reconfigure etherconf

anpassen. Aber ich weiß nicht, wie er damit klarkommt, wenn du schon manuell was an den Konfigurationsdateien geändert hast.

Bye, gabe!
VDR User #928 - Asus P5A * K6-2 450MHz * 256MB RAM * 160GB Samsung SV1604N * Nexus-S Rev2.2 * gepanschtes c't-VDR 3.06 & Tobi's Bigpatch Experimental & Kernel/Treiber c't-VDR 4

Immortal Romance Spielautomat