Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

take

Anfänger

  • »take« ist der Autor dieses Themas

Beiträge: 23

Wohnort: Hof/Saale (Bayern)

Beruf: IT

  • Nachricht senden

1

Dienstag, 18. Januar 2005, 00:24

Emergency Exit bei Timer?!? 1.3.17

Hallo zusammen und .... HILFE,

Hab ne Nexus-s (rev.2.2) und ne skystar2 (rev.2.3) unter Suse 9.2 (2.6.8-24.10-default) mit VDR 1.3.17unstable (MP3, MPlayer, DVD, burn, beep, remote, femon, AC3overDVB) und Das SuSE-eigene DVB-Treiberpack. Alles funktioniert prächtig, bis auf die Timer. (unter SuSE8.2 auch das.)

-> Erläuterung:
Starte Aufnahme ! ... ok.
Stoppe Aufnahme ! ... ok.
Setze Timer ! ... ok.
Timer startet ! ... ERROR: video data stream broken (-> emg.Exit)

Dann hilft nur noch ein Treiberreload (DVB) und VDR neu starten ! Alles wieder einwandfrei. (bis ...)

Das beste ist, manchmal funzt's, manchmal nicht! Finde nicht raus mit was es zu tun hat.

Bin am Verzweifeln.

*************************************

Hier noch der Ausschnitt aus den Messages:

Jan 17 06:37:11 vdr vdr[6602]: timer 4 added (active)
Jan 17 06:37:11 vdr vdr[6602]: timer 4 (4 0645-0650 'Die B344ren sind los') set to event Mit 19.01.2005 06:24-06:49 'Alvin und die Chipmunks'
Jan 17 06:45:00 vdr vdr[6602]: switching device 1 to channel 4
Jan 17 06:45:00 vdr vdr[6602]: timer 4 (4 0645-0650 'Die B344ren sind los') start
Jan 17 06:45:00 vdr vdr[6602]: Title: 'Alvin und die Chipmunks' Subtitle: '(null)'
Jan 17 06:45:00 vdr vdr[6602]: record /var/spool/video/Die_B344ren_sind_los/_/2005-01-17.06:45.50.99.rec
Jan 17 06:45:00 vdr vdr[6602]: creating directory /var/spool/video/Die_B344ren_sind_los
Jan 17 06:45:00 vdr vdr[6602]: creating directory /var/spool/video/Die_B344ren_sind_los/_
Jan 17 06:45:00 vdr vdr[6602]: creating directory /var/spool/video/Die_B344ren_sind_los/_/2005-01-17.06:45.50.99.rec
Jan 17 06:45:00 vdr vdr[6602]: recording to '/var/spool/video/Die_B344ren_sind_los/_/2005-01-17.06:45.50.99.rec/001.vdr'
Jan 17 06:45:00 vdr vdr[7166]: file writer thread started (pid=7166, tid=131079)
Jan 17 06:45:00 vdr vdr[7167]: recording thread started (pid=7167, tid=147464)
Jan 17 06:45:00 vdr vdr[7168]: receiver on device 1 thread started (pid=7168, tid=163849)
Jan 17 06:45:01 vdr vdr[7169]: TS buffer on device 1 thread started (pid=7169, tid=180234)
Jan 17 06:45:31 vdr vdr[7166]: ERROR: video data stream broken
Jan 17 06:45:31 vdr vdr[7166]: initiating emergency exit
Jan 17 06:45:32 vdr vdr[6602]: emergency exit requested - shutting down
Jan 17 06:45:32 vdr vdr[7167]: recording thread ended (pid=7167, tid=147464)
Jan 17 06:45:32 vdr vdr[7169]: TS buffer on device 1 thread ended (pid=7169, tid=180234)
Jan 17 06:45:32 vdr vdr[7168]: buffer stats: 0 (0%) used
Jan 17 06:45:32 vdr vdr[7168]: receiver on device 1 thread ended (pid=7168, tid=163849)
Jan 17 06:45:32 vdr vdr[7166]: file writer thread ended (pid=7166, tid=131079)
Jan 17 06:45:32 vdr vdr[6602]: buffer stats: 0 (0%) used
Jan 17 06:45:32 vdr vdr[6602]: timer 4 (4 0645-0650 'Die B344ren sind los') stop
Jan 17 06:45:32 vdr vdr[6602]: saved setup to /var/spool/video/setup.conf
Jan 17 06:45:32 vdr vdr[6604]: tuner on device 1 thread ended (pid=6604, tid=16386)
Jan 17 06:45:32 vdr vdr[6605]: Section handler thread ended (pid=6605, tid=32771)
Jan 17 06:45:32 vdr vdr[6606]: tuner on device 2 thread ended (pid=6606, tid=49156)
Jan 17 06:45:33 vdr vdr[6607]: Section handler thread ended (pid=6607, tid=65541)

******************************************

und die PCI-Infos aus lspci -vv

0000:00:13.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 01)
Subsystem: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 32
Interrupt: pin A routed to IRQ 5
Region 0: Memory at ed000000 (32-bit, non-prefetchable)
Region 1: I/O ports at 9800

0000:00:0c.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
Subsystem: Technotrend Systemtechnik GmbH Technotrend/Hauppauge DVB card rev2.1
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 32 (3750ns min, 9500ns max)
Interrupt: pin A routed to IRQ 10
Region 0: Memory at ee800000 (32-bit, non-prefetchable)

0000:00:0e.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Subsystem: C-Media Electronics Inc CMI8738/C3DX PCI Audio Device
Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping+ SERR- FastB2B-
Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 32 (500ns min, 6000ns max)
Interrupt: pin A routed to IRQ 11
Region 0: I/O ports at b800
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
Subsystem: Asustek Computer, Inc. A7V8X motherboard
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
Latency: 0
Region 0: Memory at fc000000 (32-bit, prefetchable)
Capabilities: [80] AGP version 3.5
Status: RQ=32 Iso- ArqSz=0 Cal=2 SBA+ ITACoh- GART64- HTrans- 64bit- FW- AGP3- Rate=x1,x2
Command: RQ=1 ArqSz=0 Cal=0 SBA- AGP- GART64- 64bit- FW- Rate=<none>
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-

**************************************

Alex. :§$%
vdr 1.3.18 - SuSE 9.2 (professional incl. dvb-kern) - 1xnexus-s - 1xskystar2 - duron 1400 - 256mb ram - asus k7v8x-x - ata100 platte

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »take« (19. Januar 2005, 16:46)


cooper

Erleuchteter

Beiträge: 4 478

Wohnort: Hannover/Eschwege

Beruf: Linux-Redakteur

  • Nachricht senden

2

Dienstag, 18. Januar 2005, 01:08

RE: Emergency Exit bei Timer?!? 1.3.17

Du hast Probleme mit deinem Sat-Signal/Kabel für deine zweite Karte oder der Karte selbst (Tuner, was auch immer).

VDR startet neu, weil er auf diesem Kanal keine Video-Daten von der zweiten Karte bekommt.

Viele Grüße, Mirko
LinVDR - The Digital Linux Videorecorder ................................................................. http://linvdr.org

take

Anfänger

  • »take« ist der Autor dieses Themas

Beiträge: 23

Wohnort: Hof/Saale (Bayern)

Beruf: IT

  • Nachricht senden

3

Dienstag, 18. Januar 2005, 08:15

RE: Emergency Exit bei Timer?!? 1.3.17

Danke für den Tip, aber da muss ich an einer anderen Stelle suchen, denn:

- wenn ich nach dem emg.Exit die DVB-Treiber händisch kille (skystar2, ttpci, dvb-core,...) dann kann ich problemlos (ruckelfrei und ohne Fehler) Aufnehmen/Auf beiden Karten aufnehmen, 4xAufnehmen auf 2 Transpondern und nen anderen Sender sehen.

- hab auch mal PLUGIN::FEMON eincompiliert, Signallevel minimum 68.

- hab mal ne nacht lang mit ksysguard den PCI-In/Out Pages zugesehen. Alles Einwandfrei.

- Wenn die Aufnahme im Hintergrund auf dem 2. Transponder stattfindet, läuft (meistens) auch alles ohne Absturz.


-------

Zufällig bin ich über einen Threat gestolpert, in dem die Meinung besteht, das die zweite Karte nicht schnellgenug Initialisiert ist (Lock obwohl 0bit)... ABER:

- Erhöhe ich den sleeptimer für LOCK auf 200-300ms. -> auch absturz, nur nicht so häufig.

-------

Ansonsten läuft die Kiste einwandfrei. (War auch langgenug damit beschäftigt.)
Schade dass ich nun mit so ner kleinigkeit probleme hab.

-------

!!!!!!!!!! Hä?
Mir ist gerade aufgefallen, wenn ich die Aufnahme händisch anschmeisse (z.B. Timeshift, Direktaufnahme) stürzt er net weg.

Nur bei Timerstart!!!

-------

Evtl. fällt dir noch was ein...


Gruß Alex.
vdr 1.3.18 - SuSE 9.2 (professional incl. dvb-kern) - 1xnexus-s - 1xskystar2 - duron 1400 - 256mb ram - asus k7v8x-x - ata100 platte

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »take« (18. Januar 2005, 08:18)


cooper

Erleuchteter

Beiträge: 4 478

Wohnort: Hannover/Eschwege

Beruf: Linux-Redakteur

  • Nachricht senden

4

Dienstag, 18. Januar 2005, 08:58

RE: Emergency Exit bei Timer?!? 1.3.17

Servus,

benutzt du evtl. eine PCI-Riser-Card?

Viele Grüße, Mirko
LinVDR - The Digital Linux Videorecorder ................................................................. http://linvdr.org

take

Anfänger

  • »take« ist der Autor dieses Themas

Beiträge: 23

Wohnort: Hof/Saale (Bayern)

Beruf: IT

  • Nachricht senden

5

Dienstag, 18. Januar 2005, 10:31

RE: Emergency Exit bei Timer?!? 1.3.17

NO!

Zur Hardware:

Prozessor: AMD Duron 1400 (64kb l1, 64kb l2)
Speicher: 2x Infineon DDR 256MB, 266MHz

Mainboard: ASUS K7V8X-X LE
- 2x IDE (ATA)
- USB, FireWire, Parport, Serial1, Via Sound, Lan - Onboard (Sound deaktiviert)
- AGP
- 6x PCI (Slot 1/5 2/6 - Irq sharing)
-- 1 - Haupauge Nexus-S
-- 2 - Frei (Cooler)
-- 3 - CMI8738-MC6 soundcard
-- 4 - Skystar2
-- 5 - Frei (soundcard slotblech SP/Dif)
-- 6 - Frei

-----------

Ausgabe von lspci:

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge
0000:00:0c.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
0000:00:0e.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
0000:00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
0000:00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
0000:00:13.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 01)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

------

Fällt dir dazu was ein?

Alex.
vdr 1.3.18 - SuSE 9.2 (professional incl. dvb-kern) - 1xnexus-s - 1xskystar2 - duron 1400 - 256mb ram - asus k7v8x-x - ata100 platte

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »take« (18. Januar 2005, 21:08)


6

Freitag, 4. Februar 2005, 21:40

Hi,
ich hab das gleiche Problem mit der CT-vdr Distribution. Es tritt erst auf, seit dem ich die 2te Karte eingebaut habe. Nach exakt 31 Sekunden Aufnahme startet der Vdr automatisch neu. Das passiert, wie beschrieben, nur bei Timer aufnahmen. Und nicht immer...
Denke mir also kaum, dass es an der Signalqualität liegt, obwohl das im syslog steht. Währe ja seltsam, dass es immer nach 31 sec. passiert?? Wie kann man denn weiter debuggen, wenn syslog und messages nichts mehr her gibt?


Feb 4 20:41:00 tvbox vdr[1482]: recording to '/var/lib/video.00/TVTV+Fernsehfilm/...
Feb 4 20:41:00 tvbox vdr[4080]: recording thread started (pid=4080)
Feb 4 20:41:00 tvbox vdr[4084]: receiver thread started on device 2 (pid=4084)
Feb 4 20:41:31 tvbox vdr[4080]: ERROR: video data stream broken
Feb 4 20:41:31 tvbox vdr[4080]: initiating emergency exit
...

Asus board PIV mit nexus und skystar
yaVDR 0.5.0alpha1
ASRock G41M-GS3, Intel(R) Celeron(R) CPU 440 @ 2.00GHz (35W TPD), 2x GSkill 2GB,
Cine S2 V6 , Pali GT520 1GB DDR3,
SSD 40GB + HDD SATAII 2TB , Silverstone Desktop (3x120mm), Hama Mediacenter FB

7

Freitag, 4. Februar 2005, 21:47

ich würd NOCHMAL ganz genau die Sat-Kabel Stecker prüfen.

Ich hab lange zeit genau das selbe problem gehabt und bin draufgekommen dass ein kleines stück schirmdraht den inneren leiter berührt hat (kam durch das ein- und ausbaun der dvb karten)

seitdem ich die kabel sorgfältig geprüft hab hab ich nie wieder probleme damit gehabt.

gruß
cosmo
VDR-Version: 1.3.29
Plugins: TVONSCREEN, OSDTELETEXT, STATUSLEDS, DVD, MP3
Betriebssystem: SUSE 9.3
PC: Pentium 2,8GHz, 512MB, 2 x 160GB HDD SAMSUNG
DVB: 2 x Nexus-S, 1 x Nova, Quad LNB, 85cm Schüssel
BILDER: vom VDR

take

Anfänger

  • »take« ist der Autor dieses Themas

Beiträge: 23

Wohnort: Hof/Saale (Bayern)

Beruf: IT

  • Nachricht senden

8

Dienstag, 8. Februar 2005, 13:18

Schirmdraht ist in Ordnung

Hab die stecker durchgemessen (BEIDE Katen!!!) ...
(Unendliche Ohm - OK -)

Nein, der Fehler tritt in meinen Augen häufiger auf Sendern der RTL serie auf, als auf sendern der PROSiebenSat1Media AG. Das ist mir auch aufgefallen.

Hatte mir ein Script zusammengebaut das ich über die Kommandozeile mit -r aufgerufen hab, das den VDR vor der Wiedergabe beendet, szap kurz startet (ca.3 sec. ) und den VDR wieder Startet wenn T=1 und dann T=0 gesetzt hat. Damit gibt es dann keine Probleme bei der Aufnahme mehr. ABER:
- Unsauber
- 30 Sekunden bildausfall.

ERGO:
Skystar2 ist schuld. Wird anscheinend wirklich nicht lang genug initialisiert.
-> Lock auf RTL dauert meistens 3 sek.
-> Lock auf PRO7 dauert nur 2.

ALSO:
Die VDR-Bin müsste der Skystar2 mehr zeit geben, um zu initialisieren.


Hat jemand ne Idee?

Brauch noch immer hilfe!!!
vdr 1.3.18 - SuSE 9.2 (professional incl. dvb-kern) - 1xnexus-s - 1xskystar2 - duron 1400 - 256mb ram - asus k7v8x-x - ata100 platte

9

Dienstag, 1. März 2005, 12:43

SS2 Problem

Hallo,

auch ich bin von diesem Problem betroffen. Auf den Seiten hier habe ich schon vieles gelesen, und auch viele Ratschlaege ausprobiert. Leider hat nur eine Sache wirklich Wirkung gezeigt. Schaltet man den EPG-Scan aus, resetet vdr bei der Aufnahme so gut wie nicht mehr. Klar, man kann auch die SS2 ausbauen, dann laeuft alles anstandslos. Die channels.conf muss natuerlich auch sauber sein. Hier eine Liste der Sachen, die ich getestet habe, und die nicht die erhoffte Wirkung zeigten:

- Antennenkabel durchgemessen / Diseqcs getauscht.
- Staerkeres Netzteil eingebaut
- Rechner getauscht / Platten getauscht ( mit und ohne RAID 0)
- Schuessel nachjustiert
- verschiedenste channels.conf Eintraege ausprobiert
- vdr Versionen 1.2.6 bis 1.3.22 ausprobiert!!
- alle Plugins weggelassen
- Kernels 2.4.24, 2.4.27, 2.6.8, 2.6.9, 2.6.10 ausprobiert

Es hat alles nichts geholfen! Wenn man euch also Ratschlaege hier gibt, dann sind diese, in meinen Augen mit Vorsicht zu geniessen. Nach meiner Kenntnisslage ist dieses Problem bisher nicht zufriedenstellend mit einer SS2 geloest (bis auf EPG-Scan ausschalten). Ich bin jetzt soweit, dass ich mir eine andere Budgen-Karte kaufe. Ich habe die Schnauze voll!

P.S.: was mich auch noch aergert ist die channels.conf. Scan oder dvbscan liefert bei mir Muell (eigentlich in allen bisher tetesten Versionen), das Ergebnis muss man von Hand nachbearbeiten, und brauchbare und aktuelle chennels.conf fuer meine Sat-Anlage (Astra+Hotbird+Sirius+Amos) finde ich nirgendwo. Meine channels.conf habe ich muehsam von Hand gestrickt, und neue/geaenderte Frequenzen pflege ich manuell ein (Quelle: satcodx.com)

Ich finde es beneidenswert, wenn Leute sich ueber irgendein Plugin-Problem aergern, wenn bei mir nicht einmal nach monatelangen Versuchen das Minimalsystem sauber laeuft.

cooper

Erleuchteter

Beiträge: 4 478

Wohnort: Hannover/Eschwege

Beruf: Linux-Redakteur

  • Nachricht senden

10

Dienstag, 1. März 2005, 14:04

RE: SS2 Problem

Servus,

Zitat

P.S.: was mich auch noch aergert ist die channels.conf. Scan oder dvbscan liefert bei mir Muell (eigentlich in allen bisher tetesten Versionen), das Ergebnis muss man von Hand nachbearbeiten

Hast du schon mal die automatische Scan-Funktion von VDR ausprobiert? Funktioniert zuverlässig, ohne Handarbeit und ohne Neustart von VDR. Schalte das mal für zwei oder drei Tage ein, dann hat er auch die letzten Sender auf deinen Satelliten gefunden.

Viele Grüße, Mirko
LinVDR - The Digital Linux Videorecorder ................................................................. http://linvdr.org

take

Anfänger

  • »take« ist der Autor dieses Themas

Beiträge: 23

Wohnort: Hof/Saale (Bayern)

Beruf: IT

  • Nachricht senden

11

Dienstag, 1. März 2005, 14:08

RE: SS2 Problem

Hallo zusammen....

... MUSS MICH ENTSCHULDIGEN ...

Hab irgendwie verpennt, dass dieser Treat überhaupt noch existiert...

Inzwischen diskutieren wir das selbe Thema unter:

http://www.vdr-portal.de/board/thread.php?sid=&postid=273905

Sind auch schon nah an einem annehmbaren Zustand...
vdr 1.3.18 - SuSE 9.2 (professional incl. dvb-kern) - 1xnexus-s - 1xskystar2 - duron 1400 - 256mb ram - asus k7v8x-x - ata100 platte

12

Dienstag, 1. März 2005, 14:17

RE: SS2 Problem

Danke fuer die Antwort,

aber natuerlich habe ich die automatische Scanfunktion ausprobiert, leider funktioniert da garnichts zuverlaessig. Vdr scannt nur die Transponder, die in der channels.conf auch drin sind. Wechselt ein Sender den Transponder, und ist dieser nicht in der Liste, findet vdr auch nichts.

sdu

Meister

Beiträge: 2 605

Wohnort: Vorarlberg / Österreich

  • Nachricht senden

13

Dienstag, 1. März 2005, 14:20

RE: SS2 Problem

Zitat

Original von acmelabs
Danke fuer die Antwort,

aber natuerlich habe ich die automatische Scanfunktion ausprobiert, leider funktioniert da garnichts zuverlaessig. Vdr scannt nur die Transponder, die in der channels.conf auch drin sind. Wechselt ein Sender den Transponder, und ist dieser nicht in der Liste, findet vdr auch nichts.


bist du dir sicher ? - also bei mir funktionierts - hast du die Einstellung - neue Transponder hinzufügen - ausprobiert ? - und nimm dir etwas Zeit - es dauert ein bischen :)
Gruß

sdu

*******************************************************************
gen2vdr 2.0
TT1.3, Skystar 2.6c, activy300, STBs AVBoard
*******************************************************************

14

Mittwoch, 2. März 2005, 09:02

RE: SS2 Problem

Hi,
ja, in der Tat, unter 1.3.x funktioniert das. Leider macht autopid und/oder vdr-scanner nur probleme, aber unter 1.2.6. Ich muss wohl oder uebel auf 1.3.x umsgteigen.

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

15

Mittwoch, 2. März 2005, 11:06

RE: SS2 Problem

Zitat

Original von acmelabs
... (Astra+Hotbird+Sirius+Amos) finde ich nirgendwo. Meine channels.conf habe ich muehsam von Hand gestrickt, und neue/geaenderte Frequenzen pflege ich manuell ein (Quelle: satcodx.com)....


Woher bekommst Du daten von ASTRA?
8o

Gruß

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

16

Mittwoch, 2. März 2005, 14:28

RE: SS2 Problem

Astrafrequenzen sind generell kein Problem, diese sind standardmaessig bei den dvb-utils als bsp mit dabei, bei der vdr-installation sowieso - nur meistens nicht aktuell. (irgendwo/szap/channels.conf-dvbs-astra). Willst du unter 1.2.6 eine aktuelle haben, kannst Du z.B. hier http://www.zwez.com/sat/vdr/index.html eine realtiv aktuelle bekommen. Und realativ ist hier sehr dehnbar. Eine Liste, die knapp einen Monat alt ist, bekommt man hier: http://www.dxandy.de/cgi-bin/dvbchan.pl. Hier kann man sich sogar mehre Satelliten zusammenstellen lassen. Wenn Du keinen Wert auf EPG-Daten legst (also ich schon), kannst du auch scan alias dvbscan verwenden. Ein Problem bleibt, hat man seine channels.conf ein Mal muehsam sortiert, muss man bei jeder neuen channels.conf, die von 'aussen' kommt eine erneute manuelle Sortierung vornehmen. Funktioniert also dein autopid oder/und den vdr-scanner unter 1.2.6 nicht richtig, hast du wirklich schlechte Karten an eine gute channels.conf zu kommen, und diese ist nicht nach deinen Vorstellungen sortiert. Das Sortierproblem habe ich fuer mich durch ein kleines C-Programm geloest. Dabei werden alle Eintraege aus der sortierten channels.conf durch die Eintraege in der aktuellen channels.conf ersetzt, die Reihenfolge bleibt also erhalten.

Ein kleines akw-script tuts auch fuer den Anfang:

Aufruf:
#awk -f datei.awk sortierte.conf

datei.awk:

BEGIN { FS=":"}
{
"grep \"^"$1":\" unsortierte.conf" | getline x ;
if ( $0 == x ) { print "ORG :" $0 };
if ( $0 != x ) { print "NEU :" x };
}

rudibert

Fortgeschrittener

Beiträge: 247

Wohnort: gebürtig ganz im Norden, Wohnort in Spanien

Beruf: Informatiker

  • Nachricht senden

17

Mittwoch, 2. März 2005, 17:21

@take
Auf: Möglicher Workaround für Skystar2 "Einschlafen" scheint man der Lösung des Problems für die SS2 wirklich nah zu sein! :]

@acmelabs
Kanalscannen benutze ich nicht, weil dachte das geht erst ab 1.3 ;( ..und selbstredend sind mir EPG-Daten wichtig (vdradmin!) außerdem:
  • Dein 2ter link scheint out zu sein :(
  • das script hört sich interessant an; aber was ist awk?
?(

Mein VDR

Kubuntu-64bit (vdr2.0 seit 8/2014),MS-7358-Medion-PC mit kabellosen Tastaturen, 6GB RAM, TT 1.6 + SkyStar2.3 — USV-Betrieb (ausgeschaltet ~5W, startbereit über acpi-wakeup)
wenn doch bei
Rudibert........ nur alles so zuverlässig liefe, wie der VDR...

Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von »rudibert« (2. März 2005, 17:47)


Immortal Romance Spielautomat