You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

Accom

Beginner

Posts: 46

Location: Schweiz

Occupation: Systems Engineer

  • Send private message

301

Thursday, February 12th 2009, 8:18am

Hallo TheChief

Gerne, ich bin zwar etwas weiter aber die FB läuft noch nicht zufriedenstellend.
Was hast du auf der FB (Logitech Harmony Remote Software) für ein Gerät eingestellt ?
(Ich habe seinerzeit nach Zalmann gesucht, gibt es ein Thermaltake)

Gruss
Thomas
P5E-V HDMI, 4GB Ram, 60GB SSD & 500 GB HDD, DVD-Brenner, Salteco, Asus Bravo 220
Debian Squeeze, VDR e-Tobi

302

Thursday, February 12th 2009, 8:52am

Oh, da müsst ich heute abend mal nachschauen. Aber ich bin der Meinung, ich habe irgendwas von Soundgraph iMon eingestellt.

Grüsse
TheChief
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.6/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

303

Saturday, February 14th 2009, 1:42pm

Hoi Leute,

falls ihr mit ner Harmony und dem DH102 kämpft:

Habe sie jetzt zufriedenstellend am Laufen:
Habe folgendes Gerät eingestellt:
Media-PC-> Thermaltake -> DH-102

ich habe allerdings die Tasten etwas umbelegt, da das Steuerkreuz bei mir nicht vernünftig reagiert hat (wiederholfrequenz mal zu langsam mal zu schnell)
Die Codes vom Kreuz habe ich dann einfach für weniger wichtige Befehle :USER6,7,8,9 genutzt.

PS: Die lirc.conf hab ich hier aus dem Thread....


Und so habe ich die Tasten zugeordnet:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
Stumm	Mute(Stumm)
Lauter	Volume UP(Lauter)
Leiser	VolumeDown(Leiser)
Rot	Red(Rot)
Grün	Green/grün)
Gelb	Yellow
Blau	Blue
Kanal-	ChannelDown
Kanal+	ChannelUp
Prev	Backspace
Oben	TaskSwitcher
Unten	Menu(DropDown)
Links	Left(links)
Rechts	Right(Rechts)
OK	Select(Aswählen)
Menü	Menu(Windows)
Beenden	Backspace
Verzeichnis	Thumbnail
Info	Timer(Zeitgeber)
Stopp	Stop(Stopp)
Skip Back	Skip Back (zurückspringen)
Springen vorwärts	Skip Forward (Vorspringen)
Wiedergabe 	Play (wiedergabe)
Aufnahme	Record (Aufnahme)
Zurückspulen	Rewind (Zurückspulen)
Schneller Vorlauf	FastForward (Schneller Vorlauf)
Pause	Pause
1	1
2	2
3	3
4	4
5	5
6	6
7	7
8	8
9	9
Plus	Open/Close(Öffnen/Schließen)
0	0
E	Enter (Eingabe)
	
	
Ein-/Ausschalten	Power
Channels	Eject (Auswerfen)
Recordings	AppLauncher
Timers	AppExit
Setup	Aspect(Seitenverhältnis)
Commands	Bookmark(Lesezeichen)
USER1	Caption(Untertitel)
USER2	Computer
USER3	Escape
USER4	FullScreen
USER5	Language
USER6	DirectionLeft(Nach links)
USER7	DirectionUp(Nach oben)
USER8	DirectionRight(Nach rechts)
USER9	DirectionDown(Nach unten)
Mouse/Keyboard	Mouse/Keyboard
VDR1: AMD Athlon X2 5050e ASUS M4N78PRO | Debian Squeeze 64Bit + Asus ENGT520 SILENT + vdr-2.0 | Tuner: 2 cinergy DVB-C, Nova-HD, DD cine S2 | Gehäuse: Thermaltake DH-102
VDR2: AMD Athlon X2 5050e ASUS M4N78PRO | Debian Squeeze 64Bit + Asus ENGT520 SILENT + vdr-2.0 | Tuner: DD cine S2, Nova-HD

S100: Zendeb 0.4.1beta VDR als streamdev-client

This post has been edited 2 times, last edit by "p_body" (Feb 14th 2009, 6:10pm)


304

Monday, February 16th 2009, 3:56pm

Kernel 2.6.28.2

Hallo Zusammen!

ich muste auf den Kernel 2.6.28.2 wechseln, ond stellte fest dass imontouch mit diesem nicht zurechtkommt
Hier der Auszug aus dmesg:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
[    5.913789] lirc_dev: IR Remote Control driver registered, major 61
[    5.914735] lirc_imontouch: Driver for Soundgraph iMON Touchscreen and Remote Control iMON PAD, v0.1b
[    5.914825] lirc_imontouch: Rene Harder <rehar@saweb.de>
[    5.914891] lirc_imontouch 4-1:1.0: usb_probe_interface
[    5.914892] lirc_imontouch 4-1:1.0: usb_probe_interface - got id
[    5.914894] lirc_imontouch: imontouch_probe: found IMON device, 0. interface
[    5.914953] BUG: unable to handle kernel paging request at 32303a58
[    5.915049] IP: [<f8c06b99>] imontouch_probe+0x2a6/0x66d [lirc_imontouch]
[    5.915125] *pde = 00000000
[    5.915193] Oops: 0000 [#1] SMP
[    5.915277] last sysfs file: /sys/devices/pci0000:00/0000:00:02.0/drm/card0/dev
[    5.915363] Modules linked in: lirc_imontouch(+) lirc_dev
[    5.915468]
[    5.915516] Pid: 1047, comm: modprobe Not tainted (2.6.28.2 #4) System Product Name
[    5.915603] EIP: 0060:[<f8c06b99>] EFLAGS: 00010206 CPU: 0
[    5.915659] EIP is at imontouch_probe+0x2a6/0x66d [lirc_imontouch]
[    5.915715] EAX: 32303a30 EBX: f6c2d000 ECX: 00000246 EDX: 00000246
[    5.915771] ESI: f651d01c EDI: f8c084b8 EBP: f6031d74 ESP: f6031d38
[    5.915827]  DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
[    5.915883] Process modprobe (pid: 1047, ti=f6030000 task=f6000a00 task.ti=f6030000)
[    5.915969] Stack:
[    5.916018]  f601a450 f651d000 00031d48 c049d52e f6da0400 f6d44ac8 f651d000 f651d01c
[    5.916044]  f8c084b8 f6031d64 c049d714 f6031d98 f651d000 f651d01c f8c084b8 f6031d98
[    5.916044]  c049e3a6 f8c0844c f6da0400 00000000 f8c08480 f651d01c 00000000 f8c08480
[    5.916044] Call Trace:
[    5.916044]  [<c049d52e>] ? usb_pm_unlock+0xd/0xf
[    5.916044]  [<c049d714>] ? usb_autoresume_device+0xd/0xf
[    5.916044]  [<c049e3a6>] ? usb_probe_interface+0x131/0x15f
[    5.916044]  [<c0402633>] ? driver_probe_device+0xa0/0x11b
[    5.916044]  [<c04026fa>] ? __driver_attach+0x4c/0x6b
[    5.916044]  [<c0402072>] ? bus_for_each_dev+0x3b/0x5d
[    5.916044]  [<c04024d8>] ? driver_attach+0x14/0x16
[    5.916044]  [<c04026ae>] ? __driver_attach+0x0/0x6b
[    5.916044]  [<c0401b30>] ? bus_add_driver+0x97/0x1a7
[    5.916044]  [<c04028ff>] ? driver_register+0x71/0xcd
[    5.916044]  [<c02b8154>] ? sysfs_ilookup_test+0x0/0x11
[    5.916044]  [<c049dcb0>] ? usb_register_driver+0x66/0xc0
[    5.916044]  [<f7efe000>] ? imontouch_init+0x0/0x5e [lirc_imontouch]
[    5.916044]  [<f7efe03a>] ? imontouch_init+0x3a/0x5e [lirc_imontouch]
[    5.916044]  [<c0201130>] ? _stext+0x48/0x108
[    5.916044]  [<c02608ae>] ? get_pageblock_migratetype+0x1f/0x22
[    5.916044]  [<c0279cc5>] ? PageSlab+0xf/0x11
[    5.916044]  [<c0271198>] ? __vunmap+0x86/0x8e
[    5.916044]  [<c02711e9>] ? vfree+0x25/0x27
[    5.916044]  [<c02442ab>] ? load_module+0x12f9/0x149e
[    5.916044]  [<f7fe9bd2>] ? lirc_register_plugin+0x0/0x3da [lirc_dev]
[    5.916044]  [<c0244722>] ? sys_init_module+0x87/0x17d
[    5.916044]  [<c0203a3e>] ? syscall_call+0x7/0xb
[    5.916044]  [<c0610000>] ? _write_lock_bh+0x1a/0x1e
[    5.916044] Code: 68 7c 75 c0 f8 e8 66 f3 61 c7 8b 55 e0 89 5a 28 8b 45 d0 e8 cd 18 63 c7 83 c4 0c e9 9c 00 00 00 8b 43 28 85 c0 0f 84 88 00 00 00 <ff> 70 28 89 de 68 ac 6f c0 f8 68 ba 75 c0 f8 e8 31 f3 61 c7 31
[    5.916044] EIP: [<f8c06b99>] imontouch_probe+0x2a6/0x66d [lirc_imontouch] SS:ESP 0068:f6031d38
[    5.919845] ---[ end trace 801d9f768c187b42 ]---
[    5.919925] modprobe used greatest stack depth: 6152 bytes left


Leider hab ich noch keine Erfahrung in kernel bzw. Treiberprogrammierung. hat jemand eine Idee wo ich am besten mit der Suche anfange?

Grüsse und btw: danke für den genialen Treiber!

t-cp

305

Tuesday, February 17th 2009, 8:01am

Hallo

So puenktlich zum 1. LIRC-Prerelease habe ich es endlich geschaft den Treiber an die zahlreichen Aenderungen im LIRC Project anzupassen.

Grosse Neuerungen gibt es leider noch nicht, Ich hab jetzt jedoch den Treiber fuer das 4.3" Display der iMON Touch Serie erweitert (15c2:0035), dies ist jedoch noch als sehr experimentell anzusehen.

Das Prerelease mit imontouch Treiber findet ihr hier lirc-0.8.5pre1-imontouch-0.2.1.tar.gz und den Patch fuers CVS als Attachment.

@t-cp
Teste doch bitte mal diese Treiberversion, es sind im aktuellen LIRC CVS diverse Korrekturen fuer neuere Kernel enthalten. Ich hatte selber noch keine Gelegenheit ihn mit dem 2.6.28er Kernel auszuprobieren.

Bis Dahin
Rene
rehar has attached the following file:

306

Tuesday, February 17th 2009, 8:45am

Gibts noch irgendwo ne Anleitung für graphtft? Konnte das Plugin noch nich dazu überreden, die kalibrierung zu starten.
- VDR: Thermaltake DH 102 mit 7" TouchTFT * Mystique SaTiX-S2 Dual * Debian Wheezy/vdr-2.1.6/graphtft/MainMenuHooks-Patch * Intel Pentium G3220 * DH87RL * Zotac GT630 * 1 TB System HDD * 4 GB Corsair Vegance * Harmony 900 (39-44W)
- Server: Zotac H55-ITX WiFi, Core i3 540, 4GB RAM, 4x4TB 3.5" WD RED + 1x500GB 2.5", Cine S2, vdr-2.1.6
- vdr-theme-darkred: https://github.com/TheChief79/vdr-theme-darkred

307

Tuesday, February 17th 2009, 2:56pm

Ich steh auf m Schlauch... Und ehrlich gesagt, verstehe ich den Zusammenhang auch nicht mehr... Da ich eigentlich auch ein anderes Gehäuse hab, also kein thermaltake dh102, könnt ich natürlich auch einen anderen thread auf machen. Nur ich dachte, da sich hier die ganze Patche tummeln - frag ich einfach mal in die Runde:

ich hab n Gehäuse (http://www.inter-tech.de/Deutsch/Produkt…08Tschwarz.pdf mit imon pad und möcht da vor allem gern den ir empfänger nutzen (sofern das geht) und die Knöpfe am Gehäuse belegen. Ich hab da allerdings noch ein Treiberproblem und wohl auch so ein kleines Verständnisproblem.

Erst einmal: Ich nutze easyvdr mit dem Heino-image mit Kernel-2.6.28.1.
Mein lsusb zeigt folgendes an:

Source code

1
2
3
4
5
Bus 004 Device 001: ID 1d6b:0001
Bus 003 Device 002: ID 15c2:0035 SoundGraph Inc.
Bus 003 Device 001: ID 1d6b:0001
Bus 002 Device 001: ID 1d6b:0002
Bus 001 Device 001: ID 1d6b:0002


Also in
http://codeka.com/forums/viewtopic.php?f=3&t=84
wird davon gesprochen, dass usbhid den Soundgraph blockiert. Wenn ich meine Ausgabe von

Source code

1
cat /proc/bus/usb/devices
vergleiche, kann das wohl stimmen:

Source code

1
2
3
4
5
6
7
8
T:  Bus=03 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=15c2 ProdID=0035 Rev= 0.03
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=02 Driver=usbhid
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=10ms

Daher hab ich so ähnlich wie hier beschrieben wird:

http://xbmc.org/forum/showthread.php?t=40290

versucht, dass in der Ausgabe bei "Driver" "none" steht. Aber ohne Erfolg. Erst wenn ich usbhid entlade, steht da none.
Lirc hab ich aus dem cvs noch mal gezogen. Auch versucht zu patchen, gab allerdings hunks... Wenn ich lirc dann mit lirc_imon konfiguriere (also der Eintrag Soundgraph imon Pad IR/VFD) und auch make und make install ausführe, erhalte ich folgnede lirc-devices:

Source code

1
2
3
4
easyVDR:/usr/local# ls -l /dev/lirc*
crw-r--r-- 1 root root 61, 0 2009-02-12 08:56 /dev/lirc
srw-r--r-- 1 root root     0 2009-02-12 09:38 /dev/lircd
prw-r--r-- 1 root root     0 2009-02-12 08:56 /dev/lircm

allerdings geht mode2 nach laden des lirc_imon Moduls noch nicht mal:

Source code

1
2
3
easyVDR:/usr/local# mode2
mode2: could not open /dev/lirc
mode2: default_init(): No such device

Folgende Module sind geladen:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
easyVDR:/usr/local# lsmod
Module                  Size  Used by
usbhid                 34592  0
ipv6                  242420  24
nvidia               7219960  28
agpgart                34888  1 nvidia
lirc_imon              16264  0
lirc_dev               12852  1 lirc_imon
kbtab                   4992  0
eeprom                  6416  0
i2c_viapro              8852  0
dm_snapshot            18980  0
dm_mirror              14720  0
dm_region_hash         12160  1 dm_mirror
dm_log                 10756  2 dm_mirror,dm_region_hash
dm_mod                 52548  3 dm_snapshot,dm_mirror,dm_log
tda10023                7684  0
ves1820                 7044  0
i2c_core               25108  5 nvidia,eeprom,i2c_viapro,tda10023,ves1820
snd_hda_intel         398512  0
firewire_ohci          23940  0
firewire_core          38560  1 firewire_ohci
snd_pcm_oss            38400  0
snd_mixer_oss          15488  1 snd_pcm_oss
snd_pcm                73988  2 snd_hda_intel,snd_pcm_oss
snd_timer              21640  1 snd_pcm
snd_page_alloc          9864  2 snd_hda_intel,snd_pcm
snd_hwdep               8196  1 snd_hda_intel
pcspkr                  3456  0
ohci1394               31152  0
snd                    54052  6 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_hwdep
k8temp                  5248  0
ieee1394               86084  1 ohci1394
shpchp                 32788  0
pci_hotplug            28960  1 shpchp
forcedeth              55696  0
soundcore               8288  1 snd
wmi                     7720  0
joydev                 10432  0
evdev                  10528  0

Auch wenn ich den usbhid entlade, lirc-devices mit make install neu erstelle und lirc_imon lade und dann versuche mode2 auszuführen, bekomme ich die obige Meldung.

Nach einem Neustart sind nur folgende lirc-device da:

Source code

1
2
3
easyVDR:~# ls -l /dev/lir*
lrwxrwxrwx 1 root root 10 2009-02-12 12:32 /dev/lirc -> /dev/lirc0
srw-rw-rw- 1 root root  0 2009-02-12 11:32 /dev/lircd


Hm... Was hat ich noch gemacht ? Ich hab die Datei /etc/modprobe.d/usbhid mit folgendem Eintrag erstellt:

Source code

1
options usbhid quirks=0x15c2:0x0035:0x0004


In einer anderen Doku (von easyvdr) hab ich gelesen, dass das Script lirc_on_imon auch folgendermaßen angepasst werden soll:

Source code

1
2
3
#$NICEHIGH lircd --device=/dev/lirc0 -L $LOGPATH$SCRITPNAME.log
$NICEHIGH  lircd --driver=default --device=/dev/lirc0 --pidfile=/var/run/lirc0.pid --listen=8765
$NICEHIGH lircd --driver=default --device=/dev/lirc1 --pidfile=/var/run/lirc1.pid --output=/dev/lircd --connect=localhost:8765

Hab ich zwar gemacht, aber ich weiß nicht mal, ob das irgendeiner Stelle überhaupt genutzt wird. Ich hab zwar gelesen, dass bei dem pad wohl zwei Devices angelegt werden müssten (bei mir wird ja nicht mal ein device angelegt), aber ob dies Script irgendwo ausgeführt wird oder ich diese Befehle manuell ausführen müsste, weiß ich leider nicht. Da es ja eben auch zwei Devices geben soll, hab ich schon überlegt, ob ich in der usbhid vielleicht einen anderen Wert wie 0035 hätte angeben müssen. Aber das ist der Wert, der mir über lsusb angezeigt wird...

Da ich mit mode2 ja nicht mal eine Ausgabe hinbekomme, also das Programm nicht mal auf lirc zugreifen kann, vermute ich mal, dass da erst mal der Wurm drin ist. Ich weiß nur nicht, wie ich da jetzt am besten vorgehe. Und ganz genau, weiß ich auch nicht, wofür was ist... Kenne lirc sonst nur in Zusammenhang mit dem seriellen Port und da ist das ja recht einfach. Muss ich den Soundgraph erst vom usbhid trennen ?

Zu meiner Verständnisfrage:
Und müsste dann der ir Empfänger vom imon pad Signale empfangen, wenn der lirc_imon geladen wurde und ich Tasten auf der dazugehörigen FB drücke? Oder würden dann nur die Knöpfe funktionieren ?
Und vor allem: welchen Treiber muss ich beim setup von lirc auswählen ? Und wozu ist das Script lirc_on_imon ? Brauch ich das dafür ?
Und welchen Treiber muss ich unterm setup von lirc überhaupt nutzen ? Mulitmedian ? imon pad ? (Ich hab übrigens in den lirc-sourcen auch kein autogen.sh gefunden... Falls das wichtig ist.)

Muss ich irgendeinen patch noch anpassne, da mein device ja 0035 ist.

Da es ja unter Umständen auch eben am Kernel 2.6.28 liegen könnte, teste ich das sonst auch gerne mal mit Kernel 2.6.22 oder so (oder welhcer auch immer auf der easyvdr live cd ist), allerdings würd ich vorher gerne wissen, welchen Eintrag ich eben unterm setup von lirc ausführen müsste und wo ich wlechen Eintrag auf 0035 oder so ändern müsste. Von dem reinen try and run hab ich langsam genug:(

Danke und Gruß
Kamikaze

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins


308

Tuesday, February 17th 2009, 3:58pm

Hi Kamikaze,

Der Zusammenhang ist rellativ einfach zu erklaehren, das Touchscreen Display ist vom selbern Hersteller wie das im Thermaltake DH102, Zalman HD160XT Plus und Moneual Monacaso 972.
Aber ich gebe dir recht, dieser Thread ist mittlerweile sehr aufgeblaeht und man sollte vieleicht mal einen Neuen speziell fuer das Display aufmachen.

Ich gehe recht in der Annahme das dein Display eine Diagonale von 4.3" hat also usbid 15c2:0035,
wenn ja, hier ist eine kleine Anleitung. Ich muss aber dazu sagen das ich dieses Geraet erst im Treiber hinzugefuegt habe, es gibt da diverse Unterschide zwischen 7" (0034) und 4.3" (0035), welche ich auch noch nicht testen konnte da ich selbst kein 4.3" Display besitze.


als Erstes musst du den aktuellsten Treiber downloaden und compilieren, erst dort ist ueberhaupt die Unterstuetzung fuer dein Geraet enthalten.

Source code

1
2
3
4
wget http://www.saweb.de/imontouch/lirc-0.8.5pre1-imontouch-0.2.1.tar.gz
tar xvf ./lirc-0.8.5pre1-imontouch-0.2.1.tar.gz
cd lirc-0.8.5pre1-imontouch0.2.1
./setup.sh


Im Setup musst du den entsprechenden Treiber auswaehlen, findest du unter USB->Soundgraph iMON Touch LCD mit Ok bestaetigen und im Main Menu auf Save configuration & run configure"

Sollte das ohne Probleme durchgelaufen sein den Treiber compilieren und installieren mit

Source code

1
2
make
make install

Wenn auch hier keine Fehler aufgetreten sind, ist eigentlch schon fast das Groebste geschafft, jetz muesst du nur noch den usbhid Treiber hindern das Geraet zu blockieren.

Source code

1
echo "options usbhid quirks=0x15c2:0x0035:0x0004" > /etc/modprobe.d/usbhid

hier ist jetzt ein Neustart erforderlich damit die quirks Einstellungen aktiv werden.

Wenn dein Rechner wieder hochgefahren ist sollte die Ausgabe

Source code

1
2
mount -t usbfs none /proc/bus/usb
cat /proc/bus/usb/devices


ungefaehr wie folgt aussehen

Source code

1
2
3
4
5
6
7
8
T: Bus=03 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#= 2 Spd=1.5 MxCh= 0
D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=15c2 ProdID=0035 Rev= 0.03
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=02 Driver=lirc_imontouch
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=10ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID ) Sub=00 Prot=00 Driver=lirc_imontouch
E: Ad=82(I) Atr=03(Int.) MxPS= 8 Ivl=10ms

ist dies der Fall, dann ist der Treiber geladen und verrichtet seinen Job.

Mit mode2 kannst du testen ob deine FB richtig funktioniert, es sollte fuer jede Taste ein individueller Code ausgegeben werden.

Die weitere Konfiguration von vdr ist absolut identisch mitdieserAnleitung

INFO: Diese Anleitung kann auch fuer das 7" Display verwendet werden, es sind dann nur alle 0035 durch 0034 zu ersetzen.

Ach noch was, sollte der usbhid Treiber weiterhin das Geraet blockieren, versuche den folgenden Befehl (als root natuerlich)

Source code

1
rmmod usbhid && modprobe usbhid quirks=0x15c2:0x0035:0x0004

Blockiert der usbhid Treiber dieses Geraet immer noch, kannst du noch diesen Befehl versuchen (anscheinend funktioniert das bei manchen Kernelversionen mit 0x0004nicht, laut LIRC Mailinglist)

Source code

1
rmmod usbhid && modprobe usbhid quirks=0x15c2:0x0035:0x4

Diese Einstellungen sind aber nur bis zu einem Neustart aktiv.

Gruss
Rene


BTW: Danke Kamikaze fuer die Korrekturen!

This post has been edited 3 times, last edit by "rehar" (Feb 17th 2009, 7:00pm)


309

Tuesday, February 17th 2009, 4:33pm

Hey Rene,

deine lirc-Version hatt ich schon getestet, einmal noch mal mit patch rübergeklatscht und auch ohne. Aber ohne Erfolg... Aber ... eigentlich auch ganz logisch: ich Bratze hab den falschen Eintrag beim setup von lirc gewählt, daher ging das die ganze Zeit nicht. Hab immer einen imon-Treiber gewählt, aber nie den imontouch ausprobiert. Mit dem imontouch bekomm ich nun auch ne Ausgabe von mode2. Muss allerdings mode2 --raw angeben.
So, dann mach ich mich aber mal an die lircd.conf... Hoff, dass das ohne weitere Probleme nu weiter geht.

Danke und Gruß
Melanie

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins


310

Tuesday, February 17th 2009, 4:49pm

...hm...bei manchen Tasten bekomme ich keine Ausgabe mit mode2.... z.B. auch ein paar Zahlen, z.B. die 2. Kann ich da was machen ? Oder kann ich auch eine programmierbare FB nehmen ? Sollte die mit einem bestimmten Code damit laufen ? Also rc5 code oder so ?

CU
Melanie

Edit: und vielleicht noch mal eine etwas "dümmliche Frage": wenn ich mit irrecord eine lircd.conf erstellen möchte, werd ich nach einem arbitrary button gefragt. Bei anderen lircd.conf, die ich erstellt hab mit programmierbaren FB musst ich immer die verschiedensten Tasten drücken, damit er die "Tasten und Code finden kann". Also es kam da folgende Aufforderung:

Source code

1
2
3
4
5
6
7
8
9
...
Now start pressing buttons on your remote control.

It is very important that you press many different buttons and hold them
down for approximately one second. Each button should generate at least one
dot but in no case more than ten dots of output.
Don't stop pressing buttons until two lines of dots (2x80) have been
generated.
...
Kann ich das hier auch einstellen, wenn ich irrecord mit bestimmten Parametern starte ? Oder liegt das an der lirc-Version ? Oder an der eigenen FB des Displays ?

Schanke Dön noch mal im Voraus!

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins

This post has been edited 1 times, last edit by "Kamikaze" (Feb 17th 2009, 4:59pm)


311

Tuesday, February 17th 2009, 6:01pm

Also wenn du bei bestimmten Tasten mittels mode2 keine Codes bekommst, koennte das warscheinlich am Treiber liegen.

Wie gesagt meine Informationen bezueglich des 4.3" Displays sind sehr mager.

Lade den lirc_imontouch Treiber mal bitte im debug mode

Source code

1
rmmod lirc_imontouch && modprobe lirc_imontouch debug=1


Dann schaust du dir die Kernel Ausgabe an (bei mir /var/log/messages)

Source code

1
 tail -f /var/log/messages


Dort sollte jetzt jedesmal wenn du eine Taste drueck eine Zeile ausgegeben werden die ungefaehr so aussieht

Source code

1
 ....... lirc_imontouch xxx incomming packet: 03 00 05 00 00 00 14 ff 


Kannst du mir die Ausgabe mit den dazugehoerigen Tasten hier posten, dann kann ich schauen welche Aenderungen am Code vorgenommen werden muessen.

Dieser arbitrary button ist fuer dieses Geraet eigentlich irrelevant, wenn ich mich recht erinnere berechnet irrecord hier die Pausen zwischen den Bursts bei IR-Empfaengern wo lirc die Decodierung selbst vornimmt (sicher bin ich mir da gerade aber auch nicht).
Du kannst einfach, dass machen was dort steht, bis die Frage nach einem Namen fuer deine neue Taste kommt.

Gruss
Rene

312

Tuesday, February 17th 2009, 6:25pm

Klar kann ich dir das zukommen lassen. Allerdings erst Morgen - hab so gerad nur remote-Zugriff drauf, aber so ohne die FB wohl wenig sinnig;-)

Gruß
Melanie

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins


313

Wednesday, February 18th 2009, 8:56am

Moin, moin,

schade eigentlich: wenn ich die Module manuell entlade und wieder lade erhalte ich keine Ausgabe mehr mit mode2... Muss erst mal gucken, wie woran das liegt... Schade eigentlich. Meld mich dann wieder.

CU
Melanie

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins


314

Wednesday, February 18th 2009, 10:50am

Hab da mal n anderen Thread aufgemacht... Mein Problem iss in dem Fall wohl eher easyvdr-typisch, aber da es ja grundsätzlcih um das Device 15c2:0035 geht hab ich das dennoch in der TFT-Sparte angesiedelt.

CU
Melanie

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins


315

Friday, February 20th 2009, 10:50am

Hallo

Endlich finde ich wieder etwas Zeit...
Danke für die neue version, ich habe aber noch immer den selben effekt:

Source code

1
[    5.897318] imontouch_probe: found iIMON device, 0. interface<1>BUG: unable to handle kernel paging request at 61696c89


(bis jetzt in den Kernel versionen 2.6.28.1, 2.6.28.2 und 2.6.28.6 getestet)
2.6.27.x versionen scheinen alle zu funktionieren.

Kann das noch jemand anderes reproduzieren?
2.6.28.1 scheint bei kamikaze ja keine Fehler zu produzieren...


Gruss und Danke
t-cp

316

Friday, February 20th 2009, 11:21am

Hallöchen,

jo, also an sich läuft das bei mir mit kernel 2.6.28.1 (hab wie gesagt das heino image von easyvdr isntalliert)
@t-cp: hast du vielleicht noch eine Hdd über und etwas Zeit ? Dann könntest du das image ja mal instalieren und da dann die lirc-version von rehar installieren.

Ein Problem hab ich allerdings noch, weiß nur noch nicht genau, wo, wie ich da weiter vorgehe: wenn ich ein weiteres usb-device anschließe (Maus, ext. hdd) und dev vdr neu starte, dann kann der imontouch nicht immer dem display zugeordnet werden. So erhalte ich dann auch kein /dev/lirc0-Device. Also das zusätzlcihe usb gerät scheint da etwas durcheinander zu bringen...
wenn es nicht klappt:

Source code

1
2
3
4
5
6
7
8
9
10
11
cat /proc/bus/usb/devices
...
T:  Bus=03 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=15c2 ProdID=0035 Rev= 0.03
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=02 Driver=usbhid
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
 


hier mal ein Auszug aus m syslog, wenn es nicht klappt.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
Feb 20 09:07:47 (none) kernel: [    5.263187] usb 4-3: New USB device found, idVendor=046d, idProduct=c03e
Feb 20 09:07:47 (none) kernel: [    5.263190] usb 4-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Feb 20 09:07:47 (none) kernel: [    5.263192] usb 4-3: Product: USB-PS/2 Optical Mouse
Feb 20 09:07:47 (none) kernel: [    5.263193] usb 4-3: Manufacturer: Logitech
Feb 20 09:07:47 (none) kernel: [    6.035574] usbcore: registered new interface driver hiddev
Feb 20 09:07:47 (none) kernel: [    6.048141] input: HID 15c2:0035 as /class/input/input3
Feb 20 09:07:47 (none) kernel: [    6.056015] ACPI: WMI: Mapper loaded
Feb 20 09:07:47 (none) kernel: [    6.095381] generic-usb 0003:15C2:0035.0001: input,hidraw0: USB HID v1.01 Mouse [HID 15c2:0035] on usb-0000:00:02.0-5/input0
Feb 20 09:07:47 (none) kernel: [    6.097561] lirc_dev: IR Remote Control driver registered, major 61
Feb 20 09:07:47 (none) kernel: [    6.104176] generic-usb 0003:15C2:0035.0002: hiddev0,hidraw1: USB HID v1.00 Device [HID 15c2:0035] on usb-0000:00:02.0-5/input1
Feb 20 09:07:47 (none) kernel: [    6.111280] input: Logitech USB-PS/2 Optical Mouse as /class/input/input4
Feb 20 09:07:47 (none) kernel: [    6.113709] Driver for Soundgraph iMON Touch LCD and Remote Control iMON PAD, v0.2.1<6>Rene Harder <rehar@saweb.de><6>usbcore: registered new interface driver lirc_imontouch
Feb 20 09:07:47 (none) kernel: [    6.133273] generic-usb 0003:046D:C03E.0003: input,hidraw2: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:04.0-3/input0
Feb 20 09:07:47 (none) kernel: [    6.133290] usbcore: registered new interface driver usbhid
Feb 20 09:07:47 (none) kernel: [    6.133293] usbhid: v2.6:USB HID core driver
Feb 20 09:07:47 (none) kernel: [    6.184930] forcedeth: Reverse Engineered nForce ethernet driver. Version 0.61.
Feb 20 09:07:47 (none) kernel: [    6.184946] forcedeth 0000:00:0a.0: PCI INT A -> Link[APCH] -> GSI 23 (level, low) -> IRQ 23
Feb 20 09:07:47 (none) kernel: [    6.184950] forcedeth 0000:00:0a.0: setting latency timer to 64
Feb 20 09:07:47 (none) kernel: [    6.240041] forcedeth 0000:00:0a.0: ifname eth0, PHY OUI 0x732 @ 3, addr 00:23:54:16:80:ef
Feb 20 09:07:47 (none) kernel: [    6.240045] forcedeth 0000:00:0a.0: highdma csum pwrctl mgmt timirq gbit lnktim msi desc-v3
Feb 20 09:07:47 (none) kernel: [    6.252472] pci_hotplug: PCI Hot Plug PCI Core version: 0.5
Feb 20 09:07:47 (none) kernel: [    6.254373] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
Feb 20 09:07:47 (none) kernel: [    6.281788] ohci1394 0000:01:0a.0: PCI INT A -> Link[APC4] -> GSI 19 (level, low) -> IRQ 19


nach m Neustart geht das dann meist. Hier der auszug von usbfs, wenn es geht:

Source code

1
2
3
4
5
6
7
8
T:  Bus=03 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  2 Spd=1.5 MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=15c2 ProdID=0035 Rev= 0.03
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=100mA
I:* If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=02 Driver=lirc_imontouch
E:  Ad=81(I) Atr=03(Int.) MxPS=   8 Ivl=10ms
I:* If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=lirc_imontouch
E:  Ad=82(I) Atr=03(Int.) MxPS=   8 Ivl=10ms


und ein Auszug aus m Syslog

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
Feb 20 11:11:41 (none) kernel: [    4.204984] Write protecting the kernel text: 5592k
Feb 20 11:11:41 (none) kernel: [    4.206752] Write protecting the kernel read-only data: 1628k
Feb 20 11:11:41 (none) kernel: [    4.331014] usb 3-5: new low speed USB device using ohci_hcd and address 2
Feb 20 11:11:41 (none) kernel: [    4.513212] usb 3-5: configuration #1 chosen from 1 choice
Feb 20 11:11:41 (none) kernel: [    4.516397] usb 3-5: New USB device found, idVendor=15c2, idProduct=0035
Feb 20 11:11:41 (none) kernel: [    4.518188] usb 3-5: New USB device strings: Mfr=0, Product=0, SerialNumber=0
Feb 20 11:11:41 (none) kernel: [    4.676144] usb 4-3: new low speed USB device using ohci_hcd and address 2
Feb 20 11:11:41 (none) kernel: [    4.870200] usb 4-3: configuration #1 chosen from 1 choice
Feb 20 11:11:41 (none) kernel: [    4.873270] usb 4-3: New USB device found, idVendor=046d, idProduct=c03e
Feb 20 11:11:41 (none) kernel: [    4.873272] usb 4-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
Feb 20 11:11:41 (none) kernel: [    4.873274] usb 4-3: Product: USB-PS/2 Optical Mouse
Feb 20 11:11:41 (none) kernel: [    4.873276] usb 4-3: Manufacturer: Logitech
Feb 20 11:11:41 (none) kernel: [    5.927386] lirc_dev: IR Remote Control driver registered, major 61
Feb 20 11:11:41 (none) kernel: [    5.968398] Driver for Soundgraph iMON Touch LCD and Remote Control iMON PAD, v0.2.1<6>Rene Harder <rehar@saweb.de><6>imontouch_probe: found iIMON device, 0. interface<6>imontouch_probe: first usb interface not yet registered<6>lirc_dev: lirc_register_driver: sample_rate: 0
Feb 20 11:11:41 (none) kernel: [    5.968509] imontouch_probe: Registered imontouch driver(minor:0)<6>imontouch_probe: imontouch device connected, minor 0<6>input: iMON PAD IR Mouse 15c2:0035 as /class/input/input3
Feb 20 11:11:41 (none) kernel: [    5.976070] imontouch_probe: found iIMON device, 1. interface<6>imontouch_probe: driver dectected, LIRC minor: 0<6>imontouch_probe: imontouch device connected, minor 0<6>input: USB Touchscreen 15c2:0035 as /class/input/input4
Feb 20 11:11:41 (none) kernel: [    5.981047] lirc_imontouch usb_rx_callback_intf1 incomming packet: 2a b1 d5 b7 00 00 03 01
Feb 20 11:11:41 (none) kernel: [    5.984182] usbcore: registered new interface driver lirc_imontouch
Feb 20 11:11:41 (none) kernel: [    5.989045] lirc_imontouch usb_rx_callback_intf1 incomming packet: 2a b1 95 b7 00 00 03 01
Feb 20 11:11:41 (none) kernel: [    5.997046] lirc_imontouch usb_rx_callback_intf1 incomming packet: 2a b1 d5 b7 00 00 03 01
Feb 20 11:11:41 (none) kernel: [    5.999596] usbcore: registered new interface driver hiddev
Feb 20 11:11:41 (none) kernel: [    6.008265] input: Logitech USB-PS/2 Optical Mouse as /class/input/input5
Feb 20 11:11:41 (none) kernel: [    6.038212] generic-usb 0003:046D:C03E.0001: input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:04.0-3/input0
Feb 20 11:11:41 (none) kernel: [    6.038229] usbcore: registered new interface driver usbhid
Feb 20 11:11:41 (none) kernel: [    6.038232] usbhid: v2.6:USB HID core driver
Feb 20 11:11:41 (none) kernel: [    6.154954] ACPI: WMI: Mapper loaded


wenn ich kein zusätzliches usb-gerät angeschlossen hab, konnte ich (toi toi toi) so oft neustarten, wie ich wollte: wurd alles richtig erkannt. Irgendjemand iene Idee, wie ich das unterbinden kann ? Ich möcht ja auch mal die Möglichkeit haben, weitere USB Geräte anzuschließen ? Liegt das an udev ?!

LG
Melanie

  • 1. PC Debian lenny, Xen
    AMD X2 4850e, M3N78 Pro
    DomU-satana: Debian etch, VDR 1.7.12, div. Plugins, DVB-S2
    DomU-servana: Debian etch, Fileserver und andere kleine Dienste
    DomU-endiana: Debian etch, Firewall, Router

  • 2. PC Debian sarge kernel-2.6.8
    AMD Duron 750 MHz, Technotrend DVB-T FF 1.3., Twinhan DVB-T
    VDR 1.4.7, div. Plugins


317

Friday, February 20th 2009, 3:57pm

Hallo Kamikaze,

Wenn ich mir deine Syslogs anschaue sehe ich, dass in dem Fall wo der imontouch Treiber dem Display zugeordnent wird der HID Treiber erst anschliessend geladen wird. In dem Fall wo es nicht funktioniert wird der HID Treiber bereit vorher gestartet und belegt dann das Display.

Ich vermute das die Quirks settings fuer den HID Treiber nicht wirken.
Probier mal ob du sie manuell setzen kannst also wenn der HID Treiber das Display belegt.

Source code

1
2
rmmod usbhid && modprobe usbhid quirks=0x15c2:0x0035:0x0004
rmmod lirc_imontouch && modprobe lirc_imontouch
Ich hatte neulich irgendwo gelesen, dass bei den quirks einstellungen im usbhid Treiber etwas geandert wurde, ich muss nochmal genau schauen wo und was.

Gruss
Rene

318

Saturday, February 21st 2009, 10:53am

Hallo Kamikaze

Die quirks settings hat er bei mir nicht übernommen als ich den usbhid treiber nicht als modul sondern direkt im Kernel integriert hatte.

ist das bei dir evtl das Problem?

319

Sunday, March 1st 2009, 5:49pm

Hallo zusammen,

ich versuche auch gerade, die Tasten und den Touchscreen meines Gehäuses zum laufen zu kriegen (in diesem Fall ein Zalman HD160XT PLUS), aber irgendwie bekomme ich es nicht hin...

Source code

1
2
3
4
lsusb
[...]
Bus 004 Device 002: ID 15c2:0034 SoundGraph Inc.
[...]

Ich bin vorgegangen, wie von Rene beschrieben, also Treiger gezogen, ausgepackt und über setup.sh konfiguriert. Hier habe ich den imontouch Treiber ausgewählt und mit "save configuration & run configure" verlassen.

make produziert dann folgende Fehler bei mir:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch/lirc_imontouch.c: In function 'imontouch_probe':
/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch/lirc_imontouch.c:515: warning: assignment from incompatible pointer type
/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch/lirc_imontouch.c:566: error: implicit declaration of function 'BIT_MASK'
/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch/lirc_imontouch.c:567: error: implicit declaration of function 'BIT_WORD'
make[5]: *** [/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch/lirc_imontouch.o] Error 1
make[4]: *** [_module_/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch] Error 2
make[4]: Leaving directory `/usr/src/linux-2.6.23.11-gentoo'
make[3]: *** [lirc_imontouch.o] Error 2
make[3]: Leaving directory `/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers/lirc_imontouch'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/lirc-0.8.5pre1-imontouch-0.2.1/drivers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/lirc-0.8.5pre1-imontouch-0.2.1'
make: *** [all] Error 2

Was läuft hier falsch?

Danke für Eure Hilfe im Voraus!

Gruß, kandamir
Konfiguration:
ASUS P4P800-E Deluxe
Intel Pentium 4 Mobile 1,7GHz mit CPU-Adapter ASUS CT-379 (funktioniert einwandfrei)
2GB RAM
500GB S_ATAII Festplatte
TechnoTrend Premium DVB-C 2300 FF, Rev. 1.1
2x Hauppauge Nova-T DVB-T Budget, Rev. C2B0f
Gen2VDR Linux 2.6.23.11-gentoo
Zalman HD160XT PLUS Gehäuse

320

Sunday, March 1st 2009, 11:22pm

Hi,

das liegt daran, dass diese Makros erst im Kernel > 2.6.23 vorhanden sind.
Ich habe den Treiber dementsprechend angepasst. Er kompiliert jetzt auf jedenfall mit Kernel 2.6.21 und aufwaerts.

Den modifizierten Treiber findest du hier: lirc-0.8.5pre1-imontouch-0.2.3.tar.gz

Gruss
Rene