You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

121

Wednesday, April 27th 2011, 9:44pm

Ciao Phil

Nach paar mal zappen erhalte ich manchmal:

Something went wrong! Fehlermeldungen

Im log siehts dann wie folgt aus:

Source code

1
2
Apr 27 21:40:37 ilir vdr: [12363] streamdev: No device provides channel 1 (Das Erste) at priority 0
Apr 27 21:40:37 ilir vdr: [12363] streamdev: closing streamdev connection to 127.0.0.1:39342


Sieht so aus als würde stremdev meine DVB-Karte als beschäftigt betrachten?

Und wenn wir schon dabei sind, warum hast du nicht VNSI für den Stream verwendet, läuft doch besser oder?

Ist es normal, dass etwa 15 - 20 Sekunden vergehen, bis der Stream startet?

122

Wednesday, April 27th 2011, 10:01pm

Ja, das dauert eine weile. Bei mir 12 Sekunden. Zum zappen ist das nix das stimmt.

Source code

1
 streamdev: No device provides channel 1 (Das Erste) at priority 0

hatte ich noch nicht, aber liegt nicht an iVDR.

Mit VNSI hatte ich mich bis jetzt noch nicht beschäftigt. Aber dürfte kein Problem sein, einfach Live-Stream in den Streamsettings anpassen.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

123

Wednesday, April 27th 2011, 10:19pm

Werd es auf jeden Fall mal anschauen danke.

Noch ne kurze Frage bzgl. Android Clients. Ich hab Android 2.3 CynogenMod laufen. Wenn ich jedoch den Stream starten möchte, erhalte ich einfach ne Meldung, dass kein passender Plugin gefunden wurde. Kann da jemand mit funktionierendem Stream auf Android mir verraten welches Tool bzw. Plugin verwendet werden kann.

124

Wednesday, April 27th 2011, 10:37pm

Müsste irgendein quicktime plugin sein wenn es sowas gibt. Sag mal bescheid wenn du es zum laufen bekommst.
Ich habe leider nicht die möglichkeit iVDR auf einer android plattform zu testen. Wollte das thema aber auf jeden fall noch angehen.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

carel

Intermediate

Posts: 432

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

125

Thursday, April 28th 2011, 9:56am

Hi Phil,

Leider nein, funzt noch nicht. Aber bin zweit schritte Vorwarts und eine zurück:
Ich hab nun auch ein symlink ram im '/usr/lib/cgi-bin/ivdr/' Verzeichnis gelegt, aber das muss doch eigentlich nicht sein?
Hoffe das es nur ein pfadfehler ist aber ich bicke da nicht meher durch :rolleyes:

Source code

1
2
3
4
[Thu Apr 28 09:32:15 2011] [error] [client 213.84.66.101] (13)Permission denied: exec of '/usr/lib/cgi-bin/ivdr/ram/session0/stream.m3u8' failed
[Thu Apr 28 09:32:15 2011] [error] [client 213.84.66.101] Premature end of script headers: stream.m3u8

213.84.66.101 - - [28/Apr/2011:09:32:15 +0200] "GET /cgi-bin/ivdr/ram/session0/stream.m3u8 HTTP/1.1" 500 831 "-" "AppleCoreMedia/1.0.0.8C148a (iPhone; U; CPU OS 4_2_1 like Mac OS X; nl_nl)"


HTTP code 500: "Internal server error"
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

carel

Intermediate

Posts: 432

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

126

Thursday, April 28th 2011, 10:44am

Joepie!

Es geht!!

Es fehlte ein '/' im URL setting: '/ram/' statt 'ram/'
Dieser syntax es recht Fehlerempfindlich!

Das ich der stream nun auch speichern kann finde ich sehr nett, der hammer für die Kinder!

Nun hab ich der workingdir im tmpfs (shm/ram) angelegt,, aber das läuft beim höherem Videoqualität recht schnell voll...
Gibt es etwas wie eine ringbuffer, eine max buffersize?

VIELEN dank :respekt Carel

Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

127

Thursday, April 28th 2011, 11:42am

Source code

1
2
Es fehlte ein '/' im URL setting: '/ram/' statt 'ram/'
Dieser syntax es recht Fehlerempfindlich!

Die URL-Syntax ist eben, führendes / - absoluter link, kein / - relativer link.
Ich kann natürlich ohne weiteres die paramter einengen, aber das geht stark zu lasten der flexibilität.

In der nächsten Version gibts eine Configausgabe, dann kann man die Config leichter hier posten. Da hätten wir das Problem gleich gelöst...

Quoted

Gibt es etwas wie eine ringbuffer, eine max buffersize?

Ja, der ist aber nur bei live-streams aktiv, oder besser gesagt bei aufnahmen und videos relativ hoch gesetzt.
istream.sh:

Source code

1
SEGWIN=$7		# Amount of Segments to produce

bei live-tv: 20 <- ca. 10 minuten
bei allen anderen: 1260 <- entspricht glaube ich ca. 4 Stunden

Das Problem müsstest du dann umgehen indem du das workingdir auf die Festplatte bannst.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

carel

Intermediate

Posts: 432

Location: Niederlande

Occupation: Satelliet und ICT

  • Send private message

128

Thursday, April 28th 2011, 12:28pm

Und weiter geht's testen 8)

Sobald ich das Video button, unter Media, klicke erscheint:

Source code

1
[Thu Apr 28 12:26:04 2011] ivdr.pl: Please create an writeable markedfiles.log at /usr/lib/cgi-bin/ivdr/ivdr.pl line 227


Aber ich bin 100% sicher dieser datei ist da ?!?
Intel E7400, Ubuntu Server x86_64 12.04, Nvidia GF9400, nvidia 295.40, vdr-1.7.27+ext patch, xine-lib-git + df patches, xineliboutput-git :portal1

129

Thursday, April 28th 2011, 12:51pm

Danke für den Hinweis.

Das Markieren von Dateien in 0.3.1 geht nicht. Habe es kurz vor der Veröffentlichung einen Fehler eingebaut. Einfach ignorieren, ist nur ein Hinweis.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

130

Thursday, April 28th 2011, 3:15pm

Hi,

noch einmal eine Frage zum Funktionsumfang.
Sollte es auch möglich sein das man MP3 und ISO (DVD) streamen kann
Ich glaube per Menü wird es angeboten.

Werde es später noch einmal testen schauen was dann im Log steht.

Grüße
cinfo
Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern, AVG 1, SSD: 64GB, HD1 750GB Client1: Intel D510MO,Reel eHD, 2GB RAM, SSD: 64 GB Software: Ubuntu 10.04-14.04, VDR-1.7.29 , Kernel: 3.x NAS: CPU Intel Atom 1.8 GHz, 2GB RAM mit 4 TB Speicher Client1-2: MediaMVP Revision H4 / Raspberry PI Software: Vomp Extension Dongle/Server Version 0.4.x

131

Thursday, April 28th 2011, 3:35pm

Der "öffnen" button (dieses Filmstreifensymbol) ist für die Geräte, die bestimmte Dateitypen direkt unterstüzen. Auf iPhone und Co. sind das mp3's und mp4's.

Aber du kannst sie natürlich auch über ffmpeg jagen! :D

ISO! Mhhh, wenn der ffmpeg damit klar kommt warum nicht.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

This post has been edited 1 times, last edit by "Phill" (Apr 28th 2011, 3:42pm)


132

Thursday, April 28th 2011, 3:56pm

Hi,

Quoted

ISO! Mhhh, wenn der ffmpeg damit klar kommt warum nicht.
Hier war der Ansatz das man ja bei den Mediadateien auch ISO wählen kann
und auch es Streamsymbol erscheint. Also kamm die Frage auf ob man auch ein ISO mit VOB´s streamen kann?
Wenn z.B. beim Mediaplayer der XineMediaPlayer unter Einstellungen ausgewählt ist (der das ja kann).
Ob hierfür ffmpeg benötigt werden muß sehen ich nicht -- ist ja nichts anderes als bei AVI Mediadatei nur das aus einem ISO(DVD) auf dem VDR entpackt werden muß und gesammt an den z.B. XineMediaPlayer
übergeben werden (Das alles macht ja auch der XineMediaPlayer) und die VOB´s könnten dann per "http" gestreamt werden?

Grüße
cinfo
Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern, AVG 1, SSD: 64GB, HD1 750GB Client1: Intel D510MO,Reel eHD, 2GB RAM, SSD: 64 GB Software: Ubuntu 10.04-14.04, VDR-1.7.29 , Kernel: 3.x NAS: CPU Intel Atom 1.8 GHz, 2GB RAM mit 4 TB Speicher Client1-2: MediaMVP Revision H4 / Raspberry PI Software: Vomp Extension Dongle/Server Version 0.4.x

133

Friday, April 29th 2011, 3:37am

Nachdem das Streaming jetzt dank des richtigen Hinweises von Phill läuft ist mir aufgefallen dass dieses nur für non-HD Sender klappt. Bei HD Sendern (z.B. ZDF HD) klappt es nicht. ffmpeg wird zwar aufgerufen erstellt aber keine .ts Dateien im session Verzeichnis. Im ffmpeg.log steht auch keine wirkliche Fehlermeldung. Ist das ein bekanntes Problem oder sollte Streaming von HD Inhalten ohne Probleme klappen?

Viele Grüße,
Tomix
Bei mir klappt das Streaming von ARD HD und ZDF HD auch nicht. Seltsamerweise geht aber das Streamen von Anixe HD, Campus HD, Servus HD und Luxe HD.

Hat es etwas damit zu tun, dass ARD HD und ZDF HD 720p senden, die anderen aber 1080i ?

Habe noch 3 andere Problemchen:

Die Aspectratio bei Aufnahmen stimmt häufig nicht, 16:9 wird auf 4:3 gestaucht.

Wie kann ich in Aufnahmen springen?

Und kann man den Tonkanal umschalten. Mit französich bei Arte komme ich nicht zurecht. ;-)

Pete

134

Friday, April 29th 2011, 6:27am

Hallo carthago,

wie bist du weitergekommen?
Ich habe hier das gleiche Problem: sowohl auf einem IPOD Touch als auch in Google Chrome am PC funktionieren die Einstellungen nicht.

135

Friday, April 29th 2011, 1:23pm

Die Aspectratio bei Aufnahmen stimmt häufig nicht, 16:9 wird auf 4:3 gestaucht.

Bei mir passt sie meistens. Kann es sein das das Seitenverh. nicht passt wenn der Stream mit 4:3 / 16:9 anfängt und dann später sich ändert! Das ist halt schwehr zu handhaben, bei live-streams sowieso nicht. Da halt den stream neu starten. Und bei Aufnahmen, welche frames nimmt man für die Erkennung! Wenn man irgendwelche aus der mitte nimmt kann man auch einen Werbeblock erwischen der dann wieder das falsche Seitenverh. hat.
Wie kann ich in Aufnahmen springen?

Warten bis ffmpeg genug videomaterial voraus codiert hat.
Und kann man den Tonkanal umschalten. Mit französich bei Arte komme ich nicht zurecht. ;-)

Bei "Sofort starten" auf abbrechen gehen! Ich muss das mal in die FAQ schreiben, kam doch jetzt schon häufiger die Frage.

Hallo JoergE und willkommen im Forum.
wie bist du weitergekommen?
Ich habe hier das gleiche Problem: sowohl auf einem IPOD Touch als auch in Google Chrome am PC funktionieren die Einstellungen nicht.

Ja das wüsste ich auch gern. Was steht in der log?
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

This post has been edited 1 times, last edit by "Phill" (Apr 29th 2011, 4:36pm)


136

Friday, April 29th 2011, 9:04pm

Die Aspectratio bei Aufnahmen stimmt häufig nicht, 16:9 wird auf 4:3 gestaucht.
Bei mir passt sie meistens. Kann es sein das das Seitenverh. nicht passt wenn der Stream mit 4:3 / 16:9 anfängt und dann später sich ändert! Das ist halt schwehr zu handhaben, bei live-streams sowieso nicht. Da halt den stream neu starten. Und bei Aufnahmen, welche frames nimmt man für die Erkennung! Wenn man irgendwelche aus der mitte nimmt kann man auch einen Werbeblock erwischen der dann wieder das falsche Seitenverh. hat.

Hab's nochmals getestet. Bei SD Aufnahmen ist es so, wie Du vermutet hast. Er nimmt das Seitenverhältnis, mit dem die Aufnahme beginnt. Bei 720p Aufnahmen (Eins HD, ZDF HD) macht er immer eine Art 4:3 Darstellung, auch wenn die ganze Aufnahme in 16:9 ist.

Könnte man nicht was einbauen, womit man ein bestimmtes Seitenverhältnis erzwingen kann? Dann wäre der Hauptfilm wenigstens anschaubar, auch wenn es eines manuellen Eingriffs bedarf.
Wie kann ich in Aufnahmen springen?
Warten bis ffmpeg genug videomaterial voraus codiert hat.

Sicher? Bis bei mir der Ablaufbalken (links abgelaufen, rechts Rest) die Gesamtdauer des Films anzeigt, muss ich praktisch warten, bis er fast ganz durchgelaufen ist. Dann brauche ich auch nicht mehr springen. :-/
Und kann man den Tonkanal umschalten. Mit französich bei Arte komme ich nicht zurecht. ;-)
Bei "Sofort starten" auf abbrechen gehen! Ich muss das mal in die FAQ schreiben, kam doch jetzt schon häufiger die Frage.


Momentan finde ich scheinbar keine 2 Kanalton Aufnahme. Sollten dann neben Auto noch die einzelnen Kanäle auswählbar sein?

Pete

137

Friday, April 29th 2011, 10:59pm

Hi,

Quoted

Könnte man nicht was einbauen, womit man ein bestimmtes Seitenverhältnis erzwingen kann?


Ich kenne beim ffmpeg nur dies zum Setzen des Seitenverhältnis

Quoted

`-aspect aspect'
Set aspect ratio (4:3, 16:9 or 1.3333, 1.7777).


Grüße
cinfo
Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern, AVG 1, SSD: 64GB, HD1 750GB Client1: Intel D510MO,Reel eHD, 2GB RAM, SSD: 64 GB Software: Ubuntu 10.04-14.04, VDR-1.7.29 , Kernel: 3.x NAS: CPU Intel Atom 1.8 GHz, 2GB RAM mit 4 TB Speicher Client1-2: MediaMVP Revision H4 / Raspberry PI Software: Vomp Extension Dongle/Server Version 0.4.x

This post has been edited 1 times, last edit by "cinfo" (Apr 29th 2011, 11:06pm)


138

Saturday, April 30th 2011, 1:25am


Momentan finde ich scheinbar keine 2 Kanalton Aufnahme. Sollten dann neben Auto noch die einzelnen Kanäle auswählbar sein?

Ja.
In der istream.pl werden die Audio-Kanäle analysiert.
Da könntest du mal die Zeile 127 wie unten ändern, und die log beim aufrufen des Videomaterials hier posten.

Source code

1
2
3
4
5
6
7
8
9
10
11
open(FF, $OPT{ffmpeg}." -i ".$media." 2>&1 |") or warn "ffmpeg error $!";
$ff = join("", <FF>);
close FF;
dbg($ff);
(my $_tmp = $ff) =~ /Stream #(\d\.\d).*:( Video):(.*)/;
warn $&;
my $vid = $1;

while ($ff =~ /Stream #(\d\.\d).*:( Audio):(.*)/g) {
warn $&;
$audiooption .= "<option value='-map $vid -map $1'>$&</option>";
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

This post has been edited 1 times, last edit by "Phill" (Apr 30th 2011, 1:31am)


139

Saturday, April 30th 2011, 10:45am

Nach Erstinstallation können keine Einstellungen vorgenommen werden

Zitat von »JoergE«
wie bist du weitergekommen?
Ich habe hier das gleiche Problem: sowohl auf einem IPOD Touch als auch in Google Chrome am PC funktionieren die Einstellungen nicht.

Ja das wüsste ich auch gern. Was steht in der log?
Aus /tmp/iVDR.log:
[Sat Apr 30 10:05:08 2011] ivdr.pl: couldn't parse config.pl: Can't locate XML/Simple.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl . ./components/) at components//config.pl line 311.


Geholfen hat dann ein apt-get install libxml-simple-perl.

140

Saturday, April 30th 2011, 5:57pm

So, habe jetzt auf die 0.3.1 upgedatet. Tut schon ganz nett.

Habe aber trotzdem immer noch Probleme mit dem Seitenverhältnis:

Mit dem iPad HD Preset - Auflösung umgestellt auf 720p und 2 MB Bandbreite - klappt jetzt die Wiedergabe von 720p 16:9 Material gut.

Mit dem iPad SD Preset klappt die Wiedergabe von 4:3 SD Material gut, wenn die Aufnahme in 4:3 startet.

Startet die Aufnahme in 16:9, dann ist der 4:3 Hauptfilm dann vertikal gestaucht. Habe mit verschiedenen Presets rumprobiert, aber noch keine Lösung dafür gefunden.




2. Problem ist das Springen in Aufnahmen. Ich habe meistens 5-10 Minuten Vorlauf, die ich bei Wiedergabe auf dem VDR überspringe. Bei Wiedergabe über iVDR braucht es ewig, bis sich der Wiedergabebalken aufbaut und selbst dann kann ich Anfangs nur 2-5 Minuten springen. Weiter reicht der Balken nicht. Kann es sein, dass dies damit zusammenhängt, dass mir iVDR alle 10 Sekunden eine neue stream-XX.ts Datei in der RAM-Diks erzeugt?

Jedes mal erst 10 Minuten der vorherigen Sendung anschauen zu müssen, macht auf Dauer keine Freude. Zum Abspielen bevorzuge ich deshalb derzeit noch die Air Video Lösung.

Pete

PS: Heute klappte auch das Streamen einer HD Sendung. Mit iPad HD Profil allerdings nur stotternd. Seltsamerweise klappte es mit dem andere ÖR HD Sender nicht (weiß jetzt nicht mehr, ob es ARD oder ZDF war, der tat).