You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

201

Thursday, May 19th 2011, 11:53am

Die Ursache warum du nicht in die Konfiguration kommst sollte in der ivdr.log stehen.

Bei 64bit gibts probleme mit der default ivdr.db, dann musst eine leere ivdr.db erzeugen...

Quoted

Mal wieder ne Frage zu iVDR...

Der war gut! :thumbup:
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

Posts: 2,956

Location: Isen

Occupation: System Manager

  • Send private message

202

Thursday, May 19th 2011, 12:37pm

Die Ursache warum du nicht in die Konfiguration kommst sollte in der ivdr.log stehen.

Bei mir war es nach einem

Source code

1
aptitude install libxml-simple-perl
dann möglich...

cu
Markus
:mahlzeit

Klick hier für "Aktuelle Verkaufsthreads"

Klick hier für "Meine Systeme"


  • yaVDR 0.5 headless Server in ProxMox VM, Digital Devices Cine S2 6.5 mit DuoFlex Erweiterung (Quad Tuner) per vt-d durchgereicht.
  • yaVDR 0.5 deviceless Client auf Zotac D2550 ITX Wifi Supreme am 42" LG
  • MLD RPI Edition mit vompclient


Balduin

Trainee

Posts: 88

Location: Bochum

  • Send private message

203

Thursday, May 19th 2011, 12:49pm

Danke für die Antworten, hoffentlich komme ich heute Abend zum Probieren...

Im Optimalfall melde ich mich nicht nochmal ... ;)
Zentrale: yavdr 0.5.0 - Asus A8N-E Sockel 939 - Athlon 3500+ - Nvidia Geforce GT 230 - 1GB DDR-400 - 80GB System-HD - 2TB Video-HD - DVBSKY S952 Dualtuner PCIe - Tevii 470 PCIe - 1.3 FF - Terratec Aureon - HD DVD/Blu Ray Combo-LW
Filialen: Mehrere Clients in Planung auf Zotac-Basis

204

Thursday, May 19th 2011, 4:05pm

So, habe jetzt auch die 0.3.2 drauf.

Ich glaube, ich habe ein grundsätzliches Verständnisproblem mit den Streaming-Profilen. Ich dachte, ich nehme, genügend Bandbreite vorausgesetzt, am Besten immer das Profil, das der physikalischen Auflösung des jeweiligen Bildschirms entspricht, also für das iPad 1024x768. Das gibt mir bei 1-HD der ZDF-HD (720p) aber immer ein 4:3 Format egal, welche Aspekt-Ratio ich in iVDR manuell einstelle. Mit dem 720p Profil stimmt die Darstellung.
Dafür sind jetzt SD Aufnahmen vertikal gestaucht.
Muss ich also immer das zur Quelle passende Profil auswählen? Bei vielen Aufnahmen weiß ich das ja gar nicht im Voraus. Bei Airvideo musste ich nichts umstellen, dass passt fast immer.

Das Eingeben eines Startwertes funktioniert bei mir nur bedingt. FFMEG sucht sehr lange nach dem Start und so kommt es häufig zu einem Timeout. Das passiert bei HD Aufnahmen fast immer, bei SD Aufnahmen wenn etwas weiter hinten gestartet wird.
Effekt: Irgendwann hört das Rädchen auf zu drehen aber das Videofenster erscheint nicht. Gehe ich zurück zum Startbildschirm, wird ein aktiver Stream angezeigt, dann ich dann manchmal anzeigen kann.


Pete

205

Thursday, May 19th 2011, 6:11pm

Hallo,

Quoted

am Besten immer das Profil, das der physikalischen Auflösung des jeweiligen Bildschirms entspricht
Ja, oder maximal die des Quellmaterials, da hochskalieren ja keine bessere Quali macht.

Ich habe mit HD Material nicht viel Erfahrung bei SD passt aber alles bei mir. ffmpeg hat irgendwie mit HD material noch irgendwie probleme. Oder ich peile es nicht, kann auch sein. :rolleyes:
Das erste was mir auffällt ist das bei HD die PixelAspectRatio (PAR) 1:1 ist anders wie bei SD.
In der ffmpeg.log des streams sehen zwei Videostreamzeilen, die erste ist für die Quelle die andere für die Ausgabe. bsp:

Source code

1
2
3
    Stream #0.0[0x177a]: Video: h264, yuv420p, 1280x720 [PAR 1:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 100 tbc
    ...
    Stream #0.0: Video: libx264, yuv420p, 1024x768 [PAR 4:3 DAR 16:9], q=10-51, 1024 kb/s, 90k tbn, 50 tbc
Ich kann jetzt nicht sagen ob es so richtig ist, weil bei mir gar kein Bild kommt, klingt aber erst mal plausibel. ffmpeg gleicht das unterschiedliche Pixelverhältnis darüber aus indem es die Pixel verzerrt. (PAR 4:3) Dadurch kann DAR das eigentliche Seitenverhältnis gleich bleiben.

Das mit dem offset geht leider nicht anders so weit ich weiß mit ffmpeg, wichtig ist halt was in der ffmpeg.log des streamordners steht.

@cinfo: fast vergessen, ich habe es getestet, geht leider nicht schneller da 10 Sekunden die kleinste segmentzeit ist.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

Frodo

Professional

Posts: 1,703

Location: Hessen

  • Send private message

206

Thursday, May 19th 2011, 6:12pm

Was bedeutet im ivdr.log die Meldung sh: everything_works_i_m_sure: not found?

Ich Frage deshalb weil ich sehr oft Bildaussetzer bei SD habe.
HD Material geht garnicht.
Gruß
Frodo

Meine VDR Hardware


YaVDR 0.5: TT S2-6400 und Sundtek SkyTV Ultimate (DVB-S/S2), Zotac H77ITX-C-E, Geforce 620, SilverStone ML02B-MXR, IMON LCD, softhddevice / dvbhddevice
YaVDR 0.5: Sat>IP (OctopusNet) über vtunerc, Zotac D2550ITX, Geforce 610, IMON VFD, softhddevice
YaVDR 0.5: Cine S2 V6, Intel DQ67SW, Geforce 210, SilverStone LC16M, IMON VFD, softhddevice
YaVDR 0.5: TT S2-3200, Intel DH67BL, Geforce 430, softhddevice
YaVDR 0.5: TT S2-6400, Intel DH67CF, dvbhddevice
Test HD TV-Karten: TT S2-3200, Sundtek SkyTV Ultimate (DVB-S/S2) , TeVii S480, TT-connect CT-3650 CI

207

Thursday, May 19th 2011, 6:22pm

Das ist ok ist kein fehler. Ist mittlerweile gefixt.
http://www.unixboard.de/vb3/showthread.p…nur-bei-Fehler!

Bildausetzer? Was macht die Prozessorauslastung.
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

Frodo

Professional

Posts: 1,703

Location: Hessen

  • Send private message

208

Thursday, May 19th 2011, 8:43pm

Das Problem liegt am iPhone 4 und meinem WLAN. Gibt es keine Möglich keit eine kleinere Auflösung zu streamen? Wenn ich in der Nähe (max 5 m im gleichen Raum) der Basisstation bin klappt es mit SD ohne Aussetzer durch ein Fenster und gleichen Abstand habe ich Pixelfehler und Aussetzer.
Bei HD habe ich keine Chance:

Source code

1
2
3
4
5
6
7
8
9
top - 20:41:43 up  1:30,  3 users,  load average: 2.65, 2.78, 2.62
Tasks: 205 total,   2 running, 203 sleeping,   0 stopped,   0 zombie
Cpu(s): 44.0%us,  7.5%sy, 22.9%ni, 19.8%id,  0.0%wa,  1.7%hi,  4.2%si,  0.0%st
Mem:   1802332k total,   718384k used,  1083948k free,99612k buffers
Swap:  1999864k total,    0k used,  1999864k free,   281036k cached

  PID USER  PR  NI  VIRT  RES  SHR S %CPU %MEMTIME+  COMMAND
 2724 www-data  20   0  220m  72m 1976 R  134  4.1   1:39.37 ffmpeg
 2219 root  20   0  445m  59m  12m S   24  3.4  28:25.72 vdr


Und im ffmpeg.log hagelt es Fehler:

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
[h264 @ 0x8973e70] error while decoding MB 0 10, bytestream (16841)
[h264 @ 0x8973e70] number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8973e70] concealing 2849 DC, 2849 AC, 2849 MV errors
[h264 @ 0x8973e70] concealing 713 DC, 713 AC, 713 MV errors
[h264 @ 0x8973e70] mmco: unref short failure
[h264 @ 0x8973e70] concealing 256 DC, 256 AC, 256 MV errors
[h264 @ 0x8973e70] concealing 2617 DC, 2617 AC, 2617 MV errors
[h264 @ 0x8973e70] concealing 1313 DC, 1313 AC, 1313 MV errors= 746.6kbits/s dup=2372 drop=0
[h264 @ 0x8973e70] concealing 2491 DC, 2491 AC, 2491 MV errors
[h264 @ 0x8973e70] concealing 1730 DC, 1730 AC, 1730 MV errors
[h264 @ 0x8973e70] concealing 738 DC, 738 AC, 738 MV errors
[h264 @ 0x8973e70] number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x8973e70] concealing 2756 DC, 2756 AC, 2756 MV errors
[h264 @ 0x8973e70] concealing 944 DC, 944 AC, 944 MV errors
[h264 @ 0x8973e70] concealing 1843 DC, 1843 AC, 1843 MV errors
[mp2 @ 0x8976d30] Header missing   12950kB time=142.22 bitrate= 745.9kbits/s dup=2386 drop=0
Error while decoding stream #0.3
[h264 @ 0x8973e70] cabac decode of qscale diff failed at 57 22
[h264 @ 0x8973e70] error while decoding MB 57 22, bytestream (4990)
[h264 @ 0x8973e70] concealing 1832 DC, 1832 AC, 1832 MV errors
Gruß
Frodo

Meine VDR Hardware


YaVDR 0.5: TT S2-6400 und Sundtek SkyTV Ultimate (DVB-S/S2), Zotac H77ITX-C-E, Geforce 620, SilverStone ML02B-MXR, IMON LCD, softhddevice / dvbhddevice
YaVDR 0.5: Sat>IP (OctopusNet) über vtunerc, Zotac D2550ITX, Geforce 610, IMON VFD, softhddevice
YaVDR 0.5: Cine S2 V6, Intel DQ67SW, Geforce 210, SilverStone LC16M, IMON VFD, softhddevice
YaVDR 0.5: TT S2-3200, Intel DH67BL, Geforce 430, softhddevice
YaVDR 0.5: TT S2-6400, Intel DH67CF, dvbhddevice
Test HD TV-Karten: TT S2-3200, Sundtek SkyTV Ultimate (DVB-S/S2) , TeVii S480, TT-connect CT-3650 CI

209

Thursday, May 19th 2011, 10:27pm

Quoted

Gibt es keine Möglich keit eine kleinere Auflösung zu streamen?
Einstellungen/Streamineinstellungen/Streamarten
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

Oswald-Kolle

Intermediate

Posts: 415

Location: Emsland

  • Send private message

210

Friday, May 27th 2011, 10:35am

Moin zusammen!

Hatte mittlerweile ein wenig Zeit etwas rumzuspielen.... Nach anfänglichen Problemen habe ich nun eigentlich die Installation hin bekommen...

Jedoch funktioniert das Streaming nicht! :-( Also der (für mich) wichtigste Teil fehlt noch...
Logfile kann ich heute Abend posten - jedoch kommt eigentlich keine Fehlermeldung (zumindest sehe ich keine - abgesehen von der "sh: everything_works_i_m_sure: not found", die ja keine Fehlermeldung ist? ;-) )
Es öffnet sich (im Firefox unter Ubuntu - auf nem Client, nicht auf dem Server!) zwar das Video-Fenster, jedoch mit einem X in der Mitte - und wenn ich es auf dem Android (Desire mit LeeDroid) aufrufe, kommt auch das Wiedergabefenster, aber es bleibt schwarz....

Wo ist da der Ansatz, um dem Fehler am Besten auf die Spur zu kommen?

Theoretisch sollte alles (nach Deiner Anleitung) installiert worden sein.... Kann man irgendwie das Log aufblähen, dass dort mehr geschrieben wird?
- VDR-Server: yavdr 0.5 * GA-MA785GMT-UD2H mit AMD AD235EHDGQ * 2GB (KVR1333D3N9K2) * DigitalDevices Cine S2 Rev. 5.5 & DuoFlex S2 Erweiterung
- VDR-Wohnzimmer: yavdr 0.5 * Xtreamer Ultra 2 Deluxe * 4GB Ram * 32GB SSD * GeForce 520M

Oswald-Kolle

Intermediate

Posts: 415

Location: Emsland

  • Send private message

211

Friday, May 27th 2011, 1:23pm

Dies steht im ivdr.log:

Source code

1
2
3
4
[IVDR LOG: 27.05.2011 13:21:02]192.168.0.34:/ivdr?stream=live&id=S19.2E-1-1107-17502 - Method: GET - Length:  - CONFIG: iVDR]
Streamcommand: ./istream.sh http://192.168.0.31:3000/TS/8 " " 512k 128k 480x320 /tmp/session0 20 /usr/lib/cgi-bin/ivdr/ffmpeg/bin/ffmpeg /usr/lib/cgi-bin/ivdr/ffmpeg/bin/segmenter /dev/shm/ram//session0
sh: everything_works_i_m_sure: command not found
Fertig!

Das Fertig! kommt direkt, nachdem das Flash-Fenster mit dem X drin erscheint...

Wo muss ich suchen??
- VDR-Server: yavdr 0.5 * GA-MA785GMT-UD2H mit AMD AD235EHDGQ * 2GB (KVR1333D3N9K2) * DigitalDevices Cine S2 Rev. 5.5 & DuoFlex S2 Erweiterung
- VDR-Wohnzimmer: yavdr 0.5 * Xtreamer Ultra 2 Deluxe * 4GB Ram * 32GB SSD * GeForce 520M

212

Saturday, May 28th 2011, 9:03am

Der sream läuft leider nicht out-of-the-box in android. Bis jetzt nur über einen Umweg möglich, indem man den stream in einem externen Player startet.
Es muss aber was in der iui_dev.js geändert werden damit sich der link kopieren lässt.
[ANNOUNCE] iVDR 0.3.2 - VDR WebFrontend for Touch Devices

Ich bin an dem Thema noch dran, bekomme hoffentlich demnächst mein SGS2. :] Dann kann ich iVDR auf Android zum laufen bringen.

Gruß
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

213

Sunday, May 29th 2011, 12:09am

Hallo,

ich bekomme beim Aufruf des Skripts immer ein 500 Internal Server Error, wenn ich des Skrpt über SSH ausführe folgendes:
./ivdr.pl
Content-Type: text/html; charset=utf-8

Speicherzugriffsfehler

Und in der /var/log/syslog wird folgendes ausgegeben:
May 29 00:03:36 HTPC kernel: [ 982.299924] ivdr.pl[1948]: segfault at 8 ip 08144e94 sp bfbab520 error 6 in perl[8048000+12c000]

Weiß jemand hierzu Rat? Danke!
yaVDR 0.5, Zotac ION ITX F, Digital Devices Duoflex CT V2, Mushkin SSD, 2x2 TB Samsung HDD (SATA), Blu Ray Brenner, Atric IR-Einschalter an Com-Port, Conrad MF 355 RF Fernbedienung, Logitech Anywhere, 3x Bluetooth Audio, MPD, beets…

Oswald-Kolle

Intermediate

Posts: 415

Location: Emsland

  • Send private message

214

Sunday, May 29th 2011, 8:40am

Der sream läuft leider nicht out-of-the-box in android. Bis jetzt nur über einen Umweg möglich, indem man den stream in einem externen Player startet.
Es muss aber was in der iui_dev.js geändert werden damit sich der link kopieren lässt.
[ANNOUNCE] iVDR 0.3.2 - VDR WebFrontend for Touch Devices

Ich bin an dem Thema noch dran, bekomme hoffentlich demnächst mein SGS2. :] Dann kann ich iVDR auf Android zum laufen bringen.

Gruß
Moin!
Mit der Änderung habe ich es nun auch hin bekommen, den Stream am Handy sehen zu können (über Link kopieren und im VPlayer einfügen).
Allerdings ist es ein ziemlich großes Problem, dass: Wenn ich 5 Minuten warte, bevor ich den Link dann im VPlayer habe, ich auch bei t-5 Minuten mit der Wiedergabe beginne! Es ist also kein live-Stream, sondern ein zeitversetztes Sehen! Wieso muss der Stream eigentlich noch zwischengespeichert werden? Gibt es keine Möglichkeit "on the Fly" zu streamen?

Habe mich nicht genauer mit beschäftigt, aber eventuell wäre subsonic (subsonic.org) ein Projekt, wo Du Informationen zum Streamen abzweigen könntest - dort werden MP3s und Videos konvertiert und im Browser ausgegeben - das läuft sowohl am PC als auch unter Android direkt ohne Probleme....

Gruss,
Mario
- VDR-Server: yavdr 0.5 * GA-MA785GMT-UD2H mit AMD AD235EHDGQ * 2GB (KVR1333D3N9K2) * DigitalDevices Cine S2 Rev. 5.5 & DuoFlex S2 Erweiterung
- VDR-Wohnzimmer: yavdr 0.5 * Xtreamer Ultra 2 Deluxe * 4GB Ram * 32GB SSD * GeForce 520M

215

Monday, May 30th 2011, 10:10am

@klodeckl: Sieht fast nach einem Hardwareproblem aus!?!? Oder Perl läuft niht richtig. Ist die aktuelle version installiert? Perl 5.*!
Ansonsten perl nochmal neu installieren und/oder die Fehlermeldung googlen!

@Oswald-Kolle:
Danke für den hinweis, werde ich mir mal anschauen. Habe gerade ein SGSII bestellt. 5-8 Werktage ist es da! :D *freu*
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

Habib

Professional

Posts: 732

Location: Bremer Raum

Occupation: Student

  • Send private message

216

Monday, June 13th 2011, 9:53pm

Hi,

ich hab heute das iVDR 0.3.2 installiert (nutze REEL Testung 10.12) und hätte gerne für externes Streaming das Profil aktiviert. Jetzt hab ich es so verstanden, dass die Profile automatisch vom aufrufenden Device abhängig sind (iPad oder iPhone). Im WLAN klappt das auch alles nur wenn ich extern was schauen möchte, dann ist es doch sehr ruckelig.
Es gibt ja ein Profil names extern, wir erzwinge ich denn dieses?

Danke :-)
Gruß
Habib

--------------------------------
Aufnahme-Server:
Silverstone Lascala SST-LC10M
Reel Stable 11.12.2, HDe, 1x 2TB HDD als Aufnahme Server, iVDR 0.3.2 (manuelle Fixe f. Aufnahmeverz.)
Netceiver mit 3x DUAL DVB-S2
Clients:
3x REEL NetClients
Reel Stable 11.12.2

Habib

Professional

Posts: 732

Location: Bremer Raum

Occupation: Student

  • Send private message

217

Monday, June 13th 2011, 10:27pm

Ah... ich glaube ich habe verstanden. Wenn man die Profile verschiebt dann wird immer das oberste Profil für alle folgenden Streams genommen... ist das so korrekt wiedergegeben?
Ich hab allerdings noch einen segmention fault wenn ich versuche ZDF HD auf dem Profil extern wiederzugeben... schade. Das iphone Profil haut hin, allerdings nur per WLAN.

Blödsinn, das mit dem Segmention Fault nehme ich zurück, dass war wohl nur ein vorübergehender Fehler...
Gruß
Habib

--------------------------------
Aufnahme-Server:
Silverstone Lascala SST-LC10M
Reel Stable 11.12.2, HDe, 1x 2TB HDD als Aufnahme Server, iVDR 0.3.2 (manuelle Fixe f. Aufnahmeverz.)
Netceiver mit 3x DUAL DVB-S2
Clients:
3x REEL NetClients
Reel Stable 11.12.2

This post has been edited 1 times, last edit by "Habib" (Jun 13th 2011, 10:35pm) with the following reason: Korrektur


218

Monday, June 13th 2011, 11:09pm

Ich muss das echt mal in die FAQs aufnehmen. :idee

:D Abbrechen bei "direkt starten?" drücken.

Die streams werden nicht automatisch gewählt, wär aber mal was! ;D
my VDR...
VDR 1.7.10 | XBMC | Ubuntu Karmic |MSI G45M Digital | Pentium Dual-Core E5200 2.50GHz | 6GB RAM | TT S-2300 + Speichermod + Full TS Mod (selfmade) | TT S-1600

my SZ-VDR...
VDR 1.7.10 | XBMC als Frontend | Ubuntu Karmic | Aspire Revo | Intel Atom 230 1,6 Ghz | 2GB RAM | Streamdevclient

myProjects...
iVDR - VDR-Frontend and LiveTV for TouchDevices

219

Sunday, June 19th 2011, 10:48am

Hi,

ich versuche gerade iVDR i der aktuellen beta vom ReelVDR zum laufen zu bekommen. Es geht alles bis auf die Remote "Seite" hier wird nur
die Volumenanzeige gezeigt (der Rest Schalter / Tasten fehlen).

iVDR.log

Source code

1
2
3
4
5
[IVDR LOG: 19.06.2011 10:38:59]192.1.1.27:/cgi-bin/ivdr.pl?stream=overview - Method: GET - Length: 0 - CONFIG: easyBox für iOS]
[IVDR LOG: 19.06.2011 10:38:59]192.1.1.27:/cgi-bin/ivdr.pl?STAT - Method: GET - Length: 0 - CONFIG: easyBox für iOS]
[IVDR LOG: 19.06.2011 10:39:00]192.1.1.27:/cgi-bin/ivdr.pl?REMOTE - Method: GET - Length: 0 - CONFIG: easyBox für iOS]
[IVDR LOG: 19.06.2011 10:39:01]192.1.1.27:/cgi-bin/ivdr.pl?REMOTE - Method: GET - Length: 0 - CONFIG: easyBox für iOS]
[Sun Jun 19 10:39:02 2011] ivdr.pl: couldn't parse mediastream.pl: Couldn't open file: No such file or directory


iVDR.pl

Source code

1
2
3
4
if ($cgi->url_param('media')) {
do "mediastream.pl";
warn "couldn't parse mediastream.pl: $@" if $@;
exit(0);


Die mediastream.pl liegt aber in ../cgi-bin/components/ ?


EDIT:
es war nur eine defkte rc.pl -> nach dem Austausch ist alles ok! :D



Grüße
cinfo
Server mit Tunerstation: NetCeiver, 5x DVB-S2 extern, AVG 1, SSD: 64GB, HD1 750GB Client1: Intel D510MO,Reel eHD, 2GB RAM, SSD: 64 GB Software: Ubuntu 10.04-14.04, VDR-1.7.29 , Kernel: 3.x NAS: CPU Intel Atom 1.8 GHz, 2GB RAM mit 4 TB Speicher Client1-2: MediaMVP Revision H4 / Raspberry PI Software: Vomp Extension Dongle/Server Version 0.4.x

This post has been edited 2 times, last edit by "cinfo" (Jun 19th 2011, 1:28pm)


220

Tuesday, June 28th 2011, 12:40am

Hi,

zunächst erstmal danke für all die Arbeit die bestimmt schon in dieses Projekt geflossen ist.

Ich bin heute mehr per Zufall auf iVDR gestoßen und versuche mich jetzt seit 3 Stunden daran es auf yavdr 0.3.0 zum laufen zu bekommen.
Dabei ist das größte Problem für mich, dass ich scheinbar nicht die richtige Stelle zum Nachlesen der Prerequisites gefunden habe, weder auf der Webseite, noch hier im Thread, noch im ivdr-zip.
Das legt die Einstiegshürde gleich deutlich höher und hat zumindest bei mir den Frustfaktor extrem erhöht. Ich weiss, das ist alles Hoobyarbeit, daher habe ich absolut kein Recht mich zu beschweren, aber vielleicht wäre eine Liste, was an Voraussetzungen gebraucht wird, auch für andere nützlich (ich hab mittlerweile garantiert ne Menge Pakete zu viel auf dem System). Und wer sollte es besser wissen als der Autor, was benötigt wird. Das dürfte auch eine Menge Supportfragen von iVDR Anfängern erschlagen.

Mittlerweile bin ich so weit, dass iVDR über lighttpd läuft und ich es von meinem Ipad2 aus erreichen kann. Die Grundkonfiguration ist auch erledigt. Allerdings würde eine in-App Info bei dem svdrp-Port, der sich scheinbar bei vdr 1.7 nicht mehr auf Port 2001 tummelt, hilfreich sein. Ich hab ne halbe Stunde alles mögliche in svdrphosts.conf rumprobiert dabei lag es am falschen Port).

Nunja, das läuft nun, also kann ich mich dem nächsten Thema - Streaming - hingeben. Und hier erhalte ich immer nur die Meldung "Something went wrong! Unknwon encoder libx264", libx264 ist allerdings installiert.
Brauche ich eine spezielle Version von ffmpeg? Wenn ja, dann heisst das wohl self-compile (gibts da vielleicht eine schöne Anleitung für?).
Server: Athlon II X2 250 - Asus M3N-H HDMI - 2x1GB RAM - 3TB HDDs -
1 x Digital Devices Cine S2 V6 DVB-S2 (SD Sender im Highband funktionieren mit der Karte nach wie vor unter Linux nicht, unter Windows schon)
3 x Nova Budget (die ich eigentlich durch die Cine S2 mit Erweiterungsmodul ersetzen wollte, leider aber für die SD Sender immer noch brauche)
mit yavdr 0.4.0