You are not logged in.

Dear visitor, welcome to VDR Portal. If this is your first visit here, please read the Help. It explains in detail how this page works. To use all features of this page, you should consider registering. Please use the registration form, to register here or read more information about the registration process. If you are already registered, please login here.

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

1

Monday, May 12th 2008, 12:22pm

aktueller v4l-dvb-hg und Cablestar2

Hallo,
ich habe Probleme aktuellen v4l-dvb-hg auf Kernel 2.6.24 mit meiner Cablestar2 zum laufen zu bekommen. Habe ich irgendetwas vergessen/übersehen?

alter Treiber ging

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
May 12 10:26:46 [kernel] Linux video capture interface: v2.00
May 12 10:26:46 [kernel] saa7146: register extension 'dvb'.
May 12 10:26:46 [kernel] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
May 12 10:26:46 [kernel] PCI: setting IRQ 5 as level-triggered
May 12 10:26:46 [kernel] ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
May 12 10:26:46 [kernel] saa7146: found saa7146 @ mem ecb70000 (revision 1, irq 5) (0x13c2,0x0002).
May 12 10:26:46 [kernel] DVB: registering new adapter (Technotrend/Hauppauge WinTV DVB-C rev2.X)
May 12 10:26:46 [kernel] adapter has MAC addr = 00:d0:5c:20:6d:b0
May 12 10:26:46 [kernel] dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80f12623
May 12 10:26:46 [kernel] dvb-ttpci: firmware @ card 0 supports CI link layer interface
May 12 10:26:46 [kernel] dvb-ttpci: Crystal audio DAC @ card 0 detected
May 12 10:26:46 [kernel] saa7146_vv: saa7146 (0): registered device video0 [v4l2]
May 12 10:26:46 [kernel] saa7146_vv: saa7146 (0): registered device vbi0 [v4l2]
May 12 10:26:46 [kernel] DVB: registering frontend 0 (VLSI VES1820 DVB-C)...
May 12 10:26:46 [kernel] input: DVB on-card IR receiver as /class/input/input7
May 12 10:26:46 [kernel] dvb-ttpci: found av7110-0.
May 12 10:26:46 [kernel] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
May 12 10:26:46 [kernel] flexcop-pci: will use the HW PID filter.
May 12 10:26:46 [kernel] flexcop-pci: card revision 2
May 12 10:26:46 [kernel] ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
May 12 10:26:46 [kernel] ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
May 12 10:26:46 [kernel] DVB: registering new adapter (FlexCop Digital TV device)
May 12 10:26:46 [kernel] b2c2-flexcop: MAC address = 00:d0:d7:08:0d:7f
May 12 10:26:46 [kernel] b2c2-flexcop: i2c master_xfer failed
                - Last output repeated 2 times -
May 12 10:26:46 [kernel] mt352_read_register: readreg error (reg=127, ret==-121)
May 12 10:26:46 [kernel] nxt200x: nxt200x_readbytes: i2c read error (addr 0x0a, err == -121)
May 12 10:26:46 [kernel] Unknown/Unsupported NXT chip: 00 00 00 00 00
May 12 10:26:46 [kernel] b2c2-flexcop: i2c master_xfer failed
May 12 10:26:46 [kernel] lgdt330x: i2c_read_demod_bytes: addr 0x59 select 0x02 error (ret == -121)
May 12 10:26:46 [kernel] b2c2-flexcop: i2c master_xfer failed
May 12 10:26:46 [kernel] b2c2-flexcop: found the stv0297 at i2c address: 0x1c
May 12 10:26:46 [kernel] DVB: registering frontend 1 (ST STV0297 DVB-C)...
May 12 10:26:46 [kernel] b2c2-flexcop: initialization of 'Cable2PC/CableStar 2 DVB-C' at the 'PCI' bus controlled by a 'FlexCopIIb' complete


aktuellen v4l-dvb-hg

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
May 12 11:56:50 [kernel] Linux video capture interface: v2.00
May 12 11:56:50 [kernel] saa7146: register extension 'dvb'.
May 12 11:56:50 [kernel] ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
May 12 11:56:50 [kernel] PCI: setting IRQ 5 as level-triggered
May 12 11:56:50 [kernel] ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
May 12 11:56:50 [kernel] saa7146: found saa7146 @ mem ecbae000 (revision 1, irq 5) (0x13c2,0x0002).
May 12 11:56:50 [kernel] DVB: registering new adapter (Technotrend/Hauppauge WinTV DVB-C rev2.X)
May 12 11:56:50 [kernel] adapter has MAC addr = 00:d0:5c:20:6d:b0
May 12 11:56:50 [kernel] dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80f12623
May 12 11:56:50 [kernel] dvb-ttpci: Crystal audio DAC @ card 0 detected
May 12 11:56:50 [kernel] saa7146_vv: saa7146 (0): registered device video0 [v4l2]
May 12 11:56:50 [kernel] saa7146_vv: saa7146 (0): registered device vbi0 [v4l2]
May 12 11:56:50 [kernel] DVB: registering frontend 0 (VLSI VES1820 DVB-C)...
May 12 11:56:50 [kernel] input: DVB on-card IR receiver as /class/input/input7
May 12 11:56:50 [kernel] dvb-ttpci: found av7110-0.
May 12 11:56:50 [kernel] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
May 12 11:56:50 [kernel] flexcop-pci: will use the HW PID filter.
May 12 11:56:50 [kernel] flexcop-pci: card revision 2
May 12 11:56:50 [kernel] ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
May 12 11:56:50 [kernel] DVB: registering new adapter (FlexCop Digital TV device)
May 12 11:56:50 [kernel] b2c2-flexcop: MAC address = 00:d0:d7:08:0d:7f
May 12 11:56:50 [kernel] b2c2-flexcop: i2c master_xfer failed
                - Last output repeated twice -
May 12 11:56:50 [kernel] CX24123: cx24123_i2c_readreg: reg=0x0 (error=-121)
May 12 11:56:50 [kernel] CX24123: wrong demod revision: 87
May 12 11:56:50 [kernel] b2c2-flexcop: i2c master_xfer failed
                - Last output repeated 2 times -
May 12 11:56:50 [kernel] mt352_read_register: readreg error (reg=127, ret==-121)
May 12 11:56:50 [kernel] b2c2-flexcop: i2c master_xfer failed
May 12 11:56:50 [kernel] nxt200x: nxt200x_readbytes: i2c read error (addr 0x0a, err == -121)
May 12 11:56:50 [kernel] Unknown/Unsupported NXT chip: 00 00 00 00 00
May 12 11:56:50 [kernel] b2c2-flexcop: i2c master_xfer failed
May 12 11:56:50 [kernel] lgdt330x: i2c_read_demod_bytes: addr 0x59 select 0x02 error (ret == -121)
May 12 11:56:50 [kernel] b2c2-flexcop: i2c master_xfer failed
                - Last output repeated twice -
May 12 11:56:50 [kernel] stv0297_readreg: readreg error (reg == 0x80, ret == -121)
May 12 11:56:50 [kernel] b2c2-flexcop: i2c master_xfer failed
May 12 11:56:50 [kernel] mt312_read: ret == -121
May 12 11:56:50 [kernel] b2c2-flexcop: no frontend driver found for this B2C2/FlexCop adapter
May 12 11:56:50 [kernel] ACPI: PCI interrupt for device 0000:00:0b.0 disabled


bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

2

Monday, May 12th 2008, 12:48pm

RE: aktueller v4l-dvb-hg und Cablestar2

Quoted

Original von netz
Hallo,
ich habe Probleme aktuellen v4l-dvb-hg auf Kernel 2.6.24 mit meiner Cablestar2 zum laufen zu bekommen. Habe ich irgendetwas vergessen/übersehen?


Mit diesem Changset gab es einige Änderungen an den I²C-Routinen. Da der stv0297 keine 'Repeated Startbedingung' versteht, solltest Du mal mit den alten I²C-Routinen testen (hg von vor dem 29.03.08).

Gruß
e9hack

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

3

Monday, May 12th 2008, 1:01pm

RE: aktueller v4l-dvb-hg und Cablestar2

Quoted

Original von e9hack

Quoted

Original von netz
Hallo,
ich habe Probleme aktuellen v4l-dvb-hg auf Kernel 2.6.24 mit meiner Cablestar2 zum laufen zu bekommen. Habe ich irgendetwas vergessen/übersehen?


Mit diesem Changset gab es einige Änderungen an den I²C-Routinen. Da der stv0297 keine 'Repeated Startbedingung' versteht, solltest Du mal mit den alten I²C-Routinen testen (hg von vor dem 29.03.08).


Füge mal in flexcop-fe-tuner.c zwischen diese beiden Zeilen

Source code

1
2
        /* try the cable dvb (stv0297) */
        fc->fe = dvb_attach(stv0297_attach, &alps_tdee4_stv0297_config, i2c);
noch

Source code

1
        fc->fc_i2c_adap[0].no_base_addr = 1;
ein.

Gruß
e9hack

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

4

Monday, May 12th 2008, 2:20pm

Hallo,
danke für die Info.
Jetzt weiß ich wenigstens, dass es nicht an mir liegt. ;)

Mit der eingefügten Zeile, manuell installiert, geht es dennoch nicht.

Source code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
saa7146: found saa7146 @ mem ecbc0000 (revision 1, irq 5) (0x13c2,0x0002).
DVB: registering new adapter (Technotrend/Hauppauge WinTV DVB-C rev2.X)
adapter has MAC addr = 00:d0:5c:20:6d:b0
dvb-ttpci: info @ card 0: firm f0240009, rtsl b0250018, vid 71010068, app 80f12623
dvb-ttpci: firmware @ card 0 supports CI link layer interface
dvb-ttpci: Crystal audio DAC @ card 0 detected
saa7146_vv: saa7146 (0): registered device video0 [v4l2]
saa7146_vv: saa7146 (0): registered device vbi0 [v4l2]
DVB: registering frontend 0 (VLSI VES1820 DVB-C)...
input: DVB on-card IR receiver as /class/input/input7
dvb-ttpci: found av7110-0.
b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
flexcop-pci: will use the HW PID filter.
flexcop-pci: card revision 2
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
DVB: registering new adapter (FlexCop Digital TV device)
b2c2-flexcop: MAC address = 00:d0:d7:08:0d:7f
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
CX24123: cx24123_i2c_readreg: reg=0x0 (error=-121)
CX24123: wrong demod revision: 87
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
mt352_read_register: readreg error (reg=127, ret==-121)
b2c2-flexcop: i2c master_xfer failed
nxt200x: nxt200x_readbytes: i2c read error (addr 0x0a, err == -121)
Unknown/Unsupported NXT chip: 00 00 00 00 00
b2c2-flexcop: i2c master_xfer failed
lgdt330x: i2c_read_demod_bytes: addr 0x59 select 0x02 error (ret == -121)
b2c2-flexcop: i2c master_xfer failed
b2c2-flexcop: i2c master_xfer failed
mt312_read: ret == -121
b2c2-flexcop: no frontend driver found for this B2C2/FlexCop adapter


Kann mir jemand sagen, wie ich von Hand einen Patch schreibe? Versuche wären dann einfacher.

Source code

1
DVB_LOCAL_PATCHES=/usr/local/portage/patches/v4l/*.diff emerge -av v4l-dvb-hg-endriss 


bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

5

Monday, May 12th 2008, 5:16pm

Quoted

Original von netz
Kann mir jemand sagen, wie ich von Hand einen Patch schreibe? Versuche wären dann einfacher.

Source code

1
DVB_LOCAL_PATCHES=/usr/local/portage/patches/v4l/*.diff emerge -av v4l-dvb-hg-endriss 


... geht auch so (mein zweiter Patch *schulterklopf* )
Jedoch leider ohne Erfolg.

Source code

1
2
3
diff -Naur linux/drivers/media/dvb/b2c2/flexcop-fe-tuner.c.orig linux/drivers/media/dvb/b2c2/flexcop-fe-tuner.c > flexcop-fe-tuner.diff
cp  flexcop-fe-tuner.diff /usr/local/portage/patches/v4l
DVB_LOCAL_PATCHES=/usr/local/portage/patches/v4l/*.diff emerge -av v4l-dvb-hg-endriss
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

6

Tuesday, May 13th 2008, 5:50pm

Quoted

Original von netz
Mit der eingefügten Zeile, manuell installiert, geht es dennoch nicht.

Jetzt gibts aber keine Fehlermeldung mehr, daß nichts vom stv0297 gelesen werden kann. Da aber der stv0297 nicht initialisiert wird, stimmt die Id vom stv0297 nicht. Du könntest mal in stv0297_readreg() ein printk() einbauen, daß den Wert vom gelesenen Register ausgibt.

Gruß
e9hack

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

7

Tuesday, May 13th 2008, 6:25pm

Hallo,
da kenne ich mich nicht mit aus ...

Ungefähr so?
http://209.85.129.104/search?q=cache:47y…eg+error+printk()&hl=de&ct=clnk&cd=1&client=opera

linux/drivers/media/dvb/b2c2/stv0297_cs2.c

Quoted

...
static int stv0297_readregI(struct stv0297_state *state, u8 reg)
{
int ret;
u8 b[] = { 0 };

if ((ret = stv0297_readregsI(state,reg,b,1)) < 0)
dprintk("%s: readreg error (reg == 0x%02x, ret == %i)\n", __FUNCTION__, reg, ret);
79 return -1;

return ret;

return b[0];
}
...


bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

8

Thursday, June 5th 2008, 1:59pm

Hallo,
hat jemand eine Lösung für die Cablestar2 mit aktuellen Treiber gefunden (v4l-dvb-multiproto, v4l-dvb-hg-endriss, v4l-dvb-hg)?

Als alternative ... :)
Kann mir jemand sagen, wie ich ein neues Thema in der linuxtv-dvb Mailingliste öffne?
(bereits eingeloggt)

[edit]Hmmm ... schreibe ich einfach eine Email an linux-dvb@linuxtv.org?[/edit]

bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

This post has been edited 1 times, last edit by "netz" (Jun 5th 2008, 2:01pm)


e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

9

Thursday, June 5th 2008, 10:42pm

Quoted

Original von netz
Kann mir jemand sagen, wie ich ein neues Thema in der linuxtv-dvb Mailingliste öffne?
(bereits eingeloggt)

[edit]Hmmm ... schreibe ich einfach eine Email an linux-dvb@linuxtv.org?[/edit]


Genau so, Du schreibst einfach eine Email an die Addresse. Es ist auch hilfreich, wenn Du das Changset einkreisen kannst, das scheinbar das Problem verursacht hat. Die Mail sollte natürlich in 'neudeutsch' sein.

Gruß
e9hack

UFO

Sage

Posts: 5,129

Location: Großherzogthum Baden

  • Send private message

10

Friday, June 6th 2008, 6:15am

Quoted

Original von e9hack
Es ist auch hilfreich, wenn Du das Changset einkreisen kannst, das scheinbar das Problem verursacht hat.

Dies ist sogar sehr wichtig:
Falls es nämlich keinen Maintainer (mehr) gibt, der diese Karte besitzt, wird die Mail wahrscheinlich leider ignoriert.

Eingrenzen kann man den Changeset dadurch, daß man
1. grob das Intervall bestimmt, wo der Fehler liegt[1,2]
2. das Intervall so lange halbiert, bis man den Changeset hat

CU
Oliver

[1] "hg update <nr>" bringt den Treiber auf den Stand des Changeset <nr>
[2] Das Intervall kann man grob eingrenzen, indem man z.B. in 1000er Schritten zurück geht.
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

11

Friday, June 6th 2008, 10:26am

Hallo,

Quoted

Original von e9hack
Die Mail sollte natürlich in 'neudeutsch' sein.

Es wird schwer, aber ich probiere es ... :)

@UFO
Danke, mit der Anleitung sollte ich herausbekommen ab wann der Treiber nicht mehr lief.
Ich schreibe es dann in die Mailinglist.

bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

12

Friday, June 6th 2008, 2:24pm

Jetzt stehe ich nur vor einem neuen Problem.
Ich habe zur Sicherheit aktuelle v4l-dvb-hg nochmal installiert und er lief. :schiel

Source code

1
2
3
4
5
6
cd /usr/local/src
hg clone http://linuxtv.org/hg/v4l-dvb
ln -s v4l-dvb DVB
cd DVB
make menuconfig # nur Module meiner Karten aktiviert (dvb-ttpci, b2c2-flexcop-pci)
make && make install


Also habe ich /usr/portage/distfiles/hg-src gelöscht und nach Deinstallieren der manuellen Installation, die Installation über emerge v4l-dvb-hg probiert.

Der Treiber läuft so nicht.
Das Dumme ist, manuell bekomme ich es mit allen Modulen (make distclean) und mit nur meinen Modulen aktiviert nicht mehr zu Laufen.

Wann brauche ich den einen Reboot?
Vergesse ich irgend etwas?

Source code

1
2
3
4
5
6
7
8
9
10
modprobe -r dvb-ttpci 
modprobe -r b2c2-flexcop-pci
cd /usr/local/src/DVB
make rminstall
make clean
make distclean
make menuconfig # nur Module meiner Karten aktiviert (dvb-ttpci, b2c2-flexcop-pci)
make && make install
modprobe dvb-ttpci
modprobe b2c2-flexcop-pci
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

13

Friday, June 6th 2008, 4:48pm

Quoted

Original von netz
Wann brauche ich den einen Reboot?
Vergesse ich irgend etwas?

Source code

1
2
3
4
5
6
7
8
9
10
modprobe -r dvb-ttpci 
modprobe -r b2c2-flexcop-pci
cd /usr/local/src/DVB
make rminstall
make clean
make distclean
make menuconfig # nur Module meiner Karten aktiviert (dvb-ttpci, b2c2-flexcop-pci)
make && make install
modprobe dvb-ttpci
modprobe b2c2-flexcop-pci


Wenn der gesamte v4l-Tree ohne Probleme kompiliert, brauchst Du keine Module wegkonfigurieren. Das kompilieren dauert nur länger.

Wenn Du die Module bei laufendem System neu laden willst, solltest Du vor dem 'modprobe xyz' immer 'make unload' im v4l-Verzeichnis ausführen. Das dahinterliegende Script entlädt auch alle abhängigen Module. Das solltest Du auch ausführen, wenn Du die Module vom normalen Kernel entladen willst.

Gruß
e9hack

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

14

Saturday, June 7th 2008, 11:06pm

Hallo,
ab changeset 7469 kann der frontend Treiber nicht mehr geladen werden.
Die Email an die Mailinglist ist raus. :)

bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

UFO

Sage

Posts: 5,129

Location: Großherzogthum Baden

  • Send private message

15

Sunday, June 8th 2008, 1:04am

Quoted

Original von netz
Hallo,
ab changeset 7469 kann der frontend Treiber nicht mehr geladen werden.
Die Email an die Mailinglist ist raus. :)

bis dann,
Nando


Hm, in 7469 hat Patrick wohl einiges umgebaut:
http://linuxtv.org/hg/v4l-dvb/rev/7fb12d754061

CU
Oliver
VDR Remote Control Plugin (Version 0.5.0): http://www.escape-edv.de/endriss/vdr
FAQ zum Remote Control Plugin: http://www.escape-edv.de/endriss/vdr/FAQ
Aktuelle Treiber: http://www.vdr-portal.de/board18-vdr-har…-s2-6400-teil-3
Full-TS-Mod für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-full-ts-mod bzw. hier
SDRAM-Erweiterung für SD full-featured Karten: http://www.escape-edv.de/endriss/dvb-mem-mod

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

16

Tuesday, June 10th 2008, 8:43pm

Hallo Oliver,
sollte ich noch gemächlich warten oder mal eine Email an Patrick schreiben?
(Irgendwie stehe ich nicht so auf Mailinglist's, zu viele Emails. :whatever )

bis dann,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

e9hack

Professional

Posts: 1,641

Location: BW in der Nähe von Esslingen

  • Send private message

17

Tuesday, June 10th 2008, 9:26pm

Quoted

Original von netz
sollte ich noch gemächlich warten oder mal eine Email an Patrick schreiben?
(Irgendwie stehe ich nicht so auf Mailinglist's, zu viele Emails. :whatever )


Eigentlich hättest Du die Mail gleich CC an Patrick schicken sollen.

So wie es aussieht, ist die Spezialbehandlung für den stv0297 entfallen. Der versteht auf dem I²C-Bus keine 'repeated start condition'.

Gruß
e9hack

18

Tuesday, June 10th 2008, 10:44pm

Hallo Netz,

nur so zur Info, ich habe mit meiner SkyStar2 mit dem aktuellen hg dieselben Probleme, mit dem alten changeset geht sie ohne Probleme.

MfG
Atti

Signatur

VDR 1: Gigabyte GA-Z77X-D3H mit i7 3770, Octopus mit 6 DVB-S2 Tunern, 120GB SSD als Systemplatte,3ware 9650SE 12*2 TB RAID für Aufnahmen und allgemeines Datengrab, Medion X10, NVidia Quadro 400 mit HDMI Adapter, HDMI Kabel durch die Wand aus dem Büro zum Fernseher im Wohnzimmer... somit herrlich ruhig...
System: yaVDR 0.5

VDR 2: Acer Aspire Revo z.Z. yaVDR 0.5

VDR 3: Zotac ZBOX ID41 z.Z. yaVDR 0.5

VDR-User #1010

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

19

Tuesday, June 10th 2008, 10:55pm

Schlecht, dass der Treiber im aktuellen v4l-dvb nicht mehr funzt. ?(
Gut, dass es nicht die Cablestar2 betrifft (mehr Leute mit SkyStar2). ;)

P.s. Email an Patrick ist raus.
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise

netz

Master

  • "netz" started this thread

Posts: 1,791

Location: Sachsen

  • Send private message

20

Wednesday, July 2nd 2008, 1:11pm

Hallo,
aus der Mailinglist oder von Patrick habe ich bis jetzt keine Rückmeldung.
Habe ich etwas verpasst oder hat sich noch nichts getan?

Ich würde gerne einen aktuelleren Treiber ausprobieren.
Der Hauptgrund liegt im Unterschied des Signalpegel/Qualität zwischen meinen beiden Karten bei gleichem Kabel.

femon -a0 -H

Source code

1
2
3
4
5
6
7
8
9
10
11
FE: ST STV0297 DVB-C (DVBC)
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   6% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal  67% | snr   5% | ber 0 | unc 0 | FE_HAS_LOCK

femon -a1 -H

Source code

1
2
3
4
5
6
7
8
9
10
11
12
FE: VLSI VES1820 DVB-C (DVBC)
status SCVYL | signal 100% | snr  92% | ber 10 | unc -1 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  92% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  92% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 0 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  92% | ber 50 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 50 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 20 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 20 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 20 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 10 | unc 0 | FE_HAS_LOCK
status SCVYL | signal 100% | snr  91% | ber 10 | unc 0 | FE_HAS_LOCK


Kann mir jemand weiterhelfen?

danke,
Nando
TEST FOXCONN 560A "Cool`n`Quiet"
Software: Gen2VDR V2 + vdr-1.6-ext59 + Nvram-Wakeup + KDE
Hardware: AMD Athlon 64 X2 Dual Core 4800+, 4GB DDR2RAM, SAMSUNG SATA HD501LJ 500 GB, SAMSUNG SP2514N 250 GB, HD SV1604N 160GB, HL-DT-STDVD-RAM GSA-H58N, Cablestar2, TTDVB-C + Scart-out + ASUS-SPDIF

Activy 300
Software: Gen2VDR V2 + vdr-1.4.7-ext40 + STR + FreeVo (Browser, Games, ... )
Hardware: 256MB SDRAM, HD SV1604N 160GB, DVD SD-M1612, FSDVB-C + Scart-out, Technisat Cablestar2, leise