Sie sind nicht angemeldet.

Lieber Besucher, herzlich willkommen bei: VDR Portal. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

1

Freitag, 2. November 2007, 00:16

Hi,

Zitat

Original von udobroemme
Jetzt funktioniert das Deinterlacing. Allerdings sieht das Ergebnis im Moment nicht besser aus, da bei den Frames, deren Decoding FFmpeg noch nicht unterstützt, jetzt wieder ein starkes Ruckeln auftritt. Ohne den Patch ruckelt nichts, allerdings hat man dann natürlich die Interlaced-Artefakte

Quellcode

1
[h264 @ 0xb61902f0]Interlaced pictures + spatial direct mode is not implemented
ist nur eine Meldung. Die Dekodierung läuft normal weiter. Das Ergebnis (Videobild) weicht aber vom "Soll" ab.

Ich denke eher, dass der Deinterlacer nicht optimal auf den Wechsel zwischen Interlaced- und Progressive-Frames reagiert. Mach' mal 'ne Aufnahme, starte die Wiedergabe und schalte in xine die Geschwindigkeit auf Minimum zurück. Gelegentlich taucht ein Frame auf, der in der aktuellen Umgebung nicht vorkommt, wohl aber in der letzten Interlace-Phase (z. B. ASTRA HD, Fußballszene mit Bayern Spielern, Anstoß, etc.).

Es ist echt lästig, die ganzen Böcke in all den Komponenten zu fixen, die man eigentlich verwenden wollte, um sich eben nicht mit deren Internas beschäftigen zu müssen, aber andererseits ist das der Vorteil von Open Source ;-)

BTW: taucht bei euch in der obigen Szene (endet mit Closeup auf Schiri) folgende Meldung auf:

Quellcode

1
illegal short term buffer state detected


Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

2

Freitag, 2. November 2007, 00:25

Hi,

Zitat

Original von JK1974
"Fast" heißt hier: Wie schon in der ffmpeg-ML als Antwort auf Deinen Patch geschrieben worden ist, funktioniert es bei Astra HD = MBAFF tatsächlich nicht.


Also MBAFF ist mir bei ASTRA HD (habe heute den ganzen Tag damit rumgespielt) noch nicht untergekommen. Bei der in der Mailingliste verwiesenen BBC_HD-Aufnahme ist MBAFF enthalten, es wurde aber nur top_field_first verwendet, und das funktioniert mit dem Patch.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

3

Freitag, 2. November 2007, 00:29

Oops, dachte, ich hätte eine Meldung gesehen, dass Astra HD MBAFF wäre, weil das der einzige Sender war, der von Anfang an ruckelfrei lief und bei dem es Probleme mit dem Deinterlacing gab (die genannte Fußball-Szene, Discovery-Channel-Szenen)...
Vielleicht es es auch nur der einzige Sender, der keinen spacial direct mode benutzt?
Deinen letzten ffmpeg-Patch werde ich aber heute wohl nicht mehr ausprobieren können - vielleicht am Wochenende. Gleiches gilt für die Schiri-Szene...
Auf jeden Fall aber mal zwischendrin nochmal danke für Deinen Einsatz!
yaVDR 0.5.0a
Intel Core2Duo E6750, Asus P5Q,
Gainward GT 240 512MB GDDR5, Hauppauge HVR-4000 & Nova-S2-HD, 4 GByte RAM
an Panasonic TX-P42GW10 und Onkyo TX-SR508

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »JK1974« (2. November 2007, 00:31)


rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

4

Freitag, 2. November 2007, 01:01

Hi,

Zitat

Original von rnissl
Ich denke eher, dass der Deinterlacer nicht optimal auf den Wechsel zwischen Interlaced- und Progressive-Frames reagiert.


Tja, und wieder haben sich zusätzlich Bad-Frames eingeschlichen (beim Übergang von Progressive nach Interlaced), die beiliegender Patch ausmerzen sollte.

Bye.
»rnissl« hat folgende Datei angehängt:
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

5

Freitag, 2. November 2007, 01:07

Hi,

Zitat

Original von JK1974
Oops, dachte, ich hätte eine Meldung gesehen, dass Astra HD MBAFF wäre, weil das der einzige Sender war, der von Anfang an ruckelfrei lief und bei dem es Probleme mit dem Deinterlacing gab (die genannte Fußball-Szene, Discovery-Channel-Szenen)...

Ne, ne, der sendet nur über lange Strecken "progressive". Außerdem gibt es ja zwei dieser Sender

Quellcode

1
2
ASTRA HD;BetaDigital:12722:hC23M5S1Z35:S19.2E:22000:10767+767:768=deu:0:0:10202:1:1119:0
ASTRA HD+;BetaDigital:11914:hI1C910M2S1Z35:S19.2E:27500:11279+1279:0;1283=deu:0:0:131:133:6:0
wobei HD nur progressive (zumindest soweit mir das aufgefallen ist) und HD+ weitgehende progressive sendet. Also bitte beide Sender bei Bugreports nicht verwechseln!

Zitat

Original von JK1974
Vielleicht es es auch nur der einzige Sender, der keinen spacial direct mode benutzt?

Nö, verwendet ihn abschnittsweise.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

6

Freitag, 2. November 2007, 10:55

Welche Patches soll ich testen? Nur den Letzten oder auch die zwei Neuen aus der ffmpeg-ML von gestern?
Als HD-Testkanal verwende ich das Astra HD, was ein paar Seiten vorher gepostet worden ist.
yaVDR 0.5.0a
Intel Core2Duo E6750, Asus P5Q,
Gainward GT 240 512MB GDDR5, Hauppauge HVR-4000 & Nova-S2-HD, 4 GByte RAM
an Panasonic TX-P42GW10 und Onkyo TX-SR508

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

7

Freitag, 2. November 2007, 13:58

Hi,

Zitat

Original von JK1974
Welche Patches soll ich testen? Nur den Letzten oder auch die zwei Neuen aus der ffmpeg-ML von gestern?
Als HD-Testkanal verwende ich das Astra HD, was ein paar Seiten vorher gepostet worden ist.

Die beiden für FFmpeg und den einen für libxine. Aber wie schon geschrieben existiert dann immer noch das Problem, das der Deinterlacer beim Übergang von progressive nach interlaced ein altes Bild einschiebt.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

8

Freitag, 2. November 2007, 18:22

Hi,
habe mal wieder ein neues Problem :hilfe und zwar kann ich zu keinem HD-Kanal mehr wechseln ohne das es mir den VDR abschießt.

Quellcode

1
2
3
4
5
6
7
8
9
SetPlayMode: 0
frame: (0, 0)-(720, 576), zoom: (1.00, 1.00)
SetAudioChannelDevice: 0
SetDigitalAudioDevice: 1
SetAudioChannelDevice: 0
SetPlayMode: 1
audio: synced early
[AMMVframe: (0, 0)-(16, 32), zoom: (1.00, 1.00)
Segmentation fault (core dumped)
SD-Kanäle gehen und ohne laufendes Xine geht es auch.

Kann mir jemand bitte helfen...

mfg bugfix
PC1: Intel Atom 330, 4GB RAM, 1TB, DVD-RW, Terratec Remote, yavdr 0.4
SRV: AMD Athlon II X4 615e, 8GB RAM, 9500GT, 6x 2TB RAID5, 2x Cablestar 2 HD, Imon+LCD, yavdr 0.4

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

9

Freitag, 2. November 2007, 19:15

Hi,

Zitat

Original von bugfix3k
habe mal wieder ein neues Problem :hilfe und zwar kann ich zu keinem HD-Kanal mehr wechseln ohne das es mir den VDR abschießt.

Quellcode

1
2
3
4
5
6
7
8
9
SetPlayMode: 0
frame: (0, 0)-(720, 576), zoom: (1.00, 1.00)
SetAudioChannelDevice: 0
SetDigitalAudioDevice: 1
SetAudioChannelDevice: 0
SetPlayMode: 1
audio: synced early
[AMMVframe: (0, 0)-(16, 32), zoom: (1.00, 1.00)
Segmentation fault (core dumped)
SD-Kanäle gehen und ohne laufendes Xine geht es auch.


Bitte mal VDR und vdr-xine mit Debug-Symbolen übersetzen. Dazu in vdr-xine's Makefile folgende Zeile aktivieren

Quellcode

1
#CXXFLAGS ?= -fPIC -g3 -O0 -Wall -Woverloaded-virtual
(durch Entfernen des # und Einfügen von # bei der bisherigen Zeile). In VDRs Makefile lautet die neue Zeile

Quellcode

1
CXXFLAGS ?= -g3 -O0 -Wall -Woverloaded-virtual
.

Tritt dann der Absturz wieder auf, den core-Dump in einen Debugger laden:

Quellcode

1
gdb /path/to/vdr /path/to/core
. Der gdb-Befehl

Quellcode

1
bt
liefert dann die Aufrufhierarchie, die zum Absturz geführt hat. Diese bitte melden.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

10

Freitag, 2. November 2007, 19:35

Hi rnissl,
die angeforderten Daten:

Quellcode

1
2
3
Program terminated with signal 11, Segmentation fault.
#0  0x00002b9d64d5c417 in delinearize (i=65496) at xineLib.c:208
208         return data_delinearize[ i ];


mfg bugfix
PC1: Intel Atom 330, 4GB RAM, 1TB, DVD-RW, Terratec Remote, yavdr 0.4
SRV: AMD Athlon II X4 615e, 8GB RAM, 9500GT, 6x 2TB RAID5, 2x Cablestar 2 HD, Imon+LCD, yavdr 0.4

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

11

Freitag, 2. November 2007, 20:14

Hi,

Zitat

Original von bugfix3k
die angeforderten Daten:

Quellcode

1
2
3
Program terminated with signal 11, Segmentation fault.
#0  0x00002b9d64d5c417 in delinearize (i=65496) at xineLib.c:208
208         return data_delinearize[ i ];


Unter einer "Aufrufhierarchie" stelle ich mir mehr vor, als nur eine Zeile ;-)

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

12

Freitag, 2. November 2007, 20:32

Zitat

Original von rnissl
Hi,

Zitat

Original von bugfix3k
die angeforderten Daten:

Quellcode

1
2
3
Program terminated with signal 11, Segmentation fault.
#0  0x00002b9d64d5c417 in delinearize (i=65496) at xineLib.c:208
208         return data_delinearize[ i ];


Unter einer "Aufrufhierarchie" stelle ich mir mehr vor, als nur eine Zeile ;-)

Bye.


:doof hab ich doch die hälfte auf der Strecke liegen lassen...
»bugfix3k« hat folgende Datei angehängt:
PC1: Intel Atom 330, 4GB RAM, 1TB, DVD-RW, Terratec Remote, yavdr 0.4
SRV: AMD Athlon II X4 615e, 8GB RAM, 9500GT, 6x 2TB RAID5, 2x Cablestar 2 HD, Imon+LCD, yavdr 0.4

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

13

Freitag, 2. November 2007, 20:58

Hi,

ist 'ne 64bit Maschine?

Schalt mal in vdr-xine's Setupmenü die OSD-Skalierung von "... Auto" auf "... HQ" (nicht "... SHQ"). Dann sollte zumindest der Absturz weg sein.

Wenn du das Problem weiter analysieren möchtest, dann wechsle mal oben in xineLib.c ASSERT_PALETTE aus, indem du der aktuellen Zeile // voranstellst und es bei der anderen entfernst. Wir sollten diese Debuggerei dann aber per Email oder im IRC fortsetzen.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

14

Samstag, 3. November 2007, 16:50

Zitat

Original von rnissl
Hi,

Zitat

Original von JK1974
Welche Patches soll ich testen? Nur den Letzten oder auch die zwei Neuen aus der ffmpeg-ML von gestern?
Als HD-Testkanal verwende ich das Astra HD, was ein paar Seiten vorher gepostet worden ist.

Die beiden für FFmpeg und den einen für libxine. Aber wie schon geschrieben existiert dann immer noch das Problem, das der Deinterlacer beim Übergang von progressive nach interlaced ein altes Bild einschiebt.

Bye.


sind das die beiden patches die für ffmpeg benötigt werden? http://lists.mplayerhq.hu/pipermail/ffmp…ber/037581.html

15

Samstag, 3. November 2007, 17:54

Ja, die habe ich gemeint.
yaVDR 0.5.0a
Intel Core2Duo E6750, Asus P5Q,
Gainward GT 240 512MB GDDR5, Hauppauge HVR-4000 & Nova-S2-HD, 4 GByte RAM
an Panasonic TX-P42GW10 und Onkyo TX-SR508

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

16

Samstag, 3. November 2007, 22:08

Hi,

zur Zeit ist kein Patch für xine-lib-1.2 (hg) erforderlich.
Zur Zeit ist kein Patch für FFmpeg-svn notwendig.

Daneben könnte auch noch der Patch für vdr-xine ausprobiert werden. Es sollten damit die "clock error" Meldungen ausbleiben (tun sie aber nicht), die auf zu langsamen Maschinen in LiveTV-Modus auftreten konnten, nachdem VDR den Puffer "gecleart" hat. Welche anderen Auswirkungen diese Änderung sonst noch hat, kann ich nicht sagen. Bitte auf etwaige Ungereimtheiten achten und diese berichten.

Bye.
»rnissl« hat folgende Datei angehängt:
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von »rnissl« (11. November 2007, 00:36)


17

Sonntag, 4. November 2007, 03:57

Hi,

habe gerade versucht, die neuen Patches auszutesten, aber ich habe wahrscheinlich irgendetwas mit den ffmpeg-Patches durcheinandergeworfen, denn Performance und Bild sind schlechter (Interlacing ist anscheinend permanent aktiviert und das Bild wirkt stellenweise wie "zerrissen").
Brauche ich noch den ffmpeg-Patch von http://www.vdr-portal.de/board/thread.ph…4938#post664938?
Und die beiden Patches von http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2007-November/037581.html schließen sich ja gegenseitig aus, und "nur" der zweite davon ist "approved" worden. Welcher ist hier der Richtige?
yaVDR 0.5.0a
Intel Core2Duo E6750, Asus P5Q,
Gainward GT 240 512MB GDDR5, Hauppauge HVR-4000 & Nova-S2-HD, 4 GByte RAM
an Panasonic TX-P42GW10 und Onkyo TX-SR508

18

Sonntag, 4. November 2007, 12:53

Langsam komme ich auch etwas ins Straucheln, was die Auswahl der Patches angeht. Sehe ich das richtig, dass für xine-lib aus dem hg nur noch der zuletzt gepostete Patch nötig ist?
Dr. Brömme grübelt:
Acht Wochen, nachdem man ihm beim Kölner Straßenkarneval einen Gratiskorn angeboten hatte,
dämmert ihm langsam, dass er einem hinterlistigen Alaafisten aufgesessen ist.

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

19

Sonntag, 4. November 2007, 13:15

Hi,

Zitat

Original von udobroemme
Langsam komme ich auch etwas ins Straucheln, was die Auswahl der Patches angeht. Sehe ich das richtig, dass für xine-lib aus dem hg nur noch der zuletzt gepostete Patch nötig ist?

Korrekt. Ich hoffe, ich habe das oben nun klargestellt.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

rnissl

Fortgeschrittener

  • »rnissl« ist der Autor dieses Themas

Beiträge: 555

Wohnort: Kulz / Thanstein

Beruf: Software-Entwickler

  • Nachricht senden

20

Sonntag, 4. November 2007, 13:19

Hi,

Zitat

Original von JK1974
habe gerade versucht, die neuen Patches auszutesten, aber ich habe wahrscheinlich irgendetwas mit den ffmpeg-Patches durcheinandergeworfen, denn Performance und Bild sind schlechter (Interlacing ist anscheinend permanent aktiviert und das Bild wirkt stellenweise wie "zerrissen").

Verwendest du ...,use_progressive_flag=0 beim Deinterlacer, was ihn durchgehend aktiviert?
Verwendest du -V xshm? Habe hier mit -V xv getestet.

Zitat

Original von JK1974
Brauche ich noch den ffmpeg-Patch von http://www.vdr-portal.de/board/thread.ph…4938#post664938?
Und die beiden Patches von http://lists.mplayerhq.hu/pipermail/ffmpeg-devel/2007-November/037581.html schließen sich ja gegenseitig aus, und "nur" der zweite davon ist "approved" worden. Welcher ist hier der Richtige?

Habe ich oben klargestellt.

Bye.
--
Dipl.-Inform. (FH) Reinhard Nissl
mailto:rnissl@gmx.de

Immortal Romance Spielautomat