[0.2] K-Data WakeUp Board

  • Hallo.


    Ich versuche das genannte WakeUp Board unter yavdr ans Drehen zu bekommen. Habe die Debian Scripte von Frank Jepsen an die passende Stellen kopiert aber es funktioniert nicht. Da das Script beim herunterfahren den Lirc beendet um dann die Weckzeit einzustellen vermute ich unter yavdr / Ubuntu Karmic dort das Problem, weil in der Syslog folgende Meldung beim Herunterfahren erscheint:


    Code
    1. Mar 27 22:35:42 vdr lircd-0.8.6[2092]: caught signal
    2. Mar 27 22:35:42 vdr vdr: [2309] ERROR: lircd connection broken, trying to reconnect every 3.0 seconds
    3. Mar 27 22:35:42 vdr init: remoted main process (2092) killed by TERM signal
    4. Mar 27 22:35:42 vdr init: remoted main process ended, respawning
    5. Mar 27 22:35:42 vdr lircd-0.8.6[2720]: lircd(default) ready, using /var/run/lirc/lircd
    6. Mar 27 22:35:45 vdr vdr: [2309] reconnected to lircd
    7. Mar 27 22:35:45 vdr lircd-0.8.6[2720]: accepted new client on /var/run/lirc/lircd
    8. Mar 27 22:35:48 vdr kernel: Kernel logging (proc) stopped.


    Kann es sein, dass sich das Script nicht mit upstart verträgt bzw. sich da was ins Gehege kommt?


    Die Scripte von Frank Jepsen gibt es da: vdr-wakeup_ctvdr_v3.0.tar.bz2


    Gruß


    Obelix



    The post was edited 1 time, last by obelix ().

  • Guten Morgen,


    ich habe den Thread Titel mal um [0.2] ergänzt. Bei yavdr 0.2 hat das Setzten des Timers einmal funktioniert. Interessant war, dass beim Shutdown ein 3 Minuten Counter aufgetaucht ist. Ab diesem Zeitpunkt funktionierte die FB nicht mehr. Nach Ablauf dieser Zeit, fuhr der VDR herunter und die Wakeup Zeit wurde korrekt ans Board übermittelt.


    Leider war dies eine einmalige Sache. Egal was ich nun anstelle, es wird kein Timer ans Board übertragen. Im Syslog taucht folgendes auf:



    Gruß


    Obelix



    The post was edited 1 time, last by obelix ().

  • Moin,


    ich habe das selbe Problem. Aus irgend einem Grund scheint der lircd wieder zu starten, das passiert auch wenn man einfach /etc/init.d/lirc stop ausführt oder den Prozess abschießt.

    Code
    1. Jul 11 12:08:03 vdr-hd lircd-0.8.6[2190]: caught signal
    2. Jul 11 12:08:03 vdr-hd init: remoted main process (2190) killed by TERM signal
    3. Jul 11 12:08:03 vdr-hd init: remoted main process ended, respawning
    4. Jul 11 12:08:03 vdr-hd vdr: [1536] ERROR: lircd connection broken, trying to reconnect every 3.0 seconds
    5. Jul 11 12:08:03 vdr-hd lircd-0.8.6[2208]: lircd(default) ready, using /var/run/lirc/lircd


    Ich versuche gerade heraus zu finden warum das so ist und wie man das unterbinden kann. Ich denke bei dir hat das einmal zufällig funktioniert, da hats das script einmal geschafft dazwischen zu kommen.


    Gruß Oga

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C

    The post was edited 1 time, last by ogawoga ().

  • Moin,


    lirc wird per upstart gestartet mir der option respawn was dazu führt das lircd neu gestartet wird wenn es von aussen beendet wird.


    ich habe in /usr/share/vdr/shutdown-hooks/S99.wakeup-module.sh folgendes geändert.


    Quote


    #/etc/init.d/lirc stop
    stop remoted


    Wichtig ist dabei auch das das skript als letzter hook aufgerufen wird (S99) da remoted knallhart gestoppt wird und danach die serielle schnittstelle umgestellt wird. Würde danach ein hook fehl schlagen bliebe der vdr am laufen und die FB würde nicht mehr funktionieren.


    Gruß Oga

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C

  • Ich hab noch eine Ergänzung:


    Quote


    logger -t vdr-addon-hw-wakeup "echo ATS$WAKEUPSTR > $WAKEUP_PORT"
    echo 0 > $WAKEUP_PORT
    echo ATS$WAKEUPSTR > $WAKEUP_PORT


    echo 0 > $WAKEUP_PORT schickt eie Zeile zum Wakeup Board ... bei mir wurde die erst geschickte Zeile ignoriert... wenn sie doch durch kommt sollte sie aber keinen Schaden anrichten.


    Gruß Oga

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C

  • Hallo Oga. Danke für die Info. Werde es die Tage mal testen.


    Gruß


    Obelix



  • Hallo zusammen,


    mit yaVDR 0.5 sind Änderungen am Script /usr/share/vdr/shutdown-hooks/S98.wakeup-module.sh von Frank nötig.


    Die Nullzeile vor den ersten Senden von Daten scheint weiterhin nötig zu sein (ziemlich am Ende vom Script):

    Code
    1. logger -t vdr-addon-hw-wakeup "echo ATS$WAKEUPSTR > $WAKEUP_PORT"
    2. echo 0 > $WAKEUP_PORT
    3. echo ATS$WAKEUPSTR > $WAKEUP_PORT


    Desweiteren muss lircd gestopp werden und die lirc module entladen werden um auf die Serielle Schnittstelle zugriff zu bekommen, das geht jetzt nicht mehr per /etc/init.d/lirc stop sondern so:

    Code
    1. logger -t vdr-addon-hw-wakeup "Shutting down LIRC"
    2. stop lircd
    3. rmmod lirc_serial
    4. rmmod lirc_dev
    5. setserial $WAKEUP_PORT uart 16550A
    6. sleep 1


    Viel Spaß und Gruß Oga

    SW: c't VDR mit e-tobi, vdr 1.4.x, Kernel 2.6.18.1 (PowerNow! Patch + HG Treiber), Bootzeit: 45s
    HW: PC-Chips M811, AMD Geode NX 1750+@1.125V, 512MB RAM, 1GB CF, 100MBit LAN, DVD-ROM, TT2.3 modded (4MB + S-Video, IR, S/PDIF über J2), 1 x TT-Budget S1401, 2 x TT-Budget, 256x64 GVFD, WakeUP + 4x40 LCD
    Gehäuse: 8mm Alu, Netzteil: 300W passiv Umbau, Verbrauch|CPU|Gehäuse: @533Mhz(Idle) 59W|37°C|33°C, @1400Mhz(100%) 81W|46°C|41°C

  • Hallo,


    schön, dass ihr diese Vorarbeit gemacht habt. Ich hoffe ich komme diesen Herbst/Winter auch dazu auf yaVDR umzusteigen.


    Vielleicht könnt ihr mal die Scripte zusammenpacken. Dann tue ich sie mit auf die VDR-Wakeup-Downloadseite.


    Tschüß Frank