Fritz WLAN USB Stick Installieren

  • Hallo, ich hätte da ein kleines problem... ich habe mir den Fritz WLAN USB Stick gekauft und wollte ihn auf meiner Activy auf gen2vdr installieren....


    habe mir den Treiber: http://download.avm.de/cardwar…2/fwlanusb-1.00.00.tar.gz gezogen, aber nun weiss ich nicht wie ich was installieren kann...


    kann mir jmd von euch sagen wie ich die Software installieren kann?


    Hab auch nicht wirklich was im Board gefunden für gen2vdr


    mfg
    datastreamer

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

    Edited 2 times, last by datastreamer ().

  • Obwohl das hier schon oft genug im Forum kam, nochmal in aller Kürze:


    - das Treiber - Archiv in ein Extra-Verzeichnis entpacken, z. B. unter /usr/src


    - dann in dieses Verzeichnis wechseln und die dortige README bzw. INSTALL lesen und die enthaltenen Anweisungen befolgen


    - die lauten in etwa: 'make' und dann 'make install' ausführen


    Hier nochmal der Info-Text von der AVM-Seite:


    Code
    The archives in this directory contain the current packages.    
     Please copy the file to your computer and extract the file   
     with the command 	 tar -xzvf <ARCHIVE NAME>   
    
    
     A subdirectory containing the installation files will be created 
     automatically. Install the software from this dirctory according to 
     the installation instructions in the files "LIESMICH.HTML / README.HTML".


    Dem gibt es eigentlich nichts hinzuzufügen, außer dass du nachfolgend natürlich deine WLAN-, Netzwerk- und WEP- bzw. WPA-Konfiguration an dein übriges Netzwerk anpassen musst.


    Jörg


    P.S.:


    Ich habe nochmal in die Liesmich.html reingeschaut. Darin ist alles sehr schön und ausführlich beschrieben. Im Paket ist sogar ein Install-Skript enthalten. Leichter geht die Installation kaum noch. Außerdem sind auch Ausführungen zur übrigen Konfiguration enthalten.


    Eins noch: Das waren alles Bemerkungen zu Linux allgemein. Ob speziell unter Gen2vdr etwas beachtet werden muss, weiss ich nicht, da ich es nicht verwende.

    VDR 1: Gehäuse Thermaltake Tenor, Asus P5KR mit P4 E5300, Samsung HDD, Digital Devices Cine2 (Dual DVB-S2 Budget), MSI GT220 passiv mit easyVDR 0.8.06
    VDR 2: Samsung SMT 7020S mit mld-smt 2.0

    Edited once, last by j6scjo ().

  • Ja, ich hab alles gemacht... nur bin ich am verbindungsaufbeu hängen geblieben..... laut der readme ist das der befehl


    'wpa_supplicant -Dwext -i wlan0 -c config-wpa2 -dd'


    aber der geht nicht... ich bin in dem Fritz verzeichniss was sich wiederrum in /tmp befindet...



    da sagt er immer:
    vdr01 ~ # 'wpa_supplicant -Dwext -i wlan0 -c config-wpa2 -dd'
    -bash: wpa_supplicant -Dwext -i wlan0 -c config-wpa2 -dd: command not found
    vdr01 ~ #




    weiter hatte ich ein problem bei


    Mit dem Befehl "lsmod" können Sie zusätzlich überprüfen, ob das Modul geladen wurde. Die Ausgabe sollte den folgenden Eintrag enthalten:
    -fwlanusb


    folgende ausgabe kommt:


    dr01 ~ # lsmod
    Module Size Used by
    fwlanusb 608032 0
    usb_storage 66368 0
    sg 32168 0
    snd_pcm_oss 49600 0
    snd_mixer_oss 17664 2 snd_pcm_oss
    snd_seq_oss 32768 0
    snd_seq_midi_event 8064 1 snd_seq_oss
    snd_seq 53360 4 snd_seq_oss,snd_seq_midi_event
    snd_seq_device 9228 2 snd_seq_oss,snd_seq
    realmagic84xx 11548 2
    packetcommand 40424 0
    lnbp21 3200 1
    tda826x 5128 1
    tda10086 10248 1
    budget 13704 15
    budget_core 12428 1 budget
    saa7146 19852 2 budget,budget_core
    ttpci_eeprom 3584 1 budget_core
    dvb_core 77388 2 budget,budget_core
    e100 35344 0
    snd_intel8x0 33856 1
    snd_ac97_codec 90916 1 snd_intel8x0
    ac97_bus 3456 1 snd_ac97_codec
    snd_pcm 81676 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
    snd_timer 25096 2 snd_seq,snd_pcm
    snd_page_alloc 11528 2 snd_intel8x0,snd_pcm
    i2c_i801 8972 0
    i2c_dev 8836 0
    i2c_core 22912 8 lnbp21,tda826x,tda10086,budget,budget_core,ttpci_eeprom,i2c_i801,i2c_dev



    hmm in der fritzbox wlan liste taucht meine activy jedoch nicht auf.... und der befehl zum verbindungsaufbau funzt auch net

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

  • Ok!


    Also der Befehl 'lsmod' sagt dir schonmal, dass das Kernel-Modul geladen wurde.
    Aber es ist wohl das Programm 'wpa_supplicant' noch nicht installiert, deshalb funktioniert dieser Programmaufruf nicht.
    Ich weiss nicht genau, wie in gen2vdr Programme nachinstalliert werden, im Zweifel kann man auch wieder den Source-Code herunterladen, entpacken und im entstehenden Verzeichnis mit 'make' und 'make install' das Programm 'wpa_supplicant' installieren.
    Dann müsste wenigstens der Programmaufruf funktinieren.


    was zeigen denn im jetzigen Zustand die Befehle 'ifconfig', 'iwconfig' und 'iwlist scan' an?
    Daraus kann man schon mal ersehen, ob die WLAN-Konfiguration grundsätzlich geklappt hat und dein Access-Point gesehen wird.


    Jörg

    VDR 1: Gehäuse Thermaltake Tenor, Asus P5KR mit P4 E5300, Samsung HDD, Digital Devices Cine2 (Dual DVB-S2 Budget), MSI GT220 passiv mit easyVDR 0.8.06
    VDR 2: Samsung SMT 7020S mit mld-smt 2.0

  • Hallo, also ich habe folgendes gemacht:


    Code
    emerge --sync 
    emerge -av wireless-tools 
    emerge -av fwlanusb


    dann dauert es ein wenig nach dem ersten befehl....... dann bringt er folgende ausgaben...


    !!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentoo-de'
    * IMPORTANT: 1 config files in '/etc' need updating.
    * Type emerge --help config to learn how to update config files.


    * An update to portage is available. It is _highly_ recommended
    * that you update portage now, before any other packages are updated.
    * Please run 'emerge portage' and then update ALL of your
    * configuration files.
    * To update portage, run 'emerge portage'.


    vdr01 ~ #
    vdr01 ~ # merge -av wireless-tools
    -bash: merge: command not found
    vdr01 ~ # emerge -av wireless-tools
    !!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentoo-de'
    !!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
    !!! Is the symlink correct? Is your portage tree complete?


    vdr01 ~ # emerge -av fwlanusb
    !!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/local/layman/gentoo-de'
    !!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
    !!! Is the symlink correct? Is your portage tree complete?


    vdr01 ~ #



    ich glaube das der usb stick schon richtig installiert ist, nur bekomme ich keine verbindung zu meiner fritz box her.....



    weiss kmd evtl weiter?

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

  • Zu deinen Fragen j6scjo:


    vdr01 ~ # ifconfig
    eth0 Link encap:Ethernet HWaddr 00:30:05:6A:4B:41
    inet addr:192.168.178.5 Bcast:192.168.178.255 Mask:255.255.255.0
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:171998 errors:0 dropped:0 overruns:0 frame:0
    TX packets:108308 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:191341374 (182.4 Mb) TX bytes:15971097 (15.2 Mb)


    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:726 errors:0 dropped:0 overruns:0 frame:0
    TX packets:726 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:5300542 (5.0 Mb) TX bytes:5300542 (5.0 Mb)




    vdr01 ~ # iwconfig
    lo no wireless extensions.


    eth0 no wireless extensions.




    vdr01 ~ # iwlist scan
    lo Interface doesn't support scanning.


    eth0 Interface doesn't support scanning.



    allerdings kann ich mit dem befehl


    vdr01 src # iwlist wlan0 scan
    wlan0 Scan completed :
    Cell 01 - Address: 00:04:0E:9A:11:0A
    ESSID:"DaTaStReAm"
    IE: IEEE 802.11i/WPA2 Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : CCMP
    Authentication Suites (1) : PSK
    IE: WPA Version 1
    Group Cipher : TKIP
    Pairwise Ciphers (1) : TKIP
    Authentication Suites (1) : PSK

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

  • Bereits bei dem Befehl emerge portage kommt wieder diese meldung


    vdr01 src # emerge portage
    !!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
    !!! Is the symlink correct? Is your portage tree complete?



    hab dann trotzdem weiter gemacht aber er schreibt wieder


    * Successfully synchronized overlay "gentoo-de".
    vdr01 src # emerge -av wireless-tools
    !!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
    !!! Is the symlink correct? Is your portage tree complete?


    vdr01 src # emerge -av fwlanusb
    !!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
    !!! Is the symlink correct? Is your portage tree complete?


    EDIT: Ja, das mach ich ja, aber das geht nicht...


    hab alles so gemacht wie du es gesagt hast
    des in dem beitrag habe ich bevor ich deine befehle eingegeben habe geschrieben

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

    Edited 2 times, last by datastreamer ().


  • die wireless-tools sind ja wohl bereits schon installiert.

  • es gibt aus:


    vdr01 fritz # ls -l /etc/make.profile
    lrwxrwxrwx 1 root root 48 2008-10-25 19:06 /etc/make.profile -> ../usr/portage/profiles/default-linux/x86/2006.1

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

  • OK, dann:


    Code
    rm /etc/make.profile
    ln -s /usr/portage/profiles/default-linux/x86/2007.0 /etc/make.profile
    fixpackages
    emerge  --sync
    emerge  portage
    update-eix
    update-eix-remote update
    layman -S


    Dann sollte Portage wieder funktionieren.


    --> ACHTUNG: Das gilt NUR für Gen2VDR 2.0 NICHT für 1.x

  • hmm ich nutze aber gen2vdr 1.2 und nicht das 2.0

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

  • http://www.htpc-forum.de/forum/index.php?showtopic=4110&hl=wlan
    ich denke da sind auch grundsätzliche Sachen drin egal ob 1.2 / 2.0
    Hast Du den Stick über eine USB2.0 Karte angeschlossen ?

    Software: gen2vdr V3 ( Beta8 ) / gen2vdr V2
    Hardware: Intel 5200EE - 5N7A-VM - Scythe Shuriken - BeQuiet(Netzteil) - X10-USB Remote
    SMT 7020S & P3@900 - Testsystem mit FF und X10-USB Remote
    Links für Neueinsteiger


    "Jetzt, wo ich weiß wie es geht, versteh ich auch die Gebrauchsanleitung"

  • @MrN!ice habe einen fritz Wlan USB Stick angeschlossen

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD

  • sry C-3PO der hängt sich immer an



    vdr01 src # emerge portage
    !!! ARCH is not set... Are you missing the '/etc/make.profile' symlink?
    !!! Is the symlink correct? Is your portage tree complete?


    auf

    - Das einzige Backup das Du je brauchst ist das, wofür Du damals keine Zeit hattest -
    Hardware:
    HD-VDR:
    ASRock H77 Pro4-M, Intel Celeron G1620, 2x 2.70GHz, 2x Kingston ValueRAM DIMM 2GB, DDR3-1333, Zotac GT630 (Zone Edition), L4M Twin S2 (V6.5), 60 GB SSD System,1 TB WD RED 2,5 HD


  • 1.] Ich hänge mich nicht daran auf!!
    2.] Wenn auf einem gentoo Sytem Portage nicht funktioniert, dann ist das das ERSTE (!!) was man repariert!
    3.] Da ihr es ja alle besser wisst, kilnke ich mich hier mal aus...

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!