ivtv PVR350 Treiberinstallation

  • ist nur ne hauppauge pvr350 drin, sonst nix.

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

    The post was edited 1 time, last by Rapi ().

  • die Karte läuft, über den totem movie player kann ich tv sehen mit bild und ton. auf dem fernseher habe ich allerdings kein bild. weder osd noch sonst was....
    vdr startet immer wieder neu.

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

  • Schmeiß alle nicht lebensnotwendigen Plugins raus.

  • wirbel
    das habe ich bereits gemacht, alles rausgeschmissen (graphlcd, lirc, ....) . jetzt habe ich nur pvr350 und analog-tv installiert. habe auch schon versucht analogtv mit pvrinput zu ersetzen, hat sich aber nichts geändert.
    liegt das problem an der kernelmeldung, saa7146 unregister extension dvb und saa7146 register extension dvb ? oder suche ich am falschen ort ?

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

  • Ist doch völlig uninteressant. Du brauchst ivtv und pvr350, beides hast du scheinbar installiert.



    Wenn vdr neu startet liegt das dann eher an was andrem.

  • Rapi :


    Erst einmal herzlichen Glückwunsch zum neuen Kernel und den IVTV-Treibern.


    Ich poste Dir mal meine Einstellungen für die IVTV-Module:


    Im Verzeichnis '/etc/modutils':
    1. Die Datei 'aliases' bearbeiten (z.B. mit 'mc' = Midnight Commander, ein Norton Commander Clone). Dort mittels '#' den Eintrag 'alias char-major-81 bttv' auskommentieren.
    2. Eine neue Datei mittels 'touch ivtv' erzeugen. In diese die folgenden Einträge einfügen:



    3. Den Befehl 'update-modules' ausführen, damit werden die Änderungen in die 'modules.conf' geschrieben (auf dem 'Debian-Way')


    Im Verzeichnis '/etc' in die Datei 'modules' folgende Einträge einfügen (in der Reihenfolge):


    Code
    1. i2c_dev
    2. msp3400
    3. saa7127
    4. ivtv
    5. tda9887
    6. ivtv-fb
    7. v4l1-compat


    Dann solltest Du noch folgendes prüfen:
    Die IVTV-Treiber bringen diverse Module mit, die vom Namen her auch im normalen Kernel-Source enthalten sind. Diese normalen Module werden vom Kernel zuerst aufgerufen und damit nicht die, die die IVTV-Module benötigen (diese wurden entsprechend angepasst).


    Sieh mal unter dem Verzeichnis '/lib/modules/KERNEL-VERSION/kernel/drivers/media/video' nach, ob dort folgende Module enthalten sind:


    bttv.ko
    msp3400.ko
    tda9887.ko
    tuner.ko
    tveeprom.ko


    Wenn ja (und darauf wette ich), dann füge an alle diese aufgeführten und vorhandenen Dateien ein '.HIDE' an (z.B. 'mv bttv.ko bttv.ko.HIDE' - die IVTV-Module bringen zwar kein bttv-Modul mit, wenn dieses aber durch den Kernel geladen wurde, kann es Ärger machen, wobei du es allerdings bei der Kernel-Erstellung nicht abwählen darfst, weil dann einige andere Dinge nicht mehr gehen - das wird sich wohl erst dann Ändern, wenn die IVTV-Module in den Kernel-Source übernommen worden sind, woran die Entwickler gerade arbeiten...).
    Führe anschließend ein 'depmod -ae' aus, wodurch die Äbhängigkeit der Module neu ausgelesen und geschrieben wird.


    Nun den Rechner neu starten.


    Ich habe bei meinem Kernel die kompletten DVB-Module rausgelassen, da ich keine entsprechende Karte habe und benutze.
    Sollte der VDR sich immer noch über das saa7127-Modul beschweren, dann suche bei Dir im Modules-Verzeichnis nach den entsprechenden Treibern und hänge dort einfach ebenfalls ein .HIDE an (dann depmod -ae und neu starten).


    Sieh auch mal mittels 'lsmod' nach den geladenen Treibern. Falls sich dort ein Modul namens 'i2c-i801' befindet (wird z.B. bei meinem ASUS-Board automatisch geladen), dann suche unter 'kernel/drivers/i2c/busses' und füge dort ebenfalls ein .HIDE an. Dieses Modul hat bei mir die IVTV-Treiber immer dazu veranlasst, trotz anderslautenter Konfiguration, von 'PAL' auf 'NTSC' umzuschalten.


    So wenn das alles läuft und der VDR trotzdem nicht will, kann es nur noch am VDR selbst oder an deiner 'channels.conf' (die Kanalliste) liegen.


    Für den VDR selbst habe ich von Tobi den 'vdrdevel', 'vdrdevel-plugin-pvr350' und 'vdrdevel-plugin-pvrinput' am laufen (von Wirbel teste ich gerade das PTV-Plugin, mal sehen welches besser ist ;D ).


    Meine Kanalliste wird Dir nichts nutzen, da ich an einer Hausverteileranlage sitze, die aus SAT-Empfang analog-TV macht, und sich zudem nicht an die eigentlich definierten Frequenzlisten hält.


    Gruß
    Zwickel

    yavdr 0.2, POV 330, Cine S2 Dual DVB-S2 (V5.5), OriginAE M10, mit HDMI an Samsung UE32B7090

    The post was edited 5 times, last by Zwickel ().

  • Danke erstmal für die rege Unterstützung !!


    @ zwickel: super anleitung !
    bin eben daran es umzusetzen, leider stecke ich bei "mittels touch ivtv neue datei erstellen und folgendes eintragen" ich arbeite unter X, wo soll denn nun die neue Datei hin und wie soll sie heissen ?


    werde sofort weitermachen, wenn ich diese datei erstellen konnte... :O




    p.s. kanalliste habe ich diverse beispiele aus dem netz für analog verglichen und gesehen, das sich nur die senderfrequenzen unterscheiden. diese frequenzen habe ich vom kabelbetreiber aus dem internet geholt und eingetipselt. nun steht da folgendes:
    :pvrinput
    SF1:182250:C0:C:0:301:300:305:A1:12003:0:0:0
    RTL:287250:C0:C:0:301:300:305:A1:12003:0:0:0 usw.


    weiss allerdings nicht, ob die zahlen, welche nach den freqûenzen kommen stimmen.
    habe auch wie du von tobi den vrd-devel, vdr-devel-pvr350 und vdr-devel-pvrinput am laufen.

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

    The post was edited 1 time, last by Rapi ().

  • Ordne mal jedem Sender eine eindeutige ID zu. So wie du das machst indem du jedem Sender die 12003 gibst wird das nix.

  • Hallo,


    Quote

    Original von Rapi
    die Karte läuft, über den totem movie player kann ich tv sehen mit bild und ton. auf dem fernseher habe ich allerdings kein bild. weder osd noch sonst was....
    vdr startet immer wieder neu.


    Verstehe ich das richtig: der Fernsehenempfang geht mit totem, solange die Ausgabe auf dem Monitor passiert? Der von mir angegebene Befehl funktioniert aber nicht? Hast Du vdr vor dem Test beendet, am besten mit kill?


    Das läßt darauf schließen, dass der ivtv-Treiber richtig lädt. Es könnte aber sein, dass der Ausgabetreiber ivtv-fb fehlt. Bitte einmal mit lsmod | grep ivtv-fb nachsehen, ob er geladen ist. Wenn er geladen ist, solltest Du mit

    Code
    1. mplayer -vo fb:/dev/fb0 <videofile>

    ein Video auf dem Fernseher sehen können. Eventuell musst Du statt /dev/fb0 /dev/fb1 angeben, das hängt vom dem System ab.


    Zwickels Anweisung gelten nur für die Kernel-Version 2.4, nicht aber für 2.6, sie zu befolgen bringt Dir nichts.


    Grüße,
    EddieT

    PIII-866, 512 MB Ram, Avermedia 761 DVB-T, PVR150MCE, Debian unstable, vdr 1.3.38, Xine über Xorg auf GF2MX

  • hallo eddieT
    so ist es: wenn ich den fernsehempfang mit totem auf den monitor leite, kann ich fern sehen am monitor. doch wenn ich den totem beende und das selbe nochmal mache (z.b. andere frequenz) dann steigt er aus wegen einem buffer overflow.....


    genau dieser ausgabetreiber greb ivtv-fb wird nicht geladen.

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

  • Hallo Rapi,


    Quote

    Original von Rapi
    hallo eddieT
    so ist es: wenn ich den fernsehempfang mit totem auf den monitor leite, kann ich fern sehen am monitor. doch wenn ich den totem beende und das selbe nochmal mache (z.b. andere frequenz) dann steigt er aus wegen einem buffer overflow.....


    Vermutlich hast Du gleich zwei Probleme: erstens einen instabilen Treiber für die PVR350 und dann fehlt noch der Ausgabetreiber.
    Führe doch bitte mal den folgenden Befehl aus:

    Code
    1. modinfo tuner ivtv ivtv-fb tveeprom msp3400 | grep filename


    Jetzt sollte für jedes Modul angegeben werden, von wo es geladen wird. Das Verzeichnis sollte bei allen gleich sein, ich würde so etwas wie /lib/modules/2.6.12.6/ivtv/ erwarten.
    Wenn Module aus einem anderen Verzeichnis geladen werden, must Du diese durch umbenennen deaktiveren, wie es Zwickel beschrieben hat. Danach depmod -ae nicht vergessen!
    Weiterhin solltest Du sicherstellen, das erstmal den Treibern keine Parameter mitgegeben werden. Bei der Version 0.4.0 wurde einiges geändert und die übergebenen Paramter können jetzt negative Effekte haben.

    Code
    1. grep "options tuner" /etc/modprobe.d/*
    2. grep "options ivtv" /etc/modprobe.d/*
    3. grep "options msp3400" /etc/modprobe.d/*
    4. grep "options tda9887" /etc/modprobe.d/*
    5. grep "options saa7115" /etc/modprobe.d/*
    6. grep "options saa7127" /etc/modprobe.d/*

    sollte nichts ausgeben. Ansonsten sind die entsprechenden Zeilen in der angegebenen Datei mittels eines vorangestellten "#" auszukommentieren und update-modules aufzurufen
    Wenn Du irgendetwas geändert hast, musst Du unbedingt Rechner 5 Min auszuschalten. Nur so werden die PVR-Karten sicher zurückgesetzt.


    Quote

    Original von Rapi


    genau dieser ausgabetreiber greb ivtv-fb wird nicht geladen.


    Lade den Treiber mal mit

    Code
    1. modprobe ivtv-fb

    und versuche erneut ein Video wie oben angegeben abzuspielen. Es sollte gehen oder zumindestens eine sinnvolle Fehlermeldung ausgeben.
    Grüße,
    EddieT

    PIII-866, 512 MB Ram, Avermedia 761 DVB-T, PVR150MCE, Debian unstable, vdr 1.3.38, Xine über Xorg auf GF2MX

  • @ zwickel , sorry wie soll die neue datei in /etc/modutils heissen ?


    @ eddieT, die module werden alle aus der selben quelle geladen, wie du richtig erwartet hast aus /lib/modules/2.6.12.6/ivtv



    mit den befehlen grep "options saa7127" /etc/modprobe.d/* passiert nichts, hab alle durchgetestet.


    Quote

    VDR:~# grep "options saa7127" /etc/modprobe.d/*
    VDR:~#


    irgendwann wird das ding gebändigt :]

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

  • ich glaub es nicht, es läuft !!!!


    mit 'modprobe ivtv-fb' , dann vdrvevel starten und siehe da, es läuft, ich fass es nicht !!! die fehlermeldung mit dem register/unregister ist auch weg.
    jetzt weiss ich nur noch nicht wo ich 'modprobe ivtv-fb' eintragen muss, das er ihn selber startet, dann kann ich weitermachen mit den epg daten, lirc, graphlcd .....


    ist schon mal ein erfolgserlebnis, nach verzweifelten stunden vor nem schwarzen tv....


    Recht herzlichen Dank euch allen !!!!

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am

    The post was edited 1 time, last by Rapi ().

  • Hallo,


    schön, dass es jetzt geht. :cool1
    Du kannst ivtv-fb einfach in die Datei /etc/modules eintragen, dann wird sie beim Starten gleich geladen. Alternativ könntest Du auch das Startskript von vdr anpassen. Es heist in der Regel runvdr und ist meistens in /usr/bin oder /usr/local/bin zu finden.


    Grüße,
    EddieT

    PIII-866, 512 MB Ram, Avermedia 761 DVB-T, PVR150MCE, Debian unstable, vdr 1.3.38, Xine über Xorg auf GF2MX

  • Rapi :
    Na Glückwunsch, dass es erst einmal soweit läuft... :]


    Im Verzeichnis '/etc/modutils' wird mittels 'touch ivtv' eine neue leere Datei erzeugt, da kannst du dann die Anweisungen/Konfigurationen reinschreiben. Die Dateien in diesem Verzeichnis werden dann über den Befehl 'update-modules' in die Datei 'modules.conf' im '/etc'-Verzeichnis übertragen (dies gilt nur auf Debian basierten Systemen). Diese wird dann von den Modulen beim laden berücksichtigt.


    Welche Module geladen werden sollen, wird aus der Datei 'modules' im '/etc'-Verzeichnis gelesen.


    @EddiT:
    Warum gilt meine Beschreibung nur für Kernel-Version 2.4?
    Zum einem benutze ich nur den 2.6-Kernel (und da habe ich es genau so genacht, wie beschrieben), zum anderen sind speziell die IVTV-Konfigurationen aus der Doku der IVTV-Maintainer für TreiberVersionen ab 0.2.x. Natürlich habe ich es vorher ohne irgendeine Konfiguration versucht, da die Maintainer sehr häufig das Standardverhalten bzw. die automatische Erkennung verändern.
    Was habe ich falsch gemacht, bzw. nur für 2.4 geltend? (Ich lerne gerne dazu)


    Gruß
    Zwickel

    yavdr 0.2, POV 330, Cine S2 Dual DVB-S2 (V5.5), OriginAE M10, mit HDMI an Samsung UE32B7090


  • Zwickel
    Unter Kernel 2.6 hat sich eine Menge geändert. Zumindestens Debian und damit auch c'tvdr4 wertet den Inhalt des Verzeichnisses /etc/modutils und die Datei /etc/modules.conf nicht mehr aus. Dort etwas einzutragen schadet zwar nicht, bringt aber auch nichts. Das neue Verzeichnis heisst /etc/modprobe.d/.
    Auch der Syntax der Dateien hat sich geändert, er wurde stark reduziert. Einträge wie "add above" und "add below" gibt es nicht mehr, genausowenig z.B. "post-install" und "pre-remove".
    Ein post-install macht man unter 2.6 so:

    Code
    1. install rtc modprobe --ignore-install rtc && sysctl -w dev.rtc.max-user-freq=1024

    Wie man sieht, können jetzt beliebige Befehle ausgeführt werden. Das System ist komplizierter, aber auch leistungsfähiger geworden.
    Rapi schrieb, dass er die nagelneue Treiberversion 0.4.0 einsetzen würde. Seit einiger Zeit wird in der ivtv-Mailingliste dringend davon abgeraten, bei den neueren Treibern irgendwelche Parameter zu setzen. Die automatische Erkennung wurde stark verbessert und viele Grundeinstellungen an die Einstellungen im Windowstreiber angepasst. Daher kann es kommen, das ein Parameter, der vorher notwendig war, jetzt die ganze Arbeit von Hans und den anderen zu nichte macht. Einen entsprechenden Eintrag gibt es auch im aktuellen Wiki.
    Deine Empfehlung, in die Datei /etc/modules unter anderem den Treiber ivtv-fb aufzunehmen, war allerdings genau richtig. Hätte Rapi Deine Anweisungen befolgt, wäre er auch zum Ziel gekommen.


    Grüße,
    EddieT

    PIII-866, 512 MB Ram, Avermedia 761 DVB-T, PVR150MCE, Debian unstable, vdr 1.3.38, Xine über Xorg auf GF2MX

  • @EddiT:


    Danke für die Aufklärung. Mir war zwar das Verzeichnis aufgefallen, da aber dort fast der gleiche Inhalt wie in modutils steht, konnte ich mir den Sinn nicht so ganz erklären (habe aber um ehrlich zu sein, mich auch nicht groß drum gekümmert - war ein Fehler...).


    Danke nochmal


    Gruß
    Zwickel

    yavdr 0.2, POV 330, Cine S2 Dual DVB-S2 (V5.5), OriginAE M10, mit HDMI an Samsung UE32B7090

  • hallo allerseits !


    es hat funktioniert, der VDR startet nun selbständig ohne zu mucken. :D
    Genau der Eintrag "ivtv-fb" in etc/modules hat gefehlt.


    eddi hat recht, die neue config datei habe ich gar nie erstellt, weil ich nicht recht wusste wie, hatte den befehl touch nicht begriffen. habs aber nun begriffen, sorry hat etwas lange gedauert ;)
    VDR ist dann aber trotzdem gelaufen. es hat ihm lediglich der ivtv-fb sorgen gemacht. zum test hab ich in der etc/modules mal alles wieder rausgeblasen ausser ivtv-fb, der kernel lädt noch immer alle benötigten module (lsmod). auch diejenigen, die ich dort eingetragen und wieder ausgetragen habe. schadet aber nicht, er hat immer noch gleich lange bis er gebootet hat.


    Hatte gestern mit einem kollegen noch lirc kompiliert und sogar zum laufen gebracht. war aber auch keine einfache geburt für so ein bisschen Fernbedienung. ;)


    Danke an alle die sich beteiligt haben mit wertvollen tips und anleitungen, alleine hätt ich es nicht gepackt !
    :applaus

    HW: Intel P4 2,66GHz 533FSB, ASUSP5P800, 512MB, HDD 200GB+300GB Samsung PATA, LG DVD+-RW, TT C-2300; Asus GF2GTS (passiv Umbau), GLCD240x128
    SW: CtVDR5.1, graphlcd, dvd, burn, muggle, mp3, trayopen, weatherng, streamdev server, tvonscreen, vdradmin-am