Posts by Zwickel

    Hi,


    habe selbst Fli4L jahrelang im Einsatz gehabt und war sogar mal für einige Zeit Maintainer für einige optionalen Pakete.


    Wenn du ohnehin einen Draft N als AP hinter dem Router betreiben willst, kann ich Dir Fli4l als Diskettenversion ans Herz legen - Diskette rein, Rechner booten, fertig (sofern dein P4 noch ein Diskettenlaufwerk hat :) )


    Energietechnisch natürlich schon eine Sünde ... :lol2


    Aber super stabil - ich hatte es über Jahre hinweg als Router/Firewall/HTTP-Proxy in einer Firmen-DMZ an einer T1 Standleitung (bei mir lief es allerdings von einer Boot-CD).
    Musste die Installation erst im Zuge eines Dienstleisterwechsels für unsere IT-Systeme und einem Rechenzentrumsumzuges vom Netz nehmen.


    Gruß
    Zwickel

    Hi methodus,


    wie kann ich helfen?


    Habe ein ReadyNAS Duo mit DLNA-Server und einen Samsung UE32B7090 mit DLNA Renderer.


    Wenn du mir sagen kannst, wie ich an die benötigten Daten herankommen, stelle ich dir diese gerne zur Verfügung.


    Danke für eure Arbeit!


    Gruß
    Zwickel

    Hi,


    und hier die Ausgabe von biosinfo bei einer Activy350 (zum Gegencheck):


    Following DMI entries found:
    - Mainboard vendor: "FUJITSU SIEMENS"
    - Mainboard type: "D1636"
    - Mainboard revision: "S26361-D1636"
    - BIOS vendor: "FUJITSU SIEMENS // Phoenix Technologies Ltd."
    - BIOS version: "4.06 Rev. 1.01.1636"
    - BIOS release: "12/10/2003"


    Gruß
    Zwickel

    det : Danke, aber ich denke ich warte auf das Image, da ich ohnehin erst Platz auf meinen anderen Platten schaffen muss (damit bin ich gerade beschäftigt). Ich möchte nicht die Activy-Orig.Platte benutzen, da mir sonst, ohne funktionierenden VDR, meine Frau 'den Hals rumdreht' :)


    helau : es war für mich nicht ersichtlich, dass dort mittlerweile ivtv drin ist. Im Wiki steht davon nichts, auch nichts von den für vdr und ivtv benötigten Plugins (pvrinput oder ptv) - zumindest habe ich es nicht gefunden/gesehen....


    Ich werde einfach mal beides ausprobieren - ein Dualboot ist ja schnell eingerichtet


    Danke erst einmal!!


    Gruß
    Zwickel

    Hallo det,


    ich habe mir kurz vor Weihnachten eine Activy 350 Kabel zugelegt und würde Dir gerne helfen.


    Mit Debian kenne ich mich ein wenig aus und möchte mich nicht auch noch in Gentoo einarbeiten (hatte mir auch schon gen2vdr - aber da müsste ich per se schon mal den Kernel updaten, IVTV nachkompilieren samt den nötigen VDR-Plugins...).


    Auf welcher Basis setzt du auf? easyVDR 0.4 nehme ich mal an?


    Gruß
    Zwickel

    Hi,


    mittels F2 ins Bios und die Bootreihenfolge ändern hast du aber gemacht, oder ?


    Abgesehen davon, was soll es bringen? Bislang habe ich nirgends gelesen, dass die MCE Gebrauch vom Sigma oder TIVA Chip macht. D.h. kein SCART... - oder ist da etwas an mir vorbei gegangen?


    Besitze selbst seit einer Woche eine Activy 350 Kabel.


    Gruß
    Zwickel

    Guten Morgen,


    Zu 1: Gibt es schon einige Beiträge zu, die es genauer beschreiben. Technisch geht es so: du erstellt im /boot/grub/menu.lst einen zusätzlichen Boot-Menü-Eintrag mit der 'Kernel-append' Zeile 'init 0'. D.h. sobald der Kernel soweit ist, die Befehle abzuarbeiten, fährt es sich direkt wieder runter. In einem der Shutdown-Skripte des VDR wird dann 'grub-install' mit dem Namen des Boot-Menü-Eintrages und einer Zusatzoption aufgerufen. Diese Zusatzoption sorgt dafür, dass dieser Shutdown-Kernel nur einmal beim nächsten Start aufgerufen wird und danach wieder der Standardkernel.


    Zu 2: Im VDR unter Einstellungen, Sonstiges die User Inaktiv Zeit einstellen. Nach der Zeitspanne fährt der VDR sich von selbst runter.


    Gruß
    Zwickel

    Guten Morgen,


    Dr. Seltsam :
    Nein, kein Trick.


    Beide Karten werden von IVTV-0.4.0 erkannt. Dann benutze ich das pvrinput-Plugin 0.0.8.


    Code
    1. Das Erste:203250:C0:C:0:301:300:305:A1:28106:0:0:0
    2. ZDF:175250:C0:C:0:301:300:305:A1:28006:0:0:0


    (Wundere dich nicht über die 'falschen' Frequenzen der Sender, ich hänge an einer Hausverteileranlage, die nicht unbedingt alles dem Standard entsprechend macht :( )


    Der 'Trick' liegt dann nur bei der Frequenz und dem Parameter (steht aber alles in der Doku zum Plugin), einigen festen Werten (V-PID, A-PID, T-PID und CA-ID) und daran, dass das Plugin beim Start die freien Tuner erkennt.
    Bei einer Frequenz größer 100000 wird das Plugin benutzt und über den Parameter wird das Input-Device ausgewählt.


    Im Zusammenhang mit dem S-VHS Eingang gibt es allerdings noch ein wenig 'Nachholbedarf'. Das Plugin nimmt die erste Aufnahme über das PrimaryDevice (bei mir halt die 350) auf und für weitere Aufnahmen oder Kanalwechsel die nächste freie Karte (so ist zumindest mein Eindruck).
    Soweit kein Problem, wenn ich es auch besser finden würde, das PrimaryDevice erst als letztes zu benutzen.
    Das Problem entsteht nun dadurch, dass ich an der 350 über Scart->S-VHS meine PremiereBox angeschlossen habe.
    Da ist dann als Parameter 'C89' eingestellt, denn es aber an der PVR250 gar nicht gibt, da kommt das Plugin dann durcheinander. Fernsehen darüber klappt, Aufnahmen (vielmehr der Versuch) führen zu einem Absturz des Plugin's. Ich müsste also bei den Parametern die Karte fest definieren können, was aber zur Zeit nicht geht.


    Gruß
    Zwickel

    Guten Morgen,


    bei mir läuft seit knapp zwei Wochen eine PVR350 als PrimaryDevice und eine zusätzliche PVR250 sehr stabil.


    Umschalten geht recht sauber und flüssig (ca. 1 Sekunde mit Artefakten). Ich habe den VDR 1.3.34 mit dem pvrinput-Plugin (Kernel 2.6.12.6 und IVTV-0.4) am Laufen.


    Um DVD Ausgabe über die PVR habe ich mich noch nicht gekümmert...


    Gruß
    Zwickel

    @EddiT:


    Danke für die Aufklärung. Mir war zwar das Verzeichnis aufgefallen, da aber dort fast der gleiche Inhalt wie in modutils steht, konnte ich mir den Sinn nicht so ganz erklären (habe aber um ehrlich zu sein, mich auch nicht groß drum gekümmert - war ein Fehler...).


    Danke nochmal


    Gruß
    Zwickel

    Guten Morgen,


    Nun, wie ich sagte, die Qualität der BT8x8-Karten ist nicht so toll (um, egal ob unter Windows (Software Hauppauge) oder Linux (xawtv), Livefernsehen zu wollen, geht es, aber sobald das ganze aufgezeichnet oder umkodiert (so wie beim VDR) werden soll/muss, vergiss es), zudem habe ich bislang BT-Karten nur mit Chinch-Eingang gesehen, der Qualitativ auch meist nicht so gut ist (oder hat deine einen SVHS Anschluss?).


    Die IVTV-Karten haben einen SVHS Anschluss und die Aufzeichnungsqualität ist sehr hoch, wobei das natürlich auch von der Quelle abhängt. Aus einem VHS-Video kannst du halt keine DVD-Qualität herausholen :D


    Hol Dir entweder eine PVR-Karte (wie gesagt, eine PVR250 reicht für deine Zwecke, da du diese nicht als AusgabeDevice benutzen brauchst, dafür hast du ja deine DVB-Karte (sonst PVR350). Von den PVR150 oder 500 lass im Augenblick noch die Finger, die sind im Verhalten ein wenig anders und ich habe keine Ahnung ob diese vom ptv- oder pvrinput-Plugin unterstützt werden), oder frag mal höfflich im Board nach, ob jemand mit einer PVR-Karte bei Dir Nähe München die Arbeit übernehmen würde und deine Video's aufzeichnet.


    Willst du es selbst machen, dann benutze statt des analogTV-Plugins besser das pvrinput- oder ptv-Plugin und die aktuellen IVTV-Treiber (zur Zeit Release 0.4.0).


    Gruß
    Zwickel

    Hi,


    steht alles in der Doku zu dem analogtv-Plugin, es ist die Mühe allerdings nicht/kaum wert, dein Prozessor läuft auf Anschlag, die Qualität ist so lala, häufig Aussetzer im Ton und zudem auch häufig nicht Synchron.


    Wenn du nur vor hast, mal ein oder zwei Videofilme als MPEG darüber aufzunehmen, versuchs - willst du das ganze im Dauereinsatz haben, besorg Dir besser eine PVR (in deinem Fall würde wohl eine PVR250 ausreichen - gibts für 50-60 Euro bei eBay).


    Ich habe das ganze mal vor einiger Zeit mit einem Athlon XP 1800 gemacht, die CPU war ständig bei 100% und ich hatte o.g. Probleme.


    Gruß
    Zwickel

    Hi,


    ein 'sieht so ähnlich aus' nutzt Dir leider nichts. Die BT878-Karten sind reine analog-Karten, die Ihr Signal so durchreichen. Der Prozessor muss die Umcodierung in MPEG2 machen, was eine hohe Prozessorlast verursacht. Zudem brauchen BT878 keine IVTV-Treiber, sondern nur ein Kernelmodul (bttv) und einige andere Dinge im Zusammenhang mit dem analogtv-Plugin.


    Die IVTV-Treiber brauchst du für PVR-Karten von Hauppauge (PVR350, PVR250, PVR150, PVR500, usw.). Diese Karten sind alle deutlich teuerer als eine BT878/BT848-Karte, da diese einen MPEG-Codierer onBoard haben (einige auch einen Encoder (PVR350), um darüber das Bild auf den Fernseher zu bringen).


    Katzengold sieht auch fast wie Gold aus und ist trotzdem wertlos...


    Gruß
    Zwickel

    Rapi :
    Na Glückwunsch, dass es erst einmal soweit läuft... :]


    Im Verzeichnis '/etc/modutils' wird mittels 'touch ivtv' eine neue leere Datei erzeugt, da kannst du dann die Anweisungen/Konfigurationen reinschreiben. Die Dateien in diesem Verzeichnis werden dann über den Befehl 'update-modules' in die Datei 'modules.conf' im '/etc'-Verzeichnis übertragen (dies gilt nur auf Debian basierten Systemen). Diese wird dann von den Modulen beim laden berücksichtigt.


    Welche Module geladen werden sollen, wird aus der Datei 'modules' im '/etc'-Verzeichnis gelesen.


    @EddiT:
    Warum gilt meine Beschreibung nur für Kernel-Version 2.4?
    Zum einem benutze ich nur den 2.6-Kernel (und da habe ich es genau so genacht, wie beschrieben), zum anderen sind speziell die IVTV-Konfigurationen aus der Doku der IVTV-Maintainer für TreiberVersionen ab 0.2.x. Natürlich habe ich es vorher ohne irgendeine Konfiguration versucht, da die Maintainer sehr häufig das Standardverhalten bzw. die automatische Erkennung verändern.
    Was habe ich falsch gemacht, bzw. nur für 2.4 geltend? (Ich lerne gerne dazu)


    Gruß
    Zwickel

    Rapi :


    Erst einmal herzlichen Glückwunsch zum neuen Kernel und den IVTV-Treibern.


    Ich poste Dir mal meine Einstellungen für die IVTV-Module:


    Im Verzeichnis '/etc/modutils':
    1. Die Datei 'aliases' bearbeiten (z.B. mit 'mc' = Midnight Commander, ein Norton Commander Clone). Dort mittels '#' den Eintrag 'alias char-major-81 bttv' auskommentieren.
    2. Eine neue Datei mittels 'touch ivtv' erzeugen. In diese die folgenden Einträge einfügen:



    3. Den Befehl 'update-modules' ausführen, damit werden die Änderungen in die 'modules.conf' geschrieben (auf dem 'Debian-Way')


    Im Verzeichnis '/etc' in die Datei 'modules' folgende Einträge einfügen (in der Reihenfolge):


    Code
    1. i2c_dev
    2. msp3400
    3. saa7127
    4. ivtv
    5. tda9887
    6. ivtv-fb
    7. v4l1-compat


    Dann solltest Du noch folgendes prüfen:
    Die IVTV-Treiber bringen diverse Module mit, die vom Namen her auch im normalen Kernel-Source enthalten sind. Diese normalen Module werden vom Kernel zuerst aufgerufen und damit nicht die, die die IVTV-Module benötigen (diese wurden entsprechend angepasst).


    Sieh mal unter dem Verzeichnis '/lib/modules/KERNEL-VERSION/kernel/drivers/media/video' nach, ob dort folgende Module enthalten sind:


    bttv.ko
    msp3400.ko
    tda9887.ko
    tuner.ko
    tveeprom.ko


    Wenn ja (und darauf wette ich), dann füge an alle diese aufgeführten und vorhandenen Dateien ein '.HIDE' an (z.B. 'mv bttv.ko bttv.ko.HIDE' - die IVTV-Module bringen zwar kein bttv-Modul mit, wenn dieses aber durch den Kernel geladen wurde, kann es Ärger machen, wobei du es allerdings bei der Kernel-Erstellung nicht abwählen darfst, weil dann einige andere Dinge nicht mehr gehen - das wird sich wohl erst dann Ändern, wenn die IVTV-Module in den Kernel-Source übernommen worden sind, woran die Entwickler gerade arbeiten...).
    Führe anschließend ein 'depmod -ae' aus, wodurch die Äbhängigkeit der Module neu ausgelesen und geschrieben wird.


    Nun den Rechner neu starten.


    Ich habe bei meinem Kernel die kompletten DVB-Module rausgelassen, da ich keine entsprechende Karte habe und benutze.
    Sollte der VDR sich immer noch über das saa7127-Modul beschweren, dann suche bei Dir im Modules-Verzeichnis nach den entsprechenden Treibern und hänge dort einfach ebenfalls ein .HIDE an (dann depmod -ae und neu starten).


    Sieh auch mal mittels 'lsmod' nach den geladenen Treibern. Falls sich dort ein Modul namens 'i2c-i801' befindet (wird z.B. bei meinem ASUS-Board automatisch geladen), dann suche unter 'kernel/drivers/i2c/busses' und füge dort ebenfalls ein .HIDE an. Dieses Modul hat bei mir die IVTV-Treiber immer dazu veranlasst, trotz anderslautenter Konfiguration, von 'PAL' auf 'NTSC' umzuschalten.


    So wenn das alles läuft und der VDR trotzdem nicht will, kann es nur noch am VDR selbst oder an deiner 'channels.conf' (die Kanalliste) liegen.


    Für den VDR selbst habe ich von Tobi den 'vdrdevel', 'vdrdevel-plugin-pvr350' und 'vdrdevel-plugin-pvrinput' am laufen (von Wirbel teste ich gerade das PTV-Plugin, mal sehen welches besser ist ;D ).


    Meine Kanalliste wird Dir nichts nutzen, da ich an einer Hausverteileranlage sitze, die aus SAT-Empfang analog-TV macht, und sich zudem nicht an die eigentlich definierten Frequenzlisten hält.


    Gruß
    Zwickel

    Guten Morgen,


    erst einmal Danke für dieses schöne Tool.


    Frage: Welchen MPlayer benutzt du für VTP?


    Ich habe mir den aktuellen (dev-CVS 050928) von der MPlayer-WebSite geholt, der reagiert da überhaupt nicht drauf - die Console ist zu kurz auf um den genauen Fehler zu sehen, aber viel passiert da allerdings nicht...


    Dann habe ich den gepatchen MPlayer von Februar diesen Jahres ausprobiert, der hier mal im Forum pepostet wurde (mit dem mache ich zur Zeit VTP über eine vorgeschaltete Batch-Datei), aber der klappt auch nicht mit dem VDR-Zapper (im übrigen mag der DEV-MPlayer die Aufrufsyntax aus der Batch-Datei auch nicht).
    Allerdings passiert da in der Console deutlich mehr, nur kann ich auch da den Abbruchgrund nicht erkennen.


    Ohne VTP klappt zwar das Bild, aber kein Ton (außer bei 'PES', da wird dann das ganze System unbenutzbar, hohe Traffic auf dem NIC, Prozessorbelastung auf 100%, aber kein MPlayer)


    Gruß
    Christian

    Hallo Rapi,


    ich habe auch den ctVDR4 bei mir laufen. Ich war bislang nicht in der Lage, die passenden Kernel-Headers für den ctVDR-Kernel 2.6.12-ct4 zu finden, und habe daher den Kernel aus den Quellen neu übersetzt.


    Das Problem ist nur, daß ich mich mit Linux (und Debian im speziellen) etwas auskenne, und so etwas für einen Anfänger nicht gerade einfach ist.


    Du musst Dir die benötigten Compiler und Tools installieren 'apt-get install build-essentials libncurses5-dev kernel-package', den aktuellen KernelSource holen (www.kernel.org - nimm den 2.6.12.6er - der .13.x'er macht wohl noch etwas ärger), zusätzlich den Lirc-Source (sonst fehlen Dir die Lirc-Module für die Fernbedienung - apt-get install lirc-source), cdfs habe ich nicht mehr zum laufen bekommen, die Kernel-Config aus /boot als .config in den ausgepackten Kernel-Source kopieren, 'make oldconfig' ausführen und die evtl. Fragen mit 'Enter' bestätigen (übernimmt dann den Default-Wert).
    Achso, den lirc-source auch auspacken (steht unter /usr/src - dort solltest du auch den Source des Kernels hinkopieren und dort auspacken - erstellt ein Verzeichniss 'linux-2.6.12.6'). Der Lirc-Source sollte sich dann unter /usr/src/modules befinden (ein Paket dafür kannst du Dir erstellen, nachdem du in den neuen Kernel gebootet hast - einfach im kernel-Verzeichnis 'make-kpkg modules' aufrufen).


    Nun in dem Kernel-Verzeichnis (/usr/src/linux-2.6.12.6) 'make-kpkg binary --initrd' ausführen (die darauf folgende Nachfrage bezüglich Abrechen kann mit 'N(o)' beantwortet werden).


    Nun heißt es eine gewisse Zeit zu warten, bis der Kernel fertig ist. Sollte kein Fehler auftreten, findest du nun unter /usr/src ein fertiges kernel-image-Paket. Diese kannst du mittels 'dpkg -i kernel-imagexxx' installieren, nun kannst du in den neuen Kernel booten.


    Dann kannst du mit den IVTV-Treiber weitermachen. Wenn du den Paketmanager nicht umgehen möchtest (um die Treiber wieder sauber entfernen zu können), dann benutze statt 'make install' den Befehl 'checkinstall' aus dem gleichnamigen Paket.


    Einfacherer wäre natürlich das ctVDR-KernelHeaders Paket, aber leider...


    Gruß
    Zwickel