yavdr-0.7 Installation

  • Ich versuche gerade einen neuen VDR auf frisch installiertem Ubuntu 22.04.3 LTS aufzusetzen. Aktuell hänge ich hier fest

    Code
    TASK [yavdr-common : apt | install basic packages] ************************************************************************************************************************************
    
    fatal: [localhost]: FAILED! => {
    "changed": false
    }
    
    MSG:
    
    No package matching 'yavdr-i18n' is available


    PS: Davor hat sich die Installation schon über ein nicht vorhandenes Paket python3-kmodpy beschwert.

    kmodpy konnte ich mit pip manuell installieren (und den Task yavdr-common anpassen).

  • Gibt es hier:

    Code
    yavdr-i18n:
    Installiert:           (keine)
    Installationskandidat: 20171218170112unstable-0yavdr4~focal
    Versionstabelle:
    20171218170112unstable-0yavdr4~focal 500
    500 http://ppa.launchpad.net/yavdr/experimental-main/ubuntu focal/main amd64 Packages
    500 http://ppa.launchpad.net/seahawk1986-hotmail/experimental-main/ubuntu focal/main amd64 Packages

    Hab es aber lustigerweise selbst nicht installiert und der yavdr-0,7 läuft :)

  • cs-7

    Ich übersetze die Antwort mal in Commands, falls notwendig:

    Code
    sudo add-apt-repository ppa:yavdr/experimental-main
    sudo apt update
  • Auch das ist aus dem main Repository. Ohne das wird es mit keiner Ubuntu Version gehen.

  • Ja klar, die Paketverwaltung von Ubuntu und ok sind zugegeben eine Schwäche von mir, aber liegt es nicht an den fehlenden Paketen für jammy? In /etc/apt/sources.list.d ist das main Respsitory drin:

    Code
    /etc/apt/sources.list.d$ ls -la
    total 16
    drwxr-xr-x 2 root root 4096 Okt 26 20:52 .
    drwxr-xr-x 8 root root 4096 Okt 26 20:44 ..
    -rw-r--r-- 1 root root   77 Okt 26 20:50 ppa_seahawk1986_hotmail_vdr_2_6_4_jammy.list
    -rw-r--r-- 1 root root   71 Okt 26 20:50 ppa_yavdr_experimental_main_jammy.list
  • - was steht in "ppa_yavdr_experimental_main_jammy.list"

    - was sagt "apt-get update && apt-cache policy t2scan" ?

  • Code
    cat ppa_yavdr_experimental_main_jammy.list
    deb http://ppa.launchpad.net/yavdr/experimental-main/ubuntu jammy main
  • Die Lösung dafür steht hier

    Code
    sudo add-apt-repository ppa:seahawk1986-hotmail/jammy-main
    sudo add-apt-repository ppa:seahawk1986-hotmail/vdr-2.6.4

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!