Nach Update: Tonaussetzer vdr-sxfe - frames dropped

  • Hallo zusammen,


    never change a running system, aber ich habe meine Basis-Distro von LMDE4 auf LMDE5 aufgerüstet,

    und seitdem liefert mein vdr-sxfe frontend Tonaussetzer beim Live-TV.

    Aber nur da, Aufzeichnungen laufen ohne Tonprobleme.


    Hardware:


    Linux/Kernel/VDR:


    vdr-sxfe mit --verbose liefert zum Zeitpunkt der Tonaussetzer laufende audio_out frames dropped messages.


    Unter LMDE4 mit Kernel 4.x traten diese Probleme nicht aus.


    Version ddbridge: 0.9.37 und auch 0.9.38 ausprobiert.


    Die Tonaussetzer kommen zu unterschiedlichsten Zeiten. Mal geht es gar nicht, mal läuft es 5 Minuten und erst dann passiert es. Mal erst nach dem Umschalten.

    Wenn der Ton weg ist und man vdr-sxfe beendet und neu startet geht es wieder für kurze Zeit und dann ist es wieder weg.


    Starte ich KODI und conencte zum vdr via pvr.client dann sind keine Tonprobleme da.


    Irgendwo muss im LMDE-5/Xine/VDR-SXFE Konstrukt ein Bug/Config-Problem stecken, was unter LMDE-4 nicht da war,

    aber ich finde seit Tagen nix weiterführendes in den LOGs ...


    Hat jemand evtl. eine Idee?

    Wenn jemand eine Idee hat, wo ich gucken könnte, dann immer gerne her damit.


    VG,

    Bernd

  • Hallo,

    ich hatte bei meiner aktuellen Gentoo-VDR-Neuinstallation ähnliche Probleme mit dem Ton (über HDMI).

    Im alten Setup lief alles gut mit "alsa" aktuell macht nur "pulseaudio" alles perfekt:


    Code
    vdr-sxfe --waitvdr --silent --lirc=/dev/lircd --fullscreen \
             --audio=pulseaudio --video=vdpau --display=:0.0 --reconnect xvdr://127.0.0.1

    Gentoo Linux 6.1.46, VDR 2.6.4 elchie, epgsearch, xineliboutput-2.2.0 + xvdr, vnsiserver-1.8.3 (mt KODI 19.5)

    vorher

    Gentoo Linux 5.10.52, VDR 2.4.7 (liemikuutio), burn, radio, streamdev-server, text2skin, timeline, xineliboutput-2.2.0 + xvdr


    SILENTMAXX HTPC, ASUS P7P55D-E, INTEL i5-660, 4G RAM, GeForce GT710, 2 x Hauppauge NOVA-HD-S2

  • Hey danke für den Tipp, aber pulseaudio wird benutzt.


    Aber ich bekomme diese Meldung:

    Code
    [input_vdr] WARNING: xine-engine setting "engine.buffers.video_num_frames":22 is too small for some HD channels


    Daraufhin habe ich mich auf die Suche gemacht und gesehen, dass nach einem Update der Link in /etc/vdr/plugins/xineliboutput zur config in /var/lib/vdr/plugins/xineliboutout/config verwaist war. Also config mit enginge.buffers restauriert.

    Ich musste allerdings auch /home/vdr/.xine/config_xineliboutput anpassen.



    Jetzt ist der Ton wieder klar,


    Das aber auch updates immer so viel kapuut machen müssen ... ;)


    LG,

    Bernd

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!