Beiträge von berni123

    Hallo zusammen,


    es wird mal wieder Zeit meinen in die Jahre gekommen VDR zu renovieren.

    Was für Tipps habt Ihr denn in Sachen Mainboard/Gehäuse?


    Ziel:

    Mainboard:

    + mit CPU/Grafik on board (fähig für alle aktuellen DVB-C/C2 HD Standards)

    + Gbit LAN

    + mindestens 2-3xPCIe (für DD-Karte 2xTwin-Tuner und CAM/CI)

    + COM optional für Slotblechmontage, da gute alter serieller IR-Empfänger benutzt wird


    Gehäuse: nicht zu groß, aber Platz für

    - Slots: 2-3x PCIe (je nach Board), 1x DualCAM/CI. 1x COM-Port-Slotblech

    - 1xDVD-Brenner (ja rustikal gehts noch zu, brenne gerne mal nen paar Filme weg)


    Netzteil passend zum Board

    Festplatten 2x für Raid1


    Für Tipps bedanke ich mich schon mal.


    Bernd
    :]:]:]

    So ich habe jetzt mit netfilter getrickst!


    Da laut netstat sich der vdr ums verrecken nur an 127.0.0.1:37890 gebunden hat, habe ich per:


    Code
    1. iptables -t nat -D PREROUTING -p tcp -d 192.168.0.201 --dport 37890 -j DNAT --to-destination 127.0.0.1

    erst mal alle tcp Pakete an port 37890 vom lokalen Netzwerkinterface auf das loopback device umgebogen.


    Damit dann der remote client auch die Pakete zurück bekommt habe ich unter /etc/sysctrl.d die Datei vdr.conf angelegt:

    Code
    1. #
    2. net.ipv4.conf.all.route_localnet = 1

    damit die Pakete vom loopback device auch wieder zurück geworfen werden.


    Damit kann ich dann auf dem remote Rechner per: vdr-sxfe xvdr://192.168.0.201:37890

    die Verbindung herstellen.


    Fertig!


    Nicht schön aber selten ;-)

    Dann steht bei Dir in der plugin config sicher --remote=34890, denn 37890 ist der default Wert.

    Aber Du hast die 0.0.0.0:34890 und da es bei Dir funktioniert und bei mir mit 127.0.0.1:37890 nicht, bin ich schon mal dicht dran.

    Kannst Du bei Dir mal nachsehen, was im syslog steht?


    Interessant wären diese Zeilen mit [xine..put]:

    Code
    1. Mar 11 18:48:57 vdr2 vdr: [3098] [xine..put] Binding server to 127.0.0.1:37890
    2. Mar 11 18:48:57 vdr2 vdr: [3098] [xine..put] Listening on port 37890
    3. Mar 11 18:48:57 vdr2 vdr: [3098] [xine..put] Listening for UDP broadcasts on port 37890


    Irgend jemand anderes eine Idee, warum trotz entsprechender config (siehen weiter oben), bei mir der connect aus dem Netzwerk nicht klappt?


    Gruss,

    Bernd

    Bei mir steht in allen "allowed_hosts"-Dateien immer das hier drin und ich kann von allen LAN-/WLAN-Clients zugreifen; zB von Stand-PC 192.168.192.61 auf VDR 192.168.192.50:

    127.0.0.1 # always accept localhost

    192.168.0.0/16 # any host on the local net

    (der any-Eintrag ist bei mir auskommentiert)

    Habe ich schon alles ausprobiert, sowohl die beiden Zeilen, die Du hast, als auch die any-Zeile.

    Es funktioniert einfach nicht. Es wird kein connect aus dem lokalen Netzwerk zu gelassen.

    Der tcpdump zeigt, dass nach dem syn-Paket ein reject-Paket fliegt.

    Die iptables sind leer und alle auf default policy accept.


    Kannst Du mal schauen, was bei Dir die Ausgabe von netstat -tulpn | grep 37890 ergibt?


    Bekommst Du da eine Zeile mit: tcp 0 0 127.0.0.1:37890 0.0.0.0:* zurück

    oder eine Zeile mit: tcp 0 0 0.0.0.0:37890 0.0.0.0:*

    zurück?


    Da ich ein 127.0.0.1:37890 bekomme, zusammen mit der logmeldung im syslog, dass sich xine..put an 127.0.0.1:37890 bindet,

    ergibt für mich das Verständnis, dass trotz der plugin-Konfiguration --remote=37890 keine Bindung an das physikalische

    Netzwerkinterface erfolgt. Wenn jedoch bei Dir auch die Zeile 127.0.0.1:37890 erscheint, es bei Dir aber geht, muss der

    Teufel bei mir woanders stecken.


    Hat jamend noch eine Idee?


    Viele Grüße,

    Bernd

    tcpdump:

    Code
    1. root@vdr2:~# tcpdump -i eth0 -n -l port 37890
    2. tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
    3. listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
    4. 19:37:13.905783 IP 192.168.0.2.46762 > 192.168.0.201.37890: Flags [S], seq 765292401, win 29200, options [mss 1460,sackOK,TS val 66117198 ecr 0,nop,wscale 7], length 0
    5. 19:37:13.905831 IP 192.168.0.201.37890 > 192.168.0.2.46762: Flags [R.], seq 0, ack 765292402, win 0, length 0
    6. ^C
    7. 2 packets captured
    8. 2 packets received by filter

    Da kommt ein R (reject) ...


    Das würde erklären warum netstat:

    Code
    1. root@vdr2:~# netstat -tulpn | grep 37890
    2. tcp 0 0 127.0.0.1:37890 0.0.0.0:* LISTEN 2955/vdr
    3. udp 0 0 255.255.255.255:37890 0.0.0.0:* 2955/vdr

    evtl hier 127.0.0.1:37890 ausgibt.


    Im syslog steht ja auch:

    Code
    1. Mar 11 18:48:57 vdr2 vdr: [3098] [xine..put] Binding server to 127.0.0.1:37890
    2. Mar 11 18:48:57 vdr2 vdr: [3098] [xine..put] Listening on port 37890
    3. Mar 11 18:48:57 vdr2 vdr: [3098] [xine..put] Listening for UDP broadcasts on port 37890

    Also scheint der vdr bzw. das plugin sich nicht ans lokale Netzwerk zu binden, sondern nur an das loopback, trotz der config:

    Code
    1. --local=none
    2. --primary
    3. --remote=37890

    Kann man das Problem lösen? Wie bekommt man das plugin an 127.0.0.1 UND für das äußere Netz gebunden?

    Wie sieht die allowed_hosts.conf aus? https://projects.vdr-developer…utput.git/tree/README#n51

    Siehe oben im Code ... habe auf "any" gestellt:


    Code
    1. root@vdr2:/etc/vdr/plugins# cat xineliboutput/allowed_hosts.conf
    2. #
    3. # allowed_hosts This file describes a number of host addresses that
    4. # are allowed to connect to the xineliboutput plugin
    5. # of the Video Disk Recorder (VDR) running on this system.
    6. # Syntax:
    7. #
    8. # IP-Address[/Netmask]
    9. #
    10. 0.0.0.0/0 # any host on any net (USE THIS WITH CARE!)

    Die svdrphosts steht auch auf 0.0.0.0


    Gruss,

    Bernd

    Moin zusammen,


    xineliboutput lässt kein connect von anderen hosts zu.

    Local auf dem VDR-Rechner, also auf 127.0.0.1 geht es, aber von einem anderen Host im lokalen Netz aus geht es nicht:


    Config auf dem VDR:


    Also eigentlich alles freigegeben, oder?

    Netstat zeigt zwar für den port 37890 listen 0.0.0.0:* aber eben nur von 127.0.0.1:37890 aus und nicht als 0.0.0.0:37890


    VDR-Log:

    Code
    1. Mar 11 15:39:19 vdr2 vdr: [6107] [xine..put] Binding server to 127.0.0.1:37890
    2. Mar 11 15:39:19 vdr2 vdr: [6107] [xine..put] Listening on port 37890
    3. Mar 11 15:39:19 vdr2 vdr: [6107] [xine..put] Listening for UDP broadcasts on port 37890


    Sollte VDR da nicht eher an 0.0.0.0:37890 binden?


    Oder wo kann man noch was einstellen, damit auch von einem entfernten Rechner im Netz mit vdr-sxfe zugegriffen werden kann?


    Danke für Tipps,

    Gruss,

    Bernd

    Sind das Aufnahmen die du mit deinem VDR selber gemacht hast oder von einem fremden System?

    Sind es HD Aufnahmen von oeffentlich rechtlichen Sendern oder auch Privatsendern? Ist ein "Voldemort" Plugin im Spiel?

    Selbst aufgenommen von Kabel, öffentlich rechtlich. "Voldemort" habe ich nicht.

    Habe ich doch oben geschrieben: Ich benutze den nvidia-legacy-304xx-kernel-dkms bzw. driver 304.135-1 laut Angabe von aptitude


    [ 28.031] (II) LoadModule: "nvidia"

    [ 28.062] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so

    [ 28.370] (II) Module nvidia: vendor="NVIDIA Corporation"

    [ 28.370] compiled for 4.0.2, module version = 1.0.0

    [ 28.370] Module class: X.Org Video Driver

    [ 28.408] (II) NVIDIA dlloader X Driver 304.135 Tue Jan 17 15:28:00 PST 2017

    [ 28.408] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs


    Gruss,

    Bernd

    Hi,

    Du nutzt VDPAU? Welchen nvidia Treiber? 304? Nur der geht mit der "Karte" vernünftig.

    Frontend ist softhddevice? Oder welches?

    Hast du Skindesigner an?

    MfG Stefan

    Moin,


    installiert ist mesa-vdpau-drivers 10.3.2-1+deb8u bzw. vdpau-va-driver 0.7.4-dmo5

    Ich benutze nicht den nvidia-legacy-304xx-kernel-dkms bzw. diver 304.135-1

    Als Frontend benutze ich vdr-sxfe mit xineliboutput (2.0.0)

    Als Skin benutze ich lcars, installiert ist aber auch skinenigmang, da vdr-plugin-skindesigner ist nicht installiert.


    Kann ich sonst noch was raussuchen, was hilft?


    Gruss,

    Bernd

    Distro: LMDE 2 Betsy (Debian/jessie)

    mit: deb http://e-tobi.net/vdr-experimental jessie vdr-multipatch base addons


    VDR:

    vdr: [2942] VDR version 2.2.0 started


    IPTV:

    vdr: [2942] loading plugin: /usr/lib/vdr/plugins/libvdr-iptv.so.2.2.0


    Karten:

    kernel: [ 8.859287] ddbridge 0000:06:00.0: device name: Digital Devices Cine CT V7 DVB adapter


    Treiber: dddvb-0.9.32


    Ach ja sonstige Hardware:

    AMD Athlon(tm) 64 X2 Dual Core Processor 5200+

    VGA compatible controller: NVIDIA Corporation C77 [GeForce 8200] (rev a2)

    Frontend: vdr-sxfe --lirc --fullscreen


    ... gebe gern weitere Auskünfte wenn erforderlich und wenn es helfen könnte ...

    Hallo,


    seit eingier Zeit nehme ich in HD auf und stelle fest, dass beim Abspielen von HD Aufzeichnungen das Vor- und Zurück Spulen nicht mehr geht.

    Bei SD Aufzeichnungen geht es ohne Probleme.


    Woran liegt das? Kennt jemand das Problem?

    Fehlermeldungen gibt es keine, es spult nur einfach nicht, oder mal spult es schnell vor, dann kann man es aber nicht mehr stoppen und muss den

    Film abbrechen. Alles sehr unschön und ärgerlich, da bei SD es ohne Probleme geht.


    Danke für Hinweise und viele Grüße,

    Bernd

    Hallo,


    ich breche mir gerade einen mit dem IPTV Plugin ab und bekomme es einfach nicht konfiguriert.

    Note: ich habe kein Entertain, daher hilft mir der Thread nicht weiter.


    Das was man so ergoogelt weicht teilweise ab, daher hier mal meine Config:


    In der channels.conf:


    Code
    1. GayFM;IPTV:2:S=0|P=0|F=EXT|U=IRgayfm.sh|A=0:P:0:0:256:0:0:2:0:0:0


    Im Verzeichnis /usr/share/vdr/plugins/iptv liegt die Datei: IRgayfm.sh

    auf Basis von "internetradio.sh"



    Beim Schalten auf den Kanal kommt dann: "Kanal nicht verfügbar".

    Im syslog steht:

    Oct 30 15:17:26 vdr2 vdr: [4024] switching to channel 98 (GayFM (P))

    Oct 30 15:17:26 vdr2 vdr: [4089] osdteletext-receiver thread ended (pid=4024, tid=4089)

    Oct 30 15:17:26 vdr2 vdr: [4024] buffer stats: 0 (0%) used

    Oct 30 15:17:26 vdr2 vdr: [4024] info: Kanal nicht verfügbar!


    Tja ... was nun?


    Was ist falsch?


    Hier: http://www.vdr-wiki.de/wiki/in…Iptv-plugin#Konfiguration

    steht ähnliches, nur dass die Zeitle für die channels.conf anders aussieht,

    aber ich habe das direkt aus der Kommentarzeile des Scriptes.


    Kann jemand helfen, wie ich den MP3 Stream als Kanal über IPTV eingebunden bekomme?


    Danke und Gruss,

    Bernd

    Danke für die Tips.


    Habe jetzt ddbrige 0.9.32 installiert.

    Code
    1. [ 2059.380632] Digital Devices PCIE bridge driver 0.9.32, Copyright (C) 2010-17 Digital Devices GmbH
    2. [ 2059.381285] ddbridge 0000:06:00.0: device name: Digital Devices Cine CT V7 DVB adapter
    3. [ 2059.491391] ddbridge 0000:06:00.0: Port 0: Link 0, Link Port 0 (TAB 1): DUAL DVB-C2T2 CXD2843
    4. [ 2059.602675] ddbridge 0000:06:00.0: Port 1: Link 0, Link Port 1 (TAB 2): DUAL DVB-C/C2/T/T2
    5. [ 2059.603735] ddbridge 0000:06:00.0: Port 2: DuoFlex CI 1.1
    6. [ 2059.710630] ddbridge 0000:06:00.0: Port 2: Link 0, Link Port 2 (TAB 3): DuoFlex CI
    7. [ 2059.711746] ddbridge 0000:06:00.0: Port 3: Link 0, Link Port 3 (TAB 4): DuoFlex CI_B


    Und mir ein mal via apt-get source -b vdr den VDR-Code geholt und gebaut

    und dann das vdr-plugin-ddci2 gebaut und konfiguriert.


    Code
    1. root@vdr2:/etc/vdr/conf.d# locate libvdr-ddci2
    2. /usr/lib/vdr/plugins/libvdr-ddci2.so.2.2.0


    mit:

    Code
    1. root@vdr2:/etc/vdr/conf.d# cat 50-ddci2.conf
    2. # ddci2 VDR plugin arguments
    3. #
    4. [ddci2]
    5. -A


    Wird soweit erkannt:



    Aber CAM Menü öffnet nicht:

    Code
    1. Sep 27 20:07:40 vdr2 vdr: [15301] ERROR: CAM-Menü kann nicht geöffnet werden!
    2. Sep 27 20:07:42 vdr2 vdr: [15301] max. latency time 2 seconds
    3. Sep 27 20:07:43 vdr2 vdr: [15301] ERROR: CAM-Menü kann nicht geöffnet werden!
    4. Sep 27 20:07:47 vdr2 vdr: [15301] max. latency time 5 second



    Habe beide Ports des DUO-CI ausprobiert ... was könnte jetzt noch klemmen?


    Gruss,

    Bernd

    Hallo,


    ich habe schon länger eine 4-Tuner Version (2*2) der DuoFlexCI am Laufen.

    Jetzt habe ich das DuoFlex CI ergänzt.


    Wie bekomme ich das jetzt zum Laufen?


    Syslog sagt (DDBrige 0.9.28) das es da ist:


    Aber im VDR-Menü wird nichts angezeigt.

    Ich habe beide CI Slots ausprobiert. Es wird bei beiden nicht angezeigt, allerdings habe ich

    auch nur TAB1 vom CI an TAB3 von der DuoFlex verbunden. TAB2 vom CI habe ich nicht

    verbunden.


    Google sagte was von einem vdr-plugin-ddci2, das ist aber nicht verfügbar.


    Apt:

    Code
    1. deb http://e-tobi.net/vdr-experimental jessie vdr-multipatch base addons
    2. deb-src http://e-tobi.net/vdr-experimental jessie vdr-multipatch base addon


    Gibt es irgendwo ein Repo, wo das plugin drin ist?

    Oder brauche ich das plugin nicht? (Der Post war von 2014)


    Was muss ich tun, damit das CI auch unter VDR läuft? Der Linux-Treiber erkennt das CI ja schon ...


    Drin ist ein Alphacrypt CAM.


    Danke und Gruss,

    Bernd

    Welche Distribution ist das?


    Ist ein Mint 18 LMDE (also debian basiert) mit E-Tobi Paketen.


    Hier die sources.list:



    Gruss,
    Bernd