Nvidia 535 mit softhdcuvid

  • Ich muss dazu sagen, dass ich softhdcuvid disconnected parallel zu softhddevice starte und dann umschalte, aber das hat nie Probleme gegeben.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Dazu musst du in video.c in Zeile 2702 aus 1:0:1 eim 1:-1:1 machen. Und Feedback geben :)


    Das Zittern bleibt mit folgender Änderung:

    Code
    #ifdef YADIF
    //    const char *filters_descr = "yadif_cuda=1:0:1"; // mode=send_field,parity=tff,deint=interlaced";
        const char *filters_descr = "yadif_cuda=1:-1:1"; // mode=send_field,parity=tff,deint=interlaced";
        enum AVPixelFormat pix_fmts[] = {format, AV_PIX_FMT_NONE};
    #endif

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • Ich hab gereade mein Prod-System angesschmissen, auf meinem Test-System habe ich keine 1080i Sender und nutze noch 525.


    Ich starte das das System auf einem 720p-Sender, schalte um auf softhdcuvid, s.o., schalte um auf einen 1080i-Sender, alles ok, wechsle auf einen anderen 1080i, Falschfarben, wechsle auf einen SD-Sender und zurück, alles ok.



    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Was mir gerade auffällt, das Zittern tritt nur auf, wenn der Bildinhalt sich verändert.

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • softhdcuvid.576i.Deinterlace = 3

    Das ist sicher falsch. Es sollte 0 = cuda oder 1 = yadif sein.

    Was mir gerade auffällt, das Zittern tritt nur auf, wenn der Bildinhalt sich verändert.

    da sieht mir so aus als ob die Reihenfolge der Bilder nicht stimmt. Vielleicht solltest du doch mal ffmpeg updaten. Das schadet zumindest nicht.

    Wie ist denn der X server eingestellt? Und welche cuda version hast du ?

  • Im Menü wird yadif angezeigt, ich werde das von Hand korrigieren, wenn ich eine Aufzeichnungspause habe.


    Edit


    Wechsel nach cuda und zurück nach yadif hat genügt.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

    Edited once, last by jsffm ().

  • Also, mit yadif bei SD habe ich auch das Gezittere, schalte ich zurück auf cuda sieht SD wieder sauber aus. Falschfarben treten nach wie vor nur bei 1080i auf, und zwar beim Wechsel von 1080i nach 1080i.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Wie ist denn der X server eingestellt? Und welche cuda version hast du ?

    Code
    vdr ~ # nvcc --version
    nvcc: NVIDIA (R) Cuda compiler driver
    Copyright (c) 2005-2023 NVIDIA Corporation
    Built on Tue_Aug_15_22:02:13_PDT_2023
    Cuda compilation tools, release 12.2, V12.2.140
    Build cuda_12.2.r12.2/compiler.33191640_0

    Anbei noch das Xorg.log.

    Reicht das?


    ffmpeg aktualisiere ich und werde berichten.

    Muss ich da noch evtl. ein use-flag setzen (siehe ffmpeg_use.txt)?

  • Also, mit yadif bei SD habe ich auch das Gezittere, schalte ich zurück auf cuda sieht SD wieder sauber aus.

    Da bin ich erst mal froh, dass ich nicht der einzige bin...

    Gentoo Linux ~ VDR 2.6.6 ~ DD Octopus NET V2 S2 Max - SAT>IP ~ LENOVO ThinkServer TS200V ~ Intel(R) Core(TM) i5 CPU680@3.60GHz ~ 16GB RAM ~ NVIDIA T400

  • Liegt wohl an gentoo ;D


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Das Zittern habe ich nur bei SD, HD ist top, wenn es läuft.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Anbei noch das Xorg.log.

    Du nutzt ein Custom EDID. Ist das irgendwie modifiziert oder nur das Edid das dein Monitor/TV eh liefern würde ? Bist du sicher das dein TV auf progressiv läuft ? Das zittern bei SD scheint ein Problem von Yadif zu sein.


    Das Falschfarben Problem bleibt mir ein Rätsel. Und das ist erst mit dem 535er Treiber aufgetreten ?

  • Das Falschfarben Problem bleibt mir ein Rätsel. Und das ist erst mit dem 535er Treiber aufgetreten ?

    Ja, bei 525 ist alles ok, Ich hatte Dir gestern zwei Links dazu geposted. Das eigentliche Problem ist, dass yadif manchmal nicht anspringt.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Wenn ich das richtig sehe, versucht er garnicht yadif zu starten.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • Ich sitze im Moment nicht vor dem TV, mache also quasi Ferndiagnose, beim ersten 1080i scheint yadif nicht angesprungen zu sein, nach Wechsel auf anderen 1080i war er dann da und ab dann funktioniert auch der Ksnalwechsel.


    In jedem Fall eine Verbesserung.


    Das muss ich mir nochmal genauer anschauen, wenn ich vorm TV sitze.


    Die Initialisierung ist jetzt verschoben, evtl muss es an beide Stellen.


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

  • :thumbup:


    So wollte ich das haben! :)


    vdr-User-# 755 to_h264 chk_r vdr-transcode github

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!