PPA-Paket von focal nach jammy konvertieren

  • Ich habe vor demnächst auf 22.04 upzudaten. Leider gibt es nicht für alle Pakete auch Versionen für jammy.


    Kann man ein PPA-Paket von focal nach jammy konvertieren?

    Reicht es einfach lokal neu zu bauen, oder muss da was angepasst werden? Es geht um ein vdr-Plugin

    Oder falls es nicht so einfach geht: Kann man das vom sourcecode bauen? Wie schafft man es, dass es dann zu vdr api usw. passt?


    Jemand eine Idee?

  • Im einfachsten Fall kannst du das Plugin (bzw. das Paket für das Plugin) neu aus den Sourcen bauen.

    Falls es an den Abhängigkeiten scheitert, muss man schauen, ob die unter jammy noch bau- bzw. installierbar sind und da ggf. nachhelfen.


    Ob die ABI passt, hängt nur daran, dass man die passenden Header-Dateien (Paket vdr-dev) installiert hat, die auf dem selben Stand sind wie der genutzte VDR. Bei den Plugin-Paketen kann man dafür sorgen, dass sie die Installation verweigern, wenn die ABI-Version nicht zum installierten VDR passt, aber das ist vor allem ein Frühwarnsystem, dass man Pakete aus unterschiedlichen Quellen mixt.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • neu aus den Sourcen

    Aus den 'normalen' (GIT) oder den via apt-get source vdr-plugin-d...

  • Hab gerade in der Virtualbox getestet. Das Plugin kann ich bauen und auch installieren und wird im VDR auch geladen. Hab nur keine Empfangsmöglichkeit zum testen, ob es wirklich läuft. Bin aber optimistisch.


    Somit kann ich dann riskieren, mein VDR in echt auf 22.04 upzudaten, wenn ich wieder Zeit habe

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!