yavdr-ansible focal fossa, Bild weg nach Wechsel zur Konsole und zurück

  • Hi,


    Hab da mal ne Frage wie folgt,

    Bei mir wenn der VDR läuft und ich währenddessen auf ne Konsole wechsel z.b: mit STRG+ALT+F3 und später wieder zurück zum VDR also auf Konsole 7 (STRG+ALT+F7)

    ist das Bild vom VDR immer weg, man sieht dann nur immer das yavdr Logo, ist das normal ?


    Ich habe deshalb immer erst am VDR per Fernbedienung über Applications > Internet den Firefox Browser geöffnet und wenn ich dann

    auf ne andere Konsole gewechselt hatte und irgendwann später wieder zurück zum VDR brauchte ich nur den Firefox beenden und das Bild des VDR war wieder da.


    Seit gestern jedoch geht das so auch nicht mehr (ich hab lediglich sudo -H ./install-yavdr.sh zweimal neu durchlaufen lassen da ich Dinge in der

    /yavdr-ansible/host_vars/localhost

    angepasst hatte (ein paar Plugins neu dazu eingetragen)

    Diese Plugins allerdings hatte ich zuvor schon alle manuell eingebaut und die funktionierten und auch das Problem wie oben geschildert gabs da noch nicht.


    Ebenfalls klappt nun nicht mehr in Konsole 3,

    sudo systemctl restart vdr

    Auch das hat zuvor immer das VDR Bild auf Konsole 7 wiederhergestellt, nun nicht mehr es ist auch hier nur mehr das yavdr Logo zu sehen danach.

    Starte ich das ganze System neu ist VDR Bild aber immer da der Ton aber dürfte immer da sein.



    Gruss

    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Zeig doch mal, was im Log passiert, wenn du das machst - meine Vermutung wäre, dass softhddevice sich beschwert und dann der VDR so oft crasht, bis er ins Restart-Limit von Systemd läuft.


    Mir ist nicht ganz klar, warum man auf ein anderes TTY wechseln muss, wenn man an eine Shell will, während das VDR-Frontend weiter läuft - da reicht ein Wechsel der Arbeitsflächer (STRG + ALT + links/rechts), dann ein Rechtsklick auf den Bildschirmhintergrund, um das Menü von Openbox aufzurufen, dort ein Terminal öffnen. Dann kannst du dich mit deinem Installations-User (oder root, wenn man dem ein Passwort gegeben hat) anmelden, angenommen dein User heißt bob: su - bob und von da aus kannst du eigentlich (fast) alles machen, was du sonst in auf einem TTY machen könntest.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,


    Mir ist nicht ganz klar, warum man auf ein anderes TTY wechseln muss, wenn man an eine Shell will, während das VDR-Frontend weiter läuft - da reicht ein Wechsel der Arbeitsflächer (STRG + ALT + links/rechts), dann ein Rechtsklick auf den Bildschirmhintergrund, um das Menü von Openbox aufzurufen, dort ein Terminal öffnen. Dann kannst du dich mit deinem Installations-User (oder root, wenn man dem ein Passwort gegeben hat) anmelden, angenommen dein User heißt bob: su - bob und von da aus kannst du eigentlich (fast) alles machen, was du sonst in auf einem TTY machen könntest.

    Danke erstmal - ja ich kannte das Vorgehen noch nicht, aber das werd ich dann gleich mal ausprobieren.


    Zeig doch mal, was im Log passiert, wenn du das machst - meine Vermutung wäre, dass softhddevice sich beschwert und dann der VDR so oft crasht, bis er ins Restart-Limit von Systemd läuft.

    Hab ein paar Logs gepackt (weiss nicht genau welche du brauchst) ich häng die Pakete hier an.

    Falls Zeit gebraucht wird heute am 7.10.2020 um ca. 18 Uhr 50 oder auch 16 Uhr 50 Uhr macht hier auch noch Probleme (Multiboot System)

    muss ich mir auch mal angucken.



    Gruss

    Bert

    Files

    • logs2.zip

      (23.12 kB, downloaded 9 times, last: )
    • logs1.zip

      (855.95 kB, downloaded 11 times, last: )
    • logs3.zip

      (165.29 kB, downloaded 9 times, last: )

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

    The post was edited 2 times, last by Bert ().

  • Ok, da scheint der Audio-Buffer vollzulaufen, weil durch das Umschalten des TTY die Sitzung inaktiv wird und pulseaudio dann seine Tondaten nicht mehr los wird. Das VDR-Frontend zu detachen (z.B. frontend-dbus-send stop - das lässt sich über die Tastatur mittels Windows-Taste + A aufrufen) sollte dagegen helfen.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Hi,


    Mit dem Befehl,

    Code
    1. frontend-dbus-send stop

    das funktioniert, nur aus irgendeinem Grund tut sich mit der Windows Taste + A hier nix.



    Gruss

    Bert

    Hardware:PIntel Core Duo 2,93 Ghz, AsusP5QL PRO, Gigabyte GeForce GT730 (vdpau), Budget TT-S2 1600, 4Gb Ram Dual Channel, 2x Sata Hd
    Multibootsystem
    yavdr-0.6 mit VDR 2.2.0, Ausgabe über Nvidia vdpau

  • Ah, da bin ich durcheinander gekommen - Win + a startet das Frontend, Win + s stoppt es

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)