nvram-wakeup: Rechner wacht rund 10 Minuten zu spät auf

  • Hallo erstmal. Ich war hier schon lange nich mehr aktiv. Schön, dass es das Forum noch gibt. Auch wenn man sich erstmal neu orientieren muss. Sieht ja alles ein wenig anders aus. Immerhin gibts die Smilys noch...:mahlzeit:naenae:portal1


    Nun zu meinem Problem: Ich habe nach fast 10 Jahren den VDR meines Vaters neu aufgesetzt. Ein yaVDR sollte es werden. Nach der Installation klappt das nvram-wakup noch nicht so recht. Wollte heute testweise die Tagesschau aufnehmen. Statt kurz vor 20 Uhr startet er 20:04. Ein Blick in das Log (siehe unten) zeigt, dass die Aufwachzeit beim runterfahren auf 19:04 gesetzt wird - was laut UTC ja zu den 20:04 passen dürfte nur eben einige Minuten zu spät. Die Uhrzeit im System scheint korrekt zu sein.


    Ein weiteres Problem: Nach dem automatischen Hochfahren kommt das Frontend nicht wieder hoch. Auf dem Monitor erscheint folgender Hinweis:


    Frontend detached. Press any key on your remote to continue.


    Starte ich den Rechner jetzt nochmal komplett durch (Hard-Reset), ist das Frontend wieder da.


    Danke & Grüße,

    KaiCrow


    Fileserver: Fujitsu Siemens Scenic T D1214; PIII800MHz; 384MB RAM; 250GB Samsung SP2514N; 200GB Samsung SP2014N
    VDR: Fujitsu Siemens Scenic S D1215; PIII 1GHz Coppermine; 250GB Samsung SP2514N; 512MB RAM; Hauppage PVR-350 only;Mahlzeit ISO 3.2, Kernel 2.6.23.9, vdr1.4.7-ext40
    blog.blechkopp.net

  • Statt kurz vor 20 Uhr startet er 20:04. Ein Blick in das Log (siehe unten) zeigt, dass die Aufwachzeit beim runterfahren auf 19:04 gesetzt wird - was laut UTC ja zu den 20:04 passen dürfte nur eben einige Minuten zu spät. Die Uhrzeit im System scheint korrekt zu sein.

    nvram-wakeup bekommt den Timestamp 1549998559 übergeben - das wäre laut

    Code
    1. $ date -d @1549998559
    2. Di 12. Feb 20:09:19 CET 2019

    Also würde mich das syslog vor dem gezeigten Logausschnitt interessieren, wo der VDR das Shutdown-Skript aufruft.

    Ein weiteres Problem: Nach dem automatischen Hochfahren kommt das Frontend nicht wieder hoch. Auf dem Monitor erscheint folgender Hinweis:


    Frontend detached. Press any key on your remote to continue.

    Wenn der VDR für Timer aufwacht, sitzt man ja (normalerweise) nicht davor, also ist die Voreinstellung ein paar Watt zu sparen, indem das Frontend erst attached wird, wenn der Benutzer aktiv ist und Knöpfchen auf der Fernbedienung drückt (oder die Eingabetaste auf der Tastatur, wenn kein anderes Fenster den Fokus hat).


    In der /etc/init/vdr-frontend.conf kannst du das Verhalten mit der Umgebungsvariablen start_always_detached=2 so anpassen, dass es immer Attached wird, aber dann schaltet der VDR sich erst nach dem Benutzerinaktivitätstimeout automatisch wieder aus (in yavdr-ansible gibt es einen Workaround dafür, so dass das Attachen des Frontends beim Start des Systems für einen Timer nicht zu einem verzögerten Shutdown führt).

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Danke für die Infos.


    start_always_detached habe ich bei 0 belassen. Ist ja eigentlich ganz sinnvoll. Ich habe nur gerade keine Fernbedienung zum Einrichten zur Hand und ich bekomme die Meldung mit der Tastatur nicht weg. Gäbe es da irgendeinen Trick?


    Das Log vor dem Timestamp ist tatsächlich etwas mysteriös:



    Der Timestamp taucht also nochmal im Zusammenhang mit vdr-shutdown-wrapper auf. Kurz zuvor die Zeit "20:09" bei "reboot at" ist auch komisch. Neu gestartet hat er ja aber um 20:04. Ich bin weiterhin verwirrt. ;-)


    Fileserver: Fujitsu Siemens Scenic T D1214; PIII800MHz; 384MB RAM; 250GB Samsung SP2514N; 200GB Samsung SP2014N
    VDR: Fujitsu Siemens Scenic S D1215; PIII 1GHz Coppermine; 250GB Samsung SP2514N; 512MB RAM; Hauppage PVR-350 only;Mahlzeit ISO 3.2, Kernel 2.6.23.9, vdr1.4.7-ext40
    blog.blechkopp.net

  • Du erzwingst um 19:39 Uhr den Shutdown, obwohl der VDR nicht herunterfahren will, weil ein Timer innerhalb des MinEventTimeout ansteht - dann ist das vorgesehene Verhalten laut der INSTALL Datei, die dem VDR beiliegt folgendes:

    If a timer is currently recording, or a recording would start within the next 30 minutes (default for the "Min. event timeout" setup parameter), and the user insists in shutting down now, the first and second parameter will correspond to a time that is "Min. event timeout" minutes in the future.

    Also ist der nächste Aufweckzeitpunkt vom VDR aus 30 Minuten später um 20:09 Uhr, davon zieht das Skript, das vom nvram-wakeup Hook aufgerufen wird dann noch 5 Minuten ab (konservative Schätzung, moderne Rechner booten normalerweise deutlich schneller) und du landest bei 20:04 Uhr.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von seahawk1986 ()

  • Ich habe nur gerade keine Fernbedienung zum Einrichten zur Hand und ich bekomme die Meldung mit der Tastatur nicht weg. Gäbe es da irgendeinen Trick?

    Das Frontend-Skript reagiert nur auf die Eingabetaste, wenn das root-Window den Fokus hat - ein Mausklick auf den Bildschirmhintergrund bevor man die Eingabetaste drückt sollte es eigentlich tun. Ansonsten könntest du in der /etc/openbox/rc.xml auch noch ein Tastenkürzel hinterlegen (vgl. http://openbox.org/wiki/Help:Bindings), das frontend-dbus-send /frontend atta ausführt, also z.B.:

    XML: rc.xml
    1. <keybind key="W-a">
    2. <action name="Execute">
    3. <command>frontend-dbus-send /frontend atta</command>
    4. </action>
    5. </keybind>

    Um mit Windows-Taste + a das Frontend zu starten.

    yaVDR-Dokumentation (Ceterum censeo enchiridia esse lectitanda.)

  • Nicht schlecht. Ich bin begeistert. Danke nochmals für die Weitergabe deines Wissens.


    Fileserver: Fujitsu Siemens Scenic T D1214; PIII800MHz; 384MB RAM; 250GB Samsung SP2514N; 200GB Samsung SP2014N
    VDR: Fujitsu Siemens Scenic S D1215; PIII 1GHz Coppermine; 250GB Samsung SP2514N; 512MB RAM; Hauppage PVR-350 only;Mahlzeit ISO 3.2, Kernel 2.6.23.9, vdr1.4.7-ext40
    blog.blechkopp.net