vdrnfofs - Verständnisfrage

  • Hallo jsffm


    erstmal vielen Dank für deinen Vorschlag und die Arbeit.


    ich hab mir das WIKI zu to_h264 nochmals angeschaut und ich muss gestehen dass noch immer nicht so zu 100% durchblicke.


    Mein Script erstellt in dem entsprechenden Verzeichnis eine Datei welche als Config DAtei für to_h264 dient


    also z.b in:


    Code
    1. /raid5/SiFi/Contact/2008-08-11.20.13.50.50.rec


    Dein Script sucht dann in allen Verzeichnissen von "raid5" nach diesen Dateien - hab ich das richtig verstanden ?

  • Hast Du auch die Seite über Automation gelesen?


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hi


    nein - den Teil habe ich übersehen - schaue ich mir an - DANKE !


    Ich hätte noch eine Detail Frage zu deinem Script:


    Habe mir das mal ein wenig angeschaut - verstehe ich es richtig dass bei nicht aktiviertenm ProjektX ganz normal "nur" ffmpeg verwendet wird ?


    Ich habe doch recht viele "alte" Aufnahmen im .vdr Format - würdest du hier ProjektX zwingend empfehlen ?


    CU

  • 2 x ja


    Du musst es einfach mal bei einigen Beispielen probieren, als ich das machte, war ffmpeg noch viel älter, der aktuelle kommt evtl. viel besser damit zurecht.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Der aktuelle script macht auch Gebrauch von mediainfo, ich habe das gerade auch im Wiki geändert.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo


    danke für die Infos - wenn es dir nicht zu viel aufwand macht wäre es toll wenn du es wie besprochen ändern könntest.


    Ich gehe davon aus dass du Media Info nutzt um das Input Format zu erkennen ?!?


    ich hab die tage ein wenig mit ffmpeg rum probiert.


    Ich vermute mal dass du sendungen die bereits in nativem h264 vorliegen nicht erneut umwandelst und nur den Ton umbaust...)

  • so ist es


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Siehe hier


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Der Parameter heisst fname= und ist casesensitiv wie alle Parameter.

    Am Besten packst Du ihn in die Datei h264 im Verzeichnis der jeweilgen Aufnahme.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Ich habe jetzt folgende h264-Datei zum Testen angelegt:

    Code
    1. mkv=yes
    2. odir=/out
    3. fname=test

    und das Eregbnis:

    Code
    1. ls -l /out
    2. total 1872352
    3. -rw-r--r-- 1 root root 957 15. Okt 12:30 info
    4. -rw-r--r-- 1 root root 9897 31. Jan 13:18 logfile
    5. -rw-r--r-- 1 root root 1917265821 19. Jun 2018 test.mkv


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo


    also - die .conf hab jetzt mal direkt in das Verzeichnis gelegt - beide Parameter werden auch gelesen - aber...


    Hier der entsprechnde part:


    Code
    1. odir=/out
    2. fname=gogogirls.ts


    Im "outdir" landet nur:


    Code
    1. root@debian:/out# ls
    2. info logfile

    Auf der Konsole ist dann folgendes zu sehen:


    Code
    1. [libx264 @ 0x55b08efe9300] profile High, level 4.1
    2. Output #0, mpegts, to '../2009-08-22.18.03.1-4.rec/00001.ts':


    Etwas weiter unten dann:


    Code
    1. Metadata:
    2. title : "testfile.ts"
    3. encoder : Lavf58.20.100


    Hab ich irgendwo nen Denkfehler ?

  • Ich hatte Dich schonmal gebeten, mir genauer zu sagen, was Du willst. Warum willst Du ein ts-File erstellen, da ist der Overhead größer, warum nimmst Du nicht mkv (davon war ich ausgegangen)?


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo


    Ok - ich versuche es nochmals:


    Ich würde gerne ein Output Directory definieren können welches nichts mit dem Source Dir zu tun hat (z.b: /out)

    Ich würde gerne einen Output Dateinamen definieren können z.B: "gogogirls.mkv"


    Beim Dateiformat - ich habe mich jetzt auf KODI eingesponnen daher ist mir das format relativ "jacke wie hose" so lange Kodi das sauber abspielt

  • Dann wiederhole Deinen Versuch analog zu meinem Test mit fname= ohne extension und natürlich mkv=yes.


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Wo steht denn, dass Du die .conf in das source Verzeichnis stellen sollst? Dort heisst die Datei schlicht h264


    vdr-User-# 755 to_h264 chk_r vdr-transcoding

  • Hallo


    mir ist heute noch folgendes aufgefallen:


    Kann es sein dass in dem Script noch ein Fehler zum Thema "odir" steckt ?


    Konfiguriert ist: odir=/out


    Dann wird auch alles nach /out encodiert:


    Code
    1. root@debian:/out# ls
    2. info Jurassic_Park.mkv logfile


    Es wird aber ein zusätzliches verzeichnis "out" angelegt:


    Code
    1. root@debian:/test/Jurassic_Park# ls
    2. 2009-08-22.18.03.50.99.rec out

    Das bleibt leer.


    CU

    GTR

  • schau ich mir mal an


    vdr-User-# 755 to_h264 chk_r vdr-transcoding