Owncloud / Apache konfigurieren

  • Läuft also Apache2 und Nextcloud auf dem selben Port.


    Die Default-Apache2 Site deaktivieren a2dissite 000-default ich gehe mal vom Standard aus zum testen, ob es dann funktioniert. Wahrscheinlich brauchst bei Nextcloud gar keinen Indianer - weiß es aber nicht.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Geht immer noch nicht

    Code
    1. $ sudo netstat -nlept | grep 80
    2. tcp6 0 0 :::80 :::* LISTEN 0 31449 2267/apache2
    3. $ sudo a2dissite 000-default
    4. Site 000-default disabled.
    5. To activate the new configuration, you need to run:
    6. systemctl reload apache2
    7. $ systemctl reload apache2

    bringt noch den gleichen Fehler The requested URL /nextcloud was not found on this server.

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Was passiert wenn Du systemctl disable apache2 machst und anschließend das System mal neu startest?

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Bei einer Doppelbelegung von Port 80 müßte er es doch hier anzeigen. Es wird aber nur einer angezeigt.

    Code
    1. $ sudo netstat -tlpn| grep apache
    2. tcp6 0 0 :::80 :::* LISTEN 24487/apache2
    3. tcp6 0 0 :::443 :::* LISTEN 24487/apache2
    4. $ sudo ss -tlpn| grep apache
    5. LISTEN 0 128 *:80 *:* users:(("apache2",pid=24524,fd=4),("apache2",pid=24523,fd=4),("apache2",pid=24522,fd=4),("apache2",pid=24521,fd=4),("apache2",pid=24520,fd=4),("apache2",pid=24487,fd=4))
    6. LISTEN 0 128 *:443 *:* users:(("apache2",pid=24524,fd=6),("apache2",pid=24523,fd=6),("apache2",pid=24522,fd=6),("apache2",pid=24521,fd=6),("apache2",pid=24520,fd=6),("apache2",pid=24487,fd=6))

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Sei doch mal kreativ: Lege einen Apache auf Port 81, dann kannst Du beide Apaches laufen lassen.

    Prüfe, ob Du nextcloud-snap überhaupt installiert hast, weil Du es vor zwei Tagen deinstalliert hast.

    Prüfe, ob die URL zu nextcloud stimmt. Du postest hier immer "/nextcloud", aber liegt Deine nextcloud auch in dem Unterfolder? Bei mir ist es in keinem Unterfolder, sondern direkt im Root-Folder des Web-Servers.


    Code
    1. sudo snap services nextcloud
    2. Service Startup Current
    3. nextcloud.apache enabled active
    4. nextcloud.mdns-publisher enabled active
    5. nextcloud.mysql enabled active
    6. nextcloud.nextcloud-cron enabled active
    7. nextcloud.php-fpm enabled active
    8. nextcloud.redis-server enabled active
    9. nextcloud.renew-certs enabled active



    In meinem Unterbewusstsien blinkt ganz hinten schwach eine LED mit der Beschriftung "Vorsicht Troll", weil Du scheinbar keine Ideen hast für Workarounds oder Lösungsansätze.


    Ich schaue Ende des Jahres nochmal in diesen Thread, um zu sehen, wie weit Du in der Zwischenzeit gekommen bist.

  • +1 für deine jetztige Geduld.


    Nextcloud ist wirklich einfach, Tante Google spuckt Millionen Treffer.

    Client 1 Hardware : MSI Z87-G43, I5-4570, 4 GB Ram (oversized aber war über :) ),Zotac NVidia GT630 (25 Watt),Thermaltake DH202 mit iMon-LCD ( 0038 ) und vdr-plugin-imon
    Software : yaVDR 0.6,sofhhddevice @ 1920x1080@50Hz
    Server Hardware : MSI Z87-G43, I7-4790, 16 GB RAM, 5x3 TB WD Red, Digibit-R1 (2 Devices)
    Software : Ubuntu 16.04 LTS mit yavdr-Paketen,virtualbox,diverse VM's


    Yoda: Dunkel die andere Seite ist...sehr dunkel!
    Obi-Wan: Mecker nicht, sondern iss endlich dein Toast ...

  • Bei einer Doppelbelegung von Port 80 müßte er es doch hier anzeigen. Es wird aber nur einer angezeigt.

    Gegenfrage: Wie soll er die Doppelbelegung anzeigen? Er zeigt dir nur die Anwendung wonach du grep suchen lässt mit der Ausgabe welche Ports damit belegt sind.

    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Auch von mir "Daumen hoch" für hepi wegen seiner Geduld.

    Port 81 hat übrigens funktioniert.


    Es werden bei der Suche so viele unterschiedliche Seiten ausgespuckt, die größtenteils sich auf ältere Versionen beziehen. Da ist es schwer durchzublicken. Und da ich zusammengenommen jetzt mehrere Tage wegen so ner Sch... vor dem Rechner sitze und diverse Seiten gelesen habe, ist die Geduld bei mir jetzt am Ende.

    Vor allem, wenn man die Cloud nur notgedrungen benutzen muß, weil die direkte Synchronisation mit Thunderbird nicht klappt.


    Owncloud produziert noch den selben Fehler. Übernahme der Daten in Nextcloud hat auch noch nicht funktioniert.

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

  • Du hast einfach zu viel auf einmal durchgeführt, angefangen hat es mit dem System-Upgrade. Bei so was kann man davon ausgehen dass das Probleme mitbringt wenn man solche Dienste nutzt wie du da sich PHP und MySQL auch weiter entwickelt.


    Gruß utiltiy



    VDR Projekte EPGD EPG2VDR

  • Ich habe mich jetzt wieder an die Fehlersuche bei owncloud gemacht, da ich mit der Datenübernahme zu Nextcloud Probleme habe.


    In /etc/apache2/ports.conf zusätzlich Listen 80 eingetragen und restart des Apachen bringt einen Fehler.

    Code
    1. $ sudo service apache2 status
    2. ● apache2.service - The Apache HTTP Server
    3. Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
    4. Drop-In: /lib/systemd/system/apache2.service.d
    5. └─apache2-systemd.conf
    6. Active: failed (Result: exit-code) since Sun 2019-01-06 19:36:13 CET; 25s ago
    7. Process: 9285 ExecStop=/usr/sbin/apachectl stop (code=exited, status=0/SUCCESS)
    8. Process: 9291 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
    9. Main PID: 7439 (code=exited, status=0/SUCCESS)


    Im Owncloud Desktop-Client wird die Fehlermeldung angezeigt:

    Code
    1. Keine Verbindung zu owncloud auf http://192... Server hat "404 not found" auf "GET http://192.../owncloud/owncloud/status.php" geantwortet

    Das Verzeichnis gibt es nicht. In welcher conf wird das doppelte owncloud generiert?

    DVB-S2 TT 1600, GIGABYTE GA-M68M-S2P, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    yaVDR 0.6

    gilt nur für alte Beiträge vor 2011: DVB-S Siemens FF 1.3 (bis 03.10.09 / ab 01.03.10) DVB-S2 TT 1600, GIGABYTE GA-MA78GM-S2H, AMD-BE2400, Antec Fusion Black, MCE IR-Fernbedienung
    ab 01.03.10 yaVDR 1.7.10 / Debian 2.6.31 [bis 1.3.10: 2.6.30.5, 11.07.09: 2.6.18, bis 12.09.09: 2.6.26-2-amd64, vdr1.6.0 (keine Distri!)]

    The post was edited 1 time, last by ctvdrnoob ().